[HACKERS] A suggestion on PG_TRY() exception handling code.

2006-11-16 Thread Gurjeet Singh
Hi hackers, The current usage PG_TRY() looks something like this: ... normal code ... PG_TRY(); { ... code that might throw ereport(ERROR) ... } PG_CATCH(); { ... error recovery code ... ... plus anything that you wish to do even if an error wasn't

Re: [HACKERS] A suggestion on PG_TRY() exception handling code.

2006-11-16 Thread Tom Lane
Gurjeet Singh [EMAIL PROTECTED] writes: I propose a new constuct, PG_FINALLY. I took a look through the existing uses of PG_CATCH, and found that in the places where there is duplicate code between the normal and error exits, it's usually just one or two lines. Where it's more than that, it's