Re: [HACKERS] [ISSUE] pg_dump: schema with OID 0 does not exist

2014-03-11 Thread Robert Haas
On Tue, Mar 11, 2014 at 12:23 AM, Prakash Itnal prakash...@gmail.com wrote:
 Can someone confirm is this really an issue? or any reasons for missing
 rows?

Well, your database is definitely getting corrupted somehow.  But
there's no information in your email which would enable someone to
guess how.

I blogged on this subject a while back, but I don't know whether it's
relevant to your situation:

http://rhaas.blogspot.com/2012/03/why-is-my-database-corrupted.html

-- 
Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company


-- 
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers


Re: [HACKERS] [ISSUE] pg_dump: schema with OID 0 does not exist

2014-03-10 Thread Prakash Itnal
Hi,

Can someone confirm is this really an issue? or any reasons for missing
rows?


On Tue, Feb 25, 2014 at 3:51 PM, Prakash Itnal prakash...@gmail.com wrote:

 Hi,

 Recently we observed below errors while taking dump after upgrading from
 9.0.13 to 9.1.9.

 pg_dump: schema with OID 0 does not exist

 I referred similar issues reported previously (
 http://www.postgresql.org/message-id/CAGWYGjXRJj=zugejv0ckvn4zf9hb92q+7e3aqfcvbgbmb9z...@mail.gmail.com)
 and get issue resolved after identifying and inserting some of the missing
 rows from *pg_opclass* table. Below are the rows that are missed after
 upgrade (from *pg_opclass *table):

405 | aclitem_ops |   11 |   10 |  2235
 |  1033 | t  |  0

783 | box_ops |   11 |   10 |  2593
 |   603 | t  |  0

783 | point_ops   |   11 |   10 |  1029
 |   600 | t  |603

783 | poly_ops|   11 |   10 |  2594
 |   604 | t  |603

783 | circle_ops  |   11 |   10 |  2595
 |   718 | t  |603

   2742 | _int4_ops   |   11 |   10 |  2745
 |  1007 | t  | 23

   2742 | _text_ops   |   11 |   10 |  2745
 |  1009 | t  | 25

   2742 | _abstime_ops|   11 |   10 |  2745
 |  1023 | t  |702


 Can some one help me to understand whether it is an issue? If not how and
 why these rows got disappeared after upgrade?

 Since we have an fully automated environment we do not encourage manual
 intervention. So I am trying to understand how can we handle these issues.

 --
 Cheers,
 Prakash




-- 
Cheers,
Prakash