Re: [HACKERS] Crash on backend exit w/ OpenLDAP [2.4.24, 2.4.31]

2014-07-11 Thread Noah Misch
On Thu, Jun 19, 2014 at 01:01:34PM -0400, Tom Lane wrote: Noah Misch n...@leadboat.com writes: On Thu, Jun 12, 2014 at 05:02:19PM -0400, Noah Misch wrote: You can cause the at-exit crash by building PostgreSQL against OpenLDAP 2.4.31, connecting with LDAP authentication, and issuing LOAD

Re: [HACKERS] Crash on backend exit w/ OpenLDAP [2.4.24, 2.4.31]

2014-06-19 Thread Noah Misch
On Thu, Jun 12, 2014 at 05:02:19PM -0400, Noah Misch wrote: You can cause the at-exit crash by building PostgreSQL against OpenLDAP 2.4.31, connecting with LDAP authentication, and issuing LOAD 'dblink'. 4. Detect older OpenLDAP versions at runtime, just before we would otherwise initialize

Re: [HACKERS] Crash on backend exit w/ OpenLDAP [2.4.24, 2.4.31]

2014-06-19 Thread Tom Lane
Noah Misch n...@leadboat.com writes: On Thu, Jun 12, 2014 at 05:02:19PM -0400, Noah Misch wrote: You can cause the at-exit crash by building PostgreSQL against OpenLDAP 2.4.31, connecting with LDAP authentication, and issuing LOAD 'dblink'. 4. Detect older OpenLDAP versions at runtime, just