[PHP-CVS] cvs: php4 /ext/standard array.c basic_functions.c php_array.h

2003-02-05 Thread Ilia Alshanetsky
iliaa Wed Feb 5 12:56:08 2003 EDT Modified files: /php4/ext/standard php_array.h basic_functions.c array.c Log: Added array_walk_recursive() function that can apply array_walk recursively to an array. Index: php4/ext/standard/php_array.h diff -u php4/ex

[PHP-CVS] cvs: php4 /ext/standard array.c basic_functions.c php_array.h

2003-01-13 Thread Andrey Hristov
andrey Mon Jan 13 13:12:23 2003 EDT Modified files: /php4/ext/standard array.c basic_functions.c php_array.h Log: added array_combine(). Creates an array by using the elements of the first parameter as keys and the elements of the second as correspoding keys

[PHP-CVS] cvs: php4 /ext/standard array.c basic_functions.c php_array.h

2002-09-21 Thread Andrey Hristov
andrey Sat Sep 21 10:50:04 2002 EDT Modified files: /php4/ext/standard array.c php_array.h basic_functions.c Log: New function added - array_intersect_assoc() similar to array_intersect() but the keys are also used in the comparison. So the result is a subset

Re: [PHP-CVS] cvs: php4 /ext/standard array.c basic_functions.c php_array.h

2002-09-11 Thread Andi Gutmans
You're better off changing the name of behavior to check_if_key_equal and use it as a boolean. if (check_if_key_equal) if (!check_if_key_equal) It'll be much more readable than a magic variable called behavior. If you want to keep the behavior variable you should probably make the 0 and 1 #def

[PHP-CVS] cvs: php4 /ext/standard array.c basic_functions.c php_array.h

2002-09-11 Thread Andrey Hristov
andrey Wed Sep 11 14:13:48 2002 EDT Modified files: /php4/ext/standard array.c basic_functions.c php_array.h Log: New function added : array_diff_assoc() . Like array_diff() but does additional checks on key values. Test script will be added too. #My first p