[PHP-DEV] Re: [PHP-QA] RC4

2001-03-29 Thread Phil Driscoll
Built and tested cgi version ok on NT4 SP6 IIS4 - ran all my stuff which is mainly mysql + general language stuff, + phpmyadmin +phorum. Built and done a rudimentary test (some of my code + phpMyAdmin) on Suse 6.4 Linux, again with no problems found. Cheers -- Phil Driscoll Dial Solutions +44

Re: [PHP-DEV] Question about socket ext. file descriptors

2001-03-29 Thread Andi Gutmans
Why do you need to rely on such behavior? Are you trying to do something naught? :) I think in general it's not a good idea to rely on the value and type of resources (even though this is an integer). I'm not quite sure why it returns integers and not resources. Looks like a bad thing to me as

Re: [PHP-DEV] Leaking references

2001-03-29 Thread Thomas Wentzel
DUH!!! I did a buildconf and then the errors disappeared... Thomas Wentzel wrote: Thank you very much, Wez! Perhaps you can be so nice as to answer my next question also ;) Whenever I do a configure with --enable-debug I get close to a zillion errors when compiling (or linking rather)

[PHP-DEV] PHP 4.0 Bug #9930 Updated: only small psubset of rfc1867 accepted

2001-03-29 Thread andreas
ID: 9930 User Update by: [EMAIL PROTECTED] Old-Status: Feedback Status: Open Bug Type: *General Issues Description: only small psubset of rfc1867 accepted Hello Jani, have you recieved my email? I have replyed to yours, as it came from [EMAIL PROTECTED] and you asked me, to send the diff

[PHP-DEV] PHP 4.0 Bug #9807 Updated: ereg_replace returns Warning: Invalid content of \{\}

2001-03-29 Thread stas
ID: 9807 Updated by: stas Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: *Function Specific Assigned To: Comments: Works for me in 4.0.4. Please re-check with latest version and if it still happens, please supply values of all ereg_replace arguments. Previous

[PHP-DEV] PHP 4.0 Bug #10046 Updated: linking to a PHP page with querystring causes error in php4ts.dll

2001-03-29 Thread sniper
ID: 10046 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: URL related Assigned To: Comments: Please add a shortest possible script into this bug report which can be used to reproduce this. You could also try the latest CVS build from

[PHP-DEV] PHP 4.0 Bug #8869 Updated: phpinfo() returns incorrect Configuration File Path

2001-03-29 Thread stas
ID: 8869 Updated by: stas Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: *Function Specific Assigned To: Comments: Are you sure PHP is indeed reading this file? PHP is able to work without any php.ini, so it running is not a proof it actually reads this file. Could

[PHP-DEV] PHP 4.0 Bug #10047 Updated: CRC Error while extracting from the downloaded archive

2001-03-29 Thread sniper
ID: 10047 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Bogus Bug Type: *Install and Config Assigned To: Comments: It's either your tar / gunzip that is broken or there have been some problems during the transfer. I downloaded the package myself (just before

[PHP-DEV] PHP 4.0 Bug #9300 Updated: Having an array and other variables as parameters to a fonction

2001-03-29 Thread stas
ID: 9300 Updated by: stas Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: Arrays related Assigned To: Comments: Could you please give the isolated self-contained piece of code that demonstrates the problem, and describe what it should do, on your thinking, and what

[PHP-DEV] PHP 4.0 Bug #10045 Updated: no php_calendar.dll php_ftp.dll and php_mssql70.dll

2001-03-29 Thread dbeu
ID: 10045 Updated by: dbeu Reported By: [EMAIL PROTECTED] Old-Status: Bogus Status: Closed Bug Type: *Extensibility Functions Assigned To: Comments: ftp and calendar are built-in (look at phpinfo()) there should be only one mssql extension left, named php_mssql.dll Previous Comments:

[PHP-DEV] PHP 4.0 Bug #9645 Updated: usort, uasort, uksort fail every other time

2001-03-29 Thread stas
ID: 9645 Updated by: stas Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: Arrays related Assigned To: Comments: Could you please provide short self-contained script demonstrating the problem (including data sample)? Previous Comments:

[PHP-DEV] PHP 4.0 Bug #9643 Updated: Variable member value gets lost from object during use

2001-03-29 Thread stas
ID: 9643 Updated by: stas Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: Class/Object related Assigned To: Comments: Could you please describe in more detail what happens and what the problem is? Also note that when you are using foreach, it operates on the copy

[PHP-DEV] PHP 4.0 Bug #9771 Updated: Passing Multilayered Objects, by Reference, to Independent Sub-Objects

2001-03-29 Thread stas
ID: 9771 Updated by: stas Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Closed Bug Type: Class/Object related Assigned To: Comments: You should use: $oTest0 = new Test0_t(); (new PHP 4.0.4 syntax) to do what you want. Generally, if you reference $this from the constructor

[PHP-DEV] PHP 4.0 Bug #9884 Updated: Using a return in an included file causes a major abnormality.

2001-03-29 Thread stas
ID: 9884 Updated by: stas Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Closed Bug Type: Scripting Engine problem Assigned To: Comments: Using return stops _running_ the script. However, in PHP 4, scrips are _compiled_ in full before running. That means, all functions, which are

[PHP-DEV] PHP 4.0 Bug #9963 Updated: strtr behaves differently than unix tr

2001-03-29 Thread stas
ID: 9963 Updated by: stas Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Closed Bug Type: Strings related Assigned To: Comments: The function works just like it's defined to work, so it's not a bug. You can use any of the replace functions (fastest would be str_replace, I guess) to

Re: [PHP-DEV] PHP 4.0 Bug #9884 Updated: Using a return in an included file causes a major abnormality.

2001-03-29 Thread Hartmut Holzgraefe
[EMAIL PROTECTED] wrote: ID: 9884 Updated by: stas Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Closed Bug Type: Scripting Engine problem Assigned To: Comments: Using return stops _running_ the script. However, in PHP 4, scrips are _compiled_ in full before running. That

[PHP-DEV] PHP 4.0 Bug #9596 Updated: All the php executable text I see is blurred beyond recognition

2001-03-29 Thread stas
ID: 9596 Updated by: stas Reported By: [EMAIL PROTECTED] Old-Status: Feedback Status: Bogus Bug Type: Unknown/Other Function Assigned To: Comments: Previous Comments: --- [2001-03-07 00:58:22] [EMAIL PROTECTED]

[PHP-DEV] PHP 4.0 Bug #10031 Updated: Stange behaviour in for loop with negative values

2001-03-29 Thread stas
ID: 10031 Updated by: stas Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Closed Bug Type: Variables related Assigned To: Comments: Your mistake is that you regard $start_day as number. In most cases it's OK, but ++ acts differently on strings. So use $itchy = $start_day+0 or any

[PHP-DEV] turn magic_quotes_gpc off in the .htaccess file!

2001-03-29 Thread Klaus Zahradnik
How do I do it? regards klaus -- PHP Development Mailing List http://www.php.net/ To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED] To contact the list administrators, e-mail: [EMAIL PROTECTED]

[PHP-DEV] PHP 4.0 Bug #9884 Updated: Using a return in an included file causes a major abnormality.

2001-03-29 Thread stas
ID: 9884 Updated by: stas Reported By: [EMAIL PROTECTED] Old-Status: Closed Status: Open Bug Type: Scripting Engine problem Assigned To: Comments: reopened - double function definition still there. Previous Comments: ---

Re: [PHP-DEV] PHP 4.0 Bug #9884 Updated: Using a return in an included file causes a major abnormality.

2001-03-29 Thread Stanislav Malyshev
HH this does not explain why it is possible to declare two functions HH by the same name without getting an error HH HH which of the two hello()'s is going to be called by the main script? Sorry, missed that one. Weird indeed. -- Stanislav Malyshev, Zend Products Engineer [EMAIL PROTECTED]

Re: [PHP-DEV] Question about socket ext. file descriptors

2001-03-29 Thread Andi Gutmans
Lars, I understand what you're saying but there is one important problem with the current implementation which I think outweighs everything else. The fact that right now you are likely to leak file descriptors. This is very bad especially as Apache processes live for many requests. If the

[PHP-DEV] PHP 4.0 Bug #10050: ISAPI module crashing when different sites on the same server

2001-03-29 Thread arnaud
From: [EMAIL PROTECTED] Operating system: Win 2K server PHP version: 4.0.4pl1 PHP Bug Type: IIS related Bug description: ISAPI module crashing when different sites on the same server Hello, I noticed a problem with ISAPI version of PHP 4.0.4pl1. I have IIS 5.0 running on a

[PHP-DEV] PHP 4.0 Bug #10051: php still does not start

2001-03-29 Thread wolle
From: [EMAIL PROTECTED] Operating system: win98 PHP version: 4.0.4pl1 PHP Bug Type: *Install and Config Bug description: php still does not start Look first at ID . I had that problem with php.exe. ERROR: cant find odbc32.dll I have downloaded mdac 2.6 SDK (13 MB) and

[PHP-DEV] PHP 4.0 Bug #10051 Updated: php still does not start

2001-03-29 Thread jmoore
ID: 10051 Updated by: jmoore Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Bogus Bug Type: *Install and Config Assigned To: Comments: Once again this is not a bug in PHP but a misconfig on your system. If the dll is not on your system then PHP cant find it. This is not the place

[PHP-DEV] PHP 4.0 Bug #9950 Updated: Error while running ./configure Apache

2001-03-29 Thread smphp
ID: 9950 User Update by: [EMAIL PROTECTED] Status: Open Bug Type: Compile Failure Description: Error while running ./configure Apache I did exactly what is described in ftp://ftp.suse.com/pub/suse/i386/commercial/Oracle/README.glibc-2.1.3-stubs After installing Oracle 8.1.7 on SuSE 7.1

[PHP-DEV] RE: PHP 4.0 Bug #8869 Updated: phpinfo() returns incorrect Config uration File Path

2001-03-29 Thread Clifford, Shawn A
Ah, I'll do that. I've got PHP working fine, but I had put a link from /usr/local to /opt/apache. I'll try strace (I'm a Solaris guy, so anything other than truss is heinous). Thanks, -- Shawn -Original Message- From: Bug Database [mailto:[EMAIL PROTECTED]] Sent: Thursday, March 29,

Re: [PHP-DEV] Question about socket ext. file descriptors

2001-03-29 Thread Zeev Suraski
Note that the situation isn't as bad as you thought - it's not that it's not using the resource mechanism. It is, if it wasn't, we'd be getting loads of complaints from people running out of descriptors very quickly. It just uses old, PHP 3 style resources, of type IS_LONG. They're still

Re: [PHP-DEV] Question about socket ext. file descriptors

2001-03-29 Thread Andi Gutmans
At 03:35 PM 3/29/2001 +0200, Zeev Suraski wrote: Note that the situation isn't as bad as you thought - it's not that it's not using the resource mechanism. It is, if it wasn't, we'd be getting loads of complaints from people running out of descriptors very quickly. It just uses old, PHP 3

Re: [PHP-DEV] Question about socket ext. file descriptors

2001-03-29 Thread Andi Gutmans
At 03:47 PM 3/29/2001 +0200, Zeev Suraski wrote: At 15:41 29/3/2001, Andi Gutmans wrote: At 03:35 PM 3/29/2001 +0200, Zeev Suraski wrote: Note that the situation isn't as bad as you thought - it's not that it's not using the resource mechanism. It is, if it wasn't, we'd be getting loads of

Re: [PHP-DEV] Question about socket ext. file descriptors

2001-03-29 Thread Zeev Suraski
ext/sockets does indeed appear to be broken; It doesn't obey the standard PHP return value rules at all (errors are negative numbers instead of false, resource are passed back as-is instead of as resources). I was actually looking at the other socket functions, fsockopen() and friends.

[PHP-DEV] PHP 4.0 Bug #10052: setcookie() don't work

2001-03-29 Thread plutoalien
From: [EMAIL PROTECTED] Operating system: Linux server0023 2.2.14 PHP version: 4.0.4pl1 PHP Bug Type: *General Issues Bug description: setcookie() don't work In the Internet Explorer 6.00.2462. the setcookie() function don't work. No cookie will be set. -- Edit

[PHP-DEV] PHP 4.0 Bug #10043 Updated: action handler not working

2001-03-29 Thread vlad
ID: 10043 User Update by: [EMAIL PROTECTED] Old-Status: Feedback Status: Open Bug Type: *Web Server problem Description: action handler not working I'm aware of the registerglobals. No, no functions in my code. It's relatively straihgtforward, actually. ? if ($submit=='') { echo EOT

[PHP-DEV] PHP 4.0 Bug #9950 Updated: Error while running ./configure Apache

2001-03-29 Thread sniper
ID: 9950 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: Compile Failure Assigned To: Comments: 1. Add -lpthread into your apache makefile's LIBS 2. Get the latest CVS snapshot of PHP 4 from http://snaps.php.net/ --Jani Previous Comments:

[PHP-DEV] PHP 4.0 Bug #10052 Updated: setcookie() don't work

2001-03-29 Thread sniper
ID: 10052 Updated by: sniper Reported By: [EMAIL PROTECTED] Status: Feedback Bug Type: *General Issues Assigned To: Comments: Does it work with other browsers? (works for me just fine with both IE5 and NS4.76 and Mozilla) --Jani Previous Comments:

[PHP-DEV] PHP 4.0 Bug #7163 Updated: Random Failed opening errors for both php pages and included/required files

2001-03-29 Thread sniper
ID: 7163 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Old-Bug Type: Other web server Bug Type: iPlanet related Assigned To: Comments: Does this happen with 4.0.4pl1? And if it does could you please try the latest CVS snapshot from http://snaps.php.net/ ?

[PHP-DEV] PHP 4.0 Bug #10053: Insert sentence error

2001-03-29 Thread julian . gonzalez
From: [EMAIL PROTECTED] Operating system: W2000 PHP version: 4.0.4 PHP Bug Type: COM related Bug description: Insert sentence error $oConn = new COM("ADODB.Connection"); // Data Base: ORACLE 8.0 // insert query: it works fine!!! insert into Pact

[PHP-DEV] PHP 4.0 Bug #8859 Updated: php4 tries to output strings of length 0 which leads to immediate bailing-out

2001-03-29 Thread sniper
ID: 8859 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: Other web server Assigned To: Comments: Does this happen with latest CVS snapshot from http://snaps.php.net/ ? --Jani Previous Comments:

[PHP-DEV] PHP 4.0 Bug #9116 Updated: PHP will stop returing anything in NES 4.1 SP1

2001-03-29 Thread sniper
ID: 9116 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Old-Bug Type: Other web server Bug Type: iPlanet related Assigned To: Comments: Does this happen with the latest CVS snapshot from http://snaps.php.net/ ? --Jani Previous Comments:

[PHP-DEV] PHP 4.0 Bug #10054: configure ends with attension

2001-03-29 Thread apurva_7800
From: [EMAIL PROTECTED] Operating system: Redhat 6.1 PHP version: 4.0.4pl1 PHP Bug Type: *Configuration Issues Bug description: configure ends with attension Dear Sir I have redhat linux 6.1 with krb5 1.1.1-26 imap -2000-2.6 apache 1.3.9. and php-4.0.4pl1 Now configure

[PHP-DEV] PHP 4.0 Bug #8888 Updated: Authentication in iPlanet Fails

2001-03-29 Thread sniper
ID: Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: iPlanet related Assigned To: Comments: Does this happen with latest CVS snapshot from http://snaps.php.net/ ? --Jani Previous Comments:

[PHP-DEV] PHP 4.0 Bug #9584 Updated: NSAPI PHP eating up all memory on server

2001-03-29 Thread sniper
ID: 9584 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Old-Bug Type: *Web Server problem Bug Type: iPlanet related Assigned To: Comments: Does this happen with latest CVS snapshot from http://snaps.php.net/ ? --Jani Previous Comments:

[PHP-DEV] PHP 4.0 Bug #10055: strtotime() doesn't work on MSSQL standard dates

2001-03-29 Thread rsignes
From: [EMAIL PROTECTED] Operating system: Windows 2000 PHP version: 4.0.4pl1 PHP Bug Type: Feature/Change Request Bug description: strtotime() doesn't work on MSSQL standard dates MSSQL returns dates in the format: "Mar 2 2001 9:21PM". strtodate() can't handle that, and

[PHP-DEV] PHP 4.0 Bug #10054 Updated: configure ends with attension

2001-03-29 Thread sniper
ID: 10054 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Bogus Bug Type: *Configuration Issues Assigned To: Comments: You should be doing what the configure script told you: Ask this on [EMAIL PROTECTED] ! Hint: You propably don't have the kerberos-devel rpm

[PHP-DEV] PHP 4.0 Bug #9643 Updated: Variable member value gets lost from object during use

2001-03-29 Thread robsta
ID: 9643 User Update by: [EMAIL PROTECTED] Old-Status: Feedback Status: Open Bug Type: Class/Object related Description: Variable member value gets lost from object during use Ah of course :o) Looking at the code again if I make the first foreach loop become: foreach ($crList as $index =

[PHP-DEV] PHP 4.0 Bug #10056: Unable to load libphp4.so into Apache 1.3.19

2001-03-29 Thread oliverh
From: [EMAIL PROTECTED] Operating system: Linux 2.0.34 PHP version: 4.0.3pl1 PHP Bug Type: Apache related Bug description: Unable to load libphp4.so into Apache 1.3.19 I have and use a Cobalt Qube2 (64-Bit MIPS little-endian). It uses a specific version of the Linux kernel

[PHP-DEV] PHP 4.0 Bug #7623 Updated: Servlet API - 'output_buffering=On' writes output to shell

2001-03-29 Thread sniper
ID: 7623 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Old-Bug Type: Unknown/Other Function Bug Type: Java related Assigned To: Comments: Does this happen with PHP 4.0.4pl1? And if it does could you try with the latest CVS build from http://www.php4win.de/

[PHP-DEV] PHP 4.0 Bug #10056 Updated: Unable to load libphp4.so into Apache 1.3.19

2001-03-29 Thread oliverh
ID: 10056 User Update by: [EMAIL PROTECTED] Status: Open Bug Type: Apache related Description: Unable to load libphp4.so into Apache 1.3.19 I am also unable to run any PHP version greater than 4.0.3pl1. Apache dumps core. Probably the same issue as Bug #9827. Previous Comments:

[PHP-DEV] PHP 4.0 Bug #10057: Multidimensional arrays passed to function using func_get_args

2001-03-29 Thread dave . kingdon
From: [EMAIL PROTECTED] Operating system: Linux PHP version: 4.0.2 PHP Bug Type: Unknown/Other Function Bug description: Multidimensional arrays passed to function using func_get_args When passing an array to a function declared without arguments, the contents of the array

[PHP-DEV] PHP 4.0 Bug #10058: Gettext doesn't react when I change the language

2001-03-29 Thread bogdan
From: [EMAIL PROTECTED] Operating system: Windows 2000 PHP version: 4.0.4pl1 PHP Bug Type: Gettext related Bug description: Gettext doesn't react when I change the language I set the language with this: putenv ("LC_ALL=ro"); and the translation is ok. if I change it to:

[PHP-DEV] PHP 4.0 Bug #10059: error message Fatal error: Unable to open etc...

2001-03-29 Thread boris . prin
From: [EMAIL PROTECTED] Operating system: NT4 PHP version: 4.0.0 PHP Bug Type: *Install and Config Bug description: error message "Fatal error: Unable to open etc..." When I try to open the page "index.php", this error message occurs : Fatal error: Unable to open

[PHP-DEV] PHP 4.0 Bug #10058 Updated: Gettext doesn't react when I change the language

2001-03-29 Thread bogdan
ID: 10058 User Update by: [EMAIL PROTECTED] Status: Open Bug Type: Gettext related Description: Gettext doesn't react when I change the language I set the language with this: putenv ("LC_ALL=ro"); and the translation is ok. if I change it to: putenv ("LC_ALL=de"); and reload the

[PHP-DEV] PHP 4.0 Bug #9175 Updated: Configure isn't settings vars correctly

2001-03-29 Thread sniper
ID: 9175 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Old-Bug Type: *Install and Config Bug Type: Java related Assigned To: Comments: Does this happen with latest CVS snapshot from http://snaps.php.net/ ? --Jani Previous Comments:

Re: [PHP-DEV] PHP 4.0 Bug #10058 Updated: Gettext doesn't react when I change the language

2001-03-29 Thread Alexander Bokovoy
On Thu, Mar 29, 2001 at 03:45:39PM -, [EMAIL PROTECTED] wrote: ID: 10058 User Update by: [EMAIL PROTECTED] Status: Open Bug Type: Gettext related Description: Gettext doesn't react when I change the language I set the language with this: putenv ("LC_ALL=ro"); and the translation

[PHP-DEV] PHP 4.0 Bug #10057 Updated: Multidimensional arrays passed to function using func_get_args

2001-03-29 Thread cynic
ID: 10057 Updated by: cynic Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: Unknown/Other Function Assigned To: Comments: please include a shortest possible self-contained script that reproduces the behavior Previous Comments:

[PHP-DEV] Re: PHP 4.0 Bug #10051 Updated: php still does not start

2001-03-29 Thread wolle
you say, misconfig of MY system ! how have I to configure it? what do I have to install, in order to get rid of that error-message? I cant image to be the first person, that has this problem... I have a new typical installation of win98... Please help me, I didnt want to bug you. Thx, Wolle

[PHP-DEV] Re: PHP 4.0 Bug #9116 Updated: PHP will stop returing anything in NES 4.1 SP1

2001-03-29 Thread cboyce
Jani, I have not tried the latest CVS snapshot, but this was just the raw amount of code processed by php and the stack size running out. This problem was resolved when I increased the stack size. After a while things got flaky though, I am pretty sure that is to do with the threading iPlanet

[PHP-DEV] PHP 4.0 Bug #10059 Updated: error message Fatal error: Unable to open etc...

2001-03-29 Thread sniper
ID: 10059 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: *Install and Config Assigned To: Comments: Have you tried more recent versions of PHP 4? Like PHP 4.0.4pl1 which is the latest release.. --Jani Previous Comments:

[PHP-DEV] PHP 4.0 Bug #10058 Updated: Gettext doesn't react when I change the language

2001-03-29 Thread bogdan
ID: 10058 User Update by: [EMAIL PROTECTED] Status: Open Bug Type: Gettext related Description: Gettext doesn't react when I change the language Nope. If I use only setlocale("LC_ALL","ro") - I tried other thing too like "LC_MESSAGES" or "ro_RO", changed the names of diretories - it doesn't

[PHP-DEV] PHP 4.0 Bug #9116 Updated: PHP will stop returing anything in NES 4.1 SP1

2001-03-29 Thread sniper
ID: 9116 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Feedback Status: Open Bug Type: iPlanet related Assigned To: Comments: User feedback: -- I have not tried the latest CVS snapshot, but this was just the raw amount of code processed by php and the stack size

[PHP-DEV] PHP 4.0 Bug #10057 Updated: Multidimensional arrays passed to function using func_get_args

2001-03-29 Thread cnewbill
ID: 10057 Updated by: cnewbill Reported By: [EMAIL PROTECTED] Status: Feedback Bug Type: Unknown/Other Function Assigned To: Comments: Here's my quickie test. ?php function test() { var_dump(func_get_arg(0)); } $mya = array( array(1,2,3), array(3,4,5) ); test("$mya");

[PHP-DEV] PHP 4.0 Bug #7821 Updated: Unresolved symbol with GD

2001-03-29 Thread sniper
ID: 7821 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: *Configuration Issues Assigned To: Comments: Try adding --with-xpm-dir=/path/to/libXpm/ into your configure line (without the /lib part!) --Jani Previous Comments:

[PHP-DEV] PHP 4.0 Bug #10027 Updated: HTTP_REFERER

2001-03-29 Thread sniper
ID: 10027 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: *Web Server problem Assigned To: Comments: Works for me just fine with latest CVS. (snapshot can be found at http://snaps.php.net/ ) Which webserver are you using? Apache? --Jani

Re: [PHP-DEV] Re: PHP 4.0 Bug #10051 Updated: php still does not start

2001-03-29 Thread Hartmut Holzgraefe
wolle wrote: you say, misconfig of MY system ! how have I to configure it? what do I have to install, in order to get rid of that error-message? I cant image to be the first person, that has this problem... I have a new typical installation of win98... Please help me, I didnt want to

[PHP-DEV] Empty RCS template entities

2001-03-29 Thread Jon Parise
The current RCS template contains: PR: Submitted by: Reviewed by: Obtained from: It's unnecessary to print one of those extra RCS template fields in the commit log if it's been left empty. Adding the attached script (procured from the FreeBSD project) to CVSROOT/ will strip the empty RCS lines

[PHP-DEV] PHP 4.0 Bug #10060: startup error msg format

2001-03-29 Thread cynic
From: [EMAIL PROTECTED] Operating system: NT 5 SP 1 PHP version: 4.0 Latest CVS (29/03/2001) PHP Bug Type: Apache related Bug description: startup error msg format I don't know if this is an Apache or PHP error, but it looks like PHP doesn't pass startup error messages to

[PHP-DEV] PHP 4.0 Bug #10033 Updated: Function file does not work with remote files

2001-03-29 Thread sniper
ID: 10033 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: HTTP related Assigned To: Comments: Could you please try the latest CVS snapshot from http://snaps.php.net/ ? --Jani Previous Comments:

[PHP-DEV] PHP 4.0 Bug #10036 Updated: dies on make

2001-03-29 Thread sniper
ID: 10036 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Bogus Bug Type: Compile Failure Assigned To: Comments: No bug in PHP. Either your PATH misses the place where ar is located or you don't have it at all in your system. Ask further support questions on [EMAIL

[PHP-DEV] PHP 4.0 Bug #9643 Updated: Variable member value gets lost from object during use

2001-03-29 Thread sniper
ID: 9643 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Bogus Bug Type: Class/Object related Assigned To: Comments: Previous Comments: --- [2001-03-29 06:14:28] [EMAIL PROTECTED] Could you

[PHP-DEV] PHP 4.0 Bug #7455 Updated: Problems with $this in constructor

2001-03-29 Thread sniper
ID: 7455 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Duplicate Status: Closed Bug Type: *General Issues Assigned To: Comments: Previous Comments: --- [2000-10-25 13:09:24] [EMAIL PROTECTED] 6529 I have

[PHP-DEV] PHP 4.0 Bug #7444 Updated: General reference problems

2001-03-29 Thread sniper
ID: 7444 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Duplicate Status: Bogus Bug Type: *General Issues Assigned To: Comments: Previous Comments: --- [2000-10-24 19:37:51] [EMAIL PROTECTED] We've been

[PHP-DEV] PHP 4.0 Bug #7134 Updated: misbehavior of print and sprintf AGAIN

2001-03-29 Thread sniper
ID: 7134 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Duplicate Status: Bogus Bug Type: *General Issues Assigned To: Comments: Previous Comments: --- [2000-10-11 09:01:40] [EMAIL PROTECTED] please try

[PHP-DEV] PHP 4.0 Bug #6644 Updated: Test

2001-03-29 Thread sniper
ID: 6644 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Duplicate Status: Bogus Bug Type: *General Issues Assigned To: Comments: Previous Comments: --- [2000-09-09 20:07:05] [EMAIL PROTECTED] Please

[PHP-DEV] PHP 4.0 Bug #6303 Updated: make install said libphp4.sl is not a DSO

2001-03-29 Thread sniper
ID: 6303 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Duplicate Status: Closed Bug Type: *General Issues Assigned To: Comments: Previous Comments: --- [2000-08-22 17:00:08] [EMAIL PROTECTED] I have the

[PHP-DEV] PHP 4.0 Bug #6435 Updated: can't close session(by session_destroy()) - it write warning

2001-03-29 Thread sniper
ID: 6435 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Duplicate Status: Closed Bug Type: *General Issues Assigned To: Comments: Previous Comments: --- [2000-08-30 08:31:45] [EMAIL PROTECTED] ?php

[PHP-DEV] PHP 4.0 Bug #6520 Updated: session_destroy() does not work

2001-03-29 Thread sniper
ID: 6520 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Duplicate Status: Closed Bug Type: *General Issues Assigned To: Comments: Previous Comments: --- [2000-09-03 16:30:34] [EMAIL PROTECTED] Using the

[PHP-DEV] PHP 4.0 Bug #7136 Updated: The binary version of php4.0.2 doesn't support the bindtextdomain function.

2001-03-29 Thread sniper
ID: 7136 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Duplicate Status: Bogus Bug Type: *General Issues Assigned To: Comments: Previous Comments: --- [2000-10-11 09:50:02] [EMAIL PROTECTED]

[PHP-DEV] PHP 4.0 Bug #4283 Updated: include_path error with PHP4 RC1 Roxen module

2001-03-29 Thread sniper
ID: 4283 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Old-Bug Type: *General Issues Bug Type: Other web server Assigned To: Comments: Does this happen with PHP 4.0.4pl1? --Jani Previous Comments:

[PHP-DEV] Re: PHP 4.0 Bug #8888 Updated: Authentication in iPlanet Fails

2001-03-29 Thread Dylan Neild
No idea man .. We're migrating to JSP/EJB .. So all PHP development has been reduced to "maintenance only". If I have a chance to test it after work on Friday (I can usually get some free time on one of the iPlanet machines), I'll let you know though. :) Dylan On 3/29/01 9:51 AM, "Bug

[PHP-DEV] PHP 4.0 Bug #6624 Updated: error_log() in registered shutdown function

2001-03-29 Thread sniper
ID: 6624 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Old-Bug Type: *General Issues Bug Type: Scripting Engine problem Assigned To: Comments: Does this happen with PHP 4.0.4pl1? --Jani Previous Comments:

[PHP-DEV] PHP 4.0 Bug #10017 Updated: querystrings in php

2001-03-29 Thread sniper
ID: 10017 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: *General Issues Assigned To: Comments: Do you have register_globals = on in your php.ini ? --Jani Previous Comments:

[PHP-DEV] Re: PHP 4.0 Bug #10036 Updated: dies on make

2001-03-29 Thread John Ratelle
Realized this five minutes after the post... damn PATH. Thanks, jjr --- Bug Database [EMAIL PROTECTED] wrote: ID: 10036 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Bogus Bug Type: Compile Failure Assigned To: Comments: No bug in PHP. Either your PATH

[PHP-DEV] PHP 4.0 Bug #10026 Updated: For loop always execute

2001-03-29 Thread sniper
ID: 10026 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: *General Issues Assigned To: Comments: I can't reproduce this (using code below): ?php $c=0; for($i=0; $i$c; $i++) { echo "yes\n"; } ? Could you try this one? And note:

[PHP-DEV] PHP 4.0 Bug #8618 Updated: httpd process hangs

2001-03-29 Thread sniper
ID: 8618 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Old-Bug Type: *General Issues Bug Type: Scripting Engine problem Assigned To: Comments: Does this happen with latest CVS snapshot from http://snaps.php.net/ ? --Jani Previous Comments:

[PHP-DEV] PHP 4.0 Bug #10061: bad interpretation of ascii char #0146

2001-03-29 Thread volpini
From: [EMAIL PROTECTED] Operating system: windows, linux PHP version: 4.0.4pl1 PHP Bug Type: Strings related Bug description: bad interpretation of ascii char #0146 Create a form with a textarea and type into the char #0146; when you submit the form, the php file echo a

[PHP-DEV] PHP 4.0 Bug #9886 Updated: Installation on w2k

2001-03-29 Thread sniper
ID: 9886 Updated by: sniper Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: *General Issues Assigned To: Comments: Could you please try the latest CVS build from http://www.php4win.de/ to check if this is fixed now? --Jani Previous Comments:

[PHP-DEV] PHP 4.0 Bug #10061 Updated: bad interpretation of ascii char #0146

2001-03-29 Thread hholzgra
ID: 10061 Updated by: hholzgra Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Feedback Bug Type: Strings related Assigned To: Comments: i guess this is done by the browser, not php on the server please try to code your form with method="GET" and have a look at what character is

[PHP-DEV] PHP 4.0 Bug #10062: CGI version displays '#!/usr/local/bin/php' line

2001-03-29 Thread shane . wright
From: [EMAIL PROTECTED] Operating system: RedHat 7 PHP version: 4.0.4pl1 PHP Bug Type: Unknown/Other Function Bug description: CGI version displays '#!/usr/local/bin/php' line Standard configure/make on REdHat 7 (options are: --without-apache --with-mysql --with-gd) Then

[PHP-DEV] PHP 4.0 Bug #10062 Updated: CGI version displays '#!/usr/local/bin/php' line

2001-03-29 Thread jmoore
ID: 10062 Updated by: jmoore Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Bogus Bug Type: Unknown/Other Function Assigned To: Comments: There is no need for #!/usr/local/bin/php if you have your webserver set up to parse PHP files already (IE if you have set up apache as shown in

[PHP-DEV] php4.dsw

2001-03-29 Thread Cynic
I tried to build CGI PHP using this workspace, and got the msgbox below. The build failed, of course. What are the requirements to allow for compilation of single-threaded CGI on win32 machines? --- Microsoft Visual C++ --- The source files

Re: [PHP-DEV] php4.dsw

2001-03-29 Thread Zeev Suraski
php4.dsw isn't always maintained, and that's one such example... Using php4ts.dsw should work fine. Zeev At 19:44 29/3/2001, Cynic wrote: I tried to build CGI PHP using this workspace, and got the msgbox below. The build failed, of course. What are the requirements to allow for compilation of

[PHP-DEV] PHP 4.0 Bug #10063: Session variable aren't visible from class

2001-03-29 Thread thierry . bertin
From: [EMAIL PROTECTED] Operating system: linux mandrake 7.2 PHP version: 4.0.4pl1 PHP Bug Type: Class/Object related Bug description: Session variable aren't visible from class I hope you excuse me for my poor english... So, i try to use a session and sessions variables

[PHP-DEV] PHP 4.0 Bug #10062 Updated: CGI version displays '#!/usr/local/bin/php' line

2001-03-29 Thread shane . wright
ID: 10062 User Update by: [EMAIL PROTECTED] Status: Bogus Bug Type: Unknown/Other Function Description: CGI version displays '#!/usr/local/bin/php' line I'm afraid it really is as a CGI - the reason being that my ISP won't install PHP modules and I need gd/t1lib support. This problem is

[PHP-DEV] PHP 4.0 Bug #10026 Updated: For loop always execute

2001-03-29 Thread svein
ID: 10026 User Update by: [EMAIL PROTECTED] Old-Status: Feedback Status: Open Bug Type: *General Issues Description: For loop always execute Its not easy reproduceable - i have only seen this happens ONCE - in the specified function. Its NOT a simple for-loop - the for-loop executes INSIDE a

[PHP-DEV] PHP 4.0 Bug #10026 Updated: For loop always execute

2001-03-29 Thread svein
ID: 10026 User Update by: [EMAIL PROTECTED] Status: Open Bug Type: *General Issues Description: For loop always execute When i said ONCE - i didnt mean ONCE :) It ALWAYS happen in the code referred... Previous Comments:

[PHP-DEV] PHP 4.0 Bug #10063 Updated: Session variable aren't visible from class

2001-03-29 Thread hholzgra
ID: 10063 Updated by: hholzgra Reported By: [EMAIL PROTECTED] Old-Status: Open Status: Closed Bug Type: Class/Object related Assigned To: Comments: you have to use global in every class method class methods behave exactly like normal functions in this context, a global declaration within the

[PHP-DEV] PHP 4.0 Bug #10062 Updated: CGI version displays '#!/usr/local/bin/php' line

2001-03-29 Thread jmoore
ID: 10062 Updated by: jmoore Reported By: [EMAIL PROTECTED] Old-Status: Bogus Status: Open Bug Type: Unknown/Other Function Assigned To: Comments: Hmm I might be wrong there.. What webserver is your ISP running? James Previous Comments:

[PHP-DEV] fastcgi

2001-03-29 Thread James Moore
Ive been having a play with fastcgi under win32 and what ever I do I seem to get the following errors: Compiling... fastcgi.c D:\php-4.0.5RC4\sapi\fastcgi\fastcgi.c(103) : warning C4101: 'tmp' : unreferenced local variable D:\php-4.0.5RC4\sapi\fastcgi\fastcgi.c(181) : error C2065: 'sapi_globals'

[PHP-DEV] PHP 4.0 Bug #10062 Updated: CGI version displays '#!/usr/local/bin/php' line

2001-03-29 Thread shane . wright
ID: 10062 User Update by: [EMAIL PROTECTED] Status: Open Bug Type: Unknown/Other Function Description: CGI version displays '#!/usr/local/bin/php' line They're running 1.3.12 - but that doesn't matter yet as I can't even get PHP to compile there (its Debian with glibc2.1, PHP 4.0.4pl1, same

[PHP-DEV] PHP 4.0 Bug #10062 Updated: CGI version displays '#!/usr/local/bin/php' line

2001-03-29 Thread jmoore
ID: 10062 Updated by: jmoore Reported By: [EMAIL PROTECTED] Status: Open Bug Type: Unknown/Other Function Assigned To: Comments: This isnt an Issue with apache. What are you calling your php file?? .cgi yes? there are some hacks around this but it seems more likley a config problem rather than

  1   2   >