[PHP-DEV] PHP 4.0 Bug #10188 Updated: Problem in loading dynamic module (Desc. below)

2001-04-06 Thread sniper

ID: 10188
Updated by: sniper
Reported By: [EMAIL PROTECTED]
Old-Status: Open
Status: Feedback
Old-Bug Type: Dynamic loading
Bug Type: Apache related
Assigned To: 
Comments:

Try leaving that --enable-shared option out of your configure line. And delete 
config.cache before configuring!
After configure run 'make clean ; make ; make install'.

--Jani


Previous Comments:
---

[2001-04-05 11:39:45] [EMAIL PROTECTED]
Apache 1.3.19 is configured with --enable-module=all --enable-shared=max

php-4.0.4pl1 is configured with ./configure --with-apxs=/usr/local/apache/bin/apxs 
--with-mysql=/usr/local/mysql --with-config-file-path=/usr/local/apache 
--enable-shared

After running "make"  "make install" without any errors, then I run "apachectl 
configtest" and it outputs the error:
"API module structure `php4_module' in file /usr/local/apache/libexec/libphp4.so is 
garbled - perhaps this is not an Apache module DSO?"

---



ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=10188edit=2


-- 
PHP Development Mailing List http://www.php.net/
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]




[PHP-DEV] PHP 4.0 Bug #10188 Updated: Problem in loading dynamic module (Desc. below)

2001-04-06 Thread sniper

ID: 10188
Updated by: sniper
Reported By: [EMAIL PROTECTED]
Status: Feedback
Bug Type: Apache related
Assigned To: 
Comments:

Leave it out of the PHP 4 configure line..not Apache's. :)

--Jani


Previous Comments:
---

[2001-04-06 23:08:10] [EMAIL PROTECTED]
Try leaving that --enable-shared option out of your configure line. And delete 
config.cache before configuring!
After configure run 'make clean ; make ; make install'.

--Jani


---

[2001-04-05 11:39:45] [EMAIL PROTECTED]
Apache 1.3.19 is configured with --enable-module=all --enable-shared=max

php-4.0.4pl1 is configured with ./configure --with-apxs=/usr/local/apache/bin/apxs 
--with-mysql=/usr/local/mysql --with-config-file-path=/usr/local/apache 
--enable-shared

After running "make"  "make install" without any errors, then I run "apachectl 
configtest" and it outputs the error:
"API module structure `php4_module' in file /usr/local/apache/libexec/libphp4.so is 
garbled - perhaps this is not an Apache module DSO?"

---



ATTENTION! Do NOT reply to this email!
To reply, use the web interface found at http://bugs.php.net/?id=10188edit=2


-- 
PHP Development Mailing List http://www.php.net/
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
To contact the list administrators, e-mail: [EMAIL PROTECTED]