[PHP] Installing mcrypt

2003-11-12 Thread Mike At Spy
I am installing mcrypt on a linux server. I first installed libmcrypt 2.5.7 and now am working on mcrypt 2.6.4. When I do a ./configure for mcrypt 2.6.4, it gives me this error: checking for libmcrypt - version = 2.5.0... *** 'libmcrypt-config --version' returned 2.5.7, but LIBMCRYPT (2.5.6)

[PHP] Changing the php.ini file

2003-11-05 Thread Mike At Spy
I changed a value for max uploads in my php.ini file (linux box); I restarted apache, then the whole server, to get the new value to come up and, generally, take affect. Neither of those things did it. Does anyone know what I need to do to get the ini file re-read by the OS, or system, so that

RE: [PHP] Changing the php.ini file

2003-11-05 Thread Mike At Spy
To: Mike At Spy; [EMAIL PROTECTED] Subject: RE: [PHP] Changing the php.ini file [snip] I changed a value for max uploads in my php.ini file (linux box); I restarted apache, then the whole server, to get the new value to come up and, generally, take affect. Neither of those things did it. Does

RE: [PHP] Re: Changing the php.ini file

2003-11-05 Thread Mike At Spy
install's or a backup or something? Check by setting some self-evident setting in php.ini and restarting Apache. Also, if you're sending the data to a database, make sure it's not the database who's barfing due to its own config settings or limitations. HTH Bogdan Mike At Spy wrote: I

RE: [PHP] Changing the php.ini file

2003-11-05 Thread Mike At Spy
: Wednesday, November 05, 2003 9:25 AM To: Marek Kilimajer Cc: Mike At Spy; [EMAIL PROTECTED] Subject: Re: [PHP] Changing the php.ini file Marek Kilimajer wrote: post_max_size is another setting that has effect on uploads. It should be higher than upload_max_filesize. Make sure it isn't

RE: [PHP] Changing the php.ini file

2003-11-05 Thread Mike At Spy
, 2003 9:50 AM To: 'Mike At Spy' Cc: [EMAIL PROTECTED] Subject: RE: [PHP] Changing the php.ini file On 05 November 2003 14:39, Mike At Spy contributed these pearls of wisdom: I re-checked the files - nothing I change in the php.ini files seems to take effect. How do I check apache? I

[PHP] fwrite, fopen, or fread limit?

2003-11-04 Thread Mike At Spy
Does anyone know if the commands for fwrite, fopen, or fread have memory limits in dealing with large files? I created a system for uploading files to a server. Small files work fine. Larger ones (around 7 megs) do not work at all. Thanks, -Mike -- PHP General Mailing List

RE: [PHP] fwrite, fopen, or fread limit?

2003-11-04 Thread Mike At Spy
Yes, that was it. Thanks! :) -Mike -Original Message- From: Roger Spears [mailto:[EMAIL PROTECTED] Sent: Tuesday, November 04, 2003 12:45 PM To: Mike At Spy Subject: Re: [PHP] fwrite, fopen, or fread limit? check the php.ini file, there may be a file upload limit placed

[PHP] value field filled by mysql output

2003-10-22 Thread Mike At Spy
I am creating a form for editing records output from a mysql db (edit as an html form). I've done this many times, but have never run into this issue. I have code like this for the query: $edit_list = mysql_query(SELECT general_inventory.quantity FROM products_to_categories, general_inventory

RE: [PHP] jpeg libraries.

2003-08-29 Thread Mike At Spy
* Thus wrote Mike At Spy ([EMAIL PROTECTED]): It did install some jpeg stuff under /usr/local/bin, but I don't see anything added to /usr/local/lib. After that, I re-compiled php with: --with-jpeg But nothing changed. I re-compiled again with: --with-jpeg=/usr/local

RE: [PHP] jpeg libraries.

2003-08-29 Thread Mike At Spy
: Thursday, August 28, 2003 7:27 PM To: Mike At Spy Cc: [EMAIL PROTECTED] Subject: Re: [PHP] jpeg libraries. Hi, Friday, August 29, 2003, 6:39:16 AM, you wrote: MAS I got the jpeg libraries from: MAS http://freshmeat.net/projects/libjpeg/?topic_id=105%2C809 MAS And installed them; even

[PHP] imagejpeg function output

2003-08-29 Thread Mike At Spy
Just to make sure no one is lead astray - I still have an issue getting jpeg enabled on a server with gd and php. I am asking this question 'cause I am doing some work on a different server where jpeg is enabled. Anyway, I have this sort of setup: $src_img = imagecreatefromjpeg($rand_image);

RE: [PHP] jpeg libraries.

2003-08-29 Thread Mike At Spy
Does anyone know how to get jpeg enabled in gd? Yes. I'm using php 4.3.3. Unless dramatic changes were made in 4.3.3 then the procedure should be the same as the previous versions. Namely: --with-gd --with-jpeg-dir=/directory/where/jpeg/libs/are/installed manual Image functions

RE: [PHP] imagejpeg function output

2003-08-29 Thread Mike At Spy
Hyeah, but since this is with a page, I keep getting the 'error, headers already sent' thing. How do I get past that? :) Thanks for your help! -Mike -Original Message- From: Marek Kilimajer [mailto:[EMAIL PROTECTED] Sent: Friday, August 29, 2003 12:51 PM To: Mike At Spy

RE: [PHP] jpeg libraries.

2003-08-29 Thread Mike At Spy
Jason et al; Thanks for all of your help up - I really appreciate it. However, I still have the issue that while the jpeg libraries were installed, the weren't. :\ This is what was installed through the only binary for jpeg libaries I can find on the net off hand: jpegsrc.v6b.tar.gz yields:

[PHP] GD PHP

2003-08-28 Thread Mike At Spy
Is there anything special I have to do to enable GD when using PHP 4.3.2? I'm getting an error of: Fatal error: Call to undefined function: imagecreatefromjpeg() in /home/sites/site37/web/photos/functions.php on line 594 When I use the imagecreatefromjpeg() function. Is it not usable with gd?

RE: [PHP] GD PHP

2003-08-28 Thread Mike At Spy
Cool - thanks. :) -Mike -Original Message- From: Javier Tacon [mailto:[EMAIL PROTECTED] Sent: Thursday, August 28, 2003 11:33 AM To: Mike At Spy; [EMAIL PROTECTED] Subject: RE: [PHP] GD PHP You need to compile PHP with the option --with-gd in the configure step

RE: [PHP] GD PHP

2003-08-28 Thread Mike At Spy
, 2003 11:33 AM To: Mike At Spy; [EMAIL PROTECTED] Subject: RE: [PHP] GD PHP You need to compile PHP with the option --with-gd in the configure step. The function is imagecreatefromjpeg() -Mensaje original- De: Mike At Spy [mailto:[EMAIL PROTECTED] Enviado el: jueves, 28 de

[PHP] jpeg libraries.

2003-08-28 Thread Mike At Spy
I got the jpeg libraries from: http://freshmeat.net/projects/libjpeg/?topic_id=105%2C809 And installed them; even did a make test to make sure everything was correct. It did install some jpeg stuff under /usr/local/bin, but I don't see anything added to /usr/local/lib. After that, I

[PHP] Image Magick

2003-08-26 Thread Mike At Spy
Anyone here familiar with the installation of Image Magick and what files it installs on your machine? I had an admin put it on, and then took it off - but took it off by removing what she thought were all of the files related to it. I just found some files I think that are. They are located

[PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
Hey, I've got a weird issue. I have some code, an MySQL statement, that returns an empty set, like this: $person = mysql_query(Some Statement Here); So, then I have an if/else statement: if (!$person || $person == 0 || $person == '' || $person == '0') { $result = 1; } else { $result = 4; }

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
Here's the SQL - I tested it via command line and it comes back empty set. SELECT ID FROM tblItems WHERE number = $place Does that help? -Mike -Original Message- From: Jay Blanchard [mailto:[EMAIL PROTECTED] Sent: Tuesday, July 29, 2003 1:31 PM To: Mike At Spy; [EMAIL PROTECTED

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
: Tuesday, July 29, 2003 1:44 PM To: Jay Blanchard; Mike At Spy; [EMAIL PROTECTED] Subject: RE: [PHP] Bizarre SQl, if issue [snip] ...lots of stuff... [/snip] What I forgot to say is that basically you were testing for query execution, not the number of rows returned from the database

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
Message- From: Ford, Mike [LSS] [mailto:[EMAIL PROTECTED] Sent: Tuesday, July 29, 2003 1:47 PM To: 'Mike At Spy'; [EMAIL PROTECTED] Subject: RE: [PHP] Bizarre SQl, if issue -Original Message- From: Mike At Spy [mailto:[EMAIL PROTECTED] Sent: 29 July 2003 18:37

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
[snip] Off hand, I would agree. And that is what I would expect. However, the *exact* same setup on a different server gives me a result of 'FALSE' properly. The other server has php 4.3.3 on it - the one giving the improper response has php 4.1.2. $which_person = mysql_query(SELECT

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
, July 29, 2003 2:07 PM To: 'Mike At Spy'; Ford, Mike [LSS]; [EMAIL PROTECTED] Subject: RE: [PHP] Bizarre SQl, if issue -Original Message- From: Mike At Spy [mailto:[EMAIL PROTECTED] Sent: 29 July 2003 19:01 Off hand, I would agree. And that is what I would expect

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
- From: Jay Blanchard [mailto:[EMAIL PROTECTED] Sent: Tuesday, July 29, 2003 2:24 PM To: Mike At Spy; Ford, Mike [LSS]; [EMAIL PROTECTED] Subject: RE: [PHP] Bizarre SQl, if issue [snip] I did the var_dump and got: bool(false) While $vthere (from my previous post) returns 0 (zero

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
[snip] Nothin' wrong with the SQL statement - it executes properly when I enter values that actually pull something from a table. When I enter values that are not present in the table, I go on to have the other issue of it looking like it is false, though it is not. :\ [/snip] But

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
-Original Message- From: Jay Blanchard [mailto:[EMAIL PROTECTED] Sent: Tuesday, July 29, 2003 2:41 PM To: Mike At Spy; [EMAIL PROTECTED] Subject: RE: [PHP] Bizarre SQl, if issue [snip] I still want to know what you need to do, test for query execution or value

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
-Original Message- From: Jay Blanchard [mailto:[EMAIL PROTECTED] Sent: Tuesday, July 29, 2003 2:48 PM To: Mike At Spy; [EMAIL PROTECTED] Subject: RE: [PHP] Bizarre SQl, if issue [snip] I did! Look at this again: $which_person = mysql_query(SELECT ID FROM tblItems WHERE

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
This is a reply to an e-mail that you wrote on Tue, 29 Jul 2003 at 19:46, lines prefixed by '' were originally written by you. I did! Look at this again: $which_person = mysql_query(SELECT ID FROM tblItems WHERE number = $place); $vthere = mysql_num_rows($which_person);

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
[snip] if ($vthere == '0') { True } else { False } if ($vthere == 0) { True } else { False } Same result (actually, that was the first statement I tried). :\ [/snip] Then the query is failing. But the query returns no errors - both on my code I use to test errors and the one

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
Returns 0 (zero). -Mike -Original Message- From: Jay Blanchard [mailto:[EMAIL PROTECTED] Sent: Tuesday, July 29, 2003 3:05 PM To: Mike At Spy; [EMAIL PROTECTED] Subject: RE: [PHP] Bizarre SQl, if issue [snip] And when I plug values into the query at command line - values

RE: [PHP] Bizarre SQl, if issue....

2003-07-29 Thread Mike At Spy
[snip] $person = mysql_query(The Query); $thecount = mysql_num_rows($person); echo $thecount \n; And tell us what $thecount is... Returns 0 (zero). [/snip] Then if($thecount == 0){ $whatever = 1; } else { $whatever = 4; } $whatever should be 1 But that is my point -

RE: [PHP] Compiling PHP

2003-07-09 Thread Mike At Spy
-xml --with-db3 --with-pgsql=shared --with-ldap Thanks for any help, -Mike -Original Message- From: Ralph Guzman [mailto:[EMAIL PROTECTED] Sent: Tuesday, July 08, 2003 5:51 PM To: 'Mike At Spy'; [EMAIL PROTECTED] Subject: RE: [PHP] Compiling PHP The error you are providing

[PHP] Going Back in PHP

2003-07-08 Thread Mike At Spy
I am trying to help one of our admins with a php config/setup issue on one of our servers; the admin re-compiled php, but did not include all of the correct settings. Outside of having the previous make and config files, is there any other files on the server that may hold the old settings so

[PHP] Compiling PHP

2003-07-08 Thread Mike At Spy
I am doing a new compile of PHP (4.3.3) - anyone know what this error is? configure: error: libgds or libib_util not found! Here is my configuration: ./configure --prefix=/usr --with-apxs=/usr/sbin/apxs --enable-safe-mode --wi th-config-file-path=/etc/httpd --with-exec-dir=/usr/bin --with-zlib

RE: [PHP] Compiling PHP

2003-07-08 Thread Mike At Spy
--with-db3 --with-interbase=shared --with-pgsql=shared --with-ldap --with -imap --with-pdflib=shared --with-kerberos Anyone have any ideas? I'm on linux redhat 7.3. Thanks, -Mike -Original Message- From: Mike At Spy [mailto:[EMAIL PROTECTED] Sent: Tuesday, July 08, 2003 3:47 PM

[PHP] mail() function

2003-07-07 Thread Mike At Spy
Is anyone familiar with the mail function and how it works on the server? I can't get it to work on a client's server, and this error shows up in the error log: PHP Warning: U1À‰å]Éö¼': Unable to initialize module Module compiled with debug=144, thread-safety=135 module API=1119810252 PHP

RE: [PHP] mail() function

2003-07-07 Thread Mike At Spy
To: Mike At Spy Cc: [EMAIL PROTECTED] Subject: Re: [PHP] mail() function Yeah, umm, thats a weird error message. What server platform / OS? On Mon, 2003-07-07 at 12:58, Mike At Spy wrote: Is anyone familiar with the mail function and how it works on the server? I can't get

RE: [PHP] mail() function

2003-07-07 Thread Mike At Spy
- From: Brian S. Drexler [mailto:[EMAIL PROTECTED] Sent: Monday, July 07, 2003 2:06 PM To: 'Mike At Spy' Subject: RE: [PHP] mail() function I assume you are running this on the command line. Does the file have the correct permissions? -Original Message- From: Mike At Spy

RE: [PHP] mail() function

2003-07-07 Thread Mike At Spy
They have it set to Show all errors except for notices. -Mike -Original Message- From: Brian S. Drexler [mailto:[EMAIL PROTECTED] Sent: Monday, July 07, 2003 2:18 PM To: 'Mike At Spy' Subject: RE: [PHP] mail() function Ok, so if it is a command line issue it's not the problem

[PHP] PHP and Apache

2003-06-30 Thread Mike At Spy
Recently, I had Apache upgraded on my linux redhat 7.3 server from 1.2.3 to 1.3.27. PHP stopped working when trying to process html files with php in them. In the httpd.conf file, I have AllowOverride set to All. In the Virtual Host settings I have 'AddType application/x-httpd-php .html'.

[PHP] header() issues....

2003-06-23 Thread Mike At Spy
Does anyone know if there are issues with using the header() function inside frames? Is there extra stuff that needs to be added to it to get it to work correctly? Or if there were issues with header in php 4.06? Thanks, -Mike -- PHP General Mailing List (http://www.php.net/) To

RE: [PHP] Re: header(); Issue

2003-06-19 Thread Mike At Spy
I'll give one of the suggestions a whirl (or both). I do have this same sort of thing on a different server with a more recent version of PHP - which is why I thought it might be a version issue. :) -Mike -Original Message- From: Esteban Fernandez [mailto:[EMAIL PROTECTED] Sent:

[PHP] Agh! Driving me crazy!

2003-06-18 Thread Mike At Spy
Anyone see anything wrong with this line of code? $fine = mysql_query(INSERT INTO tblPOItems(poID,poItemUPC,poItemNumber,poItemDescription,poItemInnerCasePkg, poInnerQuantity,poItemEstQuantity,poItemCostEach,poItemSuggestedSellPrice) values('$poID', '$place[0]', '$inmb', '$ides', '$iicp',

RE: [PHP] Agh! Driving me crazy!

2003-06-18 Thread Mike At Spy
Gah!!! :) Thanks! Thanks to all! :) -Mike -Original Message- From: Jennifer Goodie [mailto:[EMAIL PROTECTED] Sent: Wednesday, June 18, 2003 3:05 PM To: Mike At Spy; [EMAIL PROTECTED] Subject: RE: [PHP] Agh! Driving me crazy! You are missing the closing ) around the values

[PHP] setlocale() changes?

2003-06-05 Thread Mike At Spy
I've been getting a warning on one of my scripts since I upgraded from 4.1.2 to the most recent version of PHP. The warning is: Warning: setlocale(): Passing locale category name as string is deprecated. Use the LC_* -constants instead The script at the line that is failing sez: setlocale

RE: [PHP] setlocale() changes?

2003-06-05 Thread Mike At Spy
Actually, I must apologize to you and the list. I checked the function on the php site *after* I asked and saw that was the issue immediately. :\ :) -Mike -Original Message- From: Neil Freeman [mailto:[EMAIL PROTECTED] Sent: Wednesday, June 04, 2003 8:57 AM To: Mike At Spy Cc

RE: [PHP] PHP vs. CGI

2003-03-05 Thread Mike At Spy
Sorry, yes. :) -Mike -Original Message- From: Leif K-Brooks [mailto:[EMAIL PROTECTED] Sent: Wednesday, March 05, 2003 4:45 PM To: [EMAIL PROTECTED] Cc: [EMAIL PROTECTED] Subject: Re: [PHP] PHP vs. CGI CGI meaning perl? SpyProductions Support Team wrote: Does PHP use

[PHP] Installation Configuration Question

2003-01-29 Thread Mike At Spy
Has anyone ever had an issue where PHP, for whatever reason, stopped .htaccess files from working? Thanks, -Mike -- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php

[PHP] PHP not working in html

2002-11-07 Thread Mike At Spy
PHP isn't working in my html docs - what changes do I need to make to get it to do so? Does it need to be recompiled? Can I do it without re-compiling? Thanks, -Mike -- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php

RE: [PHP] PHP not working in html

2002-11-07 Thread Mike At Spy
And add this line: AddType application/x-httpd-php .php .htm .html Do a search for parse html php for more help. -Kevin - Original Message - From: Mike At Spy [EMAIL PROTECTED] To: [EMAIL PROTECTED] Sent: Thursday, November 07, 2002 2:16 PM Subject: [PHP] PHP not working in html

[PHP] Weird, weird, weird!

2002-10-08 Thread Mike At Spy
Anyone ever have the experience of working on a site, working with MySQL and then having something almost inexplicable happen? I was working on a script, and had this weird event. A very simple script with this: mysql_connect(localhost,user,pass); mysql_select_db(dbname) or die(Query

RE: [PHP] Re: Weird, weird, weird!

2002-10-08 Thread Mike At Spy
. Take the mysql_query out of the $cartquery assignment. -Jason Mike At Spy wrote: Anyone ever have the experience of working on a site, working with MySQL and then having something almost inexplicable happen? I was working on a script, and had this weird event. A very simple script

[PHP] Populating Other People's Forms

2002-09-10 Thread Mike At Spy
I would like to write a script that would populate someone else's form on the net and get the results. Off hand, I imagine I would use fopen() to open up the web page and pass some variables to it. The problem I have is that the form I want to populate is a multi-step CGI. Is this possible?

RE: [PHP] random array sort

2002-09-10 Thread Mike At Spy
You could use array_rand() to take stuff out of the array at random and then stuff it all back into another array. -Mike -Original Message- From: ROBERT MCPEAK [mailto:[EMAIL PROTECTED]] Sent: Tuesday, September 10, 2002 10:22 AM To: [EMAIL PROTECTED] Subject: [PHP] random array

RE: [PHP] random array sort

2002-09-10 Thread Mike At Spy
, 2002, at 10:33 AM, Mike At Spy wrote: You could use array_rand() to take stuff out of the array at random and then stuff it all back into another array. -Mike -Original Message- From: ROBERT MCPEAK [mailto:[EMAIL PROTECTED]] Sent: Tuesday, September 10, 2002 10:22 AM

RE: [PHP] Agh! trim (#$@#@^%!!!)

2002-08-21 Thread Mike At Spy
Get this - it didn't work! :( I tried decreasing the -1 to -2 and so on, but nothing on that either. :( -Mike -Original Message- From: Rasmus Lerdorf [mailto:[EMAIL PROTECTED]] Sent: Tuesday, August 20, 2002 12:45 PM To: Mike At Spy Cc: [EMAIL PROTECTED] Subject: Re: [PHP

RE: [PHP] Agh! trim (#$@#@^%!!!)

2002-08-21 Thread Mike At Spy
- From: Jason Wong [mailto:[EMAIL PROTECTED]] Sent: Wednesday, August 21, 2002 8:53 AM To: [EMAIL PROTECTED] Subject: Re: [PHP] Agh! trim (#$@#@^%!!!) On Wednesday 21 August 2002 20:36, Mike At Spy wrote: Get this - it didn't work! :( I tried decreasing the -1 to -2 and so on, but nothing

RE: [PHP] Agh! trim (#$@#@^%!!!)

2002-08-21 Thread Mike At Spy
But isn't taking off characters or spaces considered modifying a string? I'll take another look at the manual, thanks. -Mike -Original Message- From: Darren Gamble [mailto:[EMAIL PROTECTED]] Sent: Wednesday, August 21, 2002 10:32 AM To: 'Mike At Spy'; [EMAIL PROTECTED] Subject

[PHP] Agh! trim (#$@#@^%!!!)

2002-08-20 Thread Mike At Spy
Hey! :) I have an issue with trim / triml. Whenever I put a string in to trimmed, it refuses to take the period at the end of the string off. I did put more things to trim first, but this is basically what I am doing: $single = The date is 20-Aug-2002. // This is an example - see below

RE: [PHP] Agh! trim (#$@#@^%!!!)

2002-08-20 Thread Mike At Spy
Sorry, I mistyped - $date should be $single. Thanks for the suggestions and help to everyone! - I will pursue them. :) -Mike -Original Message- From: Justin French [mailto:[EMAIL PROTECTED]] Sent: Tuesday, August 20, 2002 12:50 PM To: Mike At Spy; [EMAIL PROTECTED] Subject

[PHP] PHP Compile: IMAP enabled?

2002-03-19 Thread Mike At Spy
If IMAP is entered under Loaded Modules in the apache section of a phpinfo file, does that mean IMAP has been enabled? Thanks, -Mike -- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php

[PHP] Parse Error Suggestions?

2002-03-18 Thread Mike At Spy
Anyone have any suggestions for getting better reporting on a generic Parse Error? Code is falling to the end of the script, and I can't find a problem anywhere. I looked on the PHP site for error reporting functions, but apparently they do not handle Parse Errors. Thanks, -Mike -- PHP

RE: [PHP] Parse Error Suggestions?

2002-03-18 Thread Mike At Spy
On Mon, 18 Mar 2002, Mike At Spy wrote: Anyone have any suggestions for getting better reporting on a generic Parse Error? Code is falling to the end of the script, and I can't find a problem anywhere. I'd guess you left a curly brace open. Try opening the file in an editor that lets

RE: [PHP] PHP and Pay Flow Pro

2002-03-13 Thread Mike At Spy
Thanks, great place to start. Has anyone else done this stuff? Seems like a big pain in the butt. -Mike The php.net site (http://www.php.net/manual/en/ref.pfpro.php) has all the information you'll need to implement Payflow Pro. Check out the User Contributed Notes.