RE: [PHP] PHP or MSIE Problem? -- SOLVED

2004-02-22 Thread Beau Hartshorne
I described a situation where MSIE for Windows would not post all of a form's fields under fairly unique circumstances. This problem occurs in MSIE 5, 5.5, and 6 (with the most recent hotfixes applied). No other browsers seem to be affected. When: 1. A form is submitted with the enctype attribute

[PHP] PHP or MSIE Problem?

2004-02-20 Thread Beau Hartshorne
All, When I submit a form from MSIE, under certain circumstances some of the fields don't make it into the $_POST array. I am building a CMS that accepts images and text entered into an HTML form. If I submit a form from MSIE, and if the text contains special characters (like T [TM] for example),

Re: [PHP] PHP or MSIE Problem?

2004-02-20 Thread Matt Matijevich
snip Can anyone tell me if this is a common problem? Is this a purely MSIE bug, or could PHP be a factor? /snip I would guess it is a MSIE problem. You could check the raw post data coming into php too see if it is a php bug. I think $GLOBALS['HTTP_RAW_POST_DATA'] has the post data -- PHP

Re: [PHP] PHP or MSIE Problem?

2004-02-20 Thread John Nichel
Beau Hartshorne wrote: All, When I submit a form from MSIE, under certain circumstances some of the fields don't make it into the $_POST array. I am building a CMS that accepts images and text entered into an HTML form. If I submit a form from MSIE, and if the text contains special characters

Re: [PHP] PHP or MSIE Problem?

2004-02-20 Thread John Nichel
Beau Hartshorne wrote: as you (6.0.2800.1106) (different product ID though), and can't reproduce the problem on any of my Linux webservers, or the one Win2k machine I have running PHP/Apache. I also hit your URL with IE, and The problem only occurs in the second form. Did you try that one

RE: [PHP] PHP or MSIE Problem?

2004-02-20 Thread Pablo Gosse
snip Beau Hartshorne wrote: as you (6.0.2800.1106) (different product ID though), and can't reproduce the problem on any of my Linux webservers, or the one Win2k machine I have running PHP/Apache. I also hit your URL with IE, and The problem only occurs in the second form. Did you try

Re: [PHP] PHP or MSIE Problem?

2004-02-20 Thread Richard Davey
Hello Beau, Friday, February 20, 2004, 9:30:30 PM, you wrote: BH When I submit a form from MSIE, under certain circumstances some of the BH fields don't make it into the $_POST array. I am building a CMS that BH Can anyone tell me if this is a common problem? Is this a purely MSIE BH bug, or