[PHP] qry not running??

2003-07-07 Thread Micah Montoy
Anyone see what is wrong with this? //get category info $result = mssql_query(SELECT cat_id, cat_name FROM category WHERE cat_id = '$cat_name'); $catID = mssql_result($result,0,cat_id); //line 32 $catName = mssql_result($result,0,cat_name); //line 33 I'm getting the error: Warning:

Re: [PHP] qry not running??

2003-07-07 Thread Brad Pauly
Micah Montoy wrote: //get category info $result = mssql_query(SELECT cat_id, cat_name FROM category WHERE cat_id = '$cat_name'); $catID = mssql_result($result,0,cat_id); //line 32 $catName = mssql_result($result,0,cat_name); //line 33 I'm getting the error: Warning: mssql_result(): Bad row

Re: [PHP] qry not running??

2003-07-07 Thread Miles Thompson
Micah, Echo your SELECT statement to make certain it reads the way it should. Test for number of rows returned, or an error - $result probably contains nothing, that is it's not pointing to an array. Miles At 01:23 PM 7/7/2003 -0600, Micah Montoy wrote: Anyone see what is wrong with this?

Re: [PHP] qry not running??

2003-07-07 Thread Micah Montoy
Well, I redid the code a bit but it is still blowing up with the same error message. I also did the echo bit and it returned Resource id #10. What ever that is. At least I know its returning something. But when I did mssql_row_nums($result), it returned the value 0. I'm not sure if this is

Re: [PHP] qry not running??

2003-07-07 Thread Jeff Harris
On Jul 7, 2003, Micah Montoy claimed that: |Well, I redid the code a bit but it is still blowing up with the same error |message. I also did the echo bit and it returned Resource id #10. What |ever that is. At least I know its returning something. But when I did |mssql_row_nums($result), it