[PHP] OS X and cURL Issues

2002-11-30 Thread Weston Houghton
I'm working on getting the following install working under OS 10.2.2:

./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/share/man \
--with-apxs=/usr/sbin/apxs \
--with-mysql \
--with-gd=/usr/local \
--with-png-dir=/usr/local \
--with-zlib-dir=/usr/local \
--with-jpg-dir=/usr/local \
--with-freetype-dir=/usr/local \
--enable-trans-sid \
--enable-exif \
--enable-ftp \
--enable-calendar \
--with-curl=/usr/lib \
--with-flatfile \
--with-ming=/Users/whoughto/src/ming-0.2a \
--enable-sockets \
--with-jave=/Library/Java/Home \
--with-xml

And Curl keeps throwing me the following error, but as you can see, I 
do indeed have 7.9.8 installed. Any ideas?

checking for CURL support... yes
checking for CURL in default path... found in /usr
checking for cURL 7.9.8 or greater... configure: error: cURL version 
7.9.8 or later is required to compile php with cURL support
[user/src/php4rc2] root# curl --help
curl 7.9.8 (powerpc-apple-darwin5.5) libcurl 7.9.8

Thanks,
Wes


--
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php



Re: [PHP] OS X and cURL Issues

2002-11-30 Thread Sterling Hughes
you need to upgrade the bundled cURL to version 7.9.8 (soon to be 
7.10.2), or install a special version of the cURL library for PHP's 
installation.

-Sterling


 I'm working on getting the following install working under OS 10.2.2:
 
 ../configure --prefix=/usr \
 --sysconfdir=/etc \
 --localstatedir=/var \
 --mandir=/usr/share/man \
 --with-apxs=/usr/sbin/apxs \
 --with-mysql \
 --with-gd=/usr/local \
 --with-png-dir=/usr/local \
 --with-zlib-dir=/usr/local \
 --with-jpg-dir=/usr/local \
 --with-freetype-dir=/usr/local \
 --enable-trans-sid \
 --enable-exif \
 --enable-ftp \
 --enable-calendar \
 --with-curl=/usr/lib \
 --with-flatfile \
 --with-ming=/Users/whoughto/src/ming-0.2a \
 --enable-sockets \
 --with-jave=/Library/Java/Home \
 --with-xml
 
 And Curl keeps throwing me the following error, but as you can see, I 
 do indeed have 7.9.8 installed. Any ideas?
 
 checking for CURL support... yes
 checking for CURL in default path... found in /usr
 checking for cURL 7.9.8 or greater... configure: error: cURL version 
 7.9.8 or later is required to compile php with cURL support
 [user/src/php4rc2] root# curl --help
 curl 7.9.8 (powerpc-apple-darwin5.5) libcurl 7.9.8
 
 Thanks,
 Wes
 
 
 -- 
 PHP General Mailing List (http://www.php.net/)
 To unsubscribe, visit: http://www.php.net/unsub.php
 

-- 
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php