Re: [PHP] PHP 5.2.9 Apache 2.2.11 outputs php code on Vista

2009-06-27 Thread ioan...@btinternet.com
Solved: In Windows 'Explorer' in Vista, set User permissions for the htdocs - go to htdocs folder within the Apache folders, right click, Properties, Security, Edit, select your name as User, allow Full Control, Modify etc. Now open the files you created like test.php or index1.html and save

Re: [PHP] PHP 5.2.9 Apache 2.2.11 outputs php code on Vista

2009-06-27 Thread ioan...@btinternet.com
...though phpinfo seems to work fine without this handler. ioan...@btinternet.com wrote: php now also works with Apache, I think I was missing from httpd.conf within IfModule mime_module /IfModule: AddHandler application/x-httpd-php .php AddHandler application/x-httpd-php-source .phps

Re: [PHP] PHP 5.2.9 Apache 2.2.11 outputs php code on Vista

2009-06-26 Thread ioan...@btinternet.com
I meant httpd.conf. And what is it about Vista that when in Notepad and you save a file, say test.php in directory htdocs, it shows test.php in the folder, but when you go to Windows Explorer there it is and it is gone? Nor does it load as http://localhost/test.php although http://localhost/

Re: [PHP] PHP and Apache configuration

2009-01-19 Thread Kyle Terry
On Mon, Jan 19, 2009 at 11:28 AM, R B rbp...@gmail.com wrote: Hello, I need that every time someone access one image file in my server, then redirect to a php file. I make this well with: Redirect 301 imagefile.jpg scriptfile.php But i need that the file scriptfile.php can only be

Re: [PHP] PHP and Apache configuration

2009-01-19 Thread Richard Heyes
... This may be of some help. It's from the Apache website and only allows access if the Referer header is sent by the browser and is www.yourdomain.com, ie. Direct access is not permitted: ### SetEnvIf Referer ^http://www.yourdomain.com; local_referal

Re: [PHP] PHP and Apache configuration

2009-01-19 Thread Kyle Terry
On Mon, Jan 19, 2009 at 11:38 AM, Richard Heyes rich...@php.net wrote: ... This may be of some help. It's from the Apache website and only allows access if the Referer header is sent by the browser and is www.yourdomain.com, ie. Direct access is not permitted:

Re: [PHP] PHP and Apache configuration

2009-01-19 Thread ceo
I doubt that you can use re-direct and do what you want, since a re-direct does just that: re-direct the USER to the URL. What you *could* do is get rid of the re-direct and just include('scriptfile.php'); by using ForceType on imagefile.jpg to be application/x-httpd-php Then

Re: [PHP] PHP and Apache configuration

2009-01-19 Thread R B
I like this apache solution, but if i put SetEnvIf Referer ^http://www.yourdomain.com; local_referal Then i can access the file putting this path in the URL: http://www.yourdomain.com/xyz/scriptfile.php And i don´t want the script to be access by the url. That is the main problem. Thanks On

Re: [PHP] PHP and Apache configuration

2009-01-19 Thread Török Alpár
2009/1/19 R B rbp...@gmail.com I like this apache solution, but if i put SetEnvIf Referer ^http://www.yourdomain.com; local_referal Then i can access the file putting this path in the URL: http://www.yourdomain.com/xyz/scriptfile.php And i don´t want the script to be access by the url.

Re: [PHP] PHP and Apache

2008-06-24 Thread David Robley
R B wrote: The people that will install this system, don´t have programming knowledge. They have a website, buy don´t have knowledge of configurations. If i add all the lines, it don´t works, unless the last line is the correct for that particular server. Why not just read the

Re: [PHP] PHP and Apache

2008-06-23 Thread Wolf
R B [EMAIL PROTECTED] wrote: Hello, I´m developing a PHP system that needs one of these lines in the .htaccess, depending of the server configuration: AddHandler application/x-httpd-php .xyz or AddHandler application/x-httpd-php4 .xyz or AddHandler application/x-httpd-php5

Re: [PHP] PHP and Apache

2008-06-23 Thread R B
The people that will install this system, don´t have programming knowledge. They have a website, buy don´t have knowledge of configurations. If i add all the lines, it don´t works, unless the last line is the correct for that particular server. Why not just read the manual and add the

Re: [PHP] [PHP 4.4.5 / Apache 2.2.3] Abrupt and unrepeatable Segmentationfault (11)

2006-12-01 Thread Jan Schröter
Chris wrote: If nobody provides information then try the -internals list, they'll probably be able to help a bit more. Thanks a lot! I've done so, because it's very urgent. -- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php

Re: [PHP] [PHP 4.4.5 / Apache 2.2.3] Abrupt and unrepeatable Segmentation fault (11)

2006-11-30 Thread Chris
Jan Schröter wrote: Hi all! I'm having trouble with my server(s) for some weeks now and did not find any solution for now. My System is Opensuse 10.1 (32 bit) with Apache 2.2.3 and PHP 4.4.5-dev as apache module (latest stable CVS, but wasn't the solution). Im having abrupt segmentation

Re: [PHP] PHP 5 + Apache 2 on Windows: ms sql extension problem

2006-04-26 Thread Wolf
This setup nagged me for a bit too, until I found the solution... The DLL files in C:\php need to be put into system32 directory. Once that happens they work like a charm, but until then, you are plagued with issues. I have my path set for C:\php and everything as well, but it was not until

RE: [PHP] PHP 5 + Apache 2 on Windows: ms sql extension problem

2006-04-26 Thread Ing. Edwin Cruz
Try changing your direcive extension_dir: extension_dir=C:/PHP/ext instead of extension_dir=C:\PHP\ext -Mensaje original- De: Laszlo Nagy [mailto:[EMAIL PROTECTED] Enviado el: Miércoles, 26 de Abril de 2006 04:01 a.m. Para: php-general@lists.php.net Asunto: [PHP] PHP 5 + Apache 2 on

Re: [PHP] PHP and Apache

2006-01-16 Thread Erik Saline
Where do I find fc5? Erik On Sun, Jan 15, 2006 at 09:34:40AM -0800, Erik Saline wrote: Using Fedora Core 4 using the already Apache and Mysql. I tried using the already installed PHP but mysql support was not setup or shown when using phpinfo(). I recompiled PHP with the following.

Re: [PHP] PHP and Apache

2006-01-16 Thread Rodolfo Andrade
www.google.com or http://fedoraproject.org/wiki/ But it's in test yet. Best regards Rodolfo Andrade - Original Message - From: Erik Saline To: Curt Zirzow ; php-general@lists.php.net Sent: Monday, January 16, 2006 3:06 PM Subject: Re: [PHP] PHP and Apache Where do I find fc5? Erik

Re: [PHP] PHP and Apache

2006-01-16 Thread Erik Saline
-general@lists.php.net Sent: Monday, January 16, 2006 3:06 PM Subject: Re: [PHP] PHP and Apache Where do I find fc5? Erik On Sun, Jan 15, 2006 at 09:34:40AM -0800, Erik Saline wrote: Using Fedora Core 4 using the already Apache and Mysql. I tried using the already installed PHP

Re: [PHP] PHP and Apache

2006-01-15 Thread Curt Zirzow
On Sun, Jan 15, 2006 at 09:34:40AM -0800, Erik Saline wrote: Using Fedora Core 4 using the already Apache and Mysql. I tried using the already installed PHP but mysql support was not setup or shown when using phpinfo(). I recompiled PHP with the following. './configure'

Re: [PHP] PHP mysql Apache install on FC3

2005-08-04 Thread Vidyut Luther
Look into the SELinux settings for your system, if you have that enabled, by default PHP is not allowed to get that file via the user nobody. If you look into /var/log/messages you'll see some selinux messages. You either need to disable selinux, or set your policy...http://

Re: [PHP] PHP causes Apache segmentation fault?

2005-03-14 Thread Burhan Khalid
John Swartzentruber wrote: On 3/13/2005 3:55 PM John Swartzentruber wrote: On 3/11/2005 11:57 AM John Swartzentruber wrote: I am running Fedora core3 with Apache 2.0.52 (from default RPMs), MySQL 4.1.10 (from RPMs from MySQL site), and PHP 5.0.3 built from source. I'm going through the PHP

Re: [PHP] PHP causes Apache segmentation fault?

2005-03-14 Thread John Swartzentruber
On 3/14/2005 6:03 AM Burhan Khalid wrote: John Swartzentruber wrote: When I run phpinfo(), it says my mysqli API client version is 3.23.58. When I run php -i from the command line it says it is 4.1.10a. The latter is correct. What would cause the discrepancy? The server has been stopped and

Re: [PHP] PHP causes Apache segmentation fault?

2005-03-14 Thread Richard Lynch
When I run phpinfo(), it says my mysqli API client version is 3.23.58. When I run php -i from the command line it says it is 4.1.10a. The latter is correct. What would cause the discrepancy? The server has been stopped and started many times, and PHP rebuilt a few times, so it isn't a browser

Re: [PHP] PHP causes Apache segmentation fault?

2005-03-14 Thread John Swartzentruber
On 3/14/2005 12:22 PM Richard Lynch wrote: When I run phpinfo(), it says my mysqli API client version is 3.23.58. When I run php -i from the command line it says it is 4.1.10a. The latter is correct. What would cause the discrepancy? The server has been stopped and started many times, and PHP

Re: [PHP] PHP causes Apache segmentation fault?

2005-03-14 Thread Richard Lynch
PHP I'm already building from Source. Uninstalling all of MySQL doesn't seem to be an option because of that dovecot dependency. What I'd really like to know (among so many other things) is how configure is determining which MySQL it should use. Also knowing the difference between PHP via a

Re: [PHP] PHP causes Apache segmentation fault? [SOLVED]

2005-03-14 Thread John Swartzentruber
On 3/14/2005 1:26 PM Richard Lynch wrote: PHP I'm already building from Source. Uninstalling all of MySQL doesn't seem to be an option because of that dovecot dependency. What I'd really like to know (among so many other things) is how configure is determining which MySQL it should use. Also

Re: [PHP] PHP causes Apache segmentation fault?

2005-03-13 Thread John Swartzentruber
On 3/11/2005 11:57 AM John Swartzentruber wrote: I am running Fedora core3 with Apache 2.0.52 (from default RPMs), MySQL 4.1.10 (from RPMs from MySQL site), and PHP 5.0.3 built from source. I'm going through the PHP manual and trying some of the mysqli examples. The last one I tried didn't

Re: [PHP] PHP causes Apache segmentation fault?

2005-03-13 Thread John Swartzentruber
On 3/13/2005 3:55 PM John Swartzentruber wrote: On 3/11/2005 11:57 AM John Swartzentruber wrote: I am running Fedora core3 with Apache 2.0.52 (from default RPMs), MySQL 4.1.10 (from RPMs from MySQL site), and PHP 5.0.3 built from source. I'm going through the PHP manual and trying some of the

Re: [PHP] PHP causes Apache segmentation fault?

2005-03-11 Thread Burhan Khalid
John Swartzentruber wrote: I am running Fedora core3 with Apache 2.0.52 (from default RPMs), MySQL 4.1.10 (from RPMs from MySQL site), and PHP 5.0.3 built from source. I'm going through the PHP manual and trying some of the mysqli examples. The last one I tried didn't work. The problem appears

Re: [PHP] PHP causes Apache segmentation fault?

2005-03-11 Thread John Swartzentruber
On 3/11/2005 10:33 AM Burhan Khalid wrote: John Swartzentruber wrote: I am running Fedora core3 with Apache 2.0.52 (from default RPMs), MySQL 4.1.10 (from RPMs from MySQL site), and PHP 5.0.3 built from source. I'm going through the PHP manual and trying some of the mysqli examples. The last

Re: [PHP] PHP based Apache admin tool?

2004-12-28 Thread John Nichel
Brian Dunning wrote: Is there any such thing as a PHP based GUI tool for administering Apache? I've searched high low and found nothing. - Brian I don't know of any php based ones, but there's webmin; Perl based. -- By-Tor.com ...it's all about the Rush http://www.by-tor.com -- PHP General

Re: [PHP] PHP or Apache problem?

2004-10-07 Thread Curt Zirzow
* Thus wrote william van der wee: Hi all, I'am using SuSe 9.1 with Apache and PHP. In order to get access to MS SQL server I installed freeTDS ODBC driver. Everything ok, except I can't get it in a PHP webpage. I use in my PHP scripts odbc_connect. ISGL is working. When I look in apache

Re: [PHP] PHP and Apache 2

2004-08-08 Thread Thomas Goyne
On Sun, 8 Aug 2004 16:20:55 +0300, Rosen [EMAIL PROTECTED] wrote: Hi, What is the reason, thath in the installation manual of PHP writes: WARNING: Do not use Apache 2.0 and PHP in a production environment neither on Unix nor on Windows. Thanks, Rosen

Re: [PHP] PHP and Apache Authentication

2004-06-04 Thread Matt Matijevich
[snip] Is there a way to configure apache to include something in every response? [/snip] I think you could use a autoprepend in your php.ini file http://www.php.net/reserved.variables there is a mention of it on the user comments on this page -- PHP General Mailing List

Re: [PHP] PHP 4.3.4, Apache w/ mod_ssl Compile Help

2004-04-05 Thread trlists
On 5 Apr 2004 [EMAIL PROTECTED] wrote: When doing apachectl startssl I get: [Mon Apr 5 12:19:53 2004] [warn] Loaded DSO libexec/libphp4.so uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI) Sorry, I just realized there is a

Re: [PHP] PHP and Apache 2

2004-03-13 Thread Rasmus Lerdorf
On Sat, 13 Mar 2004 [EMAIL PROTECTED] wrote: So the current situation is that Apache2-prefork+PHP is a decent solution but it hasn't been tested a whole lot. I am currently moving my app to an Apache 2 server. I did not build the server (not my area of expertise) and don't know how how it

Re: [PHP] PHP and Apache 2

2004-03-13 Thread trlists
On 13 Mar 2004 Rasmus Lerdorf wrote: I think that is pretty clear. It says that it works but we do not consider it production quality. OK, thanks. That is what I thought it meant but I wanted to be sure. As for whether your particular install will work? I have no idea. Maybe, maybe not.

Re: [PHP] PHP and Apache Using up all memory

2004-03-07 Thread Raditha Dissanayake
] To: Juan E Suris [EMAIL PROTECTED] Cc: [EMAIL PROTECTED] Sent: Saturday, March 06, 2004 11:44 PM Subject: Re: [PHP] PHP and Apache Using up all memory Hi Juan, What you can do is to switch off output buffering. If it is a really large file you might want to generate the file offline and deliver

Re: [PHP] PHP and Apache Using up all memory

2004-03-06 Thread Raditha Dissanayake
Hi Juan, What you can do is to switch off output buffering. If it is a really large file you might want to generate the file offline and deliver it using the more conventional hyperlink. all the best Juan E Suris wrote: Hi! I have a problem with PHP and Apache, where Apache uses up a huge

Re: [PHP] PHP and Apache Using up all memory

2004-03-06 Thread Juan E Suris
Dissanayake [EMAIL PROTECTED] To: Juan E Suris [EMAIL PROTECTED] Cc: [EMAIL PROTECTED] Sent: Saturday, March 06, 2004 11:44 PM Subject: Re: [PHP] PHP and Apache Using up all memory Hi Juan, What you can do is to switch off output buffering. If it is a really large file you might want to generate

Re: [PHP] PHP and Apache 2 (Was: Ver 5.0 Questions ...)

2004-01-22 Thread Chris Shiflett
--- Thomas Svenson [EMAIL PROTECTED] wrote: I am using the pre-forked model in Apache2 yes. So far I haven't noticed any problems with PHP(4/5beta). If the problems with PHP is with the non pre-forked models, then its time to update the recommendation to not run PHP on Apache2. Instead it

RE: [PHP] PHP and Apache 2 (Was: Ver 5.0 Questions ...)

2004-01-22 Thread Thomas Svenson
Chris Shiflett wrote: So, I'm not sure what documentation you're referring to exactly, nor am I sure that there would be a lot of support in updating it. This one: -8. Warning Do not use Apache 2.0 and PHP in a production environment neither on Unix nor on Windows. -8. You

Re: [PHP] PHP or Apache Problem?

2004-01-16 Thread Richard Davey
Hello Nick, Friday, January 16, 2004, 12:39:16 PM, you wrote: NW Line 19 is a simple include() but uses 'http://' rather than a local NW path (i cannot change this)... allow_url_fopen is almost certainly disabled in your php.ini file. -- Best regards, Richard

Re: [PHP] PHP or Apache Problem?

2004-01-16 Thread Nick Wilson
* and then Richard Davey declared Hello Nick, Friday, January 16, 2004, 12:39:16 PM, you wrote: NW Line 19 is a simple include() but uses 'http://' rather than a local NW path (i cannot change this)... allow_url_fopen is almost certainly disabled in your php.ini file. Yes, that

Re: [PHP] PHP or Apache Problem?

2004-01-16 Thread Nick Wilson
* and then Richard Davey declared Why do you have code comments OUTSIDE of the php tags? I can't say for sure, but it wouldn't surprise me if it caused it. I dont. That's just in my email to tell where the code begins ;-) line 1 is just ?php -- Nick W -- PHP General Mailing List

Re: [PHP] php and apache

2003-11-12 Thread John Nichel
Jen wrote: Hi there. New to the PHP space here and I'm trying to set things up. (if I'm on the wrong newsgroup, please let me know...) I've got Apache 1.3.27 running and I have downloaded PHP 4.3.4 on my computer. Next, I created a test.php file which contains: ?php phpinfo(); ? That's it

Re: [PHP] php and apache

2003-11-12 Thread Boyan Nedkov
Jen wrote: Hi there. New to the PHP space here and I'm trying to set things up. (if I'm on the wrong newsgroup, please let me know...) I've got Apache 1.3.27 running and I have downloaded PHP 4.3.4 on my computer. Next, I created a test.php file which contains: ?php phpinfo(); ? That's it

Re: [PHP] php Losing apache environment vars

2003-11-10 Thread Keith Greene
After restarting apache, the error is gone. Still not sure what was causing it. The site was running fine to begin with, and the environment vars have been in use for over a year throughout the site. Keith At 12:56 PM 11/10/2003, Keith Greene wrote: Greetings list, I have run into a problem

RE: [PHP] php and apache...single sign on

2003-09-17 Thread Jay Blanchard
[snip] I would like to piggyback on an Apache realm/dialog authentication and feed these credentials to a mysql connection (or connection to anything else) in my php scripts. Is there a way using the php Apache apis (seems like no) or via apache itself to make these credentials

Re: [PHP] PHP 4.3 Apache 2

2003-01-01 Thread Rasmus Lerdorf
It is still experimental. On Wed, 1 Jan 2003, Scott Seidl wrote: Does the new release of PHP 4.3 have official support with Apache 2.x or is it still considered developmental? Thanks -- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php

Re: [PHP] PHP 4.3 Apache 2

2003-01-01 Thread Tyler Longren
- Original Message - From: Rasmus Lerdorf [EMAIL PROTECTED] To: Scott Seidl [EMAIL PROTECTED] Cc: [EMAIL PROTECTED] Sent: Wednesday, January 01, 2003 10:59 PM Subject: Re: [PHP] PHP 4.3 Apache 2 It is still experimental. On Wed, 1 Jan 2003, Scott Seidl wrote: Does the new release of PHP 4.3 have

RE: [PHP] PHP 4.2.3, Apache 2.0.40, gettext(), and web don't work

2002-12-09 Thread Roedel, Mark
Are you *sure* your Apache module and commandline interpreter were both compiled with the same set of options? Does a phpinfo() call to the Apache module indicate that gettext is enabled there? --- Mark Roedel | Blessed is he who has learned to laugh Systems Programmer| at

Re: [PHP] PHP and Apache

2002-12-04 Thread Adam Williams
Yes On Wed, 4 Dec 2002, Vicente Valero wrote: Excuseme my confussion, I meant PHP 4.2.3. So you suggest me PHP 4.2.3 and Apache 1.3.x?? -- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php

Re: [PHP] PHP and Apache

2002-12-04 Thread Marcus Fazzi
You need Apache 2.0.40 fo uses with PHP 4.2.3, for use with 2.0.43 use PHP 4.3.0 RC2 Excuseme my confussion, I meant PHP 4.2.3. So you suggest me PHP 4.2.3 and Apache 1.3.x?? -- PHP General Mailing List (http://www.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php

RE: [PHP] PHP or Apache problem?

2002-09-12 Thread MET
The detailed answer, I have no idea. The simple answer, currently there compatibility is NOT stable, but will be soon ~ Matthew -Original Message- From: Aaron Gould [mailto:[EMAIL PROTECTED]] Sent: Thursday, September 12, 2002 9:35 AM To: PHP-GENERAL Subject: [PHP] PHP or Apache

Re: [PHP] PHP And Apache

2002-09-11 Thread Rasmus Lerdorf
Use the latest Apache 1.3.x and the latest PHP. Works just fine. Apache 2.0.x is a completely different beast. -Rasmus On Wed, 11 Sep 2002, Glenn wrote: Can anyone tell me if the latest version of PHP works with the latest Apache web server? When I try to build the server it says its not,

Re: [PHP] PHP And Apache

2002-09-11 Thread Glenn
ok then... thanks Rasmus Lerdorf [EMAIL PROTECTED] wrote in message [EMAIL PROTECTED]">news:[EMAIL PROTECTED]... Use the latest Apache 1.3.x and the latest PHP. Works just fine. Apache 2.0.x is a completely different beast. -Rasmus On Wed, 11 Sep 2002, Glenn wrote: Can anyone tell me

Re: [PHP] PHP and Apache

2002-09-06 Thread Steve Edberg
It's certainly _possible_ - Your httpd.conf (I'm assuming you use Apache, of course) file is just a text file that can be read/written like anything else. Then you could do a system('/path/to/apache/bin/apachectl restart'); to activate. Doing it this simply, thoughm means that your

Re: [PHP] PHP MySQL Apache on Linux vs. Solaris

2002-09-05 Thread Adam Williams
Go to www.mysql.com and make sure you are using the latest version of MySQL. Adam On Thu, 5 Sep 2002, Boaz Yahav wrote: Hi Since i moved from a Sun / Solaris Machine to a Compaq / Linux machine I'm having weird problems with MySQL crashing while running reports

RE: [PHP] PHP MySQL Apache on Linux vs. Solaris

2002-09-05 Thread Boaz Yahav
I'm using 3.23.52-log -Original Message- From: Adam Williams [mailto:[EMAIL PROTECTED]] Sent: Thursday, September 05, 2002 3:22 PM To: Boaz Yahav Cc: PHP General (E-mail) Subject: Re: [PHP] PHP MySQL Apache on Linux vs. Solaris Go to www.mysql.com and make sure you are using

RE: [PHP] PHP MySQL Apache on Linux vs. Solaris

2002-09-05 Thread Adam Williams
[mailto:[EMAIL PROTECTED]] Sent: Thursday, September 05, 2002 3:22 PM To: Boaz Yahav Cc: PHP General (E-mail) Subject: Re: [PHP] PHP MySQL Apache on Linux vs. Solaris Go to www.mysql.com and make sure you are using the latest version of MySQL. Adam On Thu, 5 Sep 2002

Re: [PHP] Php and Apache

2002-07-24 Thread S.Murali Krishna
On Wed, 24 Jul 2002, Varsha Agarwal wrote: Hi, I have istalled php from the red hat cd at the time i installed red hat itself. I downloaded apache and installed it. Can anyone tell me how to configure php on apache server? I mean what do I do next to run php scripts? I am totally new to all

Re: [PHP] PHP 4.2.1 / Apache

2002-07-10 Thread Jason Wong
On Wednesday 10 July 2002 17:25, [EMAIL PROTECTED] wrote: HELLO, I just installed PHP 4.2.1. I am using a Redhat 7.3, installed as server with Apache. My problem is I can t compile it as a module for Apache : ./configure --with-apache=/usr/include/apache configure: error: Invalid Apache

Re: [PHP] php and apache path...

2002-07-03 Thread Nightshade
Analysis Solutions wrote: On Tue, Jul 02, 2002 at 10:34:32PM +0200, Nightshade wrote: Analysis Solutions wrote: Document root doensn't solve my problem... ... snip ... Any solution? Read and heed what I already said: Whenever you have a question like this, run phpinfo() and see

Re: [PHP] php and apache path...

2002-07-03 Thread Erik Price
On Wednesday, July 3, 2002, at 11:08 AM, Nightshade wrote: Yea,I understood. But my question is: is right that my Document_root (shown in phpinfo) is /var/www/html/ and not /var/www/html/mysite? And if isn't right where I can change this? I'm not sure -- is that the directory that you

Re: [PHP] PHP and Apache

2002-07-03 Thread Al Baker
[EMAIL PROTECTED] Cc: PHP GEN [EMAIL PROTECTED] Sent: Tuesday, July 02, 2002 12:04 PM Subject: Re: [PHP] PHP and Apache No. Only you. :-) Platform? Environment? Configuration information? ..mike.. On Tue, 2002-07-02 at 11:01, B i g D o g wrote: Has anyone had a problem where

Re: [PHP] php and apache path...

2002-07-02 Thread Analysis Solutions
On Tue, Jul 02, 2002 at 03:47:20PM +0200, Nightshade wrote: is there a unix like ~/ , to access to root directory of my site Does $_SERVER['DOCUMENT_ROOT'] help? Whenever you have a question like this, run phpinfo() and see what's there which produces the variable you're looking for. --Dan

Re: [PHP] PHP and Apache

2002-07-02 Thread Michael Sweeney
No. Only you. :-) Platform? Environment? Configuration information? ..mike.. On Tue, 2002-07-02 at 11:01, B i g D o g wrote: Has anyone had a problem where PHP created to many open files and crashed apache? B i g D o g -- PHP General Mailing List (http://www.php.net/) To

Re: [PHP] PHP and Apache

2002-07-02 Thread B i g D o g
Message - From: Michael Sweeney [EMAIL PROTECTED] To: B i g D o g [EMAIL PROTECTED] Cc: PHP GEN [EMAIL PROTECTED] Sent: Tuesday, July 02, 2002 12:04 PM Subject: Re: [PHP] PHP and Apache No. Only you. :-) Platform? Environment? Configuration information? ..mike.. On Tue, 2002-07-02 at 11

Re: [PHP] php and apache path...

2002-07-02 Thread Nightshade
Analysis Solutions wrote: On Tue, Jul 02, 2002 at 03:47:20PM +0200, Nightshade wrote: is there a unix like ~/ , to access to root directory of my site Does $_SERVER['DOCUMENT_ROOT'] help? Whenever you have a question like this, run phpinfo() and see what's there which produces the

Re: [PHP] php and apache path...

2002-07-02 Thread Analysis Solutions
On Tue, Jul 02, 2002 at 09:55:13PM +0200, Nightshade wrote: Do you advice me to use $_SERVER['DOCUMENT_ROOT'] . remaining_path/ in all my files? I use relative paths in most circumstances. Makes things easier to move between my development machine and the actual web servers. Enjoy,

Re: [PHP] php and apache path...

2002-07-02 Thread Nightshade
Analysis Solutions wrote: On Tue, Jul 02, 2002 at 03:47:20PM +0200, Nightshade wrote: is there a unix like ~/ , to access to root directory of my site Does $_SERVER['DOCUMENT_ROOT'] help? Whenever you have a question like this, run phpinfo() and see what's there which produces the

Re: [PHP] php and apache path...

2002-07-02 Thread Analysis Solutions
On Tue, Jul 02, 2002 at 10:34:32PM +0200, Nightshade wrote: Analysis Solutions wrote: Document root doensn't solve my problem... ... snip ... Any solution? Read and heed what I already said: Whenever you have a question like this, run phpinfo() and see what's there which produces the

Re: [PHP] php and apache path...

2002-07-02 Thread Justin French
In your config file (or at the top of each page) you should establish what your document root is: $docroot = /usr/home/sitename/;# or whatever Then do something like include({$docroot}inc_dir/file.inc); Or maybe you specify an include directory in your config: $incdir =

Re: [PHP] PHP on Apache 2.0 -- Does it work?

2002-04-07 Thread Steve Magruder, D2 Director
Thanks for the info. Apache 1.3.24 isn't a bad release to be stuck with. :) I just wanted to be a little bit on the bleeding edge. Regards, Steve Tyler Longren [EMAIL PROTECTED] wrote in message 004001c1ddf3$13d82b90$0101a8c0@nightengale">news:004001c1ddf3$13d82b90$0101a8c0@nightengale...

Re: [PHP] PHP on Apache 2.0 -- Does it work?

2002-04-06 Thread Tyler Longren
Well, php 4.1.2 for windows probably wasn't compiled to work with apache 2. Apache 2 has changed too much for the php developers to keep on top of it. If you were using unix/linux, you could compile php to work with apache 2, but since you're using Windows, you're stuck with using Apache 1.3.24

Re: [PHP] PHP and Apache Win32

2002-03-01 Thread [EMAIL PROTECTED]
Yes, you have got a few thing mixed up, to be exact DSO and CGI The DSO module containing the PHP engine is loaded into Apache, and therefore it doesn't the CGI version (phpexe) anymore So 'ScriptAlias' is only needed for CGI installations, and you don't need the 'Directory' part either All

Re: [PHP] PHP and Apache authorization: how to logout. Help!

2002-02-04 Thread LaserJetter
Cc: Aras Kucinskas [EMAIL PROTECTED]; [EMAIL PROTECTED] Sent: Saturday, February 02, 2002 8:26 PM Subject: RE: [PHP] PHP and Apache authorization: how to logout. Help! On Fri, 1 Feb 2002, Matthew Walker wrote: Does anyone have the answer for this question? I need it too... As I learnt befo

RE: [PHP] PHP and Apache authorization: how to logout. Help!

2002-02-02 Thread Rodolfo Gonzalez
On Fri, 1 Feb 2002, Matthew Walker wrote: Does anyone have the answer for this question? I need it too... As I learnt before, it's not possible without closing the user's browser. My site is in directory which is protected with .htaccess file. I want to develope a logout function, which can

Re: [PHP] PHP and Apache authorization: how to logout. Help!

2002-02-02 Thread Frederick L. Steinkopf
Kucinskas [EMAIL PROTECTED]; [EMAIL PROTECTED] Sent: Saturday, February 02, 2002 8:26 PM Subject: RE: [PHP] PHP and Apache authorization: how to logout. Help! On Fri, 1 Feb 2002, Matthew Walker wrote: Does anyone have the answer for this question? I need it too... As I learnt before, it's

RE: [PHP] PHP and Apache authorization: how to logout. Help!

2002-02-01 Thread Matthew Walker
Does anyone have the answer for this question? I need it too... Matthew Walker Ecommerce Project Manager Mountain Top Herbs -Original Message- From: Aras Kucinskas [mailto:[EMAIL PROTECTED]] Sent: Thursday, January 31, 2002 10:39 AM To: [EMAIL PROTECTED] Subject: [PHP] PHP and Apache

RE: [PHP] PHP and Apache authorization: how to logout. Help!

2002-02-01 Thread Matthew Walker
I've done some investigating on my own. There is no way to do this. Period. Matthew Walker Ecommerce Project Manager Mountain Top Herbs -Original Message- From: Matthew Walker Sent: Friday, February 01, 2002 3:37 PM To: Aras Kucinskas; [EMAIL PROTECTED] Subject: RE: [PHP] PHP

RE: [PHP] PHP and Apache authorization: how to logout. Help!

2002-02-01 Thread Lazor, Ed
Even with a javascript function opening a new window and closing the old? -Original Message- From: Matthew Walker [mailto:[EMAIL PROTECTED]] Sent: Friday, February 01, 2002 3:42 PM To: Aras Kucinskas; [EMAIL PROTECTED] Subject: RE: [PHP] PHP and Apache authorization: how to logout. Help

RE: [PHP] PHP and Apache authorization: how to logout. Help!

2002-02-01 Thread Matthew Walker
: RE: [PHP] PHP and Apache authorization: how to logout. Help! Even with a javascript function opening a new window and closing the old? -Original Message- From: Matthew Walker [mailto:[EMAIL PROTECTED]] Sent: Friday, February 01, 2002 3:42 PM To: Aras Kucinskas; [EMAIL PROTECTED] Subject

RE: [PHP] PHP and Apache authorization: how to logout. Help!

2002-02-01 Thread Ken
At 03:41 PM 2/1/02 -0800, Lazor, Ed wrote: Even with a javascript function opening a new window and closing the old? -Original Message- From: Matthew Walker [mailto:[EMAIL PROTECTED]] Sent: Friday, February 01, 2002 3:42 PM I've done some investigating on my own. There is no way to do

Re: [PHP] PHP 4.1.1 + Apache 2.0.30 Ouput Filter....

2002-01-02 Thread Austin Gonyou
Ok. I fixed it. I just had my filters jacked up. After fixing them using \.php instead of *.php, I was then calling the wrong page and getting a 404, plus the browser I was using had cached the content-type and was screwing everything up. After just shutting down my browsers, dumping cache,

Re: [PHP] PHP and Apache

2001-08-13 Thread Rasmus Lerdorf
I was wondering if any of you had a problem compiling Apache 1.3.20 with mod_php4? Because I can compile, make, make install for redhat 7.1 for php 4.0.6. When I run my configure script for apache i have --activate-module=src/modules/php4/libmodphp.a as one of the lines in the script. I

Re: [PHP] PHP and Apache

2001-08-13 Thread Jay Paulson
yeah i've tried that too and i still get the same error(s) From: Rasmus Lerdorf [EMAIL PROTECTED] To: Jay Paulson [EMAIL PROTECTED] CC: PHP [EMAIL PROTECTED] Subject: Re: [PHP] PHP and Apache Date: Mon, 13 Aug 2001 12:07:39 -0700 (PDT) I was wondering if any of you had a problem compiling

Re: [PHP] PHP and Apache

2001-08-13 Thread Rasmus Lerdorf
] To: Jay Paulson [EMAIL PROTECTED] CC: PHP [EMAIL PROTECTED] Subject: Re: [PHP] PHP and Apache Date: Mon, 13 Aug 2001 12:07:39 -0700 (PDT) I was wondering if any of you had a problem compiling Apache 1.3.20 with mod_php4? Because I can compile, make, make install for redhat 7.1

RE: [PHP] PHP and Apache on OS X insight?

2001-07-19 Thread Jack Dempsey
Hi Michael, I run an OS X server with Apache, PHP, and MySQL. We have mostly Apple's in the office, with a few pc's scattered around. What reasons do you have for going with a Mac. I'll tell you this: its easier to deal with linux/unix as far as installation, upgrading, etc. However, there is an

Re: [PHP] PHP as apache module and security.

2001-05-06 Thread Estelle Martin
Hi, What do you think about the following configuration: 1) safe-mode on : this ensures that a php script can read only files that are owned by the same Unix user on the machine; then just check that people having a right to use php and mysql on your box have all a different corresponding Unix

Re: [PHP] PHP as apache module and security.

2001-05-06 Thread Andrzej Swedrzynski
On Sun, 6 May 2001, Estelle Martin wrote: What do you think about the following configuration: 1) safe-mode on : this ensures that a php script can read only files that are owned by the same Unix user on the machine; then just check that people having a right to use php and mysql on your

Re: [PHP] PHP for Apache 2.0

2001-04-18 Thread August Zajonc
- Original Message - From: "Alexander Wagner" [EMAIL PROTECTED] Newsgroups: php.general Sent: Saturday, April 14, 2001 11:07 AM Subject: Re: [PHP] PHP for Apache 2.0 Patrick Dunford wrote: According to Apache, modules made for Apache 1.3 will not work as-is in 2.0 due

Re: [PHP] PHP for Apache 2.0

2001-04-14 Thread Alexander Wagner
Patrick Dunford wrote: According to Apache, modules made for Apache 1.3 will not work as-is in 2.0 due to changes in the API. Is a version of PHP 4 for Apache 2.0 coming out? Try the configure-option --with-apxs2 instead of --with-apxs and it should work with Apache 2. PHP 4 supports far

RE: [PHP] php and apache protected directories

2001-02-26 Thread Krznaric Michael
Yes, try lib cURL it supports authentification and even SSL. http://www.php.net/manual/en/ref.curl.php Mike -Original Message- From: Marius David [mailto:[EMAIL PROTECTED]] Sent: Friday, February 23, 2001 5:33 PM To: [EMAIL PROTECTED] Subject: [PHP] php and apache protected directories

Re: [PHP] (PHP+Linux+Apache+MySQL)+(Windows+Explorer)

2001-01-18 Thread Ignacio Vazquez-Abrams
On Thu, 18 Jan 2001, Andrs de la Varga wrote: Can I have (PHP+Linux+Apache+MySQL)+(Windows+Explorer) in the same machine to develope stand alone? Andrs de la Varga http://www.vmware.com/ -- Ignacio Vazquez-Abrams [EMAIL PROTECTED] -- PHP General Mailing List (http://www.php.net/) To

Re: [PHP] (PHP+Linux+Apache+MySQL)+(Windows+Explorer)

2001-01-18 Thread jeremy brand
Cc: [EMAIL PROTECTED] Subject: Re: [PHP] (PHP+Linux+Apache+MySQL)+(Windows+Explorer) On Thu, 18 Jan 2001, Andrs de la Varga wrote: Can I have (PHP+Linux+Apache+MySQL)+(Windows+Explorer) in the same machine to develope stand alone? Andrs de la Varga http://www.vmware.com/ --