Re: [PHP] upgrading error

2002-08-14 Thread EdwardSPL

If you want to upgrade php by RPM packages, you may try this site :

http://rpms.arvin.dk/php/source/

Alex Shi wrote:

 I have PHP 4.0.4p11 on RH Linux 7.1. Today I downloaded PHP 4.1.2-7
 rpm packages (10 packages) from RH web site. These packages are
 come with RH Linux 7.3. I don't want to upgrade Linux but just upgrade
 PHP so I tried rpm -Uvh php-4.1.2-7.i386.rpm.

 I got following error message:

 error: failed dependencies:
 libcrypto.so.2   is needed by php-4.1.2-7
 libcurl.so.2   is needed by php-4.1.2-7
 libdb-3.3.so   is needed by php-4.1.2-7
 libltdl.so.3   is needed by php-4.1.2-7
 libmm.so.11   is needed by php-4.1.2-7
 libpspell.so.4   is needed by php-4.1.2-7
 libssl.so.2   is needed by php-4.1.2-7
 libxml2.so.2   is needed by php-4.1.2-7
 php = 4.0.4pl1-9 is needed by php-imap-4.0.4pl1-9
 php = 4.0.4pl1-9 is needed by php-ldap-4.0.4pl1-9
 php = 4.0.4pl1-9 is needed by php-mysql-4.0.4pl1-9
 php = 4.0.4pl1-9 is needed by php-pgsql-4.0.4pl1-9
 php = 4.0.4pl1-9 is needed by php-manual-4.0.4pl1-9

 Any idea? Seems like it is impossible to directly upgrade from 4.0.4
 to 4.1.2-7Please advice. Thanks in advace!

 Alex
 --
 ---
 TrafficBuilder Network:
 http://www.bestadv.net/index.cfm?ref=7029

 --
 PHP General Mailing List (http://www.php.net/)
 To unsubscribe, visit: http://www.php.net/unsub.php



-- 
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php




Re: [PHP] upgrading error

2002-08-13 Thread @ Edwin
Just a thought...

If you have downloaded 10 packages perhaps you need to upgrade ALL of them 
AT THE SAME TIME.

So, instead of doing:

rpm -Uvh php-4.1.2-7.i386.rpm.

Try this:

1. Put all packages in the same folder
2. rpm -Fvh *.rpm

The "F" (instead of "U") updates all INSTALLED packages only.

I didn't really check but it might work. If not, perhaps, you need to have 
more packages other than the ones you've already downloaded...

- E


I have PHP 4.0.4p11 on RH Linux 7.1. Today I downloaded PHP 4.1.2-7
rpm packages (10 packages) from RH web site. These packages are
come with RH Linux 7.3. I don't want to upgrade Linux but just upgrade
PHP so I tried rpm -Uvh php-4.1.2-7.i386.rpm.

I got following error message:

error: failed dependencies:
 libcrypto.so.2   is needed by php-4.1.2-7
 libcurl.so.2   is needed by php-4.1.2-7
 libdb-3.3.so   is needed by php-4.1.2-7
 libltdl.so.3   is needed by php-4.1.2-7
 libmm.so.11   is needed by php-4.1.2-7
 libpspell.so.4   is needed by php-4.1.2-7
 libssl.so.2   is needed by php-4.1.2-7
 libxml2.so.2   is needed by php-4.1.2-7
 php = 4.0.4pl1-9 is needed by php-imap-4.0.4pl1-9
 php = 4.0.4pl1-9 is needed by php-ldap-4.0.4pl1-9
 php = 4.0.4pl1-9 is needed by php-mysql-4.0.4pl1-9
 php = 4.0.4pl1-9 is needed by php-pgsql-4.0.4pl1-9
 php = 4.0.4pl1-9 is needed by php-manual-4.0.4pl1-9

Any idea? Seems like it is impossible to directly upgrade from 4.0.4
to 4.1.2-7Please advice. Thanks in advace!

Alex
--
---
TrafficBuilder Network:
http://www.bestadv.net/index.cfm?ref=7029


--
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php





_
ウィルスメール、迷惑メール対策なら MSN Hotmail http://www.hotmail.com/JA


-- 
PHP General Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php