[Piglit] [PATCH 13/15] arb_gpu_shader_int64: test two operands with indirect access simultaneously

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle This hits a bug in Mesa st/glsl_to_tgsi. --- .../indirect-array-two-accesses.shader_test| 61 ++ 1 file changed, 61 insertions(+) create mode 100644

[Piglit] [PATCH 11/15] glsl-1.50/linker: add explicit "link success" line to test section

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle --- .../linker/versions-mingled-multiple-shader-objects.shader_test| 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/tests/spec/glsl-1.50/linker/versions-mingled-multiple-shader-objects.shader_test

[Piglit] [PATCH 05/15] ext_framebuffer_multisample-interpolation: fix single-sample centroid-edges

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle When num_samples == 0, the centroid qualifier is ignored. --- tests/spec/ext_framebuffer_multisample/interpolation.cpp | 12 +--- 1 file changed, 9 insertions(+), 3 deletions(-) diff --git

[Piglit] [PATCH 04/15] adj-prims: beef up the test to tease out what nvidia hardware does

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle --- tests/spec/gl-3.2/adj-prims.c | 144 +- 1 file changed, 128 insertions(+), 16 deletions(-) diff --git a/tests/spec/gl-3.2/adj-prims.c b/tests/spec/gl-3.2/adj-prims.c index f4479c708..6faff74d2 100644 ---

[Piglit] [PATCH 14/15] arb_gpu_shader_fp64: add tests for frexp() corner cases

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle The only-{exponent,mantissa} tests hit a bug in Mesa's st/glsl_to_tgsi. --- .../fs-frexp-dvec4-only-exponent.shader_test | 37 + .../fs-frexp-dvec4-only-mantissa.shader_test | 38 +

[Piglit] [PATCH 09/15] arb_texture_query_levels: rename VS input to piglit_vertex

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle Using 'vertex' relies on undefined behavior, since shader_runner does not setup that attribute explicitly. --- .../spec/arb_texture_query_levels/execution/vs-baselevel.shader_test | 4 ++--

[Piglit] [PATCH 15/15] arb_tessellation_shader: add a test with an array in a struct in a per-vertex TCS out

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle This currently hits a bug in Mesa's GLSL-to-TGSI conversion. --- .../tcs-tes-array-in-struct.shader_test| 78 ++ 1 file changed, 78 insertions(+) create mode 100644

[Piglit] [PATCH 08/15] glsl-1.20/fs-structure: remove stray varying

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle --- .../glsl-1.20/execution/uniform-initializer/fs-structure.shader_test | 1 - 1 file changed, 1 deletion(-) diff --git a/tests/spec/glsl-1.20/execution/uniform-initializer/fs-structure.shader_test

[Piglit] [PATCH 01/15] arb_gpu_shader5: add interpolateAt* tests with input in a struct

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle The fact that this should be allowed was clarified in GLSL 4.60. --- .../fs-interpolateAtCentroid-struct.shader_test| 59 .../fs-interpolateAtOffset-struct.shader_test | 63 ++

[Piglit] [PATCH 02/15] glsl-4.40: add tests for interpolateAt* with swizzles / array subscripts on vectors

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle For swizzles, the language changed in GLSL 4.40. For array subscripts, it's not entirely clear whether the clarification wrt interpolant being an l-value should be backdated even earlier or not. Keeping it a 4.40 test should be enough for practical

[Piglit] [PATCH 12/15] arb_shader_ballot: add missing extension

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle --- tests/spec/arb_shader_ballot/execution/fs-ballot.shader_test | 1 + 1 file changed, 1 insertion(+) diff --git a/tests/spec/arb_shader_ballot/execution/fs-ballot.shader_test b/tests/spec/arb_shader_ballot/execution/fs-ballot.shader_test index

[Piglit] [PATCH 03/15] gl-3.2/adj-prims: fix expected vertex order for triangle strips with adjacency

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle The first two vertices are swapped for triangle strips with adjacency; see Table 10.1 of the OpenGL 4.5 (Compatibility Profile) spec. --- tests/spec/gl-3.2/adj-prims.c | 18 +- 1 file changed, 13 insertions(+), 5 deletions(-) diff

[Piglit] [PATCH 06/15] shader_tests: move input/output declarations above functions

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle The SPIRV conversion script gets confused otherwise. --- tests/shaders/glsl-vs-max-array-access-function.shader_test | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/tests/shaders/glsl-vs-max-array-access-function.shader_test

[Piglit] [PATCH 07/15] fs-inout-index-two-level: remove unnecessary and incorrect varying

2018-03-26 Thread Marek Olšák
From: Nicolai Hähnle --- .../shaders/out-parameter-indexing/fs-inout-index-two-level.shader_test | 1 - 1 file changed, 1 deletion(-) diff --git a/tests/shaders/out-parameter-indexing/fs-inout-index-two-level.shader_test

Re: [Piglit] [PATCH] Add support for Crucible

2018-03-26 Thread Dylan Baker
Quoting Juan A. Suarez Romero (2018-03-23 04:37:16) > Allow to run Crucible testsuite from piglit > > Signed-off-by: Juan A. Suarez Romero > --- > tests/crucible.py | 84 > +++ > 1 file changed, 84 insertions(+) > create

Re: [Piglit] [PATCH v3 1/1] framework: change one missed core.checkDir call to core.check_dir

2018-03-26 Thread Dylan Baker
Quoting Petri Latvala (2018-03-26 02:51:08) > > > On 03/23/2018 06:11 PM, Dylan Baker wrote: > > Quoting Petri Latvala (2018-03-23 03:11:10) > >> Commit 5e699e402a8b ("framework: rename core.checkDir to > >> core.check_dir") missed one call to checkDir in summary/feature. Also > >> convert the

Re: [Piglit] [PATCH] Fix piglit_probe_pixel_rgb on GLES2

2018-03-26 Thread Brian Paul
On 03/25/2018 01:49 PM, Rhys Perry wrote: GLES2 requires GL_RGBA to be used with GL_UNSIGNED_BYTE in glReadPixels --- tests/util/piglit-util-gl.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/tests/util/piglit-util-gl.c b/tests/util/piglit-util-gl.c index

Re: [Piglit] [PATCH v3 1/1] framework: change one missed core.checkDir call to core.check_dir

2018-03-26 Thread Petri Latvala
On 03/23/2018 06:11 PM, Dylan Baker wrote: Quoting Petri Latvala (2018-03-23 03:11:10) Commit 5e699e402a8b ("framework: rename core.checkDir to core.check_dir") missed one call to checkDir in summary/feature. Also convert the exception raised to PiglitFatalError. v2: Added exception changes