IOBuffer usability

2014-09-17 Thread Martin Nilsson (Opera Mini - AFK!) @ Pike (-) developers forum
I changed part of the ASN1 decoder to use IOBuffer. Some comments - Stdio.IOBuffer is harder to type than ADT.struct. Can we rename it to Stdio.Buffer? There is already IO in Stdio. - get_ is shorter than read_. I'm on the fence on if this is a good change though. - read_buffer dosn't

IOBuffer usability

2014-09-17 Thread Martin Nilsson (Opera Mini - AFK!) @ Pike (-) developers forum
- There are add_int8 and add_byte, but no read_byte. - The implementation of add_int8 and add_byte are copies. If we should keep two methods (I'm not convinced), we could make the method registration point to the same C function instead.

IOBuffer usability

2014-09-17 Thread Martin Nilsson (Opera Mini - AFK!) @ Pike (-) developers forum
The program id part of CMOD is a bit too losely defined. If I change IOBuffer to Buffer it becomes a String.Buffer since the code only concerns itself with the class name. That's a bit dangerous.

IOBuffer usability

2014-09-17 Thread Per Hedbor () @ Pike (-) developers forum
- Stdio.IOBuffer is harder to type than ADT.struct. Can we rename it to Stdio.Buffer? There is already IO in Stdio. I tried Stdio.Buffer but then all types suddenly became String.Buffer. I could not, at that time at least, be bothered to fix the precompiler... - read_buffer dosn't return