Re: Bug#629592: cyrus-common-2.2: confusing/contradictory information on lenny-squeeze upgrade

2011-06-08 Thread Ondřej Surý
Hi Ross, unfortunately it won't be fixed in lenny/squeeze, but I already wrote an upgrade script for squeeze-wheezy. You can find it here: http://anonscm.debian.org/gitweb/?p=pkg-cyrus-imapd/cyrus-imapd-2.4.git;a=blob;f=debian/cyrus-upgrade-db;h=c7d8d55b99982b5df97e5a875d3809a9d593228c;hb=HEAD

Bug#629592: cyrus-common-2.2: confusing/contradictory information on lenny-squeeze upgrade

2011-06-08 Thread Ondřej Surý
Slight correction, better use always the latest version of the script: http://anonscm.debian.org/gitweb/?p=pkg-cyrus-imapd/cyrus-imapd-2.4.git;a=blob;f=debian/cyrus-upgrade-db (i.e. without the hash) O. On Wed, Jun 8, 2011 at 08:47, Ondřej Surý ond...@sury.org wrote: Hi Ross, unfortunately

Bug#629592: cyrus-common-2.2: confusing/contradictory information on lenny-squeeze upgrade

2011-06-08 Thread Ondřej Surý
On Wed, Jun 8, 2011 at 10:02, Ross Boylan r...@biostat.ucsf.edu wrote: On Wed, 2011-06-08 at 08:54 +0200, Ondřej Surý wrote: Slight correction, better use always the latest version of the script:

Bug#629592: cyrus-common-2.2: confusing/contradictory information on lenny-squeeze upgrade

2011-06-08 Thread Ross Boylan
On Wed, 2011-06-08 at 08:54 +0200, Ondřej Surý wrote: Slight correction, better use always the latest version of the script: http://anonscm.debian.org/gitweb/?p=pkg-cyrus-imapd/cyrus-imapd-2.4.git;a=blob;f=debian/cyrus-upgrade-db (i.e. without the hash) O. Do you think that script will

Bug#629603: Acknowledgement (cyrus-common-2.4: Fails to upgrade to 2.4.9~beta1-1)

2011-06-08 Thread Steven Kurylo
I've attached two patches. The first once changes grep to exclude the *_path options in lib/imapoptions. This ensures cyrus-db-types.txt is generated correctly. Next, cyrus-common-2.4.postinst was only setting RET if upgrade-db failed. So RET was null in the case statement, triggering the