[postgis] tag debian/postgis-2.1.4+dfsg-1 created (now b8a83a9)

2014-10-01 Thread Markus Wanner
This is an automated email from the git hooks/post-receive script.

markus_wanner-guest pushed a change to tag debian/postgis-2.1.4+dfsg-1
in repository postgis.

at  b8a83a9   (commit)
No new revisions were added by this update.

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/postgis.git

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[postgis] branch master updated (b8a83a9 - d4a8cb6)

2014-10-15 Thread Markus Wanner
This is an automated email from the git hooks/post-receive script.

markus_wanner-guest pushed a change to branch master
in repository postgis.

  from  b8a83a9   Finalize 2.1.4+dfsg-1 for upload to unstable.
   new  d4a8cb6   Add Dutch translation by Frans Spiesschaert.

The 1 revisions listed above as new are entirely new to this
repository and will be described in separate emails.  The revisions
listed as adds were already present in the repository and have only
been added to this reference.


Summary of changes:
 debian/changelog   |  6 ++
 debian/po/{it.po = nl.po} | 41 -
 2 files changed, 26 insertions(+), 21 deletions(-)
 copy debian/po/{it.po = nl.po} (60%)

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/postgis.git

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[postgis] 01/01: Add Dutch translation by Frans Spiesschaert.

2014-10-15 Thread Markus Wanner
This is an automated email from the git hooks/post-receive script.

markus_wanner-guest pushed a commit to branch master
in repository postgis.

commit d4a8cb6ba110c6d044fe05b96362b8e98c9db4bf
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Oct 15 11:09:04 2014 +0200

Add Dutch translation by Frans Spiesschaert.
---
 debian/changelog |  6 +
 debian/po/nl.po  | 68 
 2 files changed, 74 insertions(+)

diff --git a/debian/changelog b/debian/changelog
index 344bbde..bfa8db7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+postgis (2.1.4+dfsg-2) unstable; urgency=medium
+
+  * Add Dutch translation by Frans Spiesschaert. Closes: #765409.
+
+ -- Markus Wanner mar...@bluegap.ch  Wed, 15 Oct 2014 10:58:52 +0200
+
 postgis (2.1.4+dfsg-1) unstable; urgency=medium
 
   [ Paulo Flabiano Smorigo ]
diff --git a/debian/po/nl.po b/debian/po/nl.po
new file mode 100644
index 000..5f22a1c
--- /dev/null
+++ b/debian/po/nl.po
@@ -0,0 +1,68 @@
+# Dutch translation of postgis debconf templates
+# Copyright (C) 2014 Markus Wanner mar...@bluegap.ch
+# This file is distributed under the same license as the postgis package.
+# Frans Spiesschaert frans.spiesscha...@yucom.be, 2014.
+#
+msgid 
+msgstr 
+Project-Id-Version: postgis\n
+Report-Msgid-Bugs-To: post...@packages.debian.org\n
+POT-Creation-Date: 2014-04-07 13:24+0200\n
+PO-Revision-Date: 2014-10-03 16:35+0200\n
+Last-Translator: Frans Spiesschaert frans.spiesscha...@yucom.be\n
+Language-Team: Debian Dutch l10n Team debian-l10n-du...@lists.debian.org\n
+Language: nl\n
+MIME-Version: 1.0\n
+Content-Type: text/plain; charset=UTF-8\n
+Content-Transfer-Encoding: 8bit\n
+Plural-Forms: nplurals=2; plural=(n != 1);\n
+
+#. Type: note
+#. Description
+#. Translators, note that @PGVERSION@ will automatically get replaced.
+#: ../postgresql-generic-postgis-2.0-scripts.templates:1001
+msgid PostGIS 2.0 has been deprecated - please migrate your databases
+msgstr PostGIS 2.0 is vervallen - gelieve uw gegevensbestanden om te zetten
+
+#. Type: note
+#. Description
+#. Translators, note that @PGVERSION@ will automatically get replaced.
+#: ../postgresql-generic-postgis-2.0-scripts.templates:1001
+msgid 
+The package postgresql-@PGVERSION@-postgis-2.0-scripts is installed on this 
+system, which means you likely use the PostGIS extension in some databases.
+msgstr 
+Op dit systeem is het pakket postgresql-@PGVERSION@-postgis-2.0-scripts 
+geïnstalleerd. Dit betekent wellicht dat u in sommige gegevensbestanden de 
+PostGIS-uitbreiding gebruikt.
+
+#. Type: note
+#. Description
+#. Translators, note that @PGVERSION@ will automatically get replaced.
+#: ../postgresql-generic-postgis-2.0-scripts.templates:1001
+msgid 
+Debian is now shipping PostGIS version 2.1 and dropped support for 2.0, 
+meaning bug or security fixes will no longer be provided for the older one. 
+Thus it is strongly recommended to migrate all databases to PostGIS 2.1 as 
+soon as possible.
+msgstr 
+Debian distribueert nu versie 2.1 van PostGIS en ondersteunt versie 2.0 niet 
+langer. Dit houdt in dat bugs en veiligheidslekken niet langer gerepareerd 
+worden voor de oude versie. Het is dus ten zeerste aanbevolen om zo snel 
+mogelijk alle gegevensbestanden om te zetten naar PostGIS 2.1.
+
+#. Type: note
+#. Description
+#. Translators, note that @PGVERSION@ will automatically get replaced.
+#: ../postgresql-generic-postgis-2.0-scripts.templates:1001
+msgid 
+Of course, databases that are already using PostGIS 2.0 will continue to 
+work. Note, however, that with this upgrade it's no longer possible to 
+create version 2.0 of the extension PostGIS. Instead, 'CREATE EXTENSION 
+postgis;' will now give you version 2.1. Note that this also affects backups.
+msgstr 
+Gegevensbestanden die al gebruik maken van PostGIS 2.0 zullen wel 
+functioneel blijven. Maar merk op dat het met deze opwaardering niet langer 
+mogelijk is om een PostGIS-uitbreiding aan te maken in het formaat van 
+versie 2.0. Met 'CREATE EXTENSION postgis;' zult u nu het formaat van versie 
+2.1 krijgen. Merk ook op dat dit eveneens invloed heeft op reservekopieën.

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/postgis.git

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

[postgis] branch master updated (d4a8cb6 - f9f8bdc)

2014-10-16 Thread Markus Wanner
This is an automated email from the git hooks/post-receive script.

markus_wanner-guest pushed a change to branch master
in repository postgis.

  from  d4a8cb6   Add Dutch translation by Frans Spiesschaert.
   new  f9f8bdc   Bump S-V.

The 1 revisions listed above as new are entirely new to this
repository and will be described in separate emails.  The revisions
listed as adds were already present in the repository and have only
been added to this reference.


Summary of changes:
 debian/changelog  | 1 +
 debian/control| 2 +-
 debian/control.in | 2 +-
 3 files changed, 3 insertions(+), 2 deletions(-)

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/postgis.git

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[postgis] tag debian/postgis-2.1.4+dfsg-2 created (now f9f8bdc)

2014-10-16 Thread Markus Wanner
This is an automated email from the git hooks/post-receive script.

markus_wanner-guest pushed a change to tag debian/postgis-2.1.4+dfsg-2
in repository postgis.

at  f9f8bdc   (commit)
This tag includes the following new commits:

   new  f9f8bdc   Bump S-V.

The 1 revisions listed above as new are entirely new to this
repository and will be described in separate emails.  The revisions
listed as adds were already present in the repository and have only
been added to this reference.


-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/postgis.git

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[postgis] 01/01: Bump S-V.

2014-10-16 Thread Markus Wanner
This is an automated email from the git hooks/post-receive script.

markus_wanner-guest pushed a commit to branch master
in repository postgis.

commit f9f8bdca4be72c134827fe9b22a5b391528c8045
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Oct 16 11:22:05 2014 +0200

Bump S-V.
---
 debian/changelog  | 1 +
 debian/control| 2 +-
 debian/control.in | 2 +-
 3 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index bfa8db7..513c6d5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
 postgis (2.1.4+dfsg-2) unstable; urgency=medium
 
   * Add Dutch translation by Frans Spiesschaert. Closes: #765409.
+  * Bump S-V: no changes required.
 
  -- Markus Wanner mar...@bluegap.ch  Wed, 15 Oct 2014 10:58:52 +0200
 
diff --git a/debian/control b/debian/control
index aa1e1c0..d1febd3 100644
--- a/debian/control
+++ b/debian/control
@@ -20,7 +20,7 @@ Build-Depends-Indep: default-jdk,
  libsurefire-java, libmaven-compiler-plugin-java,
  libmaven-resources-plugin-java,
  libmaven-javadoc-plugin-java
-Standards-Version: 3.9.5
+Standards-Version: 3.9.6
 Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git
 Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
diff --git a/debian/control.in b/debian/control.in
index c3147bf..7f82c74 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -20,7 +20,7 @@ Build-Depends-Indep: default-jdk,
  libsurefire-java, libmaven-compiler-plugin-java,
  libmaven-resources-plugin-java,
  libmaven-javadoc-plugin-java
-Standards-Version: 3.9.5
+Standards-Version: 3.9.6
 Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git
 Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/postgis.git

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


frequent buildd issues with postgis

2014-10-20 Thread Markus Wanner
Hi,

the postgis package quite frequently fails to build on mips and/or
mipsel buildd boxes. That was the case for the last two uploads, both
blocking migration to testing.

The issue clearly is intermittent and I suspect it's memory related.
However, fact is that there's a clear pattern of which buildd boxes
could and which couldn't build the package is the past. Since 2.1.1-4
[0], the following boxes have constantly built postgis successfully:

eberlin (mipsel, 7x)
corelli (mips, 6x)
lucatelli (mips, 4x)
eysler (mipsel, 2x)

These constantly failed:

rem (mipsel, 4x)
mayer (mipsel, 2x)
ball (mips, 2x)
swarm (mips, 1x)

I didn't find a single machine that switched between successes and
failures, since that point in time.

I'm currently unable to find any information about these machines; like
how much memory each has (db.debian.org seems down). However, maybe you
can see a pattern right away?

If so, can you establish some kind of rule to make wanna-build chose
known-good buildd machines? So that builds are more likely to succeed in
the future?

And for now: Can you please trigger a rebuild of the latest postgis
revision on mipsel, so 2.1.4 can migrate to testing (before the freeze)?

Thanks in advance.

Regards

Markus Wanner


[0]: We had portability issues in the past. Judging from other
architecture's successes or failures, postgis-2.1.1-4 seems to be the
first reasonably portable variant, where I suspect most failures to be
intermittent.



signature.asc
Description: OpenPGP digital signature
___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Re: frequent buildd issues with postgis

2014-10-23 Thread Markus Wanner
Dejan,

On 10/20/2014 01:21 PM, Dejan Latinovic wrote:
 Is seems that build fail on Broadcom boards,
 and pass on cavium and loongson.
 
 I will run build locally to confirm this theory.

Any results from that exercise?

Regards

Markus Wanner




signature.asc
Description: OpenPGP digital signature
___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

Re: frequent buildd issues with postgis

2014-10-23 Thread Markus Wanner
On 10/23/2014 01:35 PM, Dejan Latinovic wrote:
 As I suspected,
 build filed on Broadcom and pass on Cavium board.

Okay, thanks for your tests and confirmation.

 But I did not figure it out yet what is the reason of this
 behavior.
 
 I am getting the same output like this one:
 https://buildd.debian.org/status/fetch.php?pkg=postgisarch=mipselver=2.1.4%2Bdfsg-2stamp=1413547028

These indicate that Postgres restarted for some reason. Leading to
connection failures, first. Then, during the restart, the is in
recovery mode errors. The Postgres log should have some indication of
why it restarted in the first place.

Regards

Markus


___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[postgis] branch master updated (f9f8bdc - 00423b1)

2014-11-17 Thread Markus Wanner
This is an automated email from the git hooks/post-receive script.

markus_wanner-guest pushed a change to branch master
in repository postgis.

  from  f9f8bdc   Bump S-V.
   new  00423b1   Downgrade the recommends on postgis to a suggestion, so 
we don't ever recommend all the way through to another PostgreSQL major 
version, when installing a specific postgresql-X.Y-postgis-2.1 package.

The 1 revisions listed above as new are entirely new to this
repository and will be described in separate emails.  The revisions
listed as adds were already present in the repository and have only
been added to this reference.


Summary of changes:
 debian/changelog  | 8 
 debian/control| 3 ++-
 debian/control.in | 3 ++-
 3 files changed, 12 insertions(+), 2 deletions(-)

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/postgis.git

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[postgis] 01/01: Downgrade the recommends on postgis to a suggestion, so we don't ever recommend all the way through to another PostgreSQL major version, when installing a specific postgresql-X.Y-post

2014-11-17 Thread Markus Wanner
This is an automated email from the git hooks/post-receive script.

markus_wanner-guest pushed a commit to branch master
in repository postgis.

commit 00423b1d97354599a3bf969453fb5f082edb05b0
Author: Markus Wanner mar...@bluegap.ch
Date:   Mon Nov 17 09:40:04 2014 +0100

Downgrade the recommends on postgis to a suggestion, so we don't ever
recommend all the way through to another PostgreSQL major version,
when installing a specific postgresql-X.Y-postgis-2.1 package.
---
 debian/changelog  | 8 
 debian/control| 3 ++-
 debian/control.in | 3 ++-
 3 files changed, 12 insertions(+), 2 deletions(-)

diff --git a/debian/changelog b/debian/changelog
index 513c6d5..873c3fe 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+postgis (2.1.4+dfsg-3) UNRELEASED; urgency=medium
+
+  * Downgrade the recommends on postgis to a suggestion, so we don't ever
+recommend all the way through to another PostgreSQL major version,
+when installing a specific postgresql-X.Y-postgis-2.1 package.
+
+ -- Markus Wanner mar...@bluegap.ch  Mon, 17 Nov 2014 09:34:23 +0100
+
 postgis (2.1.4+dfsg-2) unstable; urgency=medium
 
   * Add Dutch translation by Frans Spiesschaert. Closes: #765409.
diff --git a/debian/control b/debian/control
index d1febd3..71eabb0 100644
--- a/debian/control
+++ b/debian/control
@@ -125,7 +125,8 @@ Package: postgresql-9.4-postgis-2.1
 Depends: ${shlibs:Depends}, postgresql-9.4,
  postgresql-9.4-postgis-scripts, liblwgeom-2.1.4,
  ${misc:Depends}
-Recommends: postgis, postgresql-contrib-9.4
+Recommends: postgresql-contrib-9.4
+Suggests: postgis
 Breaks: postgis ( 1.2.1)
 Architecture: any
 Description: Geographic objects support for PostgreSQL 9.4
diff --git a/debian/control.in b/debian/control.in
index 7f82c74..47dea65 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -125,7 +125,8 @@ Package: postgresql-PGVERSION-postgis-2.1
 Depends: ${shlibs:Depends}, postgresql-PGVERSION,
  postgresql-PGVERSION-postgis-scripts, liblwgeom-2.1.4,
  ${misc:Depends}
-Recommends: postgis, postgresql-contrib-PGVERSION
+Recommends: postgresql-contrib-PGVERSION
+Suggests: postgis
 Breaks: postgis ( 1.2.1)
 Architecture: any
 Description: Geographic objects support for PostgreSQL PGVERSION

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-grass/postgis.git

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-28-g2ec27fa

2013-04-18 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 20c607981044662def5a93e0b483772f9891ce1a
Merge: 22ccf92f12f7773648cdc5cdfcf068b716cfed89 
83ec1be71f04f2646aa8b3285ee777c4b13e2dbd
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Apr 11 22:39:58 2013 +0200

Merge branch 'upstream' (i.e. postgis-2.0.3)


-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-28-g2ec27fa

2013-04-18 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 5c35ffd6670aba11021b2139c656ff4386c0e026
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Apr 11 22:03:54 2013 +0200

Matching changelog:
 * Drop Build-Dep on postgresql server binaries - they are not needed.
 * Downgrade postgresql-9.1-postgis dependency on postgis to a
   recommendation.
 * Upgrade postgresql-9.1-java misc-depends from suggestion to dependency.
 * Fix a common spelling error in liblwgeom/lwout_wkt.c (thanks, lintian).
 * Ignore changes to auto-updated files (via source/options). Let
   debian/rules cleanup some more generated files.
 * rules: swap dh_makeshlibs and dh_installdeb.
 * Update and improve watchfile.

Not matching changelog:
 * Revive libpostgis-java: I don't think we can get away without packaging
   this. (Especially not w/o an entry in the changelog).

diff --git a/debian/changelog b/debian/changelog
index 88afb7e..936e93b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,22 @@
-postgis (2.0.1-1) unstable; urgency=low
-
-  * New upstream release, 2.0.1
-  * Removed old patches
-  * Added Makefile.comments patch
-
- -- Jerome Villeneuve Larouche jlarou...@mapgears.com  Fri, 17 Aug 2012 
14:56:22 +
+postgis (2.0.3-1) UNRELEASED; urgency=low
+
+  [Markus Wanner]
+  * New upstream release, 2.0.3
+  * Drop Build-Dep on postgresql server binaries - they are not needed.
+  * Downgrade postgresql-9.1-postgis dependency on postgis to a
+recommendation.
+  * Upgrade postgresql-9.1-java misc-depends from suggestion to dependency.
+  * Fix a common spelling error in liblwgeom/lwout_wkt.c.
+  * Ignore changes to auto-updated files (via source/options). Let
+debian/rules cleanup some more generated files.
+  * rules: swap dh_makeshlibs and dh_installdeb.
+  * Update and improve watchfile.
+
+  [Jerome Villeneuve Larouche]
+  * Removed old patches (generator, html_doc_resources, install)
+  * Added patch fixmakedoc for doc/Makefile.comments.
+
+ -- Markus Wanner mar...@bluegap.ch  Fri, 12 Apr 2013 13:02:33 +0200
 
 postgis (1.5.3-2) unstable; urgency=low
 
diff --git a/debian/control b/debian/control
index f16ed63..0128a44 100644
--- a/debian/control
+++ b/debian/control
@@ -6,8 +6,8 @@ Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo 
Lovergine frankie
 Build-Depends: debhelper (= 8), autotools-dev, flex, bison, libgeos-dev (= 
3.1.1),
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpg-java, fastjar, libjts-java (= 1.7), imagemagick,
- libcunit1-dev, dblatex, libxml2-dev, libgtk2.0-dev, postgresql-server-dev-9.1,
- ant, libgdal-dev, postgresql-9.1
+ libcunit1-dev, dblatex, libxml2-dev, libgtk2.0-dev,
+ postgresql-server-dev-9.1, ant, libgdal-dev
 Standards-Version: 3.9.2
 Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://git.debian.org/?p=pkg-grass/postgis.git
@@ -15,7 +15,8 @@ Vcs-Git: git://git.debian.org/git/pkg-grass/postgis.git
 
 Package: postgresql-9.1-postgis
 Architecture: any
-Depends: ${shlibs:Depends}, postgis, postgresql-9.1, ${misc:Depends}
+Depends: ${shlibs:Depends}, postgresql-9.1, ${misc:Depends}
+Recommends: postgis
 Conflicts: postgis ( 1.2.1)
 Description: Geographic objects support for PostgreSQL 9.1
  PostGIS adds support for geographic objects to the PostgreSQL 
object-relational
@@ -27,8 +28,8 @@ Description: Geographic objects support for PostgreSQL 9.1
  This package supports PostgreSQL 9.1.
 
 Package: postgis
-Suggests: postgresql-9.1-postgis
 Depends: ${shlibs:Depends}, ${misc:Depends}
+Suggests: postgresql-9.1-postgis
 Architecture: any
 Description: Geographic objects support for PostgreSQL -- common files
  PostGIS adds support for geographic objects to the PostgreSQL 
object-relational
@@ -40,3 +41,19 @@ Description: Geographic objects support for PostgreSQL -- 
common files
  This package contains the PostGIS userland binaries, common files and
  documentation.
 
+Package: libpostgis-java
+Architecture: all
+Section: java
+Depends: libpg-java, ${misc:Depends}
+Suggests: postgresql-9.1-postgis
+Conflicts: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
+Replaces: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
+Description: Geographic objects support for PostgreSQL -- JDBC support
+ PostGIS adds support for geographic objects to the PostgreSQL 
object-relational
+ database. In effect, PostGIS spatially enables the PostgreSQL server, 
+ allowing it to be used as a backend spatial database for geographic 
information
+ systems (GIS), much like ESRI's SDE or Oracle's Spatial extension. PostGIS
+ follows the OpenGIS Simple Features Specification for SQL.
+ .
+ This package contains JDBC support for PostGIS.
+
diff --git a/debian/patches/fix-spelling.diff b/debian/patches/fix-spelling.diff
new file mode 100644
index 000..ab43b82
--- /dev/null
+++ b/debian/patches/fix-spelling.diff
@@ -0,0 +1,38 @@
+--- a/liblwgeom

[SCM] postgis branch, master, updated. upstream/2.0.1-28-g2ec27fa

2013-04-18 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 398a2253da402d47d9871e6fa97a945a5d3ef08b
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Apr 11 23:23:35 2013 +0200

Merge in work from Stephen Frost, most notably the separation of
liblwgeom from postgis.

diff --git a/debian/changelog b/debian/changelog
index 936e93b..24c42b6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,14 @@ postgis (2.0.3-1) UNRELEASED; urgency=low
 debian/rules cleanup some more generated files.
   * rules: swap dh_makeshlibs and dh_installdeb.
   * Update and improve watchfile.
+  
+  [Stephen Frost]
+  * Split out liblwgeom2 and liblwgeom-dev from postgis.
+  * Add patches debian-versions and link-liblwgeom.
+  * Let postgis install under /usr/lib/postgresql rather than under
+/usr/lib/postgis plus symlink in the former directory.
+  * debian/rules: improve cleanup target.
+  * Simplify and tweak build rules.
 
   [Jerome Villeneuve Larouche]
   * Removed old patches (generator, html_doc_resources, install)
diff --git a/debian/control b/debian/control
index 0128a44..864f08a 100644
--- a/debian/control
+++ b/debian/control
@@ -57,3 +57,32 @@ Description: Geographic objects support for PostgreSQL -- 
JDBC support
  .
  This package contains JDBC support for PostGIS.
 
+Package: liblwgeom2
+Architecture: any
+Section: libs
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: PostGIS Lightweight Geometry library
+ PostGIS adds support for geographic objects to the PostgreSQL 
object-relational
+ database. In effect, PostGIS spatially enables the PostgreSQL server, 
+ allowing it to be used as a backend spatial database for geographic 
information
+ systems (GIS), much like ESRI's SDE or Oracle's Spatial extension. PostGIS
+ follows the OpenGIS Simple Features Specification for SQL.
+ .
+ This library is the generic geometry handling section of PostGIS. The geometry
+ objects, constructors, destructors, and a set of spatial processing functions,
+ are implemented here.
+
+Package: liblwgeom-dev
+Architecture: any
+Section: libdevel
+Depends: ${shlibs:Depends}, ${misc:Depends}, liblwgeom2 (= ${binary:Version})
+Description: PostGIS Lightweight Geometry library - Development files
+ PostGIS adds support for geographic objects to the PostgreSQL 
object-relational
+ database. In effect, PostGIS spatially enables the PostgreSQL server, 
+ allowing it to be used as a backend spatial database for geographic 
information
+ systems (GIS), much like ESRI's SDE or Oracle's Spatial extension. PostGIS
+ follows the OpenGIS Simple Features Specification for SQL.
+ .
+ This library is the generic geometry handling section of PostGIS. The geometry
+ objects, constructors, destructors, and a set of spatial processing functions,
+ are implemented here.  This package contains the development files.
diff --git a/debian/liblwgeom-dev.install b/debian/liblwgeom-dev.install
new file mode 100644
index 000..01df5de
--- /dev/null
+++ b/debian/liblwgeom-dev.install
@@ -0,0 +1,3 @@
+usr/include
+usr/lib/liblwgeom.a
+usr/lib/liblwgeom.so
diff --git a/debian/liblwgeom2.install b/debian/liblwgeom2.install
new file mode 100644
index 000..fd61f8a
--- /dev/null
+++ b/debian/liblwgeom2.install
@@ -0,0 +1 @@
+usr/lib/liblwgeom-2.0.3.so
diff --git a/debian/patches/debian-versions b/debian/patches/debian-versions
new file mode 100644
index 000..60619a4
--- /dev/null
+++ b/debian/patches/debian-versions
@@ -0,0 +1,32 @@
+Description: Update various files to Debian versions
+ There are a number of #defines and similar which change based on the
+ specific versions of software being compiled against.  Update these to
+ match the current Debian build environment.
+Author: Stephen Frost sfr...@snowman.net
+Last-Update: 2012-10-12
+
+--- a/postgis/sqldefines.h
 b/postgis/sqldefines.h
+@@ -8,9 +8,9 @@
+  */
+ #define POSTGIS_PGSQL_VERSION 91
+ #define POSTGIS_GEOS_VERSION 33
+-#define POSTGIS_PROJ_VERSION 48
++#define POSTGIS_PROJ_VERSION 47
+ #define POSTGIS_LIB_VERSION 2.0.3
+-#define POSTGIS_LIBXML2_VERSION 2.7.8
++#define POSTGIS_LIBXML2_VERSION 2.8.0
+ 
+ /*
+  * Define the build date and the version number
+--- a/doc/Makefile.comments
 b/doc/Makefile.comments
+@@ -21,7 +21,7 @@
+ DATA_built=postgis_comments.sql raster_comments.sql topology_comments.sql
+ 
+ # PGXS information
+-PG_CONFIG = /usr/bin/pg_config 
++PG_CONFIG = /usr/lib/postgresql/9.1/bin/pg_config
+ PGXS := /usr/lib/postgresql/9.1/lib/pgxs/src/makefiles/pgxs.mk
+ include $(PGXS)
+ 
diff --git a/debian/patches/link-liblwgeom b/debian/patches/link-liblwgeom
new file mode 100644
index 000..073480d
--- /dev/null
+++ b/debian/patches/link-liblwgeom
@@ -0,0 +1,28 @@
+Description: Dynamically link to liblwgeom
+ Instead of statically pulling liblwgeom into the postgis.so, dynamically
+ link to it.
+Author: Stephen Frost sfr...@snowman.net
+Last-Update: 2012-10-13
+
+--- a/postgis/Makefile.in
 b/postgis/Makefile.in
+@@ -72,7 +72,7

[SCM] postgis branch, master, updated. upstream/2.0.1-28-g2ec27fa

2013-04-18 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 2ec27fa4d78c7f4dd838cd8e0dbd49fbd975b647
Author: Markus Wanner mar...@bluegap.ch
Date:   Mon Apr 15 21:30:13 2013 +0200

Split out separate doc and scripts packages from postgis,
containing all of the (architecture and PostgreSQL version
independent) SQL / Perl scripts for each postgis version and HTML
documentation. Let the postinst script of the more specific
postgresql-postgis-* package add proper symlinks to the SQL
scripts. I consider the perl utils moved, though.

Reorganize debian/rules a bit, build in build targets, before
installing. Reduce to a single configure run.

Represent the fact that lwgeom isn't backward compatible in its
SONAME, rename liblwgeom2 to liblwgeom-2.0.3-0 accordingly.

Make the java jdbc stuff compile again. Use maven directly,
rather than trying to go via make and ant. Add required maven
build dependencies.y

Downgrade several 'Conflicts' to 'Breaks'. Make liblwgeom2 and
liblwgeom-dev break older versions of postgis - files out of
postgis into these packages.

Add a postgresql- prefix to postgis-generic.postrm.in to match
naming with the according ...postinst.in file.

Drop an unneeded 'recursive' flag for 'rm'. Tweak package
dependencies. Add a spell fix patch. Register documentation with
doc-base. Fix java jdbc version identifiers. Policy, copyright
and watchfile upgrade.

diff --git a/debian/changelog b/debian/changelog
index 24c42b6..80a0db3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,17 +1,33 @@
 postgis (2.0.3-1) UNRELEASED; urgency=low
 
   [Markus Wanner]
+  * Team upload
   * New upstream release, 2.0.3
-  * Drop Build-Dep on postgresql server binaries - they are not needed.
+  * Drop Build-Dep on postgresql server binaries.
   * Downgrade postgresql-9.1-postgis dependency on postgis to a
-recommendation.
+recommendation. Downgrade several conflicts to breaks.
   * Upgrade postgresql-9.1-java misc-depends from suggestion to dependency.
-  * Fix a common spelling error in liblwgeom/lwout_wkt.c.
-  * Ignore changes to auto-updated files (via source/options). Let
+  * Add patch fix-spelling: fixes a common spelling error in
+liblwgeom/lwout_wkt.c.
+  * Ignore changes of some auto-updated files (via source/options). Let
 debian/rules cleanup some more generated files.
-  * rules: swap dh_makeshlibs and dh_installdeb.
+  * rules: swap dh_makeshlibs and dh_installdeb, build in the appropriate
+build targets, let install only install pre-built stuff.
+  * Compile the postgis jdbc java library again, using maven directly. Add
+required Build-Depends-Indeps.
+  * Separate large SQL scripts and perl utils. Put them in their own
+architecture independent and (hopefully) PostgreSQL version
+indepentend package: postgis-data2.0.3. Let postinst add symlinks as
+appropriate.
+  * Separate PostGIS documentation into a postgis-doc package, register its
+contents with doc-base.
+  * Represent the fact that lwgeom isn't backward compatible in its SONAME,
+rename liblwgeom2 to liblwgeom-2.0.3-0 accordingly.
+  * Add patch java-version-fix: Corrects java jdbc jar version.
+  * Policy updated to 3.9.4. No changes.
+  * Update debian/copyright a bit.
   * Update and improve watchfile.
-  
+
   [Stephen Frost]
   * Split out liblwgeom2 and liblwgeom-dev from postgis.
   * Add patches debian-versions and link-liblwgeom.
@@ -24,7 +40,7 @@ postgis (2.0.3-1) UNRELEASED; urgency=low
   * Removed old patches (generator, html_doc_resources, install)
   * Added patch fixmakedoc for doc/Makefile.comments.
 
- -- Markus Wanner mar...@bluegap.ch  Fri, 12 Apr 2013 13:02:33 +0200
+ -- Markus Wanner mar...@bluegap.ch  Mon, 15 Apr 2013 22:12:27 +0200
 
 postgis (1.5.3-2) unstable; urgency=low
 
diff --git a/debian/control b/debian/control
index 864f08a..679a606 100644
--- a/debian/control
+++ b/debian/control
@@ -2,87 +2,130 @@ Source: postgis
 Section: misc
 Priority: optional
 Maintainer: Debian GIS Project pkg-grass-devel@lists.alioth.debian.org
-Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo Lovergine 
fran...@debian.org
-Build-Depends: debhelper (= 8), autotools-dev, flex, bison, libgeos-dev (= 
3.1.1),
+Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
+ Lovergine fran...@debian.org
+Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
+ flex, bison, libgeos-dev (= 3.1.1),
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpg-java, fastjar, libjts-java (= 1.7), imagemagick,
- libcunit1-dev, dblatex, libxml2-dev, libgtk2.0-dev,
- postgresql-server-dev-9.1, ant, libgdal-dev
-Standards-Version: 3.9.2
+ libcunit1-dev, dblatex, libxml2-dev, libgtk2.0-dev, libgdal-dev,
+ postgresql-server-dev-9.1
+Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
+ libmaven-clean-plugin-java

[SCM] postgis branch, master, updated. upstream/2.0.1-30-g8d15902

2013-04-20 Thread Markus Wanner
The following commit has been merged in the master branch:
commit b44d1dc39f050bbe7b094aeb4921dd574f2c2992
Author: Markus Wanner mar...@bluegap.ch
Date:   Sun Apr 21 02:35:14 2013 +0200

Very minor cleanup, no functional change.

rules: drop unneeded dpkg-buildflags invocations, rely on
buildflags.mk. Remove unneeded space at end of line.

patches/fix-manpages: drop duplicate Author: line.

diff --git a/debian/patches/fix-manpages b/debian/patches/fix-manpages
index 217c697..cad079a 100644
--- a/debian/patches/fix-manpages
+++ b/debian/patches/fix-manpages
@@ -1,7 +1,6 @@
 Description: Properly escape dashes in man pages
 Author: Markus Wanner mar...@bluegap.ch
 Last-Update: 2013-04-14
-Author: Markus Wanner mar...@bluegap.ch
 
 --- a/doc/man/shp2pgsql.1
 +++ b/doc/man/shp2pgsql.1
diff --git a/debian/rules b/debian/rules
index 0b3a786..6947d23 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,10 +26,6 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture 
-qDEB_BUILD_GNU_TYPE)
 # Use maven in offline mode.
 MVN = mvn --offline -s/etc/maven2/settings-debian.xml
 
-CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
-CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
-LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
-
 MAJOR_VERSION = $(shell grep POSTGIS_MAJOR_VERSION Version.config|cut -d= -f2)
 MINOR_VERSION = $(shell grep POSTGIS_MINOR_VERSION Version.config|cut -d= -f2)
 MICRO_VERSION = $(shell grep POSTGIS_MICRO_VERSION Version.config|cut -d= -f2)
@@ -145,7 +141,7 @@ binary-common:
dh_installman
dh_link
dh_strip
-   dh_compress 
+   dh_compress
dh_fixperms
dh_makeshlibs -Xusr/lib/postgis
dh_installdeb

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-30-g8d15902

2013-04-20 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 8d159024e036b1224692753f89c20cd373410d43
Author: Markus Wanner mar...@bluegap.ch
Date:   Sun Apr 21 02:38:35 2013 +0200

postgis-doc.doc-base: correct Document name

diff --git a/debian/postgis-doc.doc-base b/debian/postgis-doc.doc-base
index b290167..8080d88 100644
--- a/debian/postgis-doc.doc-base
+++ b/debian/postgis-doc.doc-base
@@ -1,4 +1,4 @@
-Document: doc-base
+Document: postgis-doc
 Title: PostGIS 2.0 Manual
 Section: Science/Geoscience
 

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-31-gf19f2ae

2013-04-22 Thread Markus Wanner
The following commit has been merged in the master branch:
commit f19f2ae2e75accdf294daf800d511761a139c3ce
Author: Markus Wanner mar...@bluegap.ch
Date:   Sun Apr 21 14:45:50 2013 +0200

patches/fix-manpages: Add upstream commit info.

diff --git a/debian/patches/fix-manpages b/debian/patches/fix-manpages
index cad079a..e895cd0 100644
--- a/debian/patches/fix-manpages
+++ b/debian/patches/fix-manpages
@@ -1,6 +1,7 @@
 Description: Properly escape dashes in man pages
 Author: Markus Wanner mar...@bluegap.ch
 Last-Update: 2013-04-14
+Applied-Upstream: 2.1.0, http://trac.osgeo.org/postgis/changeset/11305/trunk
 
 --- a/doc/man/shp2pgsql.1
 +++ b/doc/man/shp2pgsql.1

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-33-gabbd430

2013-04-22 Thread Markus Wanner
The following commit has been merged in the master branch:
commit abbd4301b3c4ed5a03f6a8a52b7f812a917073b1
Author: Markus Wanner mar...@bluegap.ch
Date:   Sun Apr 21 22:00:34 2013 +0200

Add myself to the list of uploaders.

diff --git a/debian/control b/debian/control
index 679a606..0947b31 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: misc
 Priority: optional
 Maintainer: Debian GIS Project pkg-grass-devel@lists.alioth.debian.org
 Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
- Lovergine fran...@debian.org
+ Lovergine fran...@debian.org, Markus Wanner mar...@bluegap.ch
 Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
  flex, bison, libgeos-dev (= 3.1.1),
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-33-gabbd430

2013-04-22 Thread Markus Wanner
The following commit has been merged in the master branch:
commit efbcac4e02c715893ed23c47cd7c713b2084e65e
Author: Markus Wanner mar...@bluegap.ch
Date:   Sun Apr 21 21:42:50 2013 +0200

Add debian/liblwgeom-2.0.3-0.symbols, including symbols of liblwgeom
since PostGIS release 2.0.0.

diff --git a/debian/liblwgeom-2.0.3-0.symbols b/debian/liblwgeom-2.0.3-0.symbols
new file mode 100644
index 000..526b64b
--- /dev/null
+++ b/debian/liblwgeom-2.0.3-0.symbols
@@ -0,0 +1,653 @@
+liblwgeom-2.0.3.so.0 liblwgeom-2.0.3-0 #MINVER#
+ GEOS2LWGEOM@Base 2.0.0
+ LWGEOM2GEOS@Base 2.0.0
+ LWGEOM_GEOS_buildArea@Base 2.0.0
+ LWGEOM_GEOS_getPointN@Base 2.0.0
+ azimuth_pt_pt@Base 2.0.0
+ box2d_clone@Base 2.0.0
+ box3d_from_gbox@Base 2.0.0
+ box3d_to_gbox@Base 2.0.0
+ bytes_from_hexbytes@Base 2.0.0
+ cart2geog@Base 2.0.0
+ clairaut_cartesian@Base 2.0.0
+ clairaut_geographic@Base 2.0.0
+ clamp_srid@Base 2.0.0
+ closest_point_on_segment@Base 2.0.0
+ crosses_dateline@Base 2.0.0
+ default_allocator@Base 2.0.0
+ default_errorreporter@Base 2.0.0
+ default_freeor@Base 2.0.0
+ default_noticereporter@Base 2.0.0
+ default_reallocator@Base 2.0.0
+ define_plane@Base 2.0.0
+ deparse_hex@Base 2.0.0
+ distance2d_pt_pt@Base 2.0.0
+ distance2d_pt_seg@Base 2.0.0
+ dumb_upper_map@Base 2.0.2
+ edge_calculate_gbox@Base 2.0.0
+ edge_calculate_gbox_slow@Base 2.0.0
+ edge_contains_coplanar_point@Base 2.0.0
+ edge_contains_point@Base 2.0.0
+ edge_distance_to_edge@Base 2.0.0
+ edge_distance_to_point@Base 2.0.0
+ edge_intersection@Base 2.0.0
+ edge_point_in_cone@Base 2.0.0
+ edge_point_on_plane@Base 2.0.0
+ error_if_srid_mismatch@Base 2.0.0
+ gbox_clone@Base 2.0.2
+ gbox_contains_point3d@Base 2.0.0
+ gbox_copy@Base 2.0.0
+ gbox_duplicate@Base 2.0.0
+ gbox_expand@Base 2.0.0
+ gbox_float_round@Base 2.0.0
+ gbox_from_string@Base 2.0.0
+ gbox_geocentric_slow@Base 2.0.0
+ gbox_init@Base 2.0.0
+ gbox_merge@Base 2.0.0
+ gbox_merge_point3d@Base 2.0.0
+ gbox_new@Base 2.0.0
+ gbox_overlaps@Base 2.0.0
+ gbox_overlaps_2d@Base 2.0.0
+ gbox_pt_outside@Base 2.0.0
+ gbox_same@Base 2.0.0
+ gbox_serialized_size@Base 2.0.0
+ gbox_to_string@Base 2.0.0
+ gbox_union@Base 2.0.0
+ geog2cart@Base 2.0.0
+ geographic_point_equals@Base 2.0.0
+ geographic_point_init@Base 2.0.0
+ geohash_point@Base 2.0.0
+ geometry_type_from_string@Base 2.0.0
+ geomtype_struct_array@Base 2.0.0
+ getMachineEndian@Base 2.0.0
+ getPoint2d@Base 2.0.0
+ getPoint2d_p@Base 2.0.0
+ getPoint2d_p_ro@Base 2.0.0
+ getPoint3dm@Base 2.0.0
+ getPoint3dm_p@Base 2.0.0
+ getPoint3dz@Base 2.0.0
+ getPoint3dz_p@Base 2.0.0
+ getPoint4d@Base 2.0.0
+ getPoint4d_p@Base 2.0.0
+ getPoint_internal@Base 2.0.0
+ get_3dcross_product@Base 2.0.0
+ get_3dvector_from_points@Base 2.0.0
+ gflags@Base 2.0.0
+ global_parser_result@Base 2.0.0
+ gserialized_copy@Base 2.0.0
+ gserialized_from_lwgeom@Base 2.0.0
+ gserialized_from_lwgeom_size@Base 2.0.0
+ gserialized_get_gbox_p@Base 2.0.0
+ gserialized_get_srid@Base 2.0.0
+ gserialized_get_type@Base 2.0.0
+ gserialized_get_zm@Base 2.0.0
+ gserialized_has_bbox@Base 2.0.0
+ gserialized_has_m@Base 2.0.0
+ gserialized_has_z@Base 2.0.0
+ gserialized_is_empty@Base 2.0.0
+ gserialized_ndims@Base 2.0.0
+ gserialized_read_gbox_p@Base 2.0.0
+ gserialized_set_srid@Base 2.0.0
+ gserialized_to_string@Base 2.0.0
+ hexbytes_from_bytes@Base 2.0.0
+ init_allocator@Base 2.0.0
+ init_errorreporter@Base 2.0.0
+ init_freeor@Base 2.0.0
+ init_noticereporter@Base 2.0.0
+ init_reallocator@Base 2.0.0
+ interpolate_point4d@Base 2.0.0
+ latitude_degrees_normalize@Base 2.0.0
+ latitude_radians_normalize@Base 2.0.0
+ longitude_degrees_normalize@Base 2.0.0
+ longitude_radians_normalize@Base 2.0.0
+ lw_asprintf@Base 2.0.0
+ lw_dist2d_check_overlap@Base 2.0.0
+ lw_dist2d_comp@Base 2.0.0
+ lw_dist2d_distanceline@Base 2.0.0
+ lw_dist2d_distancepoint@Base 2.0.0
+ lw_dist2d_distribute_bruteforce@Base 2.0.0
+ lw_dist2d_distribute_fast@Base 2.0.0
+ lw_dist2d_fast_ptarray_ptarray@Base 2.0.0
+ lw_dist2d_line_line@Base 2.0.0
+ lw_dist2d_line_poly@Base 2.0.0
+ lw_dist2d_point_line@Base 2.0.0
+ lw_dist2d_point_point@Base 2.0.0
+ lw_dist2d_point_poly@Base 2.0.0
+ lw_dist2d_poly_poly@Base 2.0.0
+ lw_dist2d_pre_seg_seg@Base 2.0.0
+ lw_dist2d_pt_pt@Base 2.0.0
+ lw_dist2d_pt_ptarray@Base 2.0.0
+ lw_dist2d_pt_seg@Base 2.0.0
+ lw_dist2d_ptarray_poly@Base 2.0.0
+ lw_dist2d_ptarray_ptarray@Base 2.0.0
+ lw_dist2d_recursive@Base 2.0.0
+ lw_dist2d_seg_seg@Base 2.0.0
+ lw_dist2d_selected_seg_seg@Base 2.0.0
+ lw_dist3d_distanceline@Base 2.0.0
+ lw_dist3d_distancepoint@Base 2.0.0
+ lw_dist3d_distribute_bruteforce@Base 2.0.0
+ lw_dist3d_line_line@Base 2.0.0
+ lw_dist3d_line_poly@Base 2.0.0
+ lw_dist3d_point_line@Base 2.0.0
+ lw_dist3d_point_point@Base 2.0.0
+ lw_dist3d_point_poly@Base 2.0.0
+ lw_dist3d_poly_poly@Base 2.0.0
+ lw_dist3d_pt_poly@Base 2.0.0
+ lw_dist3d_pt_pt@Base 2.0.0
+ lw_dist3d_pt_ptarray@Base 2.0.0
+ lw_dist3d_pt_seg@Base 2.0.0
+ lw_dist3d_ptarray_poly@Base 2.0.0
+ lw_dist3d_ptarray_ptarray@Base 2.0.0

[SCM] postgis branch, master, updated. upstream/2.0.1-34-gcd4a3fe

2013-04-23 Thread Markus Wanner
The following commit has been merged in the master branch:
commit cd4a3fe9168e1cb9203828ec1db6245194e589f1
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Apr 23 22:41:23 2013 +0200

Rename liblwgeom-2.0.3-0 back to just liblwgeom-2.0.3. Reduce patch
link-liblwgeom to make the SONAME match upstream's variant, again.

diff --git a/debian/changelog b/debian/changelog
index 80a0db3..3a128be 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -22,7 +22,7 @@ postgis (2.0.3-1) UNRELEASED; urgency=low
   * Separate PostGIS documentation into a postgis-doc package, register its
 contents with doc-base.
   * Represent the fact that lwgeom isn't backward compatible in its SONAME,
-rename liblwgeom2 to liblwgeom-2.0.3-0 accordingly.
+rename liblwgeom2 to liblwgeom-2.0.3 accordingly.
   * Add patch java-version-fix: Corrects java jdbc jar version.
   * Policy updated to 3.9.4. No changes.
   * Update debian/copyright a bit.
diff --git a/debian/control b/debian/control
index 0947b31..3de2545 100644
--- a/debian/control
+++ b/debian/control
@@ -95,7 +95,7 @@ Description: Geographic objects support for PostgreSQL -- 
JDBC support
  .
  This package contains JDBC support for PostGIS.
 
-Package: liblwgeom-2.0.3-0
+Package: liblwgeom-2.0.3
 Architecture: any
 Section: libs
 Depends: ${shlibs:Depends}, ${misc:Depends}
@@ -115,7 +115,7 @@ Package: liblwgeom-dev
 Architecture: any
 Section: libdevel
 Depends: ${shlibs:Depends}, ${misc:Depends},
- liblwgeom-2.0.3-0 (= ${binary:Version})
+ liblwgeom-2.0.3 (= ${binary:Version})
 Breaks: postgis ( 2.0.0)
 Description: PostGIS Lightweight Geometry library - Development files
  PostGIS adds support for geographic objects to the PostgreSQL
diff --git a/debian/liblwgeom-2.0.3-0.install b/debian/liblwgeom-2.0.3-0.install
deleted file mode 100644
index 8c74c36..000
--- a/debian/liblwgeom-2.0.3-0.install
+++ /dev/null
@@ -1,2 +0,0 @@
-usr/lib/liblwgeom-2.0.3.so.0.0.0
-usr/lib/liblwgeom-2.0.3.so.0
\ No newline at end of file
diff --git a/debian/liblwgeom-2.0.3.install b/debian/liblwgeom-2.0.3.install
new file mode 100644
index 000..fd61f8a
--- /dev/null
+++ b/debian/liblwgeom-2.0.3.install
@@ -0,0 +1 @@
+usr/lib/liblwgeom-2.0.3.so
diff --git a/debian/liblwgeom-2.0.3-0.symbols b/debian/liblwgeom-2.0.3.symbols
similarity index 99%
rename from debian/liblwgeom-2.0.3-0.symbols
rename to debian/liblwgeom-2.0.3.symbols
index 526b64b..fe54e08 100644
--- a/debian/liblwgeom-2.0.3-0.symbols
+++ b/debian/liblwgeom-2.0.3.symbols
@@ -1,4 +1,4 @@
-liblwgeom-2.0.3.so.0 liblwgeom-2.0.3-0 #MINVER#
+liblwgeom-2.0.3.so liblwgeom-2.0.3 #MINVER#
  GEOS2LWGEOM@Base 2.0.0
  LWGEOM2GEOS@Base 2.0.0
  LWGEOM_GEOS_buildArea@Base 2.0.0
diff --git a/debian/liblwgeom-dev.install b/debian/liblwgeom-dev.install
index 16daaa9..01df5de 100644
--- a/debian/liblwgeom-dev.install
+++ b/debian/liblwgeom-dev.install
@@ -1,3 +1,3 @@
 usr/include
-usr/lib/liblwgeom-2.0.3.a
-usr/lib/liblwgeom-2.0.3.so
+usr/lib/liblwgeom.a
+usr/lib/liblwgeom.so
diff --git a/debian/patches/link-liblwgeom b/debian/patches/link-liblwgeom
index 6018090..4190dc2 100644
--- a/debian/patches/link-liblwgeom
+++ b/debian/patches/link-liblwgeom
@@ -1,8 +1,8 @@
 Description: Dynamically link to liblwgeom
  Instead of statically pulling liblwgeom into the postgis.so, dynamically
- link to it. Rename to liblwgeom-2.0.3
+ link to it.
 Author: Stephen Frost sfr...@snowman.net, Markus Wanner mar...@bluegap.ch
-Last-Update: 2013-04-14
+Last-Update: 2013-04-23
 
 --- a/postgis/Makefile.in
 +++ b/postgis/Makefile.in
@@ -18,31 +18,10 @@ Last-Update: 2013-04-14
 -# supplied with newer versions of PostGIS
  PG_CPPFLAGS += @CPPFLAGS@ -I../liblwgeom -I../libpgcommon
 -SHLIB_LINK_F = ../liblwgeom/.libs/liblwgeom.a ../libpgcommon/libpgcommon.a 
@SHLIB_LINK@ 
-+SHLIB_LINK_F = -L../liblwgeom/.libs -llwgeom-2.0.3 
../libpgcommon/libpgcommon.a @SHLIB_LINK@
++SHLIB_LINK_F = -L../liblwgeom/.libs -llwgeom ../libpgcommon/libpgcommon.a 
@SHLIB_LINK@
  
  # Extra files to remove during 'make clean'
  EXTRA_CLEAN=$(SQL_OBJS) legacy_uninstall.sql
-@@ -114,16 +108,16 @@
- # Make all PostGIS objects depend upon liblwgeom, so that if an underlying
- # change is made, a PostGIS rebuild is triggered.
- #
--# Also they are all dependent on postgis_config.h 
-+# Also they are all dependent on postgis_config.h
- # and thus postgis_svn_revision.h
- #
--$(PG_OBJS): ../liblwgeom/.libs/liblwgeom.a ../libpgcommon/libpgcommon.a 
../postgis_config.h ../postgis_svn_revision.h
-+$(PG_OBJS): ../liblwgeom/.libs/liblwgeom-2.0.3.a ../libpgcommon/libpgcommon.a 
../postgis_config.h ../postgis_svn_revision.h
- 
- ../postgis_svn_revision.h:
-   $(MAKE) -C .. postgis_svn_revision.h
- 
--../liblwgeom/.libs/liblwgeom.a:
--  make -C ../liblwgeom liblwgeom.la
-+../liblwgeom/.libs/liblwgeom-2.0.3.a:
-+  make -C ../liblwgeom liblwgeom-2.0.3.la
- 
- ../libpgcommon/libpgcommon.a:
-   make -C ../libpgcommon libpgcommon.a
 --- a/raster/rt_pg/Makefile.in
 +++ b/raster

[SCM] postgis branch, master, updated. upstream/2.0.1-35-g5595fc8

2013-04-23 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 5595fc8668122c8f85ff0840482a759cf176532f
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Apr 23 22:54:59 2013 +0200

Use canonical Vcs-* links to silence yet another lintian warning.

diff --git a/debian/control b/debian/control
index 3de2545..c5fe450 100644
--- a/debian/control
+++ b/debian/control
@@ -15,8 +15,8 @@ Build-Depends-Indep: libpostgresql-jdbc-java, 
libsurefire-java,
  libmaven-jar-plugin-java, maven2
 Standards-Version: 3.9.4
 Homepage: http://postgis.refractions.net/
-Vcs-Browser: http://git.debian.org/?p=pkg-grass/postgis.git
-Vcs-Git: git://git.debian.org/git/pkg-grass/postgis.git
+Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git
+Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
 
 Package: postgresql-9.1-postgis
 Depends: ${shlibs:Depends}, postgresql-9.1, postgis-scripts2.0.3,

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-36-gdad4abc

2013-04-24 Thread Markus Wanner
The following commit has been merged in the master branch:
commit dad4abcc3cfc2c674befa47357473eaf5e4f02c1
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Apr 23 23:20:51 2013 +0200

Add patches/honor-build-flags: properly pass on LDFLAGS and CPPFLAGS.

diff --git a/debian/control b/debian/control
index c5fe450..8ba3889 100644
--- a/debian/control
+++ b/debian/control
@@ -12,7 +12,7 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  postgresql-server-dev-9.1
 Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
- libmaven-jar-plugin-java, maven2
+ libmaven-jar-plugin-java, libmaven-resources-plugin-java, maven2
 Standards-Version: 3.9.4
 Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git
diff --git a/debian/patches/honor-build-flags b/debian/patches/honor-build-flags
new file mode 100644
index 000..a2b50f4
--- /dev/null
+++ b/debian/patches/honor-build-flags
@@ -0,0 +1,67 @@
+Description: Better honor build flags during the build process.
+ Upstream PostGIS 'configure' overrides CPPFLAGS. Various Makefile.in
+ files don't honor LDFLAGS. This patch fixes that. Note that we are
+ patching configure directly, so as to save a call to autoconf. A real
+ patch for upstream would have to patch configure.in, instead.
+Author: Markus Wanner mar...@bluegap.ch
+Last-Update: 2013-04-23
+
+--- a/loader/Makefile.in
 b/loader/Makefile.in
+@@ -97,11 +97,11 @@
+ 
+ $(PGSQL2SHP-CLI): $(SHPLIB_OBJS) pgsql2shp-core.o pgsql2shp-cli.o 
$(LIBLWGEOM) 
+   $(LIBTOOL) --mode=link \
+-$(CC) $(CFLAGS) $^ $(ICONV_LDFLAGS) $(PGSQL_FE_LDFLAGS) 
$(GETTEXT_LDFLAGS) -o $@ 
++$(CC) $(CFLAGS) $^ $(LDFLAGS) $(ICONV_LDFLAGS) $(PGSQL_FE_LDFLAGS) 
$(GETTEXT_LDFLAGS) -o $@
+ 
+ $(SHP2PGSQL-CLI): $(SHPLIB_OBJS) shp2pgsql-core.o shp2pgsql-cli.o 
$(LIBLWGEOM) 
+   $(LIBTOOL) --mode=link \
+-$(CC) $(CFLAGS) $^ -o $@ $(GETTEXT_LDFLAGS) $(ICONV_LDFLAGS) 
++$(CC) $(CFLAGS) $^ -o $@ $(LDFLAGS) $(GETTEXT_LDFLAGS) 
$(ICONV_LDFLAGS)
+ 
+ shp2pgsql-gui.o: shp2pgsql-gui.c shp2pgsql-core.h shpcommon.h
+   $(CC) $(CFLAGS) $(GTK_CFLAGS) $(PGSQL_FE_CPPFLAGS) -o $@ -c 
shp2pgsql-gui.c
+@@ -109,7 +109,7 @@
+ $(SHP2PGSQL-GUI): $(SHPLIB_OBJS) shp2pgsql-core.o shp2pgsql-gui.o 
pgsql2shp-core.o $(LIBLWGEOM) $(GTK_WIN32_RES)
+   $(LIBTOOL) --mode=link \
+ $(CC) $(CFLAGS) $(GTK_WIN32_FLAGS) $^ -o $@ \
+-$(GTK_LIBS) $(ICONV_LDFLAGS) $(PGSQL_FE_LDFLAGS) $(GETTEXT_LDFLAGS) 
++$(GTK_LIBS) $(LDFLAGS) $(ICONV_LDFLAGS) $(PGSQL_FE_LDFLAGS) 
$(GETTEXT_LDFLAGS)
+ 
+ installdir:
+   @mkdir -p $(DESTDIR)$(bindir)
+--- a/liblwgeom/Makefile.in
 b/liblwgeom/Makefile.in
+@@ -11,6 +11,7 @@
+ # **
+ 
+ CC = @CC@
++CPPFLAGS = @CPPFLAGS@
+ CFLAGS = @CFLAGS@ @PICFLAGS@ @WARNFLAGS@ @GEOS_CPPFLAGS@ @PROJ_CPPFLAGS@
+ LDFLAGS = @LDFLAGS@ @GEOS_LDFLAGS@ -lgeos_c @PROJ_LDFLAGS@ -lproj
+ NUMERICFLAGS = @NUMERICFLAGS@
+@@ -147,10 +148,10 @@
+ 
+ # Command to build each of the .lo files
+ $(LT_SA_OBJS): %.lo: %.c
+-  $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) -c -o $@ $
++  $(LIBTOOL) --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $
+ 
+ $(LT_NM_OBJS): %.lo: %.c
+-  $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(NUMERICFLAGS) -c -o $@ $
++  $(LIBTOOL) --mode=compile $(CC) $(CPPFLAGS) $(CFLAGS) $(NUMERICFLAGS) 
-c -o $@ $
+ 
+ # Manually generate WKT parser from Flex/Bison inputs
+ # Bison 2.5, Flex 2.5.35
+--- a/configure
 b/configure
+@@ -19526,7 +19526,7 @@
+ 
+ 
+ 
+-CPPFLAGS=$PGSQL_CPPFLAGS $GEOS_CPPFLAGS $PROJ_CPPFLAGS $JSON_CPPFLAGS 
$XML2_CPPFLAGS
++CPPFLAGS=$CPPFLAGS $PGSQL_CPPFLAGS $GEOS_CPPFLAGS $PROJ_CPPFLAGS 
$JSON_CPPFLAGS $XML2_CPPFLAGS
+ 
+ SHLIB_LINK=$PGSQL_LDFLAGS $GEOS_LDFLAGS $PROJ_LDFLAGS -lgeos_c -lproj 
$JSON_LDFLAGS $XML2_LDFLAGS
+ 
diff --git a/debian/patches/series b/debian/patches/series
index f56c492..4769335 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -5,3 +5,4 @@ fix-spelling
 link-liblwgeom
 use-debian-maven
 fix-manpages
+honor-build-flags
diff --git a/debian/patches/use-debian-maven b/debian/patches/use-debian-maven
index 228f800..a004075 100644
--- a/debian/patches/use-debian-maven
+++ b/debian/patches/use-debian-maven
@@ -21,13 +21,17 @@ Last-Update: 2013-04-14
 classpathref=maven-ant-tasks.classpath /
 --- a/java/jdbc/pom.xml
 +++ b/java/jdbc/pom.xml
-@@ -82,10 +82,23 @@
+@@ -82,10 +82,27 @@
/resource
/resources
  
 -  plugins!--
 -
 +  plugins
++  plugin
++  groupIdorg.apache.maven.plugins/groupId
++  artifactIdmaven-clean-plugin/artifactId
++  /plugin
plugin

[SCM] postgis branch, master, updated. upstream/2.0.1-38-g05bea3a

2013-04-25 Thread Markus Wanner
The following commit has been merged in the master branch:
commit fff0900778c11a0bba822e01521b61d916cdecbf
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Apr 25 21:57:51 2013 +0200

Drop the postinst and postrm scripts in favor of simply providing
the necessary symlinks from the postgresql-9.1-postgis package,
directly. Requires some love from debian/rules, in the form of
moving and symlinking files properly after installation.

diff --git a/debian/changelog b/debian/changelog
index 3a128be..bb79375 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -17,8 +17,8 @@ postgis (2.0.3-1) UNRELEASED; urgency=low
 required Build-Depends-Indeps.
   * Separate large SQL scripts and perl utils. Put them in their own
 architecture independent and (hopefully) PostgreSQL version
-indepentend package: postgis-data2.0.3. Let postinst add symlinks as
-appropriate.
+indepentend package: postgis-scripts2.0.3. Provide symlinks from the
+extension package.
   * Separate PostGIS documentation into a postgis-doc package, register its
 contents with doc-base.
   * Represent the fact that lwgeom isn't backward compatible in its SONAME,
diff --git a/debian/postgis-postgresql-generic.postinst.in 
b/debian/postgis-postgresql-generic.postinst.in
deleted file mode 100644
index 5707353..000
--- a/debian/postgis-postgresql-generic.postinst.in
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh
-
-set -e
-
-if [ $1 = configure ]; then
-#  Creates a link for the shared lib in the postgres area
-#  if [ -f 
/usr/lib/postgis/@POSTGIS_VERSION@/postgres/@POSTGRES_VERSION@/lib/postgis-@SOVERSION@.so
 ]; then
-#  ln -f 
/usr/lib/postgis/@POSTGIS_VERSION@/postgres/@POSTGRES_VERSION@/lib/postgis-@SOVERSION@.so
 \
-#
/usr/lib/postgresql/@POSTGRES_VERSION@/lib/postgis-@SOVERSION@.so
-#  else
-#  echo Postgis extension not found, something wrong did probably 
happen
-#  fi
-
-   for FILE in /usr/share/postgis/@POSTGIS_VERSION@/sql/*.sql; do
-   ln -f $FILE /usr/share/postgresql/@POSTGRES_VERSION@/extension/
-   done
-fi
-
-#DEBHELPER#
-
-exit 0
diff --git a/debian/postgis-scripts2.0.3.install 
b/debian/postgis-scripts2.0.3.install
index 9790b32..c7cc660 100644
--- a/debian/postgis-scripts2.0.3.install
+++ b/debian/postgis-scripts2.0.3.install
@@ -1,3 +1,2 @@
-extensions/postgis/sql/*.sql /usr/share/postgis/2.0.3/sql/
-extensions/postgis_topology/sql/*.sql /usr/share/postgis/2.0.3/sql/
+usr/share/postgis/2.0.3
 utils/*.pl /usr/share/postgis/2.0.3/utils/
diff --git a/debian/postgresql-9.1-postgis.install 
b/debian/postgresql-9.1-postgis.install
index 65f0763..abf68bb 100644
--- a/debian/postgresql-9.1-postgis.install
+++ b/debian/postgresql-9.1-postgis.install
@@ -1,2 +1,2 @@
-usr/share/postgresql/9.1/extension/*.control
+usr/share/postgresql/9.1/extension
 usr/lib/postgresql/9.1/lib
diff --git a/debian/postgresql-postgis-generic.postrm.in 
b/debian/postgresql-postgis-generic.postrm.in
deleted file mode 100644
index 1c3cdbb..000
--- a/debian/postgresql-postgis-generic.postrm.in
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-set -e
-
-# Removes all postgis shared libs links
-if [ $1 = purge ]; then
-for version in @POSTGRES_VERSIONS@
-do
-find /usr/lib/postgresql/$version/lib -type f -name 
postgis-@SOVERSION@.so -delete || true
-done
-fi
-
-#DEBHELPER#
-
-exit 0
diff --git a/debian/rules b/debian/rules
index bf556f9..10dee3d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -54,6 +54,16 @@ build-indep-stamp: configuration-stamp
 #  Let PostGIS create a perl script from postgis_restore.pl.in
$(MAKE) -C utils
 
+#  Create a few SQL scripts that the Makefiles are not clever enough
+#  to resolve, when building arch-indep only.
+   $(MAKE) -C postgis postgis.sql postgis_upgrade_20_minor.sql
+   $(MAKE) -C raster/rt_pg rtpostgis.sql rtpostgis_upgrade_20_minor.sql
+   $(MAKE) -C topology topology.sql topology_upgrade_20_minor.sql
+
+#  This create the required SQL scripts. Again, the Makefile is not
+#  clever enough to run this before 'install'.
+   $(MAKE) -C extensions
+
touch $@
 
 configuration: configuration-stamp
@@ -99,10 +109,18 @@ install-indep: build-indep
dh_prep -i 
dh_installdirs -i
 
+   $(MAKE) -C extensions install DESTDIR=$(CURDIR)/debian/tmp
$(MAKE) -C doc docs-install \
DESTDIR=$(CURDIR)/debian/tmp \
-   PGSQL_DOCDIR=/usr/share/doc \
-   PGSQL_SHAREDIR=/usr/share/postgresql/9.1
+   PGSQL_DOCDIR=/usr/share/doc
+
+#  Move all SQL files to /usr/share/postgis - the original location's
+#  files will get replaced with symlinks.
+   mkdir -p $(CURDIR)/debian/tmp/usr/share/postgis/$(VERSION)/sql
+   set -e; \
+   for FILE in 
$(CURDIR)/debian/tmp/usr/share/postgresql/9.1/extension/*.sql; do

[SCM] postgis branch, master, updated. upstream/2.0.1-38-g05bea3a

2013-04-25 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 05bea3a03e4e7dd6244a881c11fa44dded1aef2d
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Apr 25 22:15:20 2013 +0200

Append the PostGIS version to postgresql-9.1-postgis (i.e. rename
the package), so multiple versions of it can be co-installed.

diff --git a/debian/changelog b/debian/changelog
index bb79375..6d5a4fd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -21,8 +21,11 @@ postgis (2.0.3-1) UNRELEASED; urgency=low
 extension package.
   * Separate PostGIS documentation into a postgis-doc package, register its
 contents with doc-base.
-  * Represent the fact that lwgeom isn't backward compatible in its SONAME,
-rename liblwgeom2 to liblwgeom-2.0.3 accordingly.
+  * Append the PostGIS version to postgresql-9.1-postgis, so multiple
+versions of it can be co-installed. Required to keep systems working
+after an upgrade.
+  * Represent the fact that lwgeom isn't backward by renaming liblwgeom2
+to liblwgeom-2.0.3.
   * Add patch java-version-fix: Corrects java jdbc jar version.
   * Policy updated to 3.9.4. No changes.
   * Update debian/copyright a bit.
diff --git a/debian/control b/debian/control
index 8ba3889..841b22c 100644
--- a/debian/control
+++ b/debian/control
@@ -18,7 +18,7 @@ Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git
 Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
 
-Package: postgresql-9.1-postgis
+Package: postgresql-9.1-postgis-2.0
 Depends: ${shlibs:Depends}, postgresql-9.1, postgis-scripts2.0.3,
  ${misc:Depends}
 Recommends: postgis
@@ -37,7 +37,7 @@ Description: Geographic objects support for PostgreSQL 9.1
 Package: postgis
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Suggests: postgresql-9.1-postgis
+Suggests: postgresql-9.1-postgis-2.0
 Description: Geographic objects support for PostgreSQL
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
@@ -66,7 +66,7 @@ Description: Geographic objects support for PostgreSQL -- 
documentation
 Package: postgis-scripts2.0.3
 Architecture: all
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Recommends: postgresql-9.1-postgis
+Recommends: postgresql-9.1-postgis-2.0
 Description: Geographic objects support for PostgreSQL 9.1 -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
@@ -82,7 +82,7 @@ Package: libpostgis-java
 Architecture: all
 Section: java
 Depends: libpostgresql-jdbc-java, ${misc:Depends}
-Suggests: postgresql-9.1-postgis
+Suggests: postgresql-9.1-postgis-2.0
 Breaks: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Replaces: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Description: Geographic objects support for PostgreSQL -- JDBC support
diff --git a/debian/postgresql-9.1-postgis.install 
b/debian/postgresql-9.1-postgis-2.0.install
similarity index 100%
rename from debian/postgresql-9.1-postgis.install
rename to debian/postgresql-9.1-postgis-2.0.install

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-40-g2a53869

2013-04-30 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 8bc6cb267557b3a9745366c59944b84e4d7158f7
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Apr 25 22:16:34 2013 +0200

Fix dependencies, add libjson0{,-dev}.

diff --git a/debian/control b/debian/control
index 841b22c..fbca01c 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Debian GIS Project 
pkg-grass-devel@lists.alioth.debian.org
 Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
  Lovergine fran...@debian.org, Markus Wanner mar...@bluegap.ch
 Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
- flex, bison, libgeos-dev (= 3.1.1),
+ flex, bison, libgeos-dev (= 3.1.1), libjson0-dev,
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpg-java, fastjar, libjts-java (= 1.7), imagemagick,
  libcunit1-dev, dblatex, libxml2-dev, libgtk2.0-dev, libgdal-dev,
@@ -20,7 +20,7 @@ Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
 
 Package: postgresql-9.1-postgis-2.0
 Depends: ${shlibs:Depends}, postgresql-9.1, postgis-scripts2.0.3,
- ${misc:Depends}
+ libjson0, ${misc:Depends}
 Recommends: postgis
 Breaks: postgis ( 1.2.1)
 Architecture: any
@@ -51,7 +51,7 @@ Description: Geographic objects support for PostgreSQL
 Package: postgis-doc
 Section: doc
 Architecture: all
-Depends: ${shlibs:Depends}, ${misc:Depends}
+Depends: ${misc:Depends}
 Suggests: postgis
 Description: Geographic objects support for PostgreSQL -- documentation
  PostGIS adds support for geographic objects to the PostgreSQL
@@ -65,7 +65,7 @@ Description: Geographic objects support for PostgreSQL -- 
documentation
 
 Package: postgis-scripts2.0.3
 Architecture: all
-Depends: ${shlibs:Depends}, ${misc:Depends}
+Depends: ${misc:Depends}
 Recommends: postgresql-9.1-postgis-2.0
 Description: Geographic objects support for PostgreSQL 9.1 -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-40-g2a53869

2013-04-30 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 2a538699945abd89173d406b39cd592d6d29
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Apr 25 22:17:08 2013 +0200

Add a symlink to postgis-jdbc-2.0.3.jar for libpostgis-java to remain
backwards compatible. Drop some commented code from debian/rules.

diff --git a/debian/rules b/debian/rules
index 10dee3d..0be8b9b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -45,9 +45,6 @@ build-arch-stamp: configuration-stamp
 
 build-indep: build-indep-stamp
 build-indep-stamp: configuration-stamp
-#  Documentation and common files for PostGIS
-#  [ ! -f doc/html/postgis.html.prev -a -f doc/html/postgis.html ]  cp 
doc/html/postgis.html doc/html/postgis.html.prev || true
-
 #  PostGIS JDBC (with debug support)
cd $(CURDIR)/java/jdbc  $(MVN) package
 
@@ -124,6 +121,11 @@ install-indep: build-indep
 
dh_install -i
 
+#  Link the resulting JAR file, so it's available via it's old
+#  name. (Even if postgis-jdbc.jar might be more appropriate.)
+   ln -sf postgis-jdbc-$(VERSION).jar \
+   $(CURDIR)/debian/libpostgis-java/usr/share/java/postgis.jar
+
 install-arch: build-arch
dh_testdir
dh_testroot

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-41-g06a9491

2013-05-02 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 06a9491cc42a049118d166f8bd2a4ac4ac7f7291
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu May 2 21:53:25 2013 +0200

Tweaking (build) dependencies a bit more, add minimum version
requirements from the README, move libjson0 dependency to
liblwgeom.

diff --git a/debian/control b/debian/control
index fbca01c..cac79f7 100644
--- a/debian/control
+++ b/debian/control
@@ -5,11 +5,11 @@ Maintainer: Debian GIS Project 
pkg-grass-devel@lists.alioth.debian.org
 Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
  Lovergine fran...@debian.org, Markus Wanner mar...@bluegap.ch
 Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
- flex, bison, libgeos-dev (= 3.1.1), libjson0-dev,
+ flex, bison, libgeos-dev (= 3.1.1), libjson0-dev (= 0.9~),
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpg-java, fastjar, libjts-java (= 1.7), imagemagick,
- libcunit1-dev, dblatex, libxml2-dev, libgtk2.0-dev, libgdal-dev,
- postgresql-server-dev-9.1
+ libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~), libgtk2.0-dev,
+ libgdal-dev (= 1.6.0~), postgresql-server-dev-9.1
 Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
  libmaven-jar-plugin-java, libmaven-resources-plugin-java, maven2
@@ -20,7 +20,7 @@ Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
 
 Package: postgresql-9.1-postgis-2.0
 Depends: ${shlibs:Depends}, postgresql-9.1, postgis-scripts2.0.3,
- libjson0, ${misc:Depends}
+ liblwgeom-2.0.3, ${misc:Depends}
 Recommends: postgis
 Breaks: postgis ( 1.2.1)
 Architecture: any
@@ -98,7 +98,7 @@ Description: Geographic objects support for PostgreSQL -- 
JDBC support
 Package: liblwgeom-2.0.3
 Architecture: any
 Section: libs
-Depends: ${shlibs:Depends}, ${misc:Depends}
+Depends: ${shlibs:Depends}, libjson0 (= 0.9~), ${misc:Depends}
 Description: PostGIS Lightweight Geometry library
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-42-gb1b34b5

2013-06-05 Thread Markus Wanner
The following commit has been merged in the master branch:
commit b1b34b5e3f280606617a8dc66133a6c74cad9bac
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Jun 5 08:06:18 2013 +0200

Add pgversions and allow generation of debian/control based on it.

diff --git a/debian/changelog b/debian/changelog
index 6d5a4fd..c4e1a11 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -24,10 +24,11 @@ postgis (2.0.3-1) UNRELEASED; urgency=low
   * Append the PostGIS version to postgresql-9.1-postgis, so multiple
 versions of it can be co-installed. Required to keep systems working
 after an upgrade.
-  * Represent the fact that lwgeom isn't backward by renaming liblwgeom2
-to liblwgeom-2.0.3.
+  * Represent the fact that lwgeom isn't backward compatible by renaming
+liblwgeom2 to liblwgeom-2.0.3.
   * Add patch java-version-fix: Corrects java jdbc jar version.
   * Policy updated to 3.9.4. No changes.
+  * Add pgversions and allow generation of debian/control based on it.
   * Update debian/copyright a bit.
   * Update and improve watchfile.
 
diff --git a/debian/control b/debian/control
index cac79f7..4c28137 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpg-java, fastjar, libjts-java (= 1.7), imagemagick,
  libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~), libgtk2.0-dev,
- libgdal-dev (= 1.6.0~), postgresql-server-dev-9.1
+ libgdal-dev (= 1.6.0~), postgresql-server-dev-all
 Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
  libmaven-jar-plugin-java, libmaven-resources-plugin-java, maven2
@@ -18,22 +18,6 @@ Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git
 Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
 
-Package: postgresql-9.1-postgis-2.0
-Depends: ${shlibs:Depends}, postgresql-9.1, postgis-scripts2.0.3,
- liblwgeom-2.0.3, ${misc:Depends}
-Recommends: postgis
-Breaks: postgis ( 1.2.1)
-Architecture: any
-Description: Geographic objects support for PostgreSQL 9.1
- PostGIS adds support for geographic objects to the PostgreSQL
- object-relational database. In effect, PostGIS spatially enables
- the PostgreSQL server, allowing it to be used as a backend spatial
- database for geographic information systems (GIS), much like ESRI's
- SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
- Simple Features Specification for SQL.
- .
- This package supports PostgreSQL 9.1.
-
 Package: postgis
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
@@ -67,7 +51,7 @@ Package: postgis-scripts2.0.3
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: postgresql-9.1-postgis-2.0
-Description: Geographic objects support for PostgreSQL 9.1 -- scripts
+Description: Geographic objects support for PostgreSQL -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
  the PostgreSQL server, allowing it to be used as a backend spatial
@@ -129,3 +113,20 @@ Description: PostGIS Lightweight Geometry library - 
Development files
  geometry objects, constructors, destructors, and a set of spatial
  processing functions, are implemented here.  This package contains
  the development files.
+
+Package: postgresql-9.1-postgis-2.0
+Depends: ${shlibs:Depends}, postgresql-9.1, postgis-scripts2.0.3,
+ liblwgeom-2.0.3, ${misc:Depends}
+Recommends: postgis
+Breaks: postgis ( 1.2.1)
+Architecture: any
+Description: Geographic objects support for PostgreSQL 9.1
+ PostGIS adds support for geographic objects to the PostgreSQL
+ object-relational database. In effect, PostGIS spatially enables
+ the PostgreSQL server, allowing it to be used as a backend spatial
+ database for geographic information systems (GIS), much like ESRI's
+ SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
+ Simple Features Specification for SQL.
+ .
+ This package supports PostgreSQL 9.1.
+
diff --git a/debian/control b/debian/control.in
similarity index 91%
copy from debian/control
copy to debian/control.in
index cac79f7..8aadf88 100644
--- a/debian/control
+++ b/debian/control.in
@@ -9,7 +9,7 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpg-java, fastjar, libjts-java (= 1.7), imagemagick,
  libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~), libgtk2.0-dev,
- libgdal-dev (= 1.6.0~), postgresql-server-dev-9.1
+ libgdal-dev (= 1.6.0~), postgresql-server-dev-all
 Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
  libmaven-jar-plugin-java, libmaven-resources-plugin-java, maven2
@@ -18,13 +18,13 @@ Homepage: http://postgis.refractions.net

[SCM] postgis branch, master, updated. upstream/2.0.1-44-g8d5f68a

2013-06-06 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 8d5f68a54b21fce89e0438469e0aeb5c5c25624d
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Jun 5 22:48:50 2013 +0200

It turned out the SQL scripts differ between Postgres
versions. So we need a per-postgres-version package of the
scripts (while still architecture independent). This relieves us
from the symlink dance. Rename the script package as appropriate
and adjust the changelog.

Move down the package description of
postgresql-PGVERSION-postgis-2.0 in debian/control.in to match
the generated file.

diff --git a/debian/changelog b/debian/changelog
index c4e1a11..136e66f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -16,9 +16,7 @@ postgis (2.0.3-1) UNRELEASED; urgency=low
   * Compile the postgis jdbc java library again, using maven directly. Add
 required Build-Depends-Indeps.
   * Separate large SQL scripts and perl utils. Put them in their own
-architecture independent and (hopefully) PostgreSQL version
-indepentend package: postgis-scripts2.0.3. Provide symlinks from the
-extension package.
+architecture independent indepentend package (..-scripts).
   * Separate PostGIS documentation into a postgis-doc package, register its
 contents with doc-base.
   * Append the PostGIS version to postgresql-9.1-postgis, so multiple
@@ -28,7 +26,8 @@ postgis (2.0.3-1) UNRELEASED; urgency=low
 liblwgeom2 to liblwgeom-2.0.3.
   * Add patch java-version-fix: Corrects java jdbc jar version.
   * Policy updated to 3.9.4. No changes.
-  * Add pgversions and allow generation of debian/control based on it.
+  * Add pgversions and allow generation of debian/control and various
+install files based on it.
   * Update debian/copyright a bit.
   * Update and improve watchfile.
 
diff --git a/debian/control b/debian/control
index 4c28137..a4bbb9f 100644
--- a/debian/control
+++ b/debian/control
@@ -47,21 +47,6 @@ Description: Geographic objects support for PostgreSQL -- 
documentation
  .
  This package contains the PostGIS documentation.
 
-Package: postgis-scripts2.0.3
-Architecture: all
-Depends: ${misc:Depends}
-Recommends: postgresql-9.1-postgis-2.0
-Description: Geographic objects support for PostgreSQL -- scripts
- PostGIS adds support for geographic objects to the PostgreSQL
- object-relational database. In effect, PostGIS spatially enables
- the PostgreSQL server, allowing it to be used as a backend spatial
- database for geographic information systems (GIS), much like ESRI's
- SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
- Simple Features Specification for SQL.
- .
- This package contains SQL scripts to upgrade from earlier PostGIS
- versions as well as Perl utility scripts.
-
 Package: libpostgis-java
 Architecture: all
 Section: java
@@ -115,8 +100,9 @@ Description: PostGIS Lightweight Geometry library - 
Development files
  the development files.
 
 Package: postgresql-9.1-postgis-2.0
-Depends: ${shlibs:Depends}, postgresql-9.1, postgis-scripts2.0.3,
- liblwgeom-2.0.3, ${misc:Depends}
+Depends: ${shlibs:Depends}, postgresql-9.1,
+ postgresql-9.1-postgis-2.0-scripts, liblwgeom-2.0.3,
+ ${misc:Depends}
 Recommends: postgis
 Breaks: postgis ( 1.2.1)
 Architecture: any
@@ -130,3 +116,18 @@ Description: Geographic objects support for PostgreSQL 9.1
  .
  This package supports PostgreSQL 9.1.
 
+Package: postgresql-9.1-postgis-2.0-scripts
+Architecture: all
+Depends: ${misc:Depends}
+Recommends: postgresql-9.1-postgis-2.0
+Description: Geographic objects support for PostgreSQL -- scripts
+ PostGIS adds support for geographic objects to the PostgreSQL
+ object-relational database. In effect, PostGIS spatially enables
+ the PostgreSQL server, allowing it to be used as a backend spatial
+ database for geographic information systems (GIS), much like ESRI's
+ SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
+ Simple Features Specification for SQL.
+ .
+ This package contains SQL scripts to upgrade from earlier PostGIS
+ versions for PostgreSQL 9.1 as well as Perl utility scripts.
+
diff --git a/debian/control.in b/debian/control.in
index 8aadf88..4546148 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -18,22 +18,6 @@ Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git
 Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
 
-Package: postgresql-PGVERSION-postgis-2.0
-Depends: ${shlibs:Depends}, postgresql-PGVERSION, postgis-scripts2.0.3,
- liblwgeom-2.0.3, ${misc:Depends}
-Recommends: postgis
-Breaks: postgis ( 1.2.1)
-Architecture: any
-Description: Geographic objects support for PostgreSQL PGVERSION
- PostGIS adds support for geographic objects to the PostgreSQL
- object-relational database. In effect, PostGIS spatially enables
- the PostgreSQL server, allowing it to be used as a backend spatial
- database for geographic information systems (GIS), much like ESRI's
- SDE

[SCM] postgis branch, master, updated. upstream/2.0.1-44-g8d5f68a

2013-06-06 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 5f9eaf4df3d1b53b6a4489b27226a58432368525
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Jun 5 09:14:27 2013 +0200

Auto-create required postgresql-$(PGVERSION)-postgis-2.0.install file
for the current Postgres version.

diff --git a/debian/postgresql-9.1-postgis-2.0.install 
b/debian/postgresql-9.1-postgis-2.0.install
deleted file mode 100644
index abf68bb..000
--- a/debian/postgresql-9.1-postgis-2.0.install
+++ /dev/null
@@ -1,2 +0,0 @@
-usr/share/postgresql/9.1/extension
-usr/lib/postgresql/9.1/lib
diff --git a/debian/postgresql-generic-postgis-2.0.install.in 
b/debian/postgresql-generic-postgis-2.0.install.in
new file mode 100644
index 000..bf135b6
--- /dev/null
+++ b/debian/postgresql-generic-postgis-2.0.install.in
@@ -0,0 +1,2 @@
+usr/share/postgresql/@PGVERSION@/extension
+usr/lib/postgresql/@PGVERSION@/lib
diff --git a/debian/rules b/debian/rules
index 985be34..7d6a58a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -121,6 +121,7 @@ clean:
rm -f $(CURDIR)/debian/*.postinst $(CURDIR)/debian/*.postrm
rm -f postgis/postgis_upgrade_20_minor.sql.in 
raster/rt_pg/rtpostgis_drop.sql \
raster/rt_pg/rtpostgis_upgrade_cleanup.sql
+   rm -f $(CURDIR)/debian/postgresql-*-postgis-2.0.install
dh_clean
 
 install: install-indep install-arch
@@ -170,6 +171,11 @@ install-arch: build-arch
ln -sf 
/usr/share/postgis/$(POSTGIS_VERSION)/sql/$$BASENAME $$FILE; \
done
 
+#  Auto-create required .install file for the current Postgres version.
+   cat $(CURDIR)/debian/postgresql-generic-postgis-2.0.install.in \
+   | sed -e 's/@PGVERSION@/$(NEWEST_POSTGRES_VERSION)/' \
+
$(CURDIR)/debian/postgresql-$(NEWEST_POSTGRES_VERSION)-postgis-2.0.install
+
dh_install -s
 
 check: install-arch

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-45-gcfc45f3

2013-06-06 Thread Markus Wanner
The following commit has been merged in the master branch:
commit cfc45f37bdbea590c8680d6f0cb27829c4421355
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Jun 5 22:55:40 2013 +0200

Be less specific in 
debian/postgresql-generic-postgis-2.0-scripts.install.in,
drop the perl utility scripts - those seem to be relevant at build time
exclusively.

diff --git a/debian/postgresql-generic-postgis-2.0-scripts.install.in 
b/debian/postgresql-generic-postgis-2.0-scripts.install.in
index 78b87a2..07d816f 100644
--- a/debian/postgresql-generic-postgis-2.0-scripts.install.in
+++ b/debian/postgresql-generic-postgis-2.0-scripts.install.in
@@ -1,2 +1 @@
-usr/share/postgresql/@PGVERSION@/extension/
-utils/*.pl /usr/share/postgresql/@PGVERSION@/extension/postgis-utils/
+usr/share/postgresql/@PGVERSION@

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-48-g604bb4d

2013-06-07 Thread Markus Wanner
The following commit has been merged in the master branch:
commit c91058587431fb57cfd8f63d738e8d095b0aafe2
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Jun 5 23:01:11 2013 +0200

debian/rules: tweak some comments - no functional change.

diff --git a/debian/rules b/debian/rules
index 6d504a5..135f653 100755
--- a/debian/rules
+++ b/debian/rules
@@ -82,7 +82,7 @@ build-indep-stamp: configuration-stamp
$(MAKE) -C raster/rt_pg rtpostgis.sql rtpostgis_upgrade_20_minor.sql
$(MAKE) -C topology topology.sql topology_upgrade_20_minor.sql
 
-#  This create the required SQL scripts. Again, the Makefile is not
+#  This creates the required SQL scripts. Again, the Makefile is not
 #  clever enough to run this before 'install'.
$(MAKE) -C extensions
 
@@ -132,6 +132,7 @@ install-indep: build-indep
dh_prep -i 
dh_installdirs -i
 
+#  Install extensions
$(MAKE) -C extensions install DESTDIR=$(CURDIR)/debian/tmp
$(MAKE) -C doc docs-install \
DESTDIR=$(CURDIR)/debian/tmp \
@@ -150,6 +151,7 @@ install-arch: build-arch
dh_prep -s
dh_installdirs -s
 
+#  Install docs
$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
$(MAKE) -C doc man-install \
DESTDIR=$(CURDIR)/debian/tmp \

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-48-g604bb4d

2013-06-07 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 604bb4dffdceea34e3ee3ac45f9a63bc9841e8c6
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Jun 5 23:13:32 2013 +0200

debian/changelog: prepare for upload to unstable.

diff --git a/debian/changelog b/debian/changelog
index 136e66f..3c48562 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-postgis (2.0.3-1) UNRELEASED; urgency=low
+postgis (2.0.3-1) unstable; urgency=low
 
   [Markus Wanner]
   * Team upload
@@ -43,7 +43,7 @@ postgis (2.0.3-1) UNRELEASED; urgency=low
   * Removed old patches (generator, html_doc_resources, install)
   * Added patch fixmakedoc for doc/Makefile.comments.
 
- -- Markus Wanner mar...@bluegap.ch  Mon, 15 Apr 2013 22:12:27 +0200
+ -- Markus Wanner mar...@bluegap.ch  Wed, 05 Jun 2013 23:12:35 +0200
 
 postgis (1.5.3-2) unstable; urgency=low
 

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-48-g604bb4d

2013-06-07 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 2291929d477935134fb862d5a2d77b608628ebf5
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Jun 5 22:59:26 2013 +0200

Add back the PostgreSQL version to the short description of the
postgresql-postgis-scripts package.

diff --git a/debian/control b/debian/control
index a4bbb9f..293c25d 100644
--- a/debian/control
+++ b/debian/control
@@ -120,7 +120,7 @@ Package: postgresql-9.1-postgis-2.0-scripts
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: postgresql-9.1-postgis-2.0
-Description: Geographic objects support for PostgreSQL -- scripts
+Description: Geographic objects support for PostgreSQL 9.1 -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
  the PostgreSQL server, allowing it to be used as a backend spatial
diff --git a/debian/control.in b/debian/control.in
index 4546148..1cf3c80 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -120,7 +120,7 @@ Package: postgresql-PGVERSION-postgis-2.0-scripts
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: postgresql-PGVERSION-postgis-2.0
-Description: Geographic objects support for PostgreSQL -- scripts
+Description: Geographic objects support for PostgreSQL PGVERSION -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
  the PostgreSQL server, allowing it to be used as a backend spatial

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, pgdg, created. upstream/2.0.1-49-gbc2dbed

2013-06-07 Thread Markus Wanner
The branch, pgdg has been created
at  bc2dbed306535d57a2cee5b86b9b779a90256ae4 (commit)

- Shortlog 
commit bc2dbed306535d57a2cee5b86b9b779a90256ae4
Author: Markus Wanner mar...@bluegap.ch
Date:   Fri Jun 7 16:53:09 2013 +0200

Bundle a pgdg package that additionally supports Postgres 8.4, 9.0
and 9.2. Default to suggest the Postgres 9.2 packages for pgdg,
instead of 9.1.

Adjust rules to build PostGIS for each Postgres version in
a separate directory.

---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


RFS: postgis-2.0.3

2013-06-07 Thread Markus Wanner
Hi,

recently, I've been working on packaging PostGIS 2.0 for Debian and now
consider it ready for uploading to unstable. I'm a DM and would also
appreciate upload rights for that package.

Some notes: I took great care to ensure postgis-2.0.3 won't break
existing installations of postgis-1.x. For that reason, the binary
package names now include a version, i.e. 'postgis-2.0'. Effective
upgrade from 1.x to 2.0 requires a dump/restore cycle and is left to the
user.

Upstream is mixed about liblwgeom. Basically, at the moment, there is no
backwards-compatibility guarantee. Taking a conservative approach, I
thus added the full version to the binary package name, i.e.
liblwgeom-2.0.3. As postgis itself is currently the only user of that
library in Debian, that shouldn't be much of an issue. However,
spatialite for example may eventually use it as well.

See upstream bugs on component liblwgeom:
http://trac.osgeo.org/postgis/query?status=assignedstatus=newstatus=reopenedcomponent=liblwgeom

Please see the postgis alioth repository here:
http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git

Regards

Markus Wanner



signature.asc
Description: OpenPGP digital signature
___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

[SCM] postgis branch, master, updated. upstream/2.0.1-49-gaaf80f8

2013-06-12 Thread Markus Wanner
The following commit has been merged in the master branch:
commit aaf80f86cb206d7ab8b9b3fb05a5485b597e3290
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Jun 12 15:00:19 2013 +0200

Correct patches/use-debian-maven to consistently link against
postgresql-jdbc3.jar, rather than any more or less specific
version.

diff --git a/debian/patches/use-debian-maven b/debian/patches/use-debian-maven
index a004075..e81b2b7 100644
--- a/debian/patches/use-debian-maven
+++ b/debian/patches/use-debian-maven
@@ -41,7 +41,7 @@ Last-Update: 2013-04-14
 +  
addClasspathtrue/addClasspath
 +  /manifest
 +  manifestEntries
-+  
Class-Path/usr/share/java/postgresql-jdbc.jar/Class-Path
++  
Class-Path/usr/share/java/postgresql-jdbc3.jar/Class-Path
 +  /manifestEntries
 +  /archive
 +  /configuration
@@ -56,7 +56,7 @@ Last-Update: 2013-04-14
artifactIdpostgresql/artifactId
version9.1-901.jdbc3/version
 +  scopesystem/scope
-+  
systemPath/usr/share/java/postgresql-jdbc3-9.1.jar/systemPath
++  
systemPath/usr/share/java/postgresql-jdbc3.jar/systemPath
/dependency
/dependencies
reporting

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-50-ge8dd40b

2013-06-12 Thread Markus Wanner
The following commit has been merged in the master branch:
commit e8dd40baa2e9380aa37e05b01d7fb23b6dbaa670
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Jun 12 20:47:49 2013 +0200

Land the changes from the pgdg branch, allowing the postgis extension
to be built against multiple Postgres versions.

Add 'debian/control' as a dependency of the 'clean' target so we are
sure it's up to date.

diff --git a/debian/changelog b/debian/changelog
index 3c48562..24e39c5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,8 +11,9 @@ postgis (2.0.3-1) unstable; urgency=low
 liblwgeom/lwout_wkt.c.
   * Ignore changes of some auto-updated files (via source/options). Let
 debian/rules cleanup some more generated files.
-  * rules: swap dh_makeshlibs and dh_installdeb, build in the appropriate
-build targets, let install only install pre-built stuff.
+  * rules: use a separate build directory per Postgres version, swap
+dh_makeshlibs and dh_installdeb, build in the appropriate build targets,
+let install only install pre-built stuff.
   * Compile the postgis jdbc java library again, using maven directly. Add
 required Build-Depends-Indeps.
   * Separate large SQL scripts and perl utils. Put them in their own
diff --git a/debian/pgversions b/debian/pgversions
index 1d15182..6d3dbe3 100644
--- a/debian/pgversions
+++ b/debian/pgversions
@@ -1,3 +1,6 @@
 # Note that postgis-2.0 is not recommended for 8.4 and 9.0, works fine
 # with 9.1 and 9.2, but doesn't work with 9.3, yet.
+8.4
+9.0
 9.1
+9.2
diff --git a/debian/rules b/debian/rules
index 135f653..65d39c0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -53,19 +53,40 @@ ifeq ($(POSTGIS_VERSION),..)
 $(error Cannot detect Postgis version, fix debian/rules)
 endif
 
-# For plain Debian, we support only exactly one version at a time.
+# For the Postgres APT repository, we want to support multiple
+# Postgres versions. However, docs and the JDBC jar only need to be
+# built once - in the main directory.
 NEWEST_POSTGRES_VERSION = $(shell pg_buildext supported-versions 
$(CURDIR)|tail -1)
 ifeq ($(NEWEST_POSTGRES_VERSION),)
 $(error Cannot detect Postgres version, check debian/pgversions and 
pg_buildext)
 endif
 
+OTHER_POSTGRES_VERSIONS = $(shell pg_buildext supported-versions $(CURDIR)\
+   | grep -v $(NEWEST_POSTGRES_VERSION))
+
+COMMON_CONFIGURE_ARGS = --host=$(DEB_HOST_GNU_TYPE) \
+   --build=$(DEB_BUILD_GNU_TYPE) \
+   --prefix=/usr \
+   --exec-prefix=\$${prefix} \
+   --docdir=\$${prefix}/share/doc \
+   --mandir=\$${prefix}/share/man \
+   --infodir=\$${prefix}/share/info \
+   --with-gui
+
 build: build-arch build-indep
 
 build-arch: build-arch-stamp
 build-arch-stamp: configuration-stamp
+#  Build against the newest Postgres version
$(MAKE)
$(MAKE) -C doc
 
+#  Build against all other Postgres versions
+   (set -e; \
+   for PGVER in $(OTHER_POSTGRES_VERSIONS); do \
+   $(MAKE) -C $(CURDIR)/debian/build-$$PGVER; \
+   done)
+
touch $@
 
 build-indep: build-indep-stamp
@@ -91,28 +112,48 @@ build-indep-stamp: configuration-stamp
 configuration: configuration-stamp
 configuration-stamp:
dh_testdir
-   dh_prep -s 
+   dh_prep -s
+
+#  Copy sources required to build extensions for all but the most
+#  recent Postgres version. Unfortunately, Postgis doesn't support
+#  vpath builds.
+   (set -e; \
+   for PGVER in $(OTHER_POSTGRES_VERSIONS); do \
+   mkdir $(CURDIR)/debian/build-$$PGVER; \
+   for FILE in `ls $(CURDIR)|grep -v debian`; do \
+   cp -a $$FILE $(CURDIR)/debian/build-$$PGVER; \
+   done; \
+   done)
+
 #  Documentation and common files for PostGIS
[ ! -f doc/html/postgis.html.prev -a -f doc/html/postgis.html ]  cp 
doc/html/postgis.html doc/html/postgis.html.prev || true
 
 #  PostGIS for the most recent PostgreSQL version
-   ./configure \
-   --host=$(DEB_HOST_GNU_TYPE) \
-   --build=$(DEB_BUILD_GNU_TYPE) \
-   --prefix=/usr \
-   --exec-prefix=\$${prefix} \
+   ./configure $(COMMON_CONFIGURE_ARGS) \

--datadir=\$${prefix}/share/postgresql-$(NEWEST_POSTGRES_VERSION)-postgis \
-   --docdir=\$${prefix}/share/doc \
-   --mandir=\$${prefix}/share/man \
-   --infodir=\$${prefix}/share/info \
-   
--with-pgconfig=/usr/lib/postgresql/$(NEWEST_POSTGRES_VERSION)/bin/pg_config \
-   --with-gui
+   
--with-pgconfig=/usr/lib/postgresql/$(NEWEST_POSTGRES_VERSION)/bin/pg_config
+
+#  PostGIS for all older Postgres versions
+   (set -e; \
+   for PGVER in $(OTHER_POSTGRES_VERSIONS); do \
+   cd $(CURDIR)/debian/build-$$PGVER; \
+   ./configure $(COMMON_CONFIGURE_ARGS) \
+   --datadir=\$${prefix}/share/postgresql-$$PGVER

[SCM] postgis branch, master, updated. upstream/2.0.1-51-g1870c6d

2013-06-14 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 1870c6db590d8904c5fbafee9eb195154223b74a
Author: Markus Wanner mar...@bluegap.ch
Date:   Fri Jun 14 13:24:48 2013 +0200

Change the libgdal-dev dependency to libgdal1-dev. Should fix
the build on precise.

diff --git a/debian/changelog b/debian/changelog
index 24e39c5..14e6e60 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+postgis (2.0.3-2) UNRELEASED; urgency=low
+
+  * Rather than depending on the transitional libgdal-dev package, use
+libgdal1-dev right away.
+
+ -- Markus Wanner mar...@bluegap.ch  Fri, 14 Jun 2013 13:08:58 +0200
+
 postgis (2.0.3-1) unstable; urgency=low
 
   [Markus Wanner]
diff --git a/debian/control b/debian/control
index 293c25d..16efade 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpg-java, fastjar, libjts-java (= 1.7), imagemagick,
  libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~), libgtk2.0-dev,
- libgdal-dev (= 1.6.0~), postgresql-server-dev-all
+ libgdal1-dev (= 1.6.0~), postgresql-server-dev-all
 Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
  libmaven-jar-plugin-java, libmaven-resources-plugin-java, maven2
@@ -21,7 +21,7 @@ Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
 Package: postgis
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Suggests: postgresql-9.1-postgis-2.0
+Suggests: postgresql-9.2-postgis-2.0
 Description: Geographic objects support for PostgreSQL
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
@@ -51,7 +51,7 @@ Package: libpostgis-java
 Architecture: all
 Section: java
 Depends: libpostgresql-jdbc-java, ${misc:Depends}
-Suggests: postgresql-9.1-postgis-2.0
+Suggests: postgresql-9.2-postgis-2.0
 Breaks: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Replaces: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Description: Geographic objects support for PostgreSQL -- JDBC support
diff --git a/debian/control.in b/debian/control.in
index 1cf3c80..5e42f12 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -9,7 +9,7 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpg-java, fastjar, libjts-java (= 1.7), imagemagick,
  libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~), libgtk2.0-dev,
- libgdal-dev (= 1.6.0~), postgresql-server-dev-all
+ libgdal1-dev (= 1.6.0~), postgresql-server-dev-all
 Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
  libmaven-jar-plugin-java, libmaven-resources-plugin-java, maven2

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-52-g467b742

2013-06-14 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 467b742905c66ea7eed5c9bc3626dd5638aaa948
Author: Markus Wanner mar...@bluegap.ch
Date:   Fri Jun 14 14:44:57 2013 +0200

Build-Deps: correct libgeos-dev version requirement, depend on
libpostgresql-jdbc-java instead of (transitional) libpg-java.

diff --git a/debian/changelog b/debian/changelog
index 14e6e60..555f6fd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ postgis (2.0.3-2) UNRELEASED; urgency=low
 
   * Rather than depending on the transitional libgdal-dev package, use
 libgdal1-dev right away.
+  * Build-Deps: correct libgeos-dev version requirement, depend on
+libpostgresql-jdbc-java instead of (transitional) libpg-java.
 
  -- Markus Wanner mar...@bluegap.ch  Fri, 14 Jun 2013 13:08:58 +0200
 
diff --git a/debian/control b/debian/control
index 16efade..daf1459 100644
--- a/debian/control
+++ b/debian/control
@@ -5,11 +5,11 @@ Maintainer: Debian GIS Project 
pkg-grass-devel@lists.alioth.debian.org
 Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
  Lovergine fran...@debian.org, Markus Wanner mar...@bluegap.ch
 Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
- flex, bison, libgeos-dev (= 3.1.1), libjson0-dev (= 0.9~),
+ flex, bison, libgeos-dev (= 3.3.0~), libjson0-dev (= 0.9~),
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
- default-jdk, libpg-java, fastjar, libjts-java (= 1.7), imagemagick,
- libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~), libgtk2.0-dev,
- libgdal1-dev (= 1.6.0~), postgresql-server-dev-all
+ default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
+ imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
+ libgtk2.0-dev, libgdal1-dev (= 1.6.0~), postgresql-server-dev-all
 Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
  libmaven-jar-plugin-java, libmaven-resources-plugin-java, maven2
@@ -21,7 +21,7 @@ Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
 Package: postgis
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Suggests: postgresql-9.2-postgis-2.0
+Suggests: postgresql-9.1-postgis-2.0
 Description: Geographic objects support for PostgreSQL
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
@@ -51,7 +51,7 @@ Package: libpostgis-java
 Architecture: all
 Section: java
 Depends: libpostgresql-jdbc-java, ${misc:Depends}
-Suggests: postgresql-9.2-postgis-2.0
+Suggests: postgresql-9.1-postgis-2.0
 Breaks: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Replaces: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Description: Geographic objects support for PostgreSQL -- JDBC support
diff --git a/debian/control.in b/debian/control.in
index 5e42f12..8fcf2e9 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -5,11 +5,11 @@ Maintainer: Debian GIS Project 
pkg-grass-devel@lists.alioth.debian.org
 Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
  Lovergine fran...@debian.org, Markus Wanner mar...@bluegap.ch
 Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
- flex, bison, libgeos-dev (= 3.1.1), libjson0-dev (= 0.9~),
+ flex, bison, libgeos-dev (= 3.3.0~), libjson0-dev (= 0.9~),
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
- default-jdk, libpg-java, fastjar, libjts-java (= 1.7), imagemagick,
- libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~), libgtk2.0-dev,
- libgdal1-dev (= 1.6.0~), postgresql-server-dev-all
+ default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
+ imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
+ libgtk2.0-dev, libgdal1-dev (= 1.6.0~), postgresql-server-dev-all
 Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
  libmaven-jar-plugin-java, libmaven-resources-plugin-java, maven2

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-53-g43bd658

2013-06-14 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 43bd658f8abbcafb7f9c20c61080b799d72173b4
Author: Markus Wanner mar...@bluegap.ch
Date:   Fri Jun 14 17:03:40 2013 +0200

Lower dependency on libgeos-dev to 3.2.2 and instead dynamically
disable topology support, if GEOS is not new enough - for
backportability.

diff --git a/debian/changelog b/debian/changelog
index 555f6fd..d5611cc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,9 @@ postgis (2.0.3-2) UNRELEASED; urgency=low
 libgdal1-dev right away.
   * Build-Deps: correct libgeos-dev version requirement, depend on
 libpostgresql-jdbc-java instead of (transitional) libpg-java.
+  * Lower dependency on libgeos-dev to 3.2.2 and instead dynamically
+disable topology support, if GEOS is not new enough - for
+backportability.
 
  -- Markus Wanner mar...@bluegap.ch  Fri, 14 Jun 2013 13:08:58 +0200
 
diff --git a/debian/control b/debian/control
index daf1459..eb7b948 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Debian GIS Project 
pkg-grass-devel@lists.alioth.debian.org
 Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
  Lovergine fran...@debian.org, Markus Wanner mar...@bluegap.ch
 Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
- flex, bison, libgeos-dev (= 3.3.0~), libjson0-dev (= 0.9~),
+ flex, bison, libgeos-dev (= 3.2.2~), libjson0-dev (= 0.9~),
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
diff --git a/debian/control.in b/debian/control.in
index 8fcf2e9..811d872 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -5,7 +5,7 @@ Maintainer: Debian GIS Project 
pkg-grass-devel@lists.alioth.debian.org
 Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
  Lovergine fran...@debian.org, Markus Wanner mar...@bluegap.ch
 Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
- flex, bison, libgeos-dev (= 3.3.0~), libjson0-dev (= 0.9~),
+ flex, bison, libgeos-dev (= 3.2.2~), libjson0-dev (= 0.9~),
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
diff --git a/debian/rules b/debian/rules
index 65d39c0..8ef0ca3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -73,6 +73,19 @@ COMMON_CONFIGURE_ARGS = --host=$(DEB_HOST_GNU_TYPE) \
--infodir=\$${prefix}/share/info \
--with-gui
 
+# Retrieve the version of the GEOS library installed.
+GEOS_VERSION = $(shell geos-config --version)
+
+# Depending on that, we either request or disable topology support.
+ENABLE_TOPOLOGY = $(shell dpkg --compare-versions \
+   $(GEOS_VERSION) ge 3.3.2  echo yes)
+
+ifeq ($(ENABLE_TOPOLOGY),yes)
+   COMMON_CONFIGURE_ARGS += --with-topology
+else
+   COMMON_CONFIGURE_ARGS += --without-topology
+endif
+
 build: build-arch build-indep
 
 build-arch: build-arch-stamp

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis tag, upstream/2.0.3, created. upstream/2.0.1-1-g83ec1be

2013-06-26 Thread Markus Wanner
The tag, upstream/2.0.3 has been created
at  83ec1be71f04f2646aa8b3285ee777c4b13e2dbd (commit)

- Shortlog 
commit 83ec1be71f04f2646aa8b3285ee777c4b13e2dbd
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Apr 11 22:39:48 2013 +0200

Import upstream version 2.0.3
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis tag, debian/2.0.3-1, created. upstream/2.0.1-48-g604bb4d

2013-06-26 Thread Markus Wanner
The tag, debian/2.0.3-1 has been created
at  604bb4dffdceea34e3ee3ac45f9a63bc9841e8c6 (commit)

- Shortlog 
commit 604bb4dffdceea34e3ee3ac45f9a63bc9841e8c6
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Jun 5 23:13:32 2013 +0200

debian/changelog: prepare for upload to unstable.
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


Re: RFS: postgis-2.0.3

2013-06-26 Thread Markus Wanner
Francesco,

On 06/26/2013 11:11 AM, Francesco P. Lovergine wrote:
 please provide the correct required tags to upstream/debian branches at every
 new release.

Thanks, good point. I simply didn't think about that.

In a similar vein: is it okay to create beta branches? Maybe
'upstream-beta' and 'beta' to start packaging on postgis-2.1 (or any
other beta release in the future)?

 About libgdal-dev versus libgdal1-dev, the proper dependency is libgdal-dev,
 the old libgdal1-dev should be considered only for back-compatibility.
 In this specific case I would use something like
 
 libgdal-dev | libgdal1-dev
 
 until the old releases still will be considered for backports.

The reasoning behind that was that postgis-2.0 will hardly ever be
compatible to a libgdal2-dev.

 Ratio: we will neve provide multiple versions of gdal development packages,
 so using a versioned name is pointless and inconsistent.

I see. Will change to the proposed variant above.

Regards

Markus

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-59-g07bcd4b

2013-07-18 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 3d1205cd66d6f66ad0b00678ac833a9378ab98cd
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Jul 16 21:42:28 2013 +0200

Revert libgdal1-dev dependency change. Accepting both, now. Tweak
extend-diff-ignore to save us a copying dance in debian/rules.

diff --git a/debian/changelog b/debian/changelog
index d5611cc..932c153 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,12 +1,14 @@
 postgis (2.0.3-2) UNRELEASED; urgency=low
 
-  * Rather than depending on the transitional libgdal-dev package, use
-libgdal1-dev right away.
+  * Correct dependency on libgdal-dev, allowing the old, now transitional
+libgdal1-dev to satisfy it as well.
   * Build-Deps: correct libgeos-dev version requirement, depend on
 libpostgresql-jdbc-java instead of (transitional) libpg-java.
   * Lower dependency on libgeos-dev to 3.2.2 and instead dynamically
 disable topology support, if GEOS is not new enough - for
 backportability.
+  * Tweak extend-diff-ignore to save us a copying dance in
+debian/rules. Cleanup the 'clean' target a bit.
 
  -- Markus Wanner mar...@bluegap.ch  Fri, 14 Jun 2013 13:08:58 +0200
 
diff --git a/debian/control b/debian/control
index ef1a421..da11a8a 100644
--- a/debian/control
+++ b/debian/control
@@ -9,8 +9,8 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
- libgtk2.0-dev, libgdal1-dev (= 1.6.0~), postgresql-server-dev-all,
- postgresql
+ libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
+ postgresql-server-dev-all, postgresql
 Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
  libmaven-jar-plugin-java, libmaven-resources-plugin-java, maven2
diff --git a/debian/control.in b/debian/control.in
index db1c499..c9f7812 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -9,8 +9,8 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
- libgtk2.0-dev, libgdal1-dev (= 1.6.0~), postgresql-server-dev-all,
- postgresql
+ libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
+ postgresql-server-dev-all, postgresql
 Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
  libmaven-jar-plugin-java, libmaven-resources-plugin-java, maven2
diff --git a/debian/rules b/debian/rules
index f993dda..1751d68 100755
--- a/debian/rules
+++ b/debian/rules
@@ -148,9 +148,6 @@ configuration-stamp:
done; \
done)
 
-#  Documentation and common files for PostGIS
-   [ ! -f doc/html/postgis.html.prev -a -f doc/html/postgis.html ]  cp 
doc/html/postgis.html doc/html/postgis.html.prev || true
-
 #  PostGIS for the most recent PostgreSQL version
./configure $(COMMON_CONFIGURE_ARGS) \

--datadir=\$${prefix}/share/postgresql-$(NEWEST_POSTGRES_VERSION)-postgis \
@@ -177,17 +174,16 @@ clean: debian/control
rm -rf $(CURDIR)/debian/build-$$PGVER; \
done)
 
-   rm -f raster/rt_pg/rtpostgis_drop.sql 
raster/rt_pg/rtpostgis_upgrade_cleanup.sql 
postgis/postgis_upgrade_20_minor.sql.in
-   [ -f doc/html/postgis.html.prev ]  mv doc/html/postgis.html.prev 
doc/html/postgis.html || true
[ ! -f GNUmakefile ] || $(MAKE) distclean || true
cd $(CURDIR)/java/jdbc  $(MVN) clean
-   $(MAKE) -C doc images-clean
+   [ ! -f GNUmakefile ] || $(MAKE) -C doc images-clean || true
+
+#  Cleanup after the Makefile
rm -f $(CURDIR)/debian/*.postinst $(CURDIR)/debian/*.postrm
rm -f postgis/postgis_upgrade_20_minor.sql.in 
raster/rt_pg/rtpostgis_drop.sql \
raster/rt_pg/rtpostgis_upgrade_cleanup.sql
rm -f $(CURDIR)/debian/postgresql-*-postgis-2.0.install
rm -f $(CURDIR)/debian/postgresql-*-postgis-2.0-scripts.install
-
rm -f loader/cunit/cu_tester
rm -rf liblwgeom/cunit/.libs
 
diff --git a/debian/source/options b/debian/source/options
index af35293..c2ef412 100644
--- a/debian/source/options
+++ b/debian/source/options
@@ -1,3 +1,2 @@
 # Ignore changes on auto-updated files
-extend-diff-ignore = 
(^|/)(doc/html/image_src/Makefile|libtool|postgis/sqldefines.h|doc/html/images/.*\.png)$
-
+extend-diff-ignore = 
(^|/)(doc/html/postgis\.html|doc/Makefile.comments|doc/html/image_src/Makefile|doc/html/images/.*\.png|libtool|postgis/sqldefines.h|config\.log|topology/test/load_topology-4326.sql|topology/test/load_topology.sql|topology/test/topo_predicates.sql)$

-- 
PostGIS

[SCM] postgis branch, master, updated. upstream/2.0.1-59-g07bcd4b

2013-07-18 Thread Markus Wanner
The following commit has been merged in the master branch:
commit b03bb90f3762cbbf27935660f46a1024ac38faf5
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Jul 18 19:02:13 2013 +0200

Increase version requirement on libgeos-dev back to = 3.3, effectively
reverting 43bd658f.

diff --git a/debian/changelog b/debian/changelog
index 932c153..e836c0d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,9 +4,6 @@ postgis (2.0.3-2) UNRELEASED; urgency=low
 libgdal1-dev to satisfy it as well.
   * Build-Deps: correct libgeos-dev version requirement, depend on
 libpostgresql-jdbc-java instead of (transitional) libpg-java.
-  * Lower dependency on libgeos-dev to 3.2.2 and instead dynamically
-disable topology support, if GEOS is not new enough - for
-backportability.
   * Tweak extend-diff-ignore to save us a copying dance in
 debian/rules. Cleanup the 'clean' target a bit.
 
diff --git a/debian/control b/debian/control
index da11a8a..114709c 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Debian GIS Project 
pkg-grass-devel@lists.alioth.debian.org
 Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
  Lovergine fran...@debian.org, Markus Wanner mar...@bluegap.ch
 Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
- flex, bison, libgeos-dev (= 3.2.2~), libjson0-dev (= 0.9~),
+ flex, bison, libgeos-dev (= 3.3), libjson0-dev (= 0.9~),
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
diff --git a/debian/control.in b/debian/control.in
index c9f7812..877f67a 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -5,7 +5,7 @@ Maintainer: Debian GIS Project 
pkg-grass-devel@lists.alioth.debian.org
 Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
  Lovergine fran...@debian.org, Markus Wanner mar...@bluegap.ch
 Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
- flex, bison, libgeos-dev (= 3.2.2~), libjson0-dev (= 0.9~),
+ flex, bison, libgeos-dev (= 3.3), libjson0-dev (= 0.9~),
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
diff --git a/debian/rules b/debian/rules
index 1751d68..6f2ee17 100755
--- a/debian/rules
+++ b/debian/rules
@@ -78,19 +78,6 @@ COMMON_CONFIGURE_ARGS = --host=$(DEB_HOST_GNU_TYPE) \
--infodir=\$${prefix}/share/info \
--with-gui
 
-# Retrieve the version of the GEOS library installed.
-GEOS_VERSION = $(shell geos-config --version)
-
-# Depending on that, we either request or disable topology support.
-ENABLE_TOPOLOGY = $(shell dpkg --compare-versions \
-   $(GEOS_VERSION) ge 3.3.2  echo yes)
-
-ifeq ($(ENABLE_TOPOLOGY),yes)
-   COMMON_CONFIGURE_ARGS += --with-topology
-else
-   COMMON_CONFIGURE_ARGS += --without-topology
-endif
-
 build: build-arch build-indep
 
 build-arch: build-arch-stamp

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-59-g07bcd4b

2013-07-18 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 80abd9506216eacd6125c06ec8525db58183408b
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Jul 18 19:08:25 2013 +0200

Tweak Build-Deps:
* Make maven2 a full build-dep (not just B-D-Indep). Closes: #714712.
* Drop libpostgresql-jdbc-java from B-D-I, it's already in B-D.

diff --git a/debian/changelog b/debian/changelog
index e836c0d..facd980 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,8 @@ postgis (2.0.3-2) UNRELEASED; urgency=low
 libpostgresql-jdbc-java instead of (transitional) libpg-java.
   * Tweak extend-diff-ignore to save us a copying dance in
 debian/rules. Cleanup the 'clean' target a bit.
+  * Make maven2 a full build-dep (not just B-D-Indep). Closes: #714712.
+  * Drop libpostgresql-jdbc-java from B-D-I, it's already in B-D.
 
  -- Markus Wanner mar...@bluegap.ch  Fri, 14 Jun 2013 13:08:58 +0200
 
diff --git a/debian/control b/debian/control
index 114709c..960d120 100644
--- a/debian/control
+++ b/debian/control
@@ -10,10 +10,10 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
- postgresql-server-dev-all, postgresql
-Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
+ maven2, postgresql-server-dev-all, postgresql
+Build-Depends-Indep: libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
- libmaven-jar-plugin-java, libmaven-resources-plugin-java, maven2
+ libmaven-jar-plugin-java, libmaven-resources-plugin-java
 Standards-Version: 3.9.4
 Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git
diff --git a/debian/control.in b/debian/control.in
index 877f67a..d22b636 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -10,10 +10,10 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
- postgresql-server-dev-all, postgresql
-Build-Depends-Indep: libpostgresql-jdbc-java, libsurefire-java,
+ maven2, postgresql-server-dev-all, postgresql
+Build-Depends-Indep: libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
- libmaven-jar-plugin-java, libmaven-resources-plugin-java, maven2
+ libmaven-jar-plugin-java, libmaven-resources-plugin-java
 Standards-Version: 3.9.4
 Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-59-g07bcd4b

2013-07-18 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 60710a59bec0d3ce098f5442d2cc7cd50c519e26
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Jul 18 19:03:44 2013 +0200

Tweak extend-diff-ignore a bit more.

diff --git a/debian/source/options b/debian/source/options
index c2ef412..ce502b2 100644
--- a/debian/source/options
+++ b/debian/source/options
@@ -1,2 +1,2 @@
 # Ignore changes on auto-updated files
-extend-diff-ignore = 
(^|/)(doc/html/postgis\.html|doc/Makefile.comments|doc/html/image_src/Makefile|doc/html/images/.*\.png|libtool|postgis/sqldefines.h|config\.log|topology/test/load_topology-4326.sql|topology/test/load_topology.sql|topology/test/topo_predicates.sql)$
+extend-diff-ignore = 
(^|/)(doc/html/postgis\.html|doc/Makefile|doc/Makefile.comments|doc/html/image_src/Makefile|doc/html/images/.*\.png|libtool|postgis/sqldefines.h|config\.log|topology/test/load_topology-4326.sql|topology/test/load_topology.sql|topology/test/topo_predicates.sql)$

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-59-g07bcd4b

2013-07-18 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 07bcd4b62e1fb5b0c8f9853d72fee5a46e771bbd
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Jul 18 19:14:46 2013 +0200

Pass an LD_PRELOAD to postgres when running 'make check', so the
postgis library being loaded can find liblwgeom (and doesn't try to
use a pre-installed one).

Add postgresql-common build dependency, as the above needs a relatively
new pg_createcluster feature.

diff --git a/debian/changelog b/debian/changelog
index facd980..5928fdf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,11 @@ postgis (2.0.3-2) UNRELEASED; urgency=low
   * Tweak extend-diff-ignore to save us a copying dance in
 debian/rules. Cleanup the 'clean' target a bit.
   * Make maven2 a full build-dep (not just B-D-Indep). Closes: #714712.
+  * Pass an LD_PRELOAD to postgres when running 'make check', so the
+postgis library being loaded can find liblwgeom (and doesn't try to
+use a pre-installed one).
+  * Add postgresql-common build dependency, as the above needs a relatively
+new pg_createcluster feature.
   * Drop libpostgresql-jdbc-java from B-D-I, it's already in B-D.
 
  -- Markus Wanner mar...@bluegap.ch  Fri, 14 Jun 2013 13:08:58 +0200
diff --git a/debian/control b/debian/control
index 960d120..dab471d 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,7 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
- maven2, postgresql-server-dev-all, postgresql
+ maven2, postgresql-server-dev-all, postgresql, postgresql-common (= 146)
 Build-Depends-Indep: libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
  libmaven-jar-plugin-java, libmaven-resources-plugin-java
diff --git a/debian/control.in b/debian/control.in
index d22b636..6c0d091 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -10,7 +10,7 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
- maven2, postgresql-server-dev-all, postgresql
+ maven2, postgresql-server-dev-all, postgresql, postgresql-common (= 146)
 Build-Depends-Indep: libsurefire-java,
  libmaven-clean-plugin-java, libmaven-compiler-plugin-java,
  libmaven-jar-plugin-java, libmaven-resources-plugin-java
diff --git a/debian/rules b/debian/rules
index 6f2ee17..057bc40 100755
--- a/debian/rules
+++ b/debian/rules
@@ -94,8 +94,11 @@ build-arch-stamp: configuration-stamp
 
 #   Run unit tests (against the newest Postgres version only, for
 #   now).
+   echo LD_PRELOAD = '$(CURDIR)/liblwgeom/.libs/liblwgeom-2.0.3.so' \
+$(CURDIR)/postgis-check-env.tmp
test -z '$(CHECK)' || \
-   pg_virtualenv -v $(NEWEST_POSTGRES_VERSION) make $(CHECK)
+   pg_virtualenv -v $(NEWEST_POSTGRES_VERSION) \
+   -c '--environment $(CURDIR)/postgis-check-env.tmp' make 
check
 
touch $@
 
@@ -174,6 +177,9 @@ clean: debian/control
rm -f loader/cunit/cu_tester
rm -rf liblwgeom/cunit/.libs
 
+#  Cleanup the temporary environment file.
+   rm -f postgis-check-env.tmp
+
dh_clean
 
 install: install-indep install-arch
@@ -242,8 +248,13 @@ install-arch: build-arch
 
dh_install -s
 
-check: install-arch
-   $(MAKE) check
+check: build-arch
+#   Run unit tests (against the newest Postgres version only, for
+#   now).
+   echo LD_PRELOAD = '$(CURDIR)/liblwgeom/.libs/liblwgeom-2.0.3.so' \
+$(CURDIR)/postgis-check-env.tmp
+   pg_virtualenv -v $(NEWEST_POSTGRES_VERSION) \
+   -c '--environment $(CURDIR)/postgis-check-env.tmp' make check
 
 # Must not depend on anything. This is to be called by
 # binary-arch/binary-indep

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-60-g3ca084e

2013-07-18 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 3ca084e05caa787c7896b78b9cd881168588c599
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Jul 18 20:30:01 2013 +0200

Finalize 2.0.3-2.

diff --git a/debian/changelog b/debian/changelog
index 5928fdf..f98c95f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-postgis (2.0.3-2) UNRELEASED; urgency=low
+postgis (2.0.3-2) unstable; urgency=low
 
   * Correct dependency on libgdal-dev, allowing the old, now transitional
 libgdal1-dev to satisfy it as well.
@@ -14,7 +14,7 @@ postgis (2.0.3-2) UNRELEASED; urgency=low
 new pg_createcluster feature.
   * Drop libpostgresql-jdbc-java from B-D-I, it's already in B-D.
 
- -- Markus Wanner mar...@bluegap.ch  Fri, 14 Jun 2013 13:08:58 +0200
+ -- Markus Wanner  mar...@bluegap.ch  Thu, 18 Jul 2013 20:29:41 +0200
 
 postgis (2.0.3-1) unstable; urgency=low
 

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


Bug#717307: raster2pgsql missing manpage

2013-07-19 Thread Markus Wanner
Source: postgis
Version: 2.0.3-1
Severity: wishlist
Tags: upstream

Man page for raster2pgsql is missing. Issue reported upstream here:
http://trac.osgeo.org/postgis/ticket/2386

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-62-gd2b9e25

2013-07-19 Thread Markus Wanner
The following commit has been merged in the master branch:
commit d2b9e258385c3114a172ceed4b22cd2998a49152
Author: Markus Wanner mar...@bluegap.ch
Date:   Sat Jul 20 01:10:20 2013 +0200

Add fix-test-case-for-i386 patch, back-ported from upstream's
r10642. Fixes tests on i386 (and possibly other non-amd64
architectures).

diff --git a/debian/changelog b/debian/changelog
index 60a451d..dd00df7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,12 @@
 postgis (2.0.3-3) UNRELEASED; urgency=low
 
   [Mònica Ramírez Arceda]
-  * Add a manpage to shp2pgsql-gui. Closes: #656012.
+  * Add a manpage for shp2pgsql-gui. Closes: #656012.
+
+  [Markus Wanner]
+  * Add fix-test-case-for-i386 patch, back-ported from upstream's
+r10642. Fixes tests on i386 (and possibly other non-amd64
+architectures).
 
  -- Markus Wanner mar...@bluegap.ch  Fri, 19 Jul 2013 10:59:47 +0200
 
diff --git a/debian/patches/fix-test-case-for-i386 
b/debian/patches/fix-test-case-for-i386
new file mode 100644
index 000..805c70d
--- /dev/null
+++ b/debian/patches/fix-test-case-for-i386
@@ -0,0 +1,18 @@
+Description: sanitize test case for architectures other than amd64
+ Stop penalizing windows 9.2 32-bit when it gives a stupid answer to
+ an ill-defined question. Change to be a well-defined question.
+Author: Regina Obe l...@pcorp.us
+Last-Update: 2013-07-10
+Origin: http://trac.osgeo.org/postgis/changeset/10642
+
+--- a/regress/lwgeom_regress.sql
 b/regress/lwgeom_regress.sql
+@@ -92,7 +92,7 @@
+ 
+ 
+ SELECT ST_extent(geometry(wkb_ndr)) from test_data;
+-SELECT ST_3DExtent(geometry(wkb_ndr)) from test_data;
++SELECT ST_3DExtent(geometry(wkb_ndr)) from test_data WHERE ST_NDims(wkb_ndr) 
 2;
+ SELECT ST_mem_size(ST_collect(ST_force_2d(geometry(wkb_ndr from test_data;
+ SELECT ST_mem_size(ST_collect(ST_force_3dz(geometry(wkb_ndr from 
test_data;
+ SELECT ST_mem_size(ST_collect(ST_force_4d(ST_force_2d(geometry(wkb_ndr) 
from test_data;
diff --git a/debian/patches/series b/debian/patches/series
index 4769335..d760310 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -6,3 +6,4 @@ link-liblwgeom
 use-debian-maven
 fix-manpages
 honor-build-flags
+fix-test-case-for-i386

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

[SCM] postgis branch, master, updated. upstream/2.0.1-63-g8015aa0

2013-07-22 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 8015aa0499aeb60b78f88abc4615f56a998363dd
Author: Markus Wanner mar...@bluegap.ch
Date:   Mon Jul 22 11:45:44 2013 +0200

Finalize 2.0.3-3.

diff --git a/debian/changelog b/debian/changelog
index dd00df7..3100e72 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-postgis (2.0.3-3) UNRELEASED; urgency=low
+postgis (2.0.3-3) unstable; urgency=low
 
   [Mònica Ramírez Arceda]
   * Add a manpage for shp2pgsql-gui. Closes: #656012.

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

[SCM] postgis tag, debian/2.0.3-2, created. upstream/2.0.1-60-g3ca084e

2013-07-22 Thread Markus Wanner
The tag, debian/2.0.3-2 has been created
at  3ca084e05caa787c7896b78b9cd881168588c599 (commit)

- Shortlog 
commit 3ca084e05caa787c7896b78b9cd881168588c599
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Jul 18 20:30:01 2013 +0200

Finalize 2.0.3-2.
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


RFS: postgis-2.0.3-3

2013-07-22 Thread Markus Wanner
Hi,

unfortunately, the postgis package uploaded recently run into a FTBFS. I
didn't take arch-only builds into account. That, among a couple of other
things got fixed in the mean time. Most notably, the test suite now runs
through just fine.

The current postgis-2.0.3-3 works fine on sid, wheezy and precise,
against Postgres versions 8.4 - 9.2, as per the pgapt build bot.

Please see the postgis alioth repository here:
http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git

As a DM, I'd also appreciate upload permissions for postgis.

Regards

Markus Wanner

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis tag, debian/2.0.3-4, created. upstream/2.0.1-64-g476b1b5

2013-07-23 Thread Markus Wanner
The tag, debian/2.0.3-4 has been created
at  476b1b5efb4923d2a44d615459b099db7aca3092 (commit)

- Shortlog 
commit 476b1b5efb4923d2a44d615459b099db7aca3092
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Jul 23 10:23:19 2013 +0200

Build-Deps: also make libmaven-clean-plugin-java and 
libmaven-jar-plugin-java
a full build dependency. Fixes another FTBFS. Finalize 2.0.3-4.
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


Bug#653111: postgresql-9.1-postgis: postgis dependencies are very strong

2013-07-24 Thread Markus Wanner
On 06/18/2013 02:02 PM, Jonas Smedegaard wrote:
 Package postgresql-9.1-postgis is an extension to postgresql-9.1 i.e. a
 plugin package for servers.

With postgis-2.0.3-1, dependencies changed quite a bit.

postgis and postgresql-9.1-postgis are now entirely independent
packages. postgresql-9.1-postgis only recommends postgis. And postgis in
turn just suggests postgresql-9.1-postgis.

(The later is only a suggestion mainly because i.e.
postgresql-9.2-postgis may well be a better alternative, if available.)

 What I suggest (in line with original poster but more detailed) is to
 move tool shp2pgsql-gui to new package postgis-x11, and have package
 postgis recommend package shp2pgsql-gui.

I didn't split the GUI tools out of postgis, so far. However, given the
relaxed dependencies between postgis and postgresql-9.1-postgis, do you
agree to close this bug?

Regards

Markus Wanner



signature.asc
Description: OpenPGP digital signature
___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

[SCM] postgis branch, master, updated. upstream/2.0.1-65-g6601ee7

2013-07-26 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 6601ee78bae102748aa7abd9d507aae624185c3d
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Jul 25 21:58:23 2013 +0200

* Build-Deps: rather than default-jdk, depend on openjdk 6 or 7, as the
  gcj-jdk didn't work.
* Add patch fix-kfreebsd to get rid of a compilation error on kFreeBSD.
* rules: if 'make check' fails, print all the diffs of failing tests on
  stdout.

diff --git a/debian/changelog b/debian/changelog
index 4406761..b640c7e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+postgis (2.0.3-5) unstable; urgency=low
+
+  * Build-Deps: rather than default-jdk, depend on openjdk 6 or 7, as the
+gcj-jdk didn't work.
+  * Add patch fix-kfreebsd to get rid of a compilation error on kFreeBSD.
+  * rules: if 'make check' fails, print all the diffs of failing tests on
+stdout.
+
+ -- Markus Wanner mar...@bluegap.ch  Thu, 25 Jul 2013 21:45:17 +0200
+
 postgis (2.0.3-4) unstable; urgency=low
 
   * Build-Deps: also make libmaven-clean-plugin-java and
diff --git a/debian/control b/debian/control
index 42a0f76..4ad4094 100644
--- a/debian/control
+++ b/debian/control
@@ -7,11 +7,12 @@ Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
 Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
  flex, bison, libgeos-dev (= 3.3), libjson0-dev (= 0.9~),
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
- default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
- maven2, libmaven-clean-plugin-java, libmaven-jar-plugin-java,
- postgresql-server-dev-all, postgresql, postgresql-common (= 146)
+ openjdk-6-jdk | openjdk-7-jdk, libpostgresql-jdbc-java, fastjar,
+ libjts-java (= 1.7), maven2, libmaven-clean-plugin-java,
+ libmaven-jar-plugin-java, postgresql-server-dev-all,
+ postgresql-common (= 146), postgresql
 Build-Depends-Indep: libsurefire-java, libmaven-compiler-plugin-java,
  libmaven-resources-plugin-java
 Standards-Version: 3.9.4
diff --git a/debian/control.in b/debian/control.in
index 7e5d3d3..023164a 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -7,11 +7,12 @@ Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
 Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
  flex, bison, libgeos-dev (= 3.3), libjson0-dev (= 0.9~),
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
- default-jdk, libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7),
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
- maven2, libmaven-clean-plugin-java, libmaven-jar-plugin-java,
- postgresql-server-dev-all, postgresql, postgresql-common (= 146)
+ openjdk-6-jdk | openjdk-7-jdk, libpostgresql-jdbc-java, fastjar,
+ libjts-java (= 1.7), maven2, libmaven-clean-plugin-java,
+ libmaven-jar-plugin-java, postgresql-server-dev-all,
+ postgresql-common (= 146), postgresql
 Build-Depends-Indep: libsurefire-java, libmaven-compiler-plugin-java,
  libmaven-resources-plugin-java
 Standards-Version: 3.9.4
diff --git a/debian/patches/fix-kfreebsd b/debian/patches/fix-kfreebsd
new file mode 100644
index 000..9c11885
--- /dev/null
+++ b/debian/patches/fix-kfreebsd
@@ -0,0 +1,15 @@
+Description: Treat Debian kFreeBSD the same as FreeBSD (and Linux)
+Author: Markus Wanner mar...@bluegap.ch
+Last-Update: 2013-07-27
+
+--- a/raster/rt_core/rt_api.h
 b/raster/rt_core/rt_api.h
+@@ -42,7 +42,7 @@
+ #endif
+ 
+ 
+-#if defined(__FreeBSD__) || defined(__OpenBSD__)/* seems to work like 
Linux... */
++#if defined(__FreeBSD_kernel__) || defined(__OpenBSD__)/* seems to work 
like Linux... */
+ #if !defined(LINUX)
+ #define LINUX
+ #endif
diff --git a/debian/patches/series b/debian/patches/series
index d760310..0cd3661 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -7,3 +7,4 @@ use-debian-maven
 fix-manpages
 honor-build-flags
 fix-test-case-for-i386
+fix-kfreebsd
diff --git a/debian/rules b/debian/rules
index 057bc40..fbf6dfb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -96,9 +96,18 @@ build-arch-stamp: configuration-stamp
 #   now).
echo LD_PRELOAD = '$(CURDIR)/liblwgeom/.libs/liblwgeom-2.0.3.so' \
 $(CURDIR)/postgis-check-env.tmp
-   test -z '$(CHECK)' || \
+
+   (set -e; \
+   test -z '$(CHECK)' || \
pg_virtualenv -v $(NEWEST_POSTGRES_VERSION) \
-   -c '--environment $(CURDIR)/postgis-check-env.tmp' make 
check
+   -c '--environment $(CURDIR)/postgis-check-env.tmp' make 
check || (\
+   for LOGFILE in /tmp/pgis_reg/test_*_diff; do \
+   echo  ### $LOGFILE ###; \
+   cat $$LOGFILE; \
+   done; \
+   echo  ### end of log dumps

[SCM] postgis tag, debian/2.0.3-5, created. upstream/2.0.1-65-g6601ee7

2013-07-26 Thread Markus Wanner
The tag, debian/2.0.3-5 has been created
at  6601ee78bae102748aa7abd9d507aae624185c3d (commit)

- Shortlog 
commit 6601ee78bae102748aa7abd9d507aae624185c3d
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Jul 25 21:58:23 2013 +0200

* Build-Deps: rather than default-jdk, depend on openjdk 6 or 7, as the
  gcj-jdk didn't work.
* Add patch fix-kfreebsd to get rid of a compilation error on kFreeBSD.
* rules: if 'make check' fails, print all the diffs of failing tests on
  stdout.
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-66-g76b86c1

2013-07-29 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 76b86c1fdc8e411d63e6252e1f8d5c471600b022
Author: Markus Wanner mar...@bluegap.ch
Date:   Mon Jul 29 20:58:29 2013 +0200

Cleanup check target, reduce duplication.

diff --git a/debian/changelog b/debian/changelog
index b640c7e..928cd3a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+postgis (2.0.3-6) UNRELEASED; urgency=low
+
+  * Cleanup check target, reduce duplication.
+
+ -- Markus Wanner mar...@bluegap.ch  Mon, 29 Jul 2013 17:01:22 +0200
+
 postgis (2.0.3-5) unstable; urgency=low
 
   * Build-Deps: rather than default-jdk, depend on openjdk 6 or 7, as the
diff --git a/debian/rules b/debian/rules
index fbf6dfb..e9afdba 100755
--- a/debian/rules
+++ b/debian/rules
@@ -80,7 +80,7 @@ COMMON_CONFIGURE_ARGS = --host=$(DEB_HOST_GNU_TYPE) \
 
 build: build-arch build-indep
 
-build-arch: build-arch-stamp
+build-arch: build-arch-stamp check
 build-arch-stamp: configuration-stamp
 #  Build against the newest Postgres version
$(MAKE)
@@ -92,23 +92,6 @@ build-arch-stamp: configuration-stamp
$(MAKE) -C $(CURDIR)/debian/build-$$PGVER; \
done)
 
-#   Run unit tests (against the newest Postgres version only, for
-#   now).
-   echo LD_PRELOAD = '$(CURDIR)/liblwgeom/.libs/liblwgeom-2.0.3.so' \
-$(CURDIR)/postgis-check-env.tmp
-
-   (set -e; \
-   test -z '$(CHECK)' || \
-   pg_virtualenv -v $(NEWEST_POSTGRES_VERSION) \
-   -c '--environment $(CURDIR)/postgis-check-env.tmp' make 
check || (\
-   for LOGFILE in /tmp/pgis_reg/test_*_diff; do \
-   echo  ### $LOGFILE ###; \
-   cat $$LOGFILE; \
-   done; \
-   echo  ### end of log dumps ###; \
-   exit 2) \
-   )
-
touch $@
 
 build-indep: build-indep-stamp
@@ -257,17 +240,18 @@ install-arch: build-arch
 
dh_install -s
 
-check: build-arch
+check: build-arch-stamp
 #   Run unit tests (against the newest Postgres version only, for
 #   now).
echo LD_PRELOAD = '$(CURDIR)/liblwgeom/.libs/liblwgeom-2.0.3.so' \
 $(CURDIR)/postgis-check-env.tmp
(set -e; \
+   test -z '$(CHECK)' || \
pg_virtualenv -v $(NEWEST_POSTGRES_VERSION) \
-c '--environment $(CURDIR)/postgis-check-env.tmp' make 
check || (\
for LOGFILE in /tmp/pgis_reg/test_*_diff; do \
-   echo  ### $LOGFILE ###; \
-   cat $LOGFILE; \
+   echo  ### $$LOGFILE ###; \
+   cat $$LOGFILE; \
done; \
echo  ### end of log dumps ###; \
exit 2) \

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-67-g277eecf

2013-07-31 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 277eecf24f9e663f3be2f103cbe310a19bb47842
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Jul 30 22:20:33 2013 +0200

Re-add postgis_restore.pl from the utils directory to the scripts
package.

diff --git a/debian/changelog b/debian/changelog
index 928cd3a..2b8d03f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
 postgis (2.0.3-6) UNRELEASED; urgency=low
 
   * Cleanup check target, reduce duplication.
+  * Re-add postgis_restore.pl from the utils directory. Closes: #718358.
 
  -- Markus Wanner mar...@bluegap.ch  Mon, 29 Jul 2013 17:01:22 +0200
 
diff --git a/debian/rules b/debian/rules
index e9afdba..9218c91 100755
--- a/debian/rules
+++ b/debian/rules
@@ -181,8 +181,9 @@ install-indep: build-indep
dh_prep -i 
dh_installdirs -i
 
-#  Install extensions for the most recent Postgres version
+#  Install extensions and utils for the most recent Postgres version
$(MAKE) -C extensions install DESTDIR=$(CURDIR)/debian/tmp
+   $(MAKE) -C utils install DESTDIR=$(CURDIR)/debian/tmp
 
 #  Install extensions for the older Postgres versions
(set -e; \

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


Bug#718749: postgis: FTBFS on !x86 arches

2013-08-05 Thread Markus Wanner
retitle 718749 postgis: FTBFS on non-Intel arches
forwarded 718749 http://trac.osgeo.org/postgis/ticket/2396
tags 718749 + upstream
thanks

On 08/05/2013 02:39 AM, Hector Oron wrote:
   Your package fails to build from source on Debian autobuilder network.
 
   Please check your package build logs at:
   https://buildd.debian.org/status/package.php?p=postgissuite=sid

This has been reported upstream and we are working together to make
postgis work on more than just Intel platforms.

See:
http://trac.osgeo.org/postgis/ticket/2396
http://trac.osgeo.org/postgis/ticket/2399

(Note: a single non-x86 architecture passes checks: ia64. Thus the rename.)

Regards

Markus Wanner



signature.asc
Description: OpenPGP digital signature
___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

[SCM] postgis branch, master, updated. upstream/2.0.1-68-g6553baf

2013-08-06 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 6553baf2a16e67aff39ee764ed5078dfeb424f01
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Aug 6 20:16:11 2013 +0200

Add patch fix-tests-on-big-endian to fix unit tests on big endian.

diff --git a/debian/patches/fix-tests-on-big-endian 
b/debian/patches/fix-tests-on-big-endian
new file mode 100644
index 000..aceae31
--- /dev/null
+++ b/debian/patches/fix-tests-on-big-endian
@@ -0,0 +1,36 @@
+Description: Fix an endianness issue in unit tests
+Author: Regina Obe l...@pcorp.us
+Last-Update: 2013-08-06
+Origin: http://trac.osgeo.org/postgis/changeset/11738
+
+--- a/liblwgeom/cunit/cu_libgeom.c
 b/liblwgeom/cunit/cu_libgeom.c
+@@ -693,6 +693,7 @@
+ static void test_lwgeom_force_clockwise(void)
+ {
+   LWGEOM *geom;
++  LWGEOM *geom2;
+   char *in_ewkt, *out_ewkt;
+ 
+   /* counterclockwise, must be reversed */
+@@ -743,13 +744,14 @@
+   /* NOTE: this is a narrow ring, see ticket #1302 */
+   in_ewkt  = 
010300010005917E9BA468294100917E9B8AEA2841C976BE1FA4682941C976BE9F8AEA2841B39ABE1FA46829415ACCC29F8AEA284137894120A4682941C976BE9F8AEA284100917E9BA468294100917E9B8AEA2841;
+   geom = lwgeom_from_hexwkb(in_ewkt, LW_PARSER_CHECK_NONE);
+-  lwgeom_force_clockwise(geom);
+-  out_ewkt = lwgeom_to_hexwkb(geom, WKB_ISO, NULL);
+-  if (strcmp(in_ewkt, out_ewkt))
+-  fprintf(stderr, \nExp:   %s\nObt:   %s\n, in_ewkt, out_ewkt);
+-  CU_ASSERT_STRING_EQUAL(in_ewkt, out_ewkt);
+-  lwfree(out_ewkt);
++  geom2 = lwgeom_from_hexwkb(in_ewkt, LW_PARSER_CHECK_NONE);
++  lwgeom_force_clockwise(geom2);
++  
++  /** use same check instead of strcmp to account 
++for difference in endianness **/
++  CU_ASSERT( lwgeom_same(geom, geom2) );
+   lwgeom_free(geom);
++  lwgeom_free(geom2);
+ }
+ 
+ /*
diff --git a/debian/patches/series b/debian/patches/series
index 0cd3661..17a0a48 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -8,3 +8,4 @@ fix-manpages
 honor-build-flags
 fix-test-case-for-i386
 fix-kfreebsd
+fix-tests-on-big-endian

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis tag, debian/postgis-2.0.3-6, created. upstream/2.0.1-69-ga137a07

2013-08-07 Thread Markus Wanner
The tag, debian/postgis-2.0.3-6 has been created
at  a137a075cbcc16fe27ae583ac76711840a4a43dd (commit)

- Shortlog 
commit a137a075cbcc16fe27ae583ac76711840a4a43dd
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Aug 6 20:31:06 2013 +0200

Finalize 2.0.3-6.
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-69-ga137a07

2013-08-07 Thread Markus Wanner
The following commit has been merged in the master branch:
commit a137a075cbcc16fe27ae583ac76711840a4a43dd
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Aug 6 20:31:06 2013 +0200

Finalize 2.0.3-6.

diff --git a/debian/changelog b/debian/changelog
index 2b8d03f..e84c8ad 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,11 @@
-postgis (2.0.3-6) UNRELEASED; urgency=low
+postgis (2.0.3-6) unstable; urgency=low
 
   * Cleanup check target, reduce duplication.
   * Re-add postgis_restore.pl from the utils directory. Closes: #718358.
+  * Add patch fix-tests-on-big-endian to fix unit tests on big
+endian. Closes: #718749.
 
- -- Markus Wanner mar...@bluegap.ch  Mon, 29 Jul 2013 17:01:22 +0200
+ -- Markus Wanner mar...@bluegap.ch  Wed, 06 Aug 2013 20:29:42 +0200
 
 postgis (2.0.3-5) unstable; urgency=low
 

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-70-g5ad5a07

2013-08-07 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 5ad5a075fe166ee8d6997bf41b76b2745ceb1b6d
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Aug 7 14:19:22 2013 +0200

* Switch back to depend on default-jdk. To work around gcj-jdk
  incompatibilities, restrict libpostgis-java to the same set of
  architectures that support openjdk 6 and newer.
* Adjust rules to build libpostgis-java only on architectures that
  support it.
* Use a simple rm rather than invoking maven to clean up. Allows
  us to move all java related Build-Depends back to Build-Depends-Indep.

diff --git a/debian/changelog b/debian/changelog
index e84c8ad..b176a5a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+postgis (2.0.3-7) UNRELEASED; urgency=low
+
+  * Switch back to depend on default-jdk. To work around gcj-jdk
+incompatibilities, restrict libpostgis-java to the same set of
+architectures that support openjdk 6 and newer.
+  * Adjust rules to build libpostgis-java only on architectures that
+support it.
+  * Use a simple rm rather than invoking maven. Allows us to move all java
+related Build-Depends back to Build-Depends-Indep.
+
+ -- Markus Wanner mar...@bluegap.ch  Wed, 07 Aug 2013 13:12:25 +0200
+
 postgis (2.0.3-6) unstable; urgency=low
 
   * Cleanup check target, reduce duplication.
diff --git a/debian/control b/debian/control
index 4ad4094..e466dbd 100644
--- a/debian/control
+++ b/debian/control
@@ -9,12 +9,11 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
- openjdk-6-jdk | openjdk-7-jdk, libpostgresql-jdbc-java, fastjar,
+ postgresql-server-dev-all, postgresql-common (= 146), postgresql
+Build-Depends-Indep: default-jdk, libpostgresql-jdbc-java, fastjar,
  libjts-java (= 1.7), maven2, libmaven-clean-plugin-java,
- libmaven-jar-plugin-java, postgresql-server-dev-all,
- postgresql-common (= 146), postgresql
-Build-Depends-Indep: libsurefire-java, libmaven-compiler-plugin-java,
- libmaven-resources-plugin-java
+ libmaven-jar-plugin-java, libsurefire-java,
+ libmaven-compiler-plugin-java, libmaven-resources-plugin-java
 Standards-Version: 3.9.4
 Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git
@@ -50,7 +49,8 @@ Description: Geographic objects support for PostgreSQL -- 
documentation
  This package contains the PostGIS documentation.
 
 Package: libpostgis-java
-Architecture: all
+Architecture: alpha amd64 armel armhf arm64 i386 ia64 lpia mips mipsel
+ powerpc powerpcspe ppc64 s390 s390x sh4 sparc sparc64
 Section: java
 Depends: libpostgresql-jdbc-java, ${misc:Depends}
 Suggests: postgresql-9.1-postgis-2.0
diff --git a/debian/control.in b/debian/control.in
index 023164a..d02d1ce 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -9,12 +9,11 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
- openjdk-6-jdk | openjdk-7-jdk, libpostgresql-jdbc-java, fastjar,
+ postgresql-server-dev-all, postgresql-common (= 146), postgresql
+Build-Depends-Indep: default-jdk, libpostgresql-jdbc-java, fastjar,
  libjts-java (= 1.7), maven2, libmaven-clean-plugin-java,
- libmaven-jar-plugin-java, postgresql-server-dev-all,
- postgresql-common (= 146), postgresql
-Build-Depends-Indep: libsurefire-java, libmaven-compiler-plugin-java,
- libmaven-resources-plugin-java
+ libmaven-jar-plugin-java, libsurefire-java,
+ libmaven-compiler-plugin-java, libmaven-resources-plugin-java
 Standards-Version: 3.9.4
 Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git
@@ -50,7 +49,8 @@ Description: Geographic objects support for PostgreSQL -- 
documentation
  This package contains the PostGIS documentation.
 
 Package: libpostgis-java
-Architecture: all
+Architecture: alpha amd64 armel armhf arm64 i386 ia64 lpia mips mipsel
+ powerpc powerpcspe ppc64 s390 s390x sh4 sparc sparc64
 Section: java
 Depends: libpostgresql-jdbc-java, ${misc:Depends}
 Suggests: postgresql-NEWEST_PGVERSION-postgis-2.0
diff --git a/debian/rules b/debian/rules
index 9218c91..b383076 100755
--- a/debian/rules
+++ b/debian/rules
@@ -46,6 +46,14 @@ debian/control: debian/control.in debian/pgversions
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+
+# Whether or not to build the JDBC parts the arch supports openjdk 6

[SCM] postgis branch, master, updated. upstream/2.0.1-72-gacacf66

2013-08-07 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 192c1bde88d7fbd40353f1b14bb02ff4170946c4
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Aug 7 15:19:20 2013 +0200

Revert most of 5ad5a075: we do not want libpostgis-java to be an
architecture dependent package. Keeps the 'mvn clean' vs 'rm'
change.

diff --git a/debian/changelog b/debian/changelog
index b176a5a..4500650 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,5 @@
 postgis (2.0.3-7) UNRELEASED; urgency=low
 
-  * Switch back to depend on default-jdk. To work around gcj-jdk
-incompatibilities, restrict libpostgis-java to the same set of
-architectures that support openjdk 6 and newer.
-  * Adjust rules to build libpostgis-java only on architectures that
-support it.
   * Use a simple rm rather than invoking maven. Allows us to move all java
 related Build-Depends back to Build-Depends-Indep.
 
diff --git a/debian/control b/debian/control
index e466dbd..a79bf16 100644
--- a/debian/control
+++ b/debian/control
@@ -10,10 +10,11 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
  postgresql-server-dev-all, postgresql-common (= 146), postgresql
-Build-Depends-Indep: default-jdk, libpostgresql-jdbc-java, fastjar,
- libjts-java (= 1.7), maven2, libmaven-clean-plugin-java,
- libmaven-jar-plugin-java, libsurefire-java,
- libmaven-compiler-plugin-java, libmaven-resources-plugin-java
+Build-Depends-Indep: openjdk-7-jdk | openjdk-6-jdk,
+ libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7), maven2,
+ libmaven-clean-plugin-java, libmaven-jar-plugin-java,
+ libsurefire-java, libmaven-compiler-plugin-java,
+ libmaven-resources-plugin-java
 Standards-Version: 3.9.4
 Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git
@@ -49,8 +50,7 @@ Description: Geographic objects support for PostgreSQL -- 
documentation
  This package contains the PostGIS documentation.
 
 Package: libpostgis-java
-Architecture: alpha amd64 armel armhf arm64 i386 ia64 lpia mips mipsel
- powerpc powerpcspe ppc64 s390 s390x sh4 sparc sparc64
+Architecture: all
 Section: java
 Depends: libpostgresql-jdbc-java, ${misc:Depends}
 Suggests: postgresql-9.1-postgis-2.0
diff --git a/debian/control.in b/debian/control.in
index d02d1ce..f98c340 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -10,10 +10,11 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
  postgresql-server-dev-all, postgresql-common (= 146), postgresql
-Build-Depends-Indep: default-jdk, libpostgresql-jdbc-java, fastjar,
- libjts-java (= 1.7), maven2, libmaven-clean-plugin-java,
- libmaven-jar-plugin-java, libsurefire-java,
- libmaven-compiler-plugin-java, libmaven-resources-plugin-java
+Build-Depends-Indep: openjdk-7-jdk | openjdk-6-jdk,
+ libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7), maven2,
+ libmaven-clean-plugin-java, libmaven-jar-plugin-java,
+ libsurefire-java, libmaven-compiler-plugin-java,
+ libmaven-resources-plugin-java
 Standards-Version: 3.9.4
 Homepage: http://postgis.refractions.net/
 Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-grass/postgis.git
@@ -49,8 +50,7 @@ Description: Geographic objects support for PostgreSQL -- 
documentation
  This package contains the PostGIS documentation.
 
 Package: libpostgis-java
-Architecture: alpha amd64 armel armhf arm64 i386 ia64 lpia mips mipsel
- powerpc powerpcspe ppc64 s390 s390x sh4 sparc sparc64
+Architecture: all
 Section: java
 Depends: libpostgresql-jdbc-java, ${misc:Depends}
 Suggests: postgresql-NEWEST_PGVERSION-postgis-2.0
diff --git a/debian/rules b/debian/rules
index b383076..8d0a77f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -48,12 +48,7 @@ DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture 
-qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 
-# Whether or not to build the JDBC parts the arch supports openjdk 6 or
-# newer.
-ARCH_SUPPORTS_JDBC_PKG=$(shell grep-dctrl -sArchitecture \
-   --pattern=libpostgis-jdbc $(CURDIR)/debian/control.in \
-   | grep $(DEB_BUILD_ARCH))
-JAVA_HOME=/usr/lib/jvm/default-java
+JAVA_HOME=/usr/lib/jvm/default-jdk
 
 # Use maven in offline mode and with the local Debian repo
 MVN = mvn --offline -Dmaven.repo.local=/usr/share/maven-repo
@@ -105,9 +100,7 @@ build-arch-stamp: configuration-stamp
 build-indep: build-indep-stamp
 build-indep-stamp: configuration-stamp
 #  PostGIS JDBC (with debug support)
-   if [ -n $(ARCH_SUPPORTS_JDBC_PKG) ]; then \
-   cd $(CURDIR)/java/jdbc  $(MVN) package; \
-   fi
+   cd $(CURDIR)/java/jdbc  $(MVN) package

[SCM] postgis branch, master, updated. upstream/2.0.1-72-gacacf66

2013-08-07 Thread Markus Wanner
The following commit has been merged in the master branch:
commit acacf66410f804d2924e3d59d277e4e7691ffae1
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Aug 7 15:52:33 2013 +0200

* Let rules check for different OpenJDK versions supported and set
  JAVA_HOME accordingly.

diff --git a/debian/changelog b/debian/changelog
index 4500650..0aedfca 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,7 @@
 postgis (2.0.3-7) UNRELEASED; urgency=low
 
+  * Let rules check for different OpenJDK versions supported and set
+JAVA_HOME accordingly.
   * Use a simple rm rather than invoking maven. Allows us to move all java
 related Build-Depends back to Build-Depends-Indep.
 
diff --git a/debian/control b/debian/control
index a79bf16..314d141 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,7 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
  postgresql-server-dev-all, postgresql-common (= 146), postgresql
-Build-Depends-Indep: openjdk-7-jdk | openjdk-6-jdk,
+Build-Depends-Indep: openjdk-8-jdk | openjdk-7-jdk | openjdk-6-jdk,
  libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7), maven2,
  libmaven-clean-plugin-java, libmaven-jar-plugin-java,
  libsurefire-java, libmaven-compiler-plugin-java,
diff --git a/debian/control.in b/debian/control.in
index f98c340..3ca9bb0 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -10,7 +10,7 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
  postgresql-server-dev-all, postgresql-common (= 146), postgresql
-Build-Depends-Indep: openjdk-7-jdk | openjdk-6-jdk,
+Build-Depends-Indep: openjdk-8-jdk | openjdk-7-jdk | openjdk-6-jdk,
  libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7), maven2,
  libmaven-clean-plugin-java, libmaven-jar-plugin-java,
  libsurefire-java, libmaven-compiler-plugin-java,
diff --git a/debian/rules b/debian/rules
index 8d0a77f..6d05dfb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -48,7 +48,18 @@ DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture 
-qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 
-JAVA_HOME=/usr/lib/jvm/default-jdk
+# Determine JAVA_HOME to use. Depends on which Build-Depends-Indep
+# variant has been used.
+JAVA_HOME = /usr/lib/jvm/java-8-openjdk-$(DEB_BUILD_ARCH)
+ifeq ($(wildcard $(JAVA_HOME)),)
+  JAVA_HOME=/usr/lib/jvm/java-7-openjdk-$(DEB_BUILD_ARCH)
+  ifeq ($(wildcard $(JAVA_HOME)),)
+JAVA_HOME=/usr/lib/jvm/java-6-openjdk-$(DEB_BUILD_ARCH)
+ifeq ($(wildcard $(JAVA_HOME)),)
+  $(error Cannot detect JAVA_HOME in $(JAVA_HOME))
+endif
+  endif
+endif
 
 # Use maven in offline mode and with the local Debian repo
 MVN = mvn --offline -Dmaven.repo.local=/usr/share/maven-repo

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-73-gfff72e6

2013-08-07 Thread Markus Wanner
The following commit has been merged in the master branch:
commit fff72e60848ed926c2c61e6125368bd48f8a568f
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Aug 7 16:41:59 2013 +0200

Actually export JAVA_HOME to maven.

diff --git a/debian/rules b/debian/rules
index 6d05dfb..ee64381 100755
--- a/debian/rules
+++ b/debian/rules
@@ -62,7 +62,7 @@ ifeq ($(wildcard $(JAVA_HOME)),)
 endif
 
 # Use maven in offline mode and with the local Debian repo
-MVN = mvn --offline -Dmaven.repo.local=/usr/share/maven-repo
+MVN = JAVA_HOME=$(JAVA_HOME) mvn --offline 
-Dmaven.repo.local=/usr/share/maven-repo
 
 MAJOR_VERSION = $(shell grep POSTGIS_MAJOR_VERSION Version.config|cut -d= -f2)
 MINOR_VERSION = $(shell grep POSTGIS_MINOR_VERSION Version.config|cut -d= -f2)

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis tag, debian/2.0.3-6, created. upstream/2.0.1-69-ga137a07

2013-08-07 Thread Markus Wanner
The tag, debian/2.0.3-6 has been created
at  a137a075cbcc16fe27ae583ac76711840a4a43dd (commit)

- Shortlog 
commit a137a075cbcc16fe27ae583ac76711840a4a43dd
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Aug 6 20:31:06 2013 +0200

Finalize 2.0.3-6.
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis tag, debian/2.0.3-7, created. upstream/2.0.1-74-g640dd66

2013-08-07 Thread Markus Wanner
The tag, debian/2.0.3-7 has been created
at  640dd66818dda05438b04f983eb31982086af9dd (commit)

- Shortlog 
commit 640dd66818dda05438b04f983eb31982086af9dd
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Aug 7 17:13:01 2013 +0200

Finalize 2.0.3-7 for upload to unstable.
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-74-g640dd66

2013-08-07 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 640dd66818dda05438b04f983eb31982086af9dd
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Aug 7 17:13:01 2013 +0200

Finalize 2.0.3-7 for upload to unstable.

diff --git a/debian/changelog b/debian/changelog
index 0aedfca..410b0f3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-postgis (2.0.3-7) UNRELEASED; urgency=low
+postgis (2.0.3-7) unstable; urgency=low
 
   * Let rules check for different OpenJDK versions supported and set
 JAVA_HOME accordingly.

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-75-g217fba8

2013-08-07 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 217fba8d0e3cfe73e78c3b17ae80f58c0bd67ed3
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Aug 7 22:02:46 2013 +0200

Don't err out when setting JAVA_HOME, but only later in
build-indep. So arch-only builds that don't have (nor need) the java
cruft available can succeed.

diff --git a/debian/changelog b/debian/changelog
index 410b0f3..c8780be 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+postgis (2.0.3-8) UNRELEASED; urgency=low
+
+  * Don't err out when setting JAVA_HOME, but only later in
+build-indep. So arch-only builds that don't have (nor need) the java
+cruft available can succeed.
+
+ -- Markus Wanner mar...@bluegap.ch  Wed, 07 Aug 2013 20:37:28 +0200
+
 postgis (2.0.3-7) unstable; urgency=low
 
   * Let rules check for different OpenJDK versions supported and set
diff --git a/debian/rules b/debian/rules
index ee64381..7d4f8b4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -52,11 +52,11 @@ DEB_BUILD_ARCH  ?= $(shell dpkg-architecture 
-qDEB_BUILD_ARCH)
 # variant has been used.
 JAVA_HOME = /usr/lib/jvm/java-8-openjdk-$(DEB_BUILD_ARCH)
 ifeq ($(wildcard $(JAVA_HOME)),)
-  JAVA_HOME=/usr/lib/jvm/java-7-openjdk-$(DEB_BUILD_ARCH)
+  JAVA_HOME = /usr/lib/jvm/java-7-openjdk-$(DEB_BUILD_ARCH)
   ifeq ($(wildcard $(JAVA_HOME)),)
-JAVA_HOME=/usr/lib/jvm/java-6-openjdk-$(DEB_BUILD_ARCH)
+JAVA_HOME = /usr/lib/jvm/java-6-openjdk-$(DEB_BUILD_ARCH)
 ifeq ($(wildcard $(JAVA_HOME)),)
-  $(error Cannot detect JAVA_HOME in $(JAVA_HOME))
+  JAVA_HOME =
 endif
   endif
 endif
@@ -110,6 +110,10 @@ build-arch-stamp: configuration-stamp
 
 build-indep: build-indep-stamp
 build-indep-stamp: configuration-stamp
+#  Re-check JAVA_HOME
+   @[ -n $(JAVA_HOME) ] || (echo ERROR: didn't find a Java JDK; exit 2)
+   @[ -x $(JAVA_HOME)/bin/javac ] || (echo ERROR: no javac in 
JAVA_HOME=$(JAVA_HOME); exit 2)
+
 #  PostGIS JDBC (with debug support)
cd $(CURDIR)/java/jdbc  $(MVN) package
 

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-76-ga72a354

2013-08-07 Thread Markus Wanner
The following commit has been merged in the master branch:
commit a72a3541a249865f16cfca5a399e1b3c2ae221b1
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Aug 7 22:56:50 2013 +0200

Finalize 2.0.3-8 for upload to unstable.

diff --git a/debian/changelog b/debian/changelog
index c8780be..03cd057 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,10 @@
-postgis (2.0.3-8) UNRELEASED; urgency=low
+postgis (2.0.3-8) unstable; urgency=low
 
   * Don't err out when setting JAVA_HOME, but only later in
 build-indep. So arch-only builds that don't have (nor need) the java
 cruft available can succeed.
 
- -- Markus Wanner mar...@bluegap.ch  Wed, 07 Aug 2013 20:37:28 +0200
+ -- Markus Wanner mar...@bluegap.ch  Wed, 07 Aug 2013 22:10:02 +0200
 
 postgis (2.0.3-7) unstable; urgency=low
 

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis tag, debian/2.0.3-8, created. upstream/2.0.1-76-ga72a354

2013-08-07 Thread Markus Wanner
The tag, debian/2.0.3-8 has been created
at  a72a3541a249865f16cfca5a399e1b3c2ae221b1 (commit)

- Shortlog 
commit a72a3541a249865f16cfca5a399e1b3c2ae221b1
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Aug 7 22:56:50 2013 +0200

Finalize 2.0.3-8 for upload to unstable.
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


Re: [postgis-devel] Postgis on non-Intel architectures

2013-08-08 Thread Markus Wanner
Following up on this:

Robe's recent patch solved the cunit test issue for big endian
architectures (i.e. #2396, r11738). However, all non-Intel arches still
fail later in the tests.

Note that this is all 2.0.3 (plus the back-ported r11738).

A summary is below. Shall I file separate bugs for each failing test?
Or reopen the ones that fail in 'tickets'?

Regards

Markus Wanner




armel, armhf:

 tickets .. failed (diff expected obtained: /tmp/pgis_reg/test_66_diff)


 ### /tmp/pgis_reg/test_66_diff ###
--- tickets_expected2012-12-19 18:28:02.0 +
+++ /tmp/pgis_reg/test_66_out   2013-08-08 01:32:24.0 +
@@ -186,8 +186,8 @@
 #745|GEOMETRYCOLLECTION(POLYGON((-72 42 1,-70 43 1,-71 41 1,-72 42 1)))
 #1450|POINT|POLYGON
 #1482|4326
-#852.1|1|f|f
-#852.1|2|f|f
+#852.1|1|t|t
+#852.1|2|t|t
 #852.2|1|t|t
 #852.2|2|t|t
 #1489|MULTIPOINT EMPTY|0|MULTILINESTRING EMPTY|0|MULTIPOLYGON 
EMPTY|0|GEOMETRYCOLLECTION EMPTY|0
@@ -199,7 +199,7 @@
 #1398a|POINT(-119.093153 45.632669)
 #1398b|POINT(-160.137654 77.091608)
 #1543|MULTILINESTRING((0 0,10 0,10 10,0 0),(0 0))|POLYGON((0 0,10 10,10 0,0 0))
-#1578|f|f
+#1578|f|t
 #1580.1|Point[B]
 ERROR:  transform: couldn't project point (180 90 0): tolerance condition 
error (-20)
 #1580.3|Point[B]
make: *** [check] Error 2
dpkg-buildpackage: error: debian/rules build-arch gave error exit status 2
 ### end of log dumps ###



mips, sparc, powerpc, s390:

 regress .. failed (diff expected obtained: /tmp/pgis_reg/test_24_diff)
 empty .. failed (diff expected obtained: /tmp/pgis_reg/test_35_diff)
 sql-mm-compoundcurve .. failed (diff expected obtained: 
/tmp/pgis_reg/test_42_diff)
 sql-mm-curvepoly .. failed (diff expected obtained: /tmp/pgis_reg/test_43_diff)
 tickets .. failed (diff expected obtained: /tmp/pgis_reg/test_66_diff)

 ### /tmp/pgis_reg/test_24_diff ###
--- regress_expected2012-02-27 22:08:12.0 +
+++ /tmp/pgis_reg/test_24_out   2013-08-07 23:54:28.069320748 +
@@ -154,7 +154,7 @@
 148|LINESTRING(0 0,5 0,10 0)
 149|GEOMETRYCOLLECTION EMPTY
 150|SRID=6;GEOMETRYCOLLECTION(POLYGON((0 0,1 0,1 1,0 1,0 0)))
-151|010320E61001000500F03FF03FF03FF03F
+151|00200310E6000100053FF03FF03FF03FF0
 152|4326
 152.1|t
 152.2|4326
@@ -167,7 +167,7 @@
 159|MULTIPOLYGON EMPTY
 160|MULTIPOINT(1 1)
 161|MULTILINESTRING((0 0,1 1),(2 2,3 3))
-162|0102000300F771D98DE33826C04440F771D98DE33826C00080514000805140F771D98DE33826C0
+162|020003C02638E38DD971F74044C02638E38DD971F74051800040518000C02638E38DD971F7
 163|POLYGON((0 0 0,1 0 0,1 1 0,0 1 0,0 0 0))
 164|POLYGON((0 0 0,1 0 0,1 1 0,0 1 0,0 0 1))
 ERROR:  geometry contains non-closed rings
 ### /tmp/pgis_reg/test_35_diff ###
--- empty_expected  2012-02-27 22:08:12.0 +
+++ /tmp/pgis_reg/test_35_out   2013-08-07 23:59:23.919612529 +
@@ -23,13 +23,13 @@
 T3.16|
 T3.17|
 T3.18|
-ST_Buffer(empty, tolerance) == empty|010300
-ST_Union(geometry, empty) == 
geometry|01030001000400244014401440
-ST_Union(empty, empty) == empty|010300
-ST_Intersection(geometry, empty) == geometry|010300
-ST_Intersection(empty, empty) == empty|010300
-ST_Difference(geometry, empty) == 
geometry|01030001000400244014401440
-ST_Difference(empty, geometry) == empty|010300
+ST_Buffer(empty, tolerance) == empty|03
+ST_Union(geometry, empty) == 
geometry|0300010004402440144014
+ST_Union(empty, empty) == empty|03
+ST_Intersection(geometry, empty) == geometry|03
+ST_Intersection(empty, empty) == empty|03
+ST_Difference(geometry, empty) == 
geometry|0300010004402440144014
+ST_Difference(empty, geometry) == empty|03
 ST_Distance(geometry, empty) == NULL|
 ST_DWithin(geometry, empty, tolerance) == FALSE|f
 ST_Within(geometry, empty) == FALSE|f
@@ -47,8 +47,8 @@
 ST_NRings(empty) == 0|0
 ST_NumPoints(empty) == 0|0
 ST_NPoints(empty) == 0|0
-ST_GeometryN(empty, n) == empty|010300
-ST_ExteriorRing(empty) == empty|010200
+ST_GeometryN(empty, n) == empty|03

[SCM] postgis tag, upstream/2.1.0, created. upstream/2.0.1-4-g85dc048

2013-08-19 Thread Markus Wanner
The tag, upstream/2.1.0 has been created
at  85dc04837269a98872acc715264fdcfb3dccfd99 (commit)

- Shortlog 
commit 85dc04837269a98872acc715264fdcfb3dccfd99
Author: Markus Wanner mar...@bluegap.ch
Date:   Mon Aug 19 17:29:12 2013 +0200

Import upstream version 2.1.0
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-81-g4108387

2013-08-27 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 923462fbc2bcde956e04c04a2b7c20605289df0d
Merge: a72a3541a249865f16cfca5a399e1b3c2ae221b1 
85dc04837269a98872acc715264fdcfb3dccfd99
Author: Markus Wanner mar...@bluegap.ch
Date:   Mon Aug 19 17:31:37 2013 +0200

Merge branch 'upstream' (i.e. postgis-2.1.0)


-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-81-g4108387

2013-08-27 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 410838766cfd944067db8bbf30725d8cf779fb6b
Author: Markus Wanner mar...@bluegap.ch
Date:   Mon Aug 26 22:02:29 2013 +0200

 * New upstream release
 * Update pgversions
 * Adjust liblwgeom version and symbols for new version.
 * Update build dependencies according to README.postgis
 * Adapt patches debian-versions, java-version-fix, link-liblwgeom,
   honor-build-flags.
 * Refresh line numbers on patches: fixmakedoc, fix-spelling.
 * Drop patches: fix-manpages, fix-test-case-for-i386,
   fix-tests-on-big-endian: applied upstream.
 * shp2pgsql-gui.1 is now provided upstream. Drop the debian variant.

diff --git a/debian/changelog b/debian/changelog
index 03cd057..13bcce9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,19 @@
+postgis (2.1.0-1) UNRELEASED; urgency=low
+
+  * New upstream release
+  * Update pgversions
+  * Adjust liblwgeom version and symbols for new version.
+  * Update build dependencies according to README.postgis (FIXME: prefer
+geos-3.4)
+  * Adapt patches debian-versions, java-version-fix, link-liblwgeom,
+honor-build-flags.
+  * Refresh line numbers on patches: fixmakedoc, fix-spelling.
+  * Drop patches: fix-manpages, fix-test-case-for-i386,
+fix-tests-on-big-endian: applied upstream.
+  * shp2pgsql-gui.1 is now provided upstream. Drop the debian variant.
+
+ -- Markus Wanner mar...@bluegap.ch  Mon, 26 Aug 2013 22:02:22 +0200
+
 postgis (2.0.3-8) unstable; urgency=low
 
   * Don't err out when setting JAVA_HOME, but only later in
diff --git a/debian/control b/debian/control
index 314d141..01cc42b 100644
--- a/debian/control
+++ b/debian/control
@@ -6,9 +6,9 @@ Uploaders: Stephen Frost sfr...@debian.org, Francesco Paolo
  Lovergine fran...@debian.org, Markus Wanner mar...@bluegap.ch
 Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), autotools-dev,
  flex, bison, libgeos-dev (= 3.3), libjson0-dev (= 0.9~),
- libproj-dev (= 4.5.0), libssl-dev, xsltproc, docbook, docbook-xsl,
+ libproj-dev (= 4.6.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
- libgtk2.0-dev, libgdal-dev (= 1.6.0~) | libgdal1-dev (= 1.6.0~),
+ libgtk2.0-dev, libgdal-dev (= 1.9.0~) | libgdal1-dev (= 1.9.0~),
  postgresql-server-dev-all, postgresql-common (= 146), postgresql
 Build-Depends-Indep: openjdk-8-jdk | openjdk-7-jdk | openjdk-6-jdk,
  libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7), maven2,
@@ -23,7 +23,7 @@ Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
 Package: postgis
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Suggests: postgresql-9.1-postgis-2.0
+Suggests: postgresql-9.2-postgis-2.1
 Description: Geographic objects support for PostgreSQL
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
@@ -53,7 +53,7 @@ Package: libpostgis-java
 Architecture: all
 Section: java
 Depends: libpostgresql-jdbc-java, ${misc:Depends}
-Suggests: postgresql-9.1-postgis-2.0
+Suggests: postgresql-9.2-postgis-2.1
 Breaks: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Replaces: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Description: Geographic objects support for PostgreSQL -- JDBC support
@@ -66,7 +66,7 @@ Description: Geographic objects support for PostgreSQL -- 
JDBC support
  .
  This package contains JDBC support for PostGIS.
 
-Package: liblwgeom-2.0.3
+Package: liblwgeom-2.1.0
 Architecture: any
 Section: libs
 Depends: ${shlibs:Depends}, libjson0 (= 0.9~), ${misc:Depends}
@@ -86,7 +86,7 @@ Package: liblwgeom-dev
 Architecture: any
 Section: libdevel
 Depends: ${shlibs:Depends}, ${misc:Depends},
- liblwgeom-2.0.3 (= ${binary:Version})
+ liblwgeom-2.1.0 (= ${binary:Version})
 Breaks: postgis ( 2.0.0)
 Description: PostGIS Lightweight Geometry library - Development files
  PostGIS adds support for geographic objects to the PostgreSQL
@@ -101,9 +101,41 @@ Description: PostGIS Lightweight Geometry library - 
Development files
  processing functions, are implemented here.  This package contains
  the development files.
 
-Package: postgresql-9.1-postgis-2.0
+Package: postgresql-9.0-postgis-2.1
+Depends: ${shlibs:Depends}, postgresql-9.0,
+ postgresql-9.0-postgis-2.1-scripts, liblwgeom-2.1.0,
+ ${misc:Depends}
+Recommends: postgis
+Breaks: postgis ( 1.2.1)
+Architecture: any
+Description: Geographic objects support for PostgreSQL 9.0
+ PostGIS adds support for geographic objects to the PostgreSQL
+ object-relational database. In effect, PostGIS spatially enables
+ the PostgreSQL server, allowing it to be used as a backend spatial
+ database for geographic information systems (GIS), much like ESRI's
+ SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
+ Simple Features Specification for SQL.
+ .
+ This package supports PostgreSQL 9.0.
+
+Package: postgresql-9.0-postgis-2.1-scripts

[SCM] postgis branch, master, updated. upstream/2.0.1-82-gd0159e1

2013-08-27 Thread Markus Wanner
The following commit has been merged in the master branch:
commit d0159e1e97bc90a153edf75a755e4154bd691cc6
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Aug 27 11:17:41 2013 +0200

* Modify pgversions to use a new pg_buildext feature. Fixes an issue
  on wheezy+pgapt, where the newest isn't necessarily the default
  Postgres version.

diff --git a/debian/changelog b/debian/changelog
index 13bcce9..7128c9c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,7 @@
 postgis (2.1.0-1) UNRELEASED; urgency=low
 
   * New upstream release
-  * Update pgversions
+  * Update pgversions, use '9.0+' feature of pg-common = 148.
   * Adjust liblwgeom version and symbols for new version.
   * Update build dependencies according to README.postgis (FIXME: prefer
 geos-3.4)
diff --git a/debian/control b/debian/control
index 01cc42b..60fcfcb 100644
--- a/debian/control
+++ b/debian/control
@@ -9,7 +9,7 @@ Build-Depends: debhelper (= 8), dpkg-dev (= 1.16.1~), 
autotools-dev,
  libproj-dev (= 4.6.0), libssl-dev, xsltproc, docbook, docbook-xsl,
  imagemagick, libcunit1-dev, dblatex, libxml2-dev (= 2.5.0~),
  libgtk2.0-dev, libgdal-dev (= 1.9.0~) | libgdal1-dev (= 1.9.0~),
- postgresql-server-dev-all, postgresql-common (= 146), postgresql
+ postgresql-server-dev-all, postgresql-common (= 148~), postgresql
 Build-Depends-Indep: openjdk-8-jdk | openjdk-7-jdk | openjdk-6-jdk,
  libpostgresql-jdbc-java, fastjar, libjts-java (= 1.7), maven2,
  libmaven-clean-plugin-java, libmaven-jar-plugin-java,
@@ -23,7 +23,7 @@ Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
 Package: postgis
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Suggests: postgresql-9.2-postgis-2.1
+Suggests: postgresql-9.1-postgis-2.1
 Description: Geographic objects support for PostgreSQL
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
@@ -53,7 +53,7 @@ Package: libpostgis-java
 Architecture: all
 Section: java
 Depends: libpostgresql-jdbc-java, ${misc:Depends}
-Suggests: postgresql-9.2-postgis-2.1
+Suggests: postgresql-9.1-postgis-2.1
 Breaks: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Replaces: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Description: Geographic objects support for PostgreSQL -- JDBC support
@@ -101,38 +101,6 @@ Description: PostGIS Lightweight Geometry library - 
Development files
  processing functions, are implemented here.  This package contains
  the development files.
 
-Package: postgresql-9.0-postgis-2.1
-Depends: ${shlibs:Depends}, postgresql-9.0,
- postgresql-9.0-postgis-2.1-scripts, liblwgeom-2.1.0,
- ${misc:Depends}
-Recommends: postgis
-Breaks: postgis ( 1.2.1)
-Architecture: any
-Description: Geographic objects support for PostgreSQL 9.0
- PostGIS adds support for geographic objects to the PostgreSQL
- object-relational database. In effect, PostGIS spatially enables
- the PostgreSQL server, allowing it to be used as a backend spatial
- database for geographic information systems (GIS), much like ESRI's
- SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
- Simple Features Specification for SQL.
- .
- This package supports PostgreSQL 9.0.
-
-Package: postgresql-9.0-postgis-2.1-scripts
-Architecture: all
-Depends: ${misc:Depends}
-Recommends: postgresql-9.0-postgis-2.1
-Description: Geographic objects support for PostgreSQL 9.0 -- scripts
- PostGIS adds support for geographic objects to the PostgreSQL
- object-relational database. In effect, PostGIS spatially enables
- the PostgreSQL server, allowing it to be used as a backend spatial
- database for geographic information systems (GIS), much like ESRI's
- SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
- Simple Features Specification for SQL.
- .
- This package contains SQL scripts to upgrade from earlier PostGIS
- versions for PostgreSQL 9.0 as well as Perl utility scripts.
-
 Package: postgresql-9.1-postgis-2.1
 Depends: ${shlibs:Depends}, postgresql-9.1,
  postgresql-9.1-postgis-2.1-scripts, liblwgeom-2.1.0,
@@ -165,35 +133,3 @@ Description: Geographic objects support for PostgreSQL 9.1 
-- scripts
  This package contains SQL scripts to upgrade from earlier PostGIS
  versions for PostgreSQL 9.1 as well as Perl utility scripts.
 
-Package: postgresql-9.2-postgis-2.1
-Depends: ${shlibs:Depends}, postgresql-9.2,
- postgresql-9.2-postgis-2.1-scripts, liblwgeom-2.1.0,
- ${misc:Depends}
-Recommends: postgis
-Breaks: postgis ( 1.2.1)
-Architecture: any
-Description: Geographic objects support for PostgreSQL 9.2
- PostGIS adds support for geographic objects to the PostgreSQL
- object-relational database. In effect, PostGIS spatially enables
- the PostgreSQL server, allowing it to be used as a backend spatial
- database for geographic information systems (GIS), much like ESRI's
- SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
- Simple Features Specification for SQL

[SCM] postgis tag, debian/2.1.0-1, created. upstream/2.0.1-84-g2913e57

2013-08-31 Thread Markus Wanner
The tag, debian/2.1.0-1 has been created
at  2913e578a696fd80f09087999a6e566454b32881 (commit)

- Shortlog 
commit 2913e578a696fd80f09087999a6e566454b32881
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Aug 28 20:38:39 2013 +0200

Prepare for upload to unstable.
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


Re: Postgis upload.

2013-08-31 Thread Markus Wanner
On 08/31/2013 04:46 PM, Marco Nenciarini wrote:
 ...you
 want me to upload the new version of postgis in the current git status.
 
 If yes please tag the new version and send me a quick note. I'll upload
 it ASAP.

Tagged, please upload.

Regards

Markus

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-84-g2913e57

2013-09-01 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 2913e578a696fd80f09087999a6e566454b32881
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Aug 28 20:38:39 2013 +0200

Prepare for upload to unstable.

diff --git a/debian/changelog b/debian/changelog
index 5edbe6b..db73e94 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-postgis (2.1.0-1) UNRELEASED; urgency=low
+postgis (2.1.0-1) unstable; urgency=low
 
   * New upstream release
   * Update pgversions, use '9.0+' feature of pg-common = 148.

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-84-g2913e57

2013-09-01 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 5c7a0a094727f2bc242aa4b0c209a592f8e87cf6
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Aug 28 20:36:25 2013 +0200

Correct the shp2pgsql-gui.1 manpage by stripping an UTF-8 marker.

diff --git a/debian/changelog b/debian/changelog
index 7128c9c..5edbe6b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,7 +10,8 @@ postgis (2.1.0-1) UNRELEASED; urgency=low
   * Refresh line numbers on patches: fixmakedoc, fix-spelling.
   * Drop patches: fix-manpages, fix-test-case-for-i386,
 fix-tests-on-big-endian: applied upstream.
-  * shp2pgsql-gui.1 is now provided upstream. Drop the debian variant.
+  * shp2pgsql-gui.1 is now provided upstream. Drop the debian variant. Add
+a patch stripping an initial UTF-8 marker from the upstream file.
 
  -- Markus Wanner mar...@bluegap.ch  Mon, 26 Aug 2013 22:02:22 +0200
 
diff --git a/debian/patches/fix-manpage b/debian/patches/fix-manpage
new file mode 100644
index 000..bdb8aa5
--- /dev/null
+++ b/debian/patches/fix-manpage
@@ -0,0 +1,8 @@
+--- a/loader/shp2pgsql-gui.1
 b/loader/shp2pgsql-gui.1
+@@ -1,4 +1,4 @@
+-.TH SHP2PGSQL-GUI 1 January 14, 2012  PostGIS
++.TH SHP2PGSQL-GUI 1 January 14, 2012  PostGIS
+ 
+ .SH NAME
+ shp2pgsql-gui \- Graphical User Interface for shp2pgsql
diff --git a/debian/patches/series b/debian/patches/series
index a03355c..30534e1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -6,3 +6,4 @@ link-liblwgeom
 use-debian-maven
 honor-build-flags
 fix-kfreebsd
+fix-manpage

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

[SCM] postgis branch, master, updated. upstream/2.0.1-87-g7202c7e

2013-09-10 Thread Markus Wanner
The following commit has been merged in the master branch:
commit f3a8f80f4f835c4b30fd807103100dab50a73234
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Sep 10 21:54:12 2013 +0200

Correct generation of debian/control: drop an unnecessary grep in
debian/pgversions. I broke it when changing to '9.0+'.  Add a
comment to debian/pgversions explaining why '9.0+' is needed
rather than explicitly specifying all supported major versions.

Copy binaries for the common binary package 'postgis' from the
newest version via debian/rules rather than hard-coding 9.1 in
postgis.install.

Add experimental patch from upstream to increase pass rate on
non-Intel architectures (upstream-r11934).

Add a description and some tags to patch fix-manpage.

Drop patch fix-manpages from the git repo, it has already been
removed from the quilt patch series.

diff --git a/debian/changelog b/debian/changelog
index db73e94..1cf3c15 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+postgis (2.1.0-2) UNRELEASED; urgency=low
+
+  * Correct generation of debian/control: drop an unnecessary grep in
+debian/pgversions. I broke it when changing to '9.0+'.
+  * Copy binaries for the common binary package 'postgis' from the newest
+version, rather than hardcoding 9.1.
+  * Add experimental patch from upstream to increase pass rate on
+non-Intel architectures (upstream-r11934).
+  * Add a description and some tags to patch fix-manpage.
+
+ -- Markus Wanner mar...@bluegap.ch  Tue, 10 Sep 2013 21:53:57 +0200
+
 postgis (2.1.0-1) unstable; urgency=low
 
   * New upstream release
diff --git a/debian/control b/debian/control
index 60fcfcb..9537f89 100644
--- a/debian/control
+++ b/debian/control
@@ -23,7 +23,7 @@ Vcs-Git: git://anonscm.debian.org/pkg-grass/postgis.git
 Package: postgis
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
-Suggests: postgresql-9.1-postgis-2.1
+Suggests: postgresql-9.3-postgis-2.1
 Description: Geographic objects support for PostgreSQL
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
@@ -53,7 +53,7 @@ Package: libpostgis-java
 Architecture: all
 Section: java
 Depends: libpostgresql-jdbc-java, ${misc:Depends}
-Suggests: postgresql-9.1-postgis-2.1
+Suggests: postgresql-9.3-postgis-2.1
 Breaks: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Replaces: libpostgis-jdbc, libpostgisjava, postgresql-postgis-java
 Description: Geographic objects support for PostgreSQL -- JDBC support
@@ -101,14 +101,14 @@ Description: PostGIS Lightweight Geometry library - 
Development files
  processing functions, are implemented here.  This package contains
  the development files.
 
-Package: postgresql-9.1-postgis-2.1
-Depends: ${shlibs:Depends}, postgresql-9.1,
- postgresql-9.1-postgis-2.1-scripts, liblwgeom-2.1.0,
+Package: postgresql-9.3-postgis-2.1
+Depends: ${shlibs:Depends}, postgresql-9.3,
+ postgresql-9.3-postgis-2.1-scripts, liblwgeom-2.1.0,
  ${misc:Depends}
 Recommends: postgis
 Breaks: postgis ( 1.2.1)
 Architecture: any
-Description: Geographic objects support for PostgreSQL 9.1
+Description: Geographic objects support for PostgreSQL 9.3
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
  the PostgreSQL server, allowing it to be used as a backend spatial
@@ -116,13 +116,13 @@ Description: Geographic objects support for PostgreSQL 9.1
  SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
  Simple Features Specification for SQL.
  .
- This package supports PostgreSQL 9.1.
+ This package supports PostgreSQL 9.3.
 
-Package: postgresql-9.1-postgis-2.1-scripts
+Package: postgresql-9.3-postgis-2.1-scripts
 Architecture: all
 Depends: ${misc:Depends}
-Recommends: postgresql-9.1-postgis-2.1
-Description: Geographic objects support for PostgreSQL 9.1 -- scripts
+Recommends: postgresql-9.3-postgis-2.1
+Description: Geographic objects support for PostgreSQL 9.3 -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
  the PostgreSQL server, allowing it to be used as a backend spatial
@@ -131,5 +131,5 @@ Description: Geographic objects support for PostgreSQL 9.1 
-- scripts
  Simple Features Specification for SQL.
  .
  This package contains SQL scripts to upgrade from earlier PostGIS
- versions for PostgreSQL 9.1 as well as Perl utility scripts.
+ versions for PostgreSQL 9.3 as well as Perl utility scripts.
 
diff --git a/debian/patches/fix-manpage b/debian/patches/fix-manpage
index bdb8aa5..24ef34e 100644
--- a/debian/patches/fix-manpage
+++ b/debian/patches/fix-manpage
@@ -1,3 +1,7 @@
+Description: Remove what looks like an UTF-8 marker or some such.
+Author: Markus Wanner mar...@bluegap.ch
+Last-Update: 2013-09-09
+
 --- a/loader/shp2pgsql-gui.1
 +++ b/loader

[SCM] postgis branch, master, updated. upstream/2.0.1-87-g7202c7e

2013-09-10 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 7202c7e1029f89efde8292b8c4b3ea085edb0d47
Merge: f3a8f80f4f835c4b30fd807103100dab50a73234 
0a553086a7d525b0beda6594c887a9a38bc972ec
Author: Markus Wanner mar...@bluegap.ch
Date:   Tue Sep 10 21:56:40 2013 +0200

Merge branch 'master' of git://anonscm.debian.org/pkg-grass/postgis

diff --combined debian/rules
index 7bb1f40,51ae5f6..28c06d1
--- a/debian/rules
+++ b/debian/rules
@@@ -19,7 -19,7 +19,7 @@@ DPKG_EXPORT_BUILDFLAGS = 
  include /usr/share/dpkg/buildflags.mk
  
  CHECK = check
- ifneq (,$(findstring nocheck,$(DEB_BUILLD_OPTIONS)))
+ ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
CHECK =
  endif
  
@@@ -36,7 -36,8 +36,7 @@@ debian/control: debian/control.in debia
sed -e s:NEWEST_PGVERSION:$$NEWEST_VERSION:  $@.pgxs_tmp; \
for v in $$VERSIONS; \
  do \
 -  grep -q ^$$v debian/pgversions   \
 -   grep-dctrl -P PGVERSION $  \
 +  grep-dctrl -P PGVERSION $  \
| sed -e s:PGVERSION:$$v:  $@.pgxs_tmp; \
done; \
mv $@.pgxs_tmp $@) || (rm -f $@.pgxs_tmp; exit 1)
@@@ -249,7 -250,7 +249,7 @@@ install-arch: build-arc
PGSQL_DOCDIR=/usr/share/doc \
PGSQL_MANDIR=/usr/share/man
  
 -# Auto-create required .install file for the current Postgres version.
 +# Auto-create required .install file for each Postgres major version
(set -e; \
for PGVER in $(OTHER_POSTGRES_VERSIONS) $(NEWEST_POSTGRES_VERSION); do \
cat $(CURDIR)/debian/postgresql-generic-postgis-2.1.install.in \
@@@ -260,12 -261,6 +260,12 @@@
 
$(CURDIR)/debian/postgresql-$$PGVER-postgis-2.1-scripts.install; \
done)
  
 +# Copy binaries from the NEWEST_POSTGRES_VERSION build to the
 +# 'postgis' binary package.
 +  mkdir -p $(CURDIR)/debian/postgis/usr/bin
 +  cp -r 
$(CURDIR)/debian/tmp/usr/lib/postgresql/$(NEWEST_POSTGRES_VERSION)/bin/* \
 +  $(CURDIR)/debian/postgis/usr/bin/
 +
dh_install -s
  
  check: build-arch-stamp

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-88-g6e83235

2013-09-11 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 6e832359f7dbd3f04f27d730e31cc4b75463843d
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Sep 11 13:58:40 2013 +0200

Finalize for upload of 2.1.0-2 to unstable.

diff --git a/debian/changelog b/debian/changelog
index 1cf3c15..7c8c59a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-postgis (2.1.0-2) UNRELEASED; urgency=low
+postgis (2.1.0-2) unstable; urgency=low
 
   * Correct generation of debian/control: drop an unnecessary grep in
 debian/pgversions. I broke it when changing to '9.0+'.

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis tag, debian/2.1.0-2, created. upstream/2.0.1-88-g6e83235

2013-09-11 Thread Markus Wanner
The tag, debian/2.1.0-2 has been created
at  6e832359f7dbd3f04f27d730e31cc4b75463843d (commit)

- Shortlog 
commit 6e832359f7dbd3f04f27d730e31cc4b75463843d
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Sep 11 13:58:40 2013 +0200

Finalize for upload of 2.1.0-2 to unstable.
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-90-g8f9631a

2013-09-25 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 8f9631aaf245d7c5c8d902cb0b26e9675c88490e
Author: Markus Wanner mar...@bluegap.ch
Date:   Wed Sep 25 22:34:26 2013 +0200

Add minor-r11979-correction patch to account for some new WARNINGs, that
didn't appear, before.

diff --git a/debian/changelog b/debian/changelog
index b268d8a..0f17409 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,8 @@
 postgis (2.1.0-3) UNRELEASED; urgency=low
 
   * Update patch upstream-r11934 to cover rev 11979, instead. It seems to
-be a more thorough fix.
+be a more thorough fix. Add minor-r11979-correction patch to account
+for some new WARNINGs, that didn't appear, before.
 
  -- Markus Wanner mar...@bluegap.ch  Wed, 25 Sep 2013 20:19:09 +0200
 
diff --git a/debian/patches/minor-r11979-correction 
b/debian/patches/minor-r11979-correction
new file mode 100644
index 000..dc48696
--- /dev/null
+++ b/debian/patches/minor-r11979-correction
@@ -0,0 +1,26 @@
+Description: pass big-endian online regression tests - adjust expectations
+ For some reason, these additional WARNINGs now appear, which r11979 doesn't
+ take into account.
+Author: Markus Wanner mar...@bluegap.ch
+Last-Update: 2013-09-25
+
+--- a/regress/regress_expected
 b/regress/regress_expected
+@@ -147,12 +147,17 @@
+ 142|SRID=5;MULTILINESTRING((2 2,3 3))
+ 143|SRID=6;MULTIPOLYGON(((0 0,1 0,1 1,0 1,0 0)))
+ 143c1|MULTICURVE(CIRCULARSTRING(0 0,1 1,2 2))
++WARNING:  ST_Force_3dm signature was deprecated in 2.1.0. Please use 
ST_Force3DM
+ 144|POINTM(1 2 0)
++WARNING:  ST_Force_3dz signature was deprecated in 2.1.0. Please use 
ST_Force3DZ
+ 145|POINT(1 2 0)
++WARNING:  ST_Force_4d signature was deprecated in 2.1.0. Please use ST_Force4D
+ 146|POINT(1 2 0 3)
++WARNING:  ST_Force_4d signature was deprecated in 2.1.0. Please use ST_Force4D
+ 147|POINT(1 2 3 0)
+ 148|LINESTRING(0 0,5 0,10 0)
+ 149|GEOMETRYCOLLECTION EMPTY
++WARNING:  ST_Force_Collection signature was deprecated in 2.1.0. Please use 
ST_ForceCollection
+ 150|SRID=6;GEOMETRYCOLLECTION(POLYGON((0 0,1 0,1 1,0 1,0 0)))
+ 
151|01030001000500f03ff03ff03ff03f
+ 152|4326
diff --git a/debian/patches/series b/debian/patches/series
index bc1742b..014a780 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,5 @@
 upstream-r11979
+minor-r11979-correction
 debian-versions
 java-version-fix
 fixmakedoc

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-91-g9918caf

2013-09-26 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 9918caf61e4c371a5fd5ff14961401e9c55938ab
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Sep 26 08:47:56 2013 +0200

Add transitional postgis-2.0-scripts packages for all Pg versions ever
supported. These effectively remove scripts and the postgis.control
file prior to installing a newer *-postgis-2.1-scrips package, which
Breaks+Replaces it.

diff --git a/debian/changelog b/debian/changelog
index 0f17409..fc6335e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,9 @@
 postgis (2.1.0-3) UNRELEASED; urgency=low
 
+  * Add transitional postgis-2.0-scripts packages for all Pg versions ever
+supported. These effectively remove scripts and the postgis.control
+file prior to installing a newer *-postgis-2.1-scrips package, which
+Breaks+Replaces it.
   * Update patch upstream-r11934 to cover rev 11979, instead. It seems to
 be a more thorough fix. Add minor-r11979-correction patch to account
 for some new WARNINGs, that didn't appear, before.
diff --git a/debian/control b/debian/control
index 316cc4f..3ebcf17 100644
--- a/debian/control
+++ b/debian/control
@@ -101,101 +101,41 @@ Description: PostGIS Lightweight Geometry library - 
Development files
  processing functions, are implemented here.  This package contains
  the development files.
 
-Package: postgresql-9.0-postgis-2.1
-Depends: ${shlibs:Depends}, postgresql-9.0,
- postgresql-9.0-postgis-2.1-scripts, liblwgeom-2.1.0,
- ${misc:Depends}
-Recommends: postgis
-Breaks: postgis ( 1.2.1)
-Architecture: any
-Description: Geographic objects support for PostgreSQL 9.0
- PostGIS adds support for geographic objects to the PostgreSQL
- object-relational database. In effect, PostGIS spatially enables
- the PostgreSQL server, allowing it to be used as a backend spatial
- database for geographic information systems (GIS), much like ESRI's
- SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
- Simple Features Specification for SQL.
- .
- This package supports PostgreSQL 9.0.
-
-Package: postgresql-9.0-postgis-2.1-scripts
+Package: postgresql-8.4-postgis-2.0-scripts
 Architecture: all
 Depends: ${misc:Depends}
-Recommends: postgresql-9.0-postgis-2.1
-Description: Geographic objects support for PostgreSQL 9.0 -- scripts
- PostGIS adds support for geographic objects to the PostgreSQL
- object-relational database. In effect, PostGIS spatially enables
- the PostgreSQL server, allowing it to be used as a backend spatial
- database for geographic information systems (GIS), much like ESRI's
- SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
- Simple Features Specification for SQL.
+Description: PostGIS for PostgreSQL 8.4 -- scripts -- dummy package
+ This package contained the scripts for PostGIS version 2.0, that's
+ now deprecated. It extended PostgreSQL 8.4.
  .
- This package contains SQL scripts to upgrade from earlier PostGIS
- versions for PostgreSQL 9.0 as well as Perl utility scripts.
+ This is a transitional dummy package. It can safely be removed.
 
-Package: postgresql-9.1-postgis-2.1
-Depends: ${shlibs:Depends}, postgresql-9.1,
- postgresql-9.1-postgis-2.1-scripts, liblwgeom-2.1.0,
- ${misc:Depends}
-Recommends: postgis
-Breaks: postgis ( 1.2.1)
-Architecture: any
-Description: Geographic objects support for PostgreSQL 9.1
- PostGIS adds support for geographic objects to the PostgreSQL
- object-relational database. In effect, PostGIS spatially enables
- the PostgreSQL server, allowing it to be used as a backend spatial
- database for geographic information systems (GIS), much like ESRI's
- SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
- Simple Features Specification for SQL.
- .
- This package supports PostgreSQL 9.1.
-
-Package: postgresql-9.1-postgis-2.1-scripts
+Package: postgresql-9.0-postgis-2.0-scripts
 Architecture: all
 Depends: ${misc:Depends}
-Recommends: postgresql-9.1-postgis-2.1
-Description: Geographic objects support for PostgreSQL 9.1 -- scripts
- PostGIS adds support for geographic objects to the PostgreSQL
- object-relational database. In effect, PostGIS spatially enables
- the PostgreSQL server, allowing it to be used as a backend spatial
- database for geographic information systems (GIS), much like ESRI's
- SDE or Oracle's Spatial extension. PostGIS follows the OpenGIS
- Simple Features Specification for SQL.
+Description: PostGIS for PostgreSQL 9.0 -- scripts -- dummy package
+ This package contained the scripts for PostGIS version 2.0, that's
+ now deprecated. It extended PostgreSQL 9.0.
  .
- This package contains SQL scripts to upgrade from earlier PostGIS
- versions for PostgreSQL 9.1 as well as Perl utility scripts.
+ This is a transitional dummy package. It can safely be removed.
 
-Package: postgresql-9.2-postgis-2.1
-Depends: ${shlibs:Depends}, postgresql-9.2,
- postgresql-9.2-postgis-2.1-scripts, liblwgeom-2.1.0,
- ${misc:Depends}
-Recommends: postgis
-Breaks: postgis

[SCM] postgis branch, master, updated. upstream/2.0.1-92-gc2379ec

2013-09-26 Thread Markus Wanner
The following commit has been merged in the master branch:
commit c2379ecbf4854813b005b551ec376a19120ab25e
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Sep 26 08:56:55 2013 +0200

Add appropriate notification messages to the transitional scripts
packages, so the user becomes aware he needs to migrate his
databases himself.

diff --git a/debian/changelog b/debian/changelog
index fc6335e..1d902f5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,7 +3,7 @@ postgis (2.1.0-3) UNRELEASED; urgency=low
   * Add transitional postgis-2.0-scripts packages for all Pg versions ever
 supported. These effectively remove scripts and the postgis.control
 file prior to installing a newer *-postgis-2.1-scrips package, which
-Breaks+Replaces it.
+Breaks+Replaces it. Add appropriate notification messages on upgrade.
   * Update patch upstream-r11934 to cover rev 11979, instead. It seems to
 be a more thorough fix. Add minor-r11979-correction patch to account
 for some new WARNINGs, that didn't appear, before.
diff --git a/debian/postgresql-8.4-postgis-2.0-scripts.config 
b/debian/postgresql-8.4-postgis-2.0-scripts.config
new file mode 100644
index 000..a67d43e
--- /dev/null
+++ b/debian/postgresql-8.4-postgis-2.0-scripts.config
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+set -e
+
+# Source debconf library.
+. /usr/share/debconf/confmodule
+
+# Should first check for installed extensions.
+db_input critical postgis/pg8.4_postgis2.0_deprecated || true
+db_go
diff --git a/debian/postgresql-8.4-postgis-2.0-scripts.postinst 
b/debian/postgresql-8.4-postgis-2.0-scripts.postinst
new file mode 100644
index 000..a48
--- /dev/null
+++ b/debian/postgresql-8.4-postgis-2.0-scripts.postinst
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+set -e
+
+. /usr/share/debconf/confmodule
+db_stop
+
+#DEBHELPER#
diff --git a/debian/postgresql-8.4-postgis-2.0-scripts.templates 
b/debian/postgresql-8.4-postgis-2.0-scripts.templates
new file mode 100644
index 000..f631a2f
--- /dev/null
+++ b/debian/postgresql-8.4-postgis-2.0-scripts.templates
@@ -0,0 +1,16 @@
+Template: postgis/pg8.4_postgis2.0_deprecated
+Type: note
+Description: PostGIS 2.0 has been deprecated - please migrate your databases
+ The package postgresql-8.4-postgis-2.0-scripts is installed on this
+ system, which means you likely use the PostGIS extension in some
+ databases.
+ .
+ On Debian, we now ship PostGIS version 2.1 and dropped support for
+ 2.0, meaning we no longer provide bug or security fixes. Thus we
+ strongly recommend you migrate your databases to PostGIS 2.1 on some
+ newer version of PostgreSQL as soon as possible.
+ .
+ Note that databases that are already using PostGIS 2.0 will continue to
+ work. However, with this upgrade to PostGIS 2.1 a CREATE EXTENSION postgis
+ in PostgreSQL version 9.0 will now give you PostGIS 2.1.
+
diff --git a/debian/postgresql-9.0-postgis-2.0-scripts.config 
b/debian/postgresql-9.0-postgis-2.0-scripts.config
new file mode 100644
index 000..10e4951
--- /dev/null
+++ b/debian/postgresql-9.0-postgis-2.0-scripts.config
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+set -e
+
+# Source debconf library.
+. /usr/share/debconf/confmodule
+
+# Should first check for installed extensions.
+db_input critical postgis/pg9.0_postgis2.0_deprecated || true
+db_go
diff --git a/debian/postgresql-9.0-postgis-2.0-scripts.postinst 
b/debian/postgresql-9.0-postgis-2.0-scripts.postinst
new file mode 100644
index 000..a48
--- /dev/null
+++ b/debian/postgresql-9.0-postgis-2.0-scripts.postinst
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+set -e
+
+. /usr/share/debconf/confmodule
+db_stop
+
+#DEBHELPER#
diff --git a/debian/postgresql-9.0-postgis-2.0-scripts.templates 
b/debian/postgresql-9.0-postgis-2.0-scripts.templates
new file mode 100644
index 000..8a99d98
--- /dev/null
+++ b/debian/postgresql-9.0-postgis-2.0-scripts.templates
@@ -0,0 +1,16 @@
+Template: postgis/pg9.0_postgis2.0_deprecated
+Type: note
+Description: PostGIS 2.0 has been deprecated - please migrate your databases
+ The package postgresql-9.0-postgis-2.0-scripts is installed on this
+ system, which means you likely use the PostGIS extension in some
+ databases.
+ .
+ On Debian, we now ship PostGIS version 2.1 and dropped support for
+ 2.0, meaning we no longer provide bug or security fixes. Thus we
+ strongly recommend you migrate your databases to PostGIS 2.1 as soon
+ as possible.
+ .
+ Note that databases that are already using PostGIS 2.0 will continue to
+ work. However, with this upgrade to PostGIS 2.1 a CREATE EXTENSION postgis
+ in PostgreSQL version 9.0 will now give you PostGIS 2.1.
+
diff --git a/debian/postgresql-9.1-postgis-2.0-scripts.config 
b/debian/postgresql-9.1-postgis-2.0-scripts.config
new file mode 100644
index 000..4ef0062
--- /dev/null
+++ b/debian/postgresql-9.1-postgis-2.0-scripts.config
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+set -e
+
+# Source debconf library.
+. /usr/share/debconf/confmodule
+
+# Should first check for installed extensions.
+db_input

[SCM] postgis branch, master, updated. upstream/2.0.1-93-gb9ad98c

2013-09-26 Thread Markus Wanner
The following commit has been merged in the master branch:
commit b9ad98ce2f7d60320ef37b6a7823705145791a1c
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Sep 26 15:28:25 2013 +0200

Fiddle with the upgrade notification texts a bit, so lintian doesn't
complain.

diff --git a/debian/postgresql-8.4-postgis-2.0-scripts.templates 
b/debian/postgresql-8.4-postgis-2.0-scripts.templates
index f631a2f..0854ccd 100644
--- a/debian/postgresql-8.4-postgis-2.0-scripts.templates
+++ b/debian/postgresql-8.4-postgis-2.0-scripts.templates
@@ -5,12 +5,12 @@ Description: PostGIS 2.0 has been deprecated - please migrate 
your databases
  system, which means you likely use the PostGIS extension in some
  databases.
  .
- On Debian, we now ship PostGIS version 2.1 and dropped support for
- 2.0, meaning we no longer provide bug or security fixes. Thus we
- strongly recommend you migrate your databases to PostGIS 2.1 on some
- newer version of PostgreSQL as soon as possible.
+ Debian is now shipping PostGIS version 2.1 and dropped support for
+ 2.0, meaning bug or security fixes will no longer be provided for the
+ older one. Thus it is strongly recommended to migrate all databases
+ to PostGIS 2.1 (and some newer PostgreSQL version) as soon as possible.
  .
- Note that databases that are already using PostGIS 2.0 will continue to
- work. However, with this upgrade to PostGIS 2.1 a CREATE EXTENSION postgis
- in PostgreSQL version 9.0 will now give you PostGIS 2.1.
+ Databases that are already using PostGIS 2.0 will continue to
+ work. Note, however, that with this upgrade it's no longer possible
+ to create the extension PostGIS 2.0.
 
diff --git a/debian/postgresql-9.0-postgis-2.0-scripts.templates 
b/debian/postgresql-9.0-postgis-2.0-scripts.templates
index 8a99d98..4976c0e 100644
--- a/debian/postgresql-9.0-postgis-2.0-scripts.templates
+++ b/debian/postgresql-9.0-postgis-2.0-scripts.templates
@@ -5,12 +5,12 @@ Description: PostGIS 2.0 has been deprecated - please migrate 
your databases
  system, which means you likely use the PostGIS extension in some
  databases.
  .
- On Debian, we now ship PostGIS version 2.1 and dropped support for
- 2.0, meaning we no longer provide bug or security fixes. Thus we
- strongly recommend you migrate your databases to PostGIS 2.1 as soon
- as possible.
+ Debian is now shipping PostGIS version 2.1 and dropped support for
+ 2.0, meaning bug or security fixes will no longer be provided for the
+ older one. Thus it is strongly recommended to migrate all databases
+ to PostGIS 2.1 as soon as possible.
  .
- Note that databases that are already using PostGIS 2.0 will continue to
- work. However, with this upgrade to PostGIS 2.1 a CREATE EXTENSION postgis
- in PostgreSQL version 9.0 will now give you PostGIS 2.1.
+ Databases that are already using PostGIS 2.0 will continue to
+ work. Note, however, that with this upgrade it's no longer possible
+ to create the extension PostGIS 2.0.
 
diff --git a/debian/postgresql-9.1-postgis-2.0-scripts.templates 
b/debian/postgresql-9.1-postgis-2.0-scripts.templates
index 05d983f..f233d0a 100644
--- a/debian/postgresql-9.1-postgis-2.0-scripts.templates
+++ b/debian/postgresql-9.1-postgis-2.0-scripts.templates
@@ -5,12 +5,12 @@ Description: PostGIS 2.0 has been deprecated - please migrate 
your databases
  system, which means you likely use the PostGIS extension in some
  databases.
  .
- On Debian, we now ship PostGIS version 2.1 and dropped support for
- 2.0, meaning we no longer provide bug or security fixes. Thus we
- strongly recommend you migrate your databases to PostGIS 2.1 as soon
- as possible.
+ Debian is now shipping PostGIS version 2.1 and dropped support for
+ 2.0, meaning bug or security fixes will no longer be provided for the
+ older one. Thus it is strongly recommended to migrate all databases
+ to PostGIS 2.1 as soon as possible.
  .
- Note that databases that are already using PostGIS 2.0 will continue to
- work. However, with this upgrade to PostGIS 2.1 a CREATE EXTENSION postgis
- in PostgreSQL version 9.1 will now give you PostGIS 2.1.
+ Databases that are already using PostGIS 2.0 will continue to
+ work. Note, however, that with this upgrade it's no longer possible
+ to create the extension PostGIS 2.0.
 
diff --git a/debian/postgresql-9.2-postgis-2.0-scripts.templates 
b/debian/postgresql-9.2-postgis-2.0-scripts.templates
index 180c2b8..8988114 100644
--- a/debian/postgresql-9.2-postgis-2.0-scripts.templates
+++ b/debian/postgresql-9.2-postgis-2.0-scripts.templates
@@ -1,16 +1,16 @@
 Template: postgis/pg9.2_postgis2.0_deprecated
 Type: note
 Description: PostGIS 2.0 has been deprecated - please migrate your databases
- The package postgresql-9.2-postgis-2.0-scripts is installed on this
+ The package postgresql-9.1-postgis-2.0-scripts is installed on this
  system, which means you likely use the PostGIS extension in some
  databases.
  .
- On Debian, we now ship PostGIS version 2.1 and dropped support for
- 2.0, meaning we

[SCM] postgis branch, master, updated. upstream/2.0.1-95-gcc7a441

2013-09-26 Thread Markus Wanner
The following commit has been merged in the master branch:
commit cc7a441bd3a265afe4f7773d2460e3111eefd67b
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Sep 26 15:55:28 2013 +0200

Re-apply the scripts upgrade fixes. Other than an increment to
2.1.0-4, this rev matches b9ad98.

diff --git a/debian/changelog b/debian/changelog
index 016e904..ff238c8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+postgis (2.1.0-4) UNRELEASED; urgency=low
+
+  * Add transitional postgis-2.0-scripts packages for all Pg versions ever
+supported. These effectively remove scripts and the postgis.control
+file prior to installing a newer *-postgis-2.1-scrips package, which
+Breaks+Replaces it. Add appropriate notification messages on upgrade.
+
+ -- Markus Wanner mar...@bluegap.ch  Thu, 26 Sep 2013 15:55:00 +0200
+
 postgis (2.1.0-3) unstable; urgency=low
 
   * Update patch upstream-r11934 to cover rev 11979, instead. It seems to
diff --git a/debian/control b/debian/control
index 9537f89..3ebcf17 100644
--- a/debian/control
+++ b/debian/control
@@ -101,6 +101,42 @@ Description: PostGIS Lightweight Geometry library - 
Development files
  processing functions, are implemented here.  This package contains
  the development files.
 
+Package: postgresql-8.4-postgis-2.0-scripts
+Architecture: all
+Depends: ${misc:Depends}
+Description: PostGIS for PostgreSQL 8.4 -- scripts -- dummy package
+ This package contained the scripts for PostGIS version 2.0, that's
+ now deprecated. It extended PostgreSQL 8.4.
+ .
+ This is a transitional dummy package. It can safely be removed.
+
+Package: postgresql-9.0-postgis-2.0-scripts
+Architecture: all
+Depends: ${misc:Depends}
+Description: PostGIS for PostgreSQL 9.0 -- scripts -- dummy package
+ This package contained the scripts for PostGIS version 2.0, that's
+ now deprecated. It extended PostgreSQL 9.0.
+ .
+ This is a transitional dummy package. It can safely be removed.
+
+Package: postgresql-9.1-postgis-2.0-scripts
+Architecture: all
+Depends: ${misc:Depends}
+Description: PostGIS for PostgreSQL 9.1 -- scripts -- dummy package
+ This package contained the scripts for PostGIS version 2.0, that's
+ now deprecated. It extended PostgreSQL 9.1.
+ .
+ This is a transitional dummy package. It can safely be removed.
+
+Package: postgresql-9.2-postgis-2.0-scripts
+Architecture: all
+Depends: ${misc:Depends}
+Description: PostGIS for PostgreSQL 9.2 -- scripts -- dummy package
+ This package contained the scripts for PostGIS version 2.0, that's
+ now deprecated. It extended PostgreSQL 9.2.
+ .
+ This is a transitional dummy package. It can safely be removed.
+
 Package: postgresql-9.3-postgis-2.1
 Depends: ${shlibs:Depends}, postgresql-9.3,
  postgresql-9.3-postgis-2.1-scripts, liblwgeom-2.1.0,
@@ -122,6 +158,8 @@ Package: postgresql-9.3-postgis-2.1-scripts
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: postgresql-9.3-postgis-2.1
+Replaces: postgresql-9.3-postgis-2.0-scripts ( 2.1.0~)
+Breaks: postgresql-9.3-postgis-2.0-scripts ( 2.1.0~)
 Description: Geographic objects support for PostgreSQL 9.3 -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
diff --git a/debian/control.in b/debian/control.in
index e3ab48c..7c4b857 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -122,6 +122,8 @@ Package: postgresql-PGVERSION-postgis-2.1-scripts
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: postgresql-PGVERSION-postgis-2.1
+Replaces: postgresql-PGVERSION-postgis-2.0-scripts ( 2.1.0~)
+Breaks: postgresql-PGVERSION-postgis-2.0-scripts ( 2.1.0~)
 Description: Geographic objects support for PostgreSQL PGVERSION -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
@@ -132,3 +134,39 @@ Description: Geographic objects support for PostgreSQL 
PGVERSION -- scripts
  .
  This package contains SQL scripts to upgrade from earlier PostGIS
  versions for PostgreSQL PGVERSION as well as Perl utility scripts.
+
+Package: postgresql-8.4-postgis-2.0-scripts
+Architecture: all
+Depends: ${misc:Depends}
+Description: PostGIS for PostgreSQL 8.4 -- scripts -- dummy package
+ This package contained the scripts for PostGIS version 2.0, that's
+ now deprecated. It extended PostgreSQL 8.4.
+ .
+ This is a transitional dummy package. It can safely be removed.
+
+Package: postgresql-9.0-postgis-2.0-scripts
+Architecture: all
+Depends: ${misc:Depends}
+Description: PostGIS for PostgreSQL 9.0 -- scripts -- dummy package
+ This package contained the scripts for PostGIS version 2.0, that's
+ now deprecated. It extended PostgreSQL 9.0.
+ .
+ This is a transitional dummy package. It can safely be removed.
+
+Package: postgresql-9.1-postgis-2.0-scripts
+Architecture: all
+Depends: ${misc:Depends}
+Description: PostGIS for PostgreSQL 9.1 -- scripts -- dummy package
+ This package contained

[SCM] postgis branch, master, updated. upstream/2.0.1-95-gcc7a441

2013-09-26 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 677a81952a57a6cb893e24e2db908b3d019f69c4
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Sep 26 15:46:46 2013 +0200

Temporarily revert all of the scripts upgrade fixes.

Finalize 2.1.0-3 for upload to unstable (to test the latest
big-endian patches).

diff --git a/debian/changelog b/debian/changelog
index 1d902f5..016e904 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,14 +1,10 @@
-postgis (2.1.0-3) UNRELEASED; urgency=low
+postgis (2.1.0-3) unstable; urgency=low
 
-  * Add transitional postgis-2.0-scripts packages for all Pg versions ever
-supported. These effectively remove scripts and the postgis.control
-file prior to installing a newer *-postgis-2.1-scrips package, which
-Breaks+Replaces it. Add appropriate notification messages on upgrade.
   * Update patch upstream-r11934 to cover rev 11979, instead. It seems to
 be a more thorough fix. Add minor-r11979-correction patch to account
 for some new WARNINGs, that didn't appear, before.
 
- -- Markus Wanner mar...@bluegap.ch  Wed, 25 Sep 2013 20:19:09 +0200
+ -- Markus Wanner mar...@bluegap.ch  Thu, 26 Sep 2013 15:36:22 +0200
 
 postgis (2.1.0-2) unstable; urgency=low
 
diff --git a/debian/control b/debian/control
index 3ebcf17..9537f89 100644
--- a/debian/control
+++ b/debian/control
@@ -101,42 +101,6 @@ Description: PostGIS Lightweight Geometry library - 
Development files
  processing functions, are implemented here.  This package contains
  the development files.
 
-Package: postgresql-8.4-postgis-2.0-scripts
-Architecture: all
-Depends: ${misc:Depends}
-Description: PostGIS for PostgreSQL 8.4 -- scripts -- dummy package
- This package contained the scripts for PostGIS version 2.0, that's
- now deprecated. It extended PostgreSQL 8.4.
- .
- This is a transitional dummy package. It can safely be removed.
-
-Package: postgresql-9.0-postgis-2.0-scripts
-Architecture: all
-Depends: ${misc:Depends}
-Description: PostGIS for PostgreSQL 9.0 -- scripts -- dummy package
- This package contained the scripts for PostGIS version 2.0, that's
- now deprecated. It extended PostgreSQL 9.0.
- .
- This is a transitional dummy package. It can safely be removed.
-
-Package: postgresql-9.1-postgis-2.0-scripts
-Architecture: all
-Depends: ${misc:Depends}
-Description: PostGIS for PostgreSQL 9.1 -- scripts -- dummy package
- This package contained the scripts for PostGIS version 2.0, that's
- now deprecated. It extended PostgreSQL 9.1.
- .
- This is a transitional dummy package. It can safely be removed.
-
-Package: postgresql-9.2-postgis-2.0-scripts
-Architecture: all
-Depends: ${misc:Depends}
-Description: PostGIS for PostgreSQL 9.2 -- scripts -- dummy package
- This package contained the scripts for PostGIS version 2.0, that's
- now deprecated. It extended PostgreSQL 9.2.
- .
- This is a transitional dummy package. It can safely be removed.
-
 Package: postgresql-9.3-postgis-2.1
 Depends: ${shlibs:Depends}, postgresql-9.3,
  postgresql-9.3-postgis-2.1-scripts, liblwgeom-2.1.0,
@@ -158,8 +122,6 @@ Package: postgresql-9.3-postgis-2.1-scripts
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: postgresql-9.3-postgis-2.1
-Replaces: postgresql-9.3-postgis-2.0-scripts ( 2.1.0~)
-Breaks: postgresql-9.3-postgis-2.0-scripts ( 2.1.0~)
 Description: Geographic objects support for PostgreSQL 9.3 -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
diff --git a/debian/control.in b/debian/control.in
index 7c4b857..e3ab48c 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -122,8 +122,6 @@ Package: postgresql-PGVERSION-postgis-2.1-scripts
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: postgresql-PGVERSION-postgis-2.1
-Replaces: postgresql-PGVERSION-postgis-2.0-scripts ( 2.1.0~)
-Breaks: postgresql-PGVERSION-postgis-2.0-scripts ( 2.1.0~)
 Description: Geographic objects support for PostgreSQL PGVERSION -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
@@ -134,39 +132,3 @@ Description: Geographic objects support for PostgreSQL 
PGVERSION -- scripts
  .
  This package contains SQL scripts to upgrade from earlier PostGIS
  versions for PostgreSQL PGVERSION as well as Perl utility scripts.
-
-Package: postgresql-8.4-postgis-2.0-scripts
-Architecture: all
-Depends: ${misc:Depends}
-Description: PostGIS for PostgreSQL 8.4 -- scripts -- dummy package
- This package contained the scripts for PostGIS version 2.0, that's
- now deprecated. It extended PostgreSQL 8.4.
- .
- This is a transitional dummy package. It can safely be removed.
-
-Package: postgresql-9.0-postgis-2.0-scripts
-Architecture: all
-Depends: ${misc:Depends}
-Description: PostGIS for PostgreSQL 9.0 -- scripts -- dummy package
- This package contained the scripts for PostGIS version 2.0, that's
- now deprecated

[SCM] postgis tag, debian/2.1.0-3, created. upstream/2.0.1-94-g677a819

2013-09-26 Thread Markus Wanner
The tag, debian/2.1.0-3 has been created
at  677a81952a57a6cb893e24e2db908b3d019f69c4 (commit)

- Shortlog 
commit 677a81952a57a6cb893e24e2db908b3d019f69c4
Author: Markus Wanner mar...@bluegap.ch
Date:   Thu Sep 26 15:46:46 2013 +0200

Temporarily revert all of the scripts upgrade fixes.

Finalize 2.1.0-3 for upload to unstable (to test the latest
big-endian patches).
---

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-98-g1ff0917

2013-10-01 Thread Markus Wanner
The following commit has been merged in the master branch:
commit e4282ec094e56a46d79650a74dc19e507ed9e5d1
Author: Markus Wanner mar...@bluegap.ch
Date:   Mon Sep 30 12:29:29 2013 +0200

Fiddle with the postgis-2.0 db migration notice a bit: also mention
the effect on backups.

diff --git a/debian/postgresql-8.4-postgis-2.0-scripts.templates 
b/debian/postgresql-8.4-postgis-2.0-scripts.templates
index 0854ccd..f421344 100644
--- a/debian/postgresql-8.4-postgis-2.0-scripts.templates
+++ b/debian/postgresql-8.4-postgis-2.0-scripts.templates
@@ -10,7 +10,9 @@ Description: PostGIS 2.0 has been deprecated - please migrate 
your databases
  older one. Thus it is strongly recommended to migrate all databases
  to PostGIS 2.1 (and some newer PostgreSQL version) as soon as possible.
  .
- Databases that are already using PostGIS 2.0 will continue to
- work. Note, however, that with this upgrade it's no longer possible
- to create the extension PostGIS 2.0.
+ Of course, databases that are already using PostGIS 2.0 will continue
+ to work. Note, however, that with this upgrade it's no longer
+ possible to create version 2.0 of the extension PostGIS. Instead,
+ 'CREATE EXTENSION postgis;' will now give you version 2.1. Note that
+ this also affects backups.
 
diff --git a/debian/postgresql-9.0-postgis-2.0-scripts.templates 
b/debian/postgresql-9.0-postgis-2.0-scripts.templates
index 4976c0e..fd7fa2c 100644
--- a/debian/postgresql-9.0-postgis-2.0-scripts.templates
+++ b/debian/postgresql-9.0-postgis-2.0-scripts.templates
@@ -10,7 +10,9 @@ Description: PostGIS 2.0 has been deprecated - please migrate 
your databases
  older one. Thus it is strongly recommended to migrate all databases
  to PostGIS 2.1 as soon as possible.
  .
- Databases that are already using PostGIS 2.0 will continue to
- work. Note, however, that with this upgrade it's no longer possible
- to create the extension PostGIS 2.0.
+ Of course, databases that are already using PostGIS 2.0 will continue
+ to work. Note, however, that with this upgrade it's no longer
+ possible to create version 2.0 of the extension PostGIS. Instead,
+ 'CREATE EXTENSION postgis;' will now give you version 2.1. Note that
+ this also affects backups.
 
diff --git a/debian/postgresql-9.1-postgis-2.0-scripts.templates 
b/debian/postgresql-9.1-postgis-2.0-scripts.templates
index f233d0a..d0ada7f 100644
--- a/debian/postgresql-9.1-postgis-2.0-scripts.templates
+++ b/debian/postgresql-9.1-postgis-2.0-scripts.templates
@@ -10,7 +10,9 @@ Description: PostGIS 2.0 has been deprecated - please migrate 
your databases
  older one. Thus it is strongly recommended to migrate all databases
  to PostGIS 2.1 as soon as possible.
  .
- Databases that are already using PostGIS 2.0 will continue to
- work. Note, however, that with this upgrade it's no longer possible
- to create the extension PostGIS 2.0.
+ Of course, databases that are already using PostGIS 2.0 will continue
+ to work. Note, however, that with this upgrade it's no longer
+ possible to create version 2.0 of the extension PostGIS. Instead,
+ 'CREATE EXTENSION postgis;' will now give you version 2.1. Note that
+ this also affects backups.
 
diff --git a/debian/postgresql-9.2-postgis-2.0-scripts.templates 
b/debian/postgresql-9.2-postgis-2.0-scripts.templates
index 8988114..c0d16cf 100644
--- a/debian/postgresql-9.2-postgis-2.0-scripts.templates
+++ b/debian/postgresql-9.2-postgis-2.0-scripts.templates
@@ -10,7 +10,9 @@ Description: PostGIS 2.0 has been deprecated - please migrate 
your databases
  older one. Thus it is strongly recommended to migrate all databases
  to PostGIS 2.1 as soon as possible.
  .
- Databases that are already using PostGIS 2.0 will continue to
- work. Note, however, that with this upgrade it's no longer possible
- to create the extension PostGIS 2.0.
+ Of course, databases that are already using PostGIS 2.0 will continue
+ to work. Note, however, that with this upgrade it's no longer
+ possible to create version 2.0 of the extension PostGIS. Instead,
+ 'CREATE EXTENSION postgis;' will now give you version 2.1. Note that
+ this also affects backups.
 

-- 
PostGIS for PostgreSQL

___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel


[SCM] postgis branch, master, updated. upstream/2.0.1-98-g1ff0917

2013-10-01 Thread Markus Wanner
The following commit has been merged in the master branch:
commit 1ff09179dfda03aafadbd8e5e1733f210c3751dc
Author: Markus Wanner mar...@bluegap.ch
Date:   Mon Sep 30 15:27:31 2013 +0200

Template-ify the *-postgis-2.0-scripts transitional packages, using
current supported pg versions intersected with a hard-coded set of
postgis-2.0 supported Postgres versions.

Move the *-postgis-2.0-scripts package control sections out of
control.in. They are now found in control.postgis-2.0.in, so we
can treat them separately.

diff --git a/debian/changelog b/debian/changelog
index 1a9017a..440ce25 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,10 +2,11 @@ postgis (2.1.0-4) UNRELEASED; urgency=low
 
   * Rename pg-X.Y-postgis-2.1-scripts package to exclude PostGIS version
 number.
-  * Add transitional postgis-2.0-scripts packages for all Pg versions ever
-supported. These effectively remove scripts and the postgis.control
-file prior to installing a newer *-postgis-2.1-scrips package, which
-Breaks+Replaces it. Add appropriate notification messages on upgrade.
+  * Add transitional postgis-2.0-scripts packages for all Postgres
+versions supported by the old *and* new PostGIS version. These
+effectively remove scripts and the postgis.control file prior to
+installing a newer *-postgis-scripts package, which Breaks+Replaces
+the old one. Add appropriate notification messages on upgrade.
 
  -- Markus Wanner mar...@bluegap.ch  Thu, 26 Sep 2013 15:55:00 +0200
 
diff --git a/debian/control b/debian/control
index 9f55759..ff6ef18 100644
--- a/debian/control
+++ b/debian/control
@@ -101,42 +101,6 @@ Description: PostGIS Lightweight Geometry library - 
Development files
  processing functions, are implemented here.  This package contains
  the development files.
 
-Package: postgresql-8.4-postgis-2.0-scripts
-Architecture: all
-Depends: ${misc:Depends}
-Description: PostGIS for PostgreSQL 8.4 -- scripts -- dummy package
- This package contained the scripts for PostGIS version 2.0, that's
- now deprecated. It extended PostgreSQL 8.4.
- .
- This is a transitional dummy package. It can safely be removed.
-
-Package: postgresql-9.0-postgis-2.0-scripts
-Architecture: all
-Depends: ${misc:Depends}
-Description: PostGIS for PostgreSQL 9.0 -- scripts -- dummy package
- This package contained the scripts for PostGIS version 2.0, that's
- now deprecated. It extended PostgreSQL 9.0.
- .
- This is a transitional dummy package. It can safely be removed.
-
-Package: postgresql-9.1-postgis-2.0-scripts
-Architecture: all
-Depends: ${misc:Depends}
-Description: PostGIS for PostgreSQL 9.1 -- scripts -- dummy package
- This package contained the scripts for PostGIS version 2.0, that's
- now deprecated. It extended PostgreSQL 9.1.
- .
- This is a transitional dummy package. It can safely be removed.
-
-Package: postgresql-9.2-postgis-2.0-scripts
-Architecture: all
-Depends: ${misc:Depends}
-Description: PostGIS for PostgreSQL 9.2 -- scripts -- dummy package
- This package contained the scripts for PostGIS version 2.0, that's
- now deprecated. It extended PostgreSQL 9.2.
- .
- This is a transitional dummy package. It can safely be removed.
-
 Package: postgresql-9.3-postgis-2.1
 Depends: ${shlibs:Depends}, postgresql-9.3,
  postgresql-9.3-postgis-scripts, liblwgeom-2.1.0,
@@ -158,8 +122,10 @@ Package: postgresql-9.3-postgis-scripts
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: postgresql-9.3-postgis-2.1
-Replaces: postgresql-9.3-postgis-2.0-scripts ( 2.1.0~)
-Breaks: postgresql-9.3-postgis-2.0-scripts ( 2.1.0~)
+Replaces: postgresql-9.3-postgis-2.0-scripts ( 2.1.0~),
+ postgresql-9.3-postgis-2.1-scripts ( 2.1.0-4~)
+Breaks: postgresql-9.3-postgis-2.0-scripts ( 2.1.0~),
+ postgresql-9.3-postgis-2.1-scripts ( 2.1.0-4~)
 Description: Geographic objects support for PostgreSQL 9.3 -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
@@ -171,3 +137,13 @@ Description: Geographic objects support for PostgreSQL 9.3 
-- scripts
  This package contains SQL scripts to upgrade from earlier PostGIS
  versions for PostgreSQL 9.3 as well as Perl utility scripts.
 
+Package: postgresql-9.3-postgis-2.1-scripts
+Architecture: all
+Depends: ${misc:Depends}
+Description: PostGIS for PostgreSQL 9.3 -- scripts -- dummy package
+ This package contained SQL scripts to upgrade from earlier PostGIS
+ versions for PostgreSQL 9.3 as well as Perl utility scripts.
+ It got renamed to postgresql-9.3-postgis-scripts.
+ .
+ This is a transitional dummy package. It can safely be removed.
+
diff --git a/debian/control.in b/debian/control.in
index 7de542a..bdaf56b 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -147,38 +147,3 @@ Description: PostGIS for PostgreSQL PGVERSION -- scripts 
-- dummy package
  .
  This is a transitional dummy package. It can safely be removed.
 
-Package: postgresql-8.4

[SCM] postgis branch, master, updated. upstream/2.0.1-98-g1ff0917

2013-10-01 Thread Markus Wanner
The following commit has been merged in the master branch:
commit ba5465a9638e7f535f0ac0087ed617abd694f420
Author: Markus Wanner mar...@bluegap.ch
Date:   Mon Sep 30 11:37:46 2013 +0200

Rename pg-X.Y-postgis-2.1-scripts package to exclude PostGIS version
number.

diff --git a/debian/changelog b/debian/changelog
index ff238c8..1a9017a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,7 @@
 postgis (2.1.0-4) UNRELEASED; urgency=low
 
+  * Rename pg-X.Y-postgis-2.1-scripts package to exclude PostGIS version
+number.
   * Add transitional postgis-2.0-scripts packages for all Pg versions ever
 supported. These effectively remove scripts and the postgis.control
 file prior to installing a newer *-postgis-2.1-scrips package, which
diff --git a/debian/control b/debian/control
index 3ebcf17..9f55759 100644
--- a/debian/control
+++ b/debian/control
@@ -139,7 +139,7 @@ Description: PostGIS for PostgreSQL 9.2 -- scripts -- dummy 
package
 
 Package: postgresql-9.3-postgis-2.1
 Depends: ${shlibs:Depends}, postgresql-9.3,
- postgresql-9.3-postgis-2.1-scripts, liblwgeom-2.1.0,
+ postgresql-9.3-postgis-scripts, liblwgeom-2.1.0,
  ${misc:Depends}
 Recommends: postgis
 Breaks: postgis ( 1.2.1)
@@ -154,7 +154,7 @@ Description: Geographic objects support for PostgreSQL 9.3
  .
  This package supports PostgreSQL 9.3.
 
-Package: postgresql-9.3-postgis-2.1-scripts
+Package: postgresql-9.3-postgis-scripts
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: postgresql-9.3-postgis-2.1
diff --git a/debian/control.in b/debian/control.in
index 7c4b857..7de542a 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -103,7 +103,7 @@ Description: PostGIS Lightweight Geometry library - 
Development files
 
 Package: postgresql-PGVERSION-postgis-2.1
 Depends: ${shlibs:Depends}, postgresql-PGVERSION,
- postgresql-PGVERSION-postgis-2.1-scripts, liblwgeom-2.1.0,
+ postgresql-PGVERSION-postgis-scripts, liblwgeom-2.1.0,
  ${misc:Depends}
 Recommends: postgis
 Breaks: postgis ( 1.2.1)
@@ -118,12 +118,14 @@ Description: Geographic objects support for PostgreSQL 
PGVERSION
  .
  This package supports PostgreSQL PGVERSION.
 
-Package: postgresql-PGVERSION-postgis-2.1-scripts
+Package: postgresql-PGVERSION-postgis-scripts
 Architecture: all
 Depends: ${misc:Depends}
 Recommends: postgresql-PGVERSION-postgis-2.1
-Replaces: postgresql-PGVERSION-postgis-2.0-scripts ( 2.1.0~)
-Breaks: postgresql-PGVERSION-postgis-2.0-scripts ( 2.1.0~)
+Replaces: postgresql-PGVERSION-postgis-2.0-scripts ( 2.1.0~),
+ postgresql-PGVERSION-postgis-2.1-scripts ( 2.1.0-4~)
+Breaks: postgresql-PGVERSION-postgis-2.0-scripts ( 2.1.0~),
+ postgresql-PGVERSION-postgis-2.1-scripts ( 2.1.0-4~)
 Description: Geographic objects support for PostgreSQL PGVERSION -- scripts
  PostGIS adds support for geographic objects to the PostgreSQL
  object-relational database. In effect, PostGIS spatially enables
@@ -135,6 +137,16 @@ Description: Geographic objects support for PostgreSQL 
PGVERSION -- scripts
  This package contains SQL scripts to upgrade from earlier PostGIS
  versions for PostgreSQL PGVERSION as well as Perl utility scripts.
 
+Package: postgresql-PGVERSION-postgis-2.1-scripts
+Architecture: all
+Depends: ${misc:Depends}
+Description: PostGIS for PostgreSQL PGVERSION -- scripts -- dummy package
+ This package contained SQL scripts to upgrade from earlier PostGIS
+ versions for PostgreSQL PGVERSION as well as Perl utility scripts.
+ It got renamed to postgresql-PGVERSION-postgis-scripts.
+ .
+ This is a transitional dummy package. It can safely be removed.
+
 Package: postgresql-8.4-postgis-2.0-scripts
 Architecture: all
 Depends: ${misc:Depends}
diff --git a/debian/postgresql-generic-postgis-2.1-scripts.install.in 
b/debian/postgresql-generic-postgis-scripts.install.in
similarity index 100%
rename from debian/postgresql-generic-postgis-2.1-scripts.install.in
rename to debian/postgresql-generic-postgis-scripts.install.in
diff --git a/debian/rules b/debian/rules
index 65ca336..f7e4c8b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -186,7 +186,7 @@ clean: debian/control
raster/rt_pg/rtpostgis_drop.sql \
raster/rt_pg/rtpostgis_upgrade_cleanup.sql
rm -f $(CURDIR)/debian/postgresql-*-postgis-2.1.install
-   rm -f $(CURDIR)/debian/postgresql-*-postgis-2.1-scripts.install
+   rm -f $(CURDIR)/debian/postgresql-*-postgis-scripts.install
rm -f loader/cunit/cu_tester
rm -rf liblwgeom/cunit/.libs
 
@@ -255,9 +255,9 @@ install-arch: build-arch
cat $(CURDIR)/debian/postgresql-generic-postgis-2.1.install.in \
| sed -e s/@PGVERSION@/$$PGVER/ \
 
$(CURDIR)/debian/postgresql-$$PGVER-postgis-2.1.install; \
-   cat 
$(CURDIR)/debian/postgresql-generic-postgis-2.1-scripts.install.in \
+   cat 
$(CURDIR)/debian/postgresql-generic-postgis-scripts.install.in \
| sed -e s/@PGVERSION

postgis: sid vs pgapt

2013-10-01 Thread Markus Wanner
Christoph, Marco,

I renamed the scripts package(s) to exclude the postgis version. That
hopefully simplifies packaging newer PostGIS versions in the future. And
keeps us from having to maintain an increasing amount of transitional
packages.

I tweaked the can safely be removed wording in the long description a
bit. However, please also keep in mind that the upgrade already makes
postgis-2.0 un-creatable. A postgis-2.0 package installed, the
transitional package cannot be removed due its dependency, though.

As discussed, I also automated the creation of .postinst, .templates,
and .config files for all transitional *-postgis-2.0-scripts packages.
Meaning these get created from debian/rules at build time.

I figured we best use debian/pgversions and subtract the Postgres
versions that were not supported by the former Postgis version. So that
we don't create postgresql-9.3-postgis-2.0-scripts, for example.

This however means we don't create postgresql-8.4-postgis-2.0-scripts,
either. Which I think is a good thing. Upon upgrade, the user won't get
a warning for 8.4-postgis-2.0, that way. I'd argue that's okay, as the
extension provided by postgresql-8.4-postgis-2.0{,-scripts} can continue
to work perfectly fine (including scripts), because there's no
postgis-2.1-scripts package to override it. And Debian usually doesn't
emit a notice in case support for a package runs out...

That also saves us from doing tricks with determining the set of old PG
versions supported depending on pgdg vs Debian proper.

Note: on Debian, this also means we don't ship a transitional
postgresql-9.1-postgis-2.0-scripts package. Its postgis 2.0 will
continue to work just fine. Once you add the pgapt repository and
upgrade, you'd still get that notice, though (and the breakage).

What I didn't look at are translations. Lintian emits a warning, but
other than that, upgrades present me the English message. Given the
notice doesn't ever appear on Debian proper, so far, can we do without
translations (i.e. for pgapt)?

On top of that, I've been unable to merge the debconf templates. My
testing seems to indicate you cannot have a common 'templates' file
shared between multiple packages. If you know of a way to do that,
please let me know. In any case, due to the automatic generation, they
all stem from a single
postgresql-generic-postgis-2.0-scripts.templates.in, anyways, now.
However, this might make translations even harder...

Does this all make sense to you? Did I miss anything? Can I finalize
2.1.0-4 for upload to unstable? (Which again needs a sponsor due to the
renaming).

Regards

Markus Wanner



signature.asc
Description: OpenPGP digital signature
___
Pkg-grass-devel mailing list
Pkg-grass-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-grass-devel

  1   2   3   4   >