Bug#710805: eclipse-wtp: fails to build from source

2013-06-02 Thread Jeremy Bicha
Package: eclipse-wtp Version: 3.4.2-2 Severity: serious Justification: fails to build from source User: ubuntu-de...@lists.ubuntu.com Usertags: origin-ubuntu saucy eclipse-wtp 3.4.2-2 fails to build from source in a clean chroot. BUILD FAILED

Bug#836391: gradle: recent update of jsch to version 0.1.54 breaks Gradle based projects

2016-09-06 Thread Jeremy Bicha
Do you know why the new gradle 2.13-4 still fails to build on Ubuntu yakkety? https://launchpad.net/ubuntu/+source/gradle/2.13-4/+build/10712522 Thanks, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-j

Bug#848389: derby: Fails to build from source

2016-12-16 Thread Jeremy Bicha
at org.apache.tools.ant.taskdefs.Get$GetThread.run(Get.java:631) Thanks, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. Please use debian-j...@lists.debian.org for discussions and questions.

Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-08-12 Thread Jeremy Bicha
rt of the deprecated libraries which are being removed.) If you have any question don't hesitate to ask. On behalf of the Debian WebKit Maintainers, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintaine

Bug#856521: libwala-java-doc: uninstallable in sid: unsatisfiable Depends: default-java-doc

2017-04-30 Thread Jeremy Bicha
I don't know what this package is trying to do, but maybe you meant for it to depend on default-jdk-doc instead? Thanks, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. Please use de

Bug#681726: Time to remove eclipse from Testing?

2017-11-01 Thread Jeremy Bicha
On Fri, Oct 20, 2017 at 6:24 PM, Emmanuel Bourg <ebo...@apache.org> wrote: > Le 20/10/2017 à 23:52, Jeremy Bicha a écrit : > >> Never mind. I tried doing the dak queries and I eventually got more >> than 500 reverse-depends before I gave up. (Attached) > > Funny, I n

Bug#681726: Time to remove eclipse from Testing?

2017-11-09 Thread Jeremy Bicha
On Fri, Oct 20, 2017 at 5:52 PM, Jeremy Bicha <jbi...@debian.org> wrote: > On Fri, Oct 20, 2017 at 12:47 PM, Markus Koschany <a...@debian.org> wrote: >> Am 20.10.2017 um 18:43 schrieb Jeremy Bicha: >>> Are there any objections to me requesting that the ftpmasters

Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-24 Thread Jeremy Bicha
. Thanks, Jeremy Bicha From 89a84e10dd70b681cfa523462e5918850efbfde6 Mon Sep 17 00:00:00 2001 From: Jeremy Bicha <jbi...@ubuntu.com> Date: Tue, 24 Oct 2017 15:25:30 -0400 Subject: [PATCH] Drop unnecessary Build-Depends on libwebkitgtk-dev Closes: #871964 --- debian/changelog | 7 +++ debian/c

Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-24 Thread Jeremy Bicha
in my opinion it doesn't need to block webkitgtk's removal. I am mentioning both of these outstanding RC bugs in the RM bug I plan to file with the Release Team next week so it will be up to them to decide. Thanks, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://list

Bug#681726: Time to remove eclipse from Testing?

2017-10-20 Thread Jeremy Bicha
On Fri, Oct 20, 2017 at 12:47 PM, Markus Koschany <a...@debian.org> wrote: > Am 20.10.2017 um 18:43 schrieb Jeremy Bicha: >> Are there any objections to me requesting that the ftpmasters remove >> swt-gtk and eclipse from Debian Testing so that we can complete the >> web

Bug#879243: tuxguitar: Unusable in GNOME on Wayland

2017-10-20 Thread Jeremy Bicha
cursor. The Debian GNOME team intends to use Wayland by default on GNOME for Debian 10 "Buster". This might be a bug in swt4-gtk so feel free to reassign as needed. (I normally don't use any Java apps. I just happened to try this one while checking 879228.) Thanks, Je

Bug#868404: swt4-gtk: Please drop the (build-)dependency against gnome-vfs

2017-12-29 Thread Jeremy Bicha
) and one reverse-recommends (eclipse-rcp, so we'd need to drop that recommends). Thanks, Jeremy Bicha From 9a099e629cedbebb6960171d3b1617c0d74df86c Mon Sep 17 00:00:00 2001 From: Jeremy Bicha <jbi...@debian.org> Date: Fri, 29 Dec 2017 10:18:58 -0500 Subject: [PATCH] Drop libswt-gnome-gtk-4-jni

Bug#879170: Asked Release Team to resolve swt-gtk depends issue

2017-12-27 Thread Jeremy Bicha
Oops, I should have CC'd the bugs. https://lists.debian.org/debian-release/2017/12/msg00660.html Thanks, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. Please use debian-j...@lists.debi

Bug#868404: libswt-gnome-gtk-3-jni: Raising severity of libgnome rdepends bugs

2018-02-14 Thread Jeremy Bicha
00169.html On behalf of the Debian GNOME team, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. Please use debian-j...@lists.debian.org for discussions and questions.

Bug#868404: NMU in progress dropping libswt-gnome-gtk4-jni package

2018-02-18 Thread Jeremy Bicha
when I tried dropping the libgnome dependency. git formatted patch attached to be applied with the other patch attached to this bug. Thanks, Jeremy Bicha From a5f8981e56b348aebf69da3ca821c71598dac8d0 Mon Sep 17 00:00:00 2001 From: Jeremy Bicha <jbi...@debian.org> Date: Sun, 18 Feb 2018 21

Bug#868406: NMU in progress dropping libswt-gnome-gtk3-jni package

2018-02-18 Thread Jeremy Bicha
. Thanks, Jeremy Bicha From 1db7cde5709cede83b1d44dd8349af9f3fc1a8bc Mon Sep 17 00:00:00 2001 From: Jeremy Bicha <jbi...@debian.org> Date: Sun, 18 Feb 2018 21:27:38 -0500 Subject: [PATCH] releasing package swt-gtk version 3.8.2-4.3 --- debian/Makefile | 2 +-

Bug#868404: swt-gtk: Please drop the (build-)dependency against gnome-vfs

2017-12-25 Thread Jeremy Bicha
To be a bit more clear, this package Build-Depends on libgnomeui-dev which depends on gnome-vfs. Thanks, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. Please use debian-j...@lists.debi

Bug#886083: eclipse-platform: raising severity of gconf dependency bug

2018-03-25 Thread Jeremy Bicha
us complete this goal. [1] https://lists.debian.org/debian-devel/2018/02/msg00169.html On behalf of the Debian GNOME team, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. Please use de

Bug#893768: eclipse-rcp: Please don't depend on libswt-webkit-gtk-3-jni

2018-03-21 Thread Jeremy Bicha
Testing. Please investigate whether it's possible to drop this dependency. I'm guessing it's still possible for apps to use the Eclipse platform without that library: it's just that web browser powered widgets won't work? On behalf of the Debian Webkit Maintainers, Jeremy Bicha

Bug#880470: libswt-webkit-gtk-3-jni: Depend on libwebkitgtk-1.0-0 which is deprecated

2018-03-23 Thread Jeremy Bicha
Control: severity -1 serious Control: block -1 by 893768 Now that the latest version has migrated to testing, let's bump the severity again. Thanks, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintain

Accepted swt4-gtk 4.6.3-1.1 (source) into unstable

2018-03-05 Thread Jeremy Bicha
: unstable Urgency: medium Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org> Changed-By: Jeremy Bicha <jbi...@debian.org> Description: libswt-cairo-gtk-4-jni - Standard Widget Toolkit for GTK+ Cairo JNI library libswt-glx-gtk-4-jni - Standard Wi

Accepted swt-gtk 3.8.2-4.3 (source) into unstable

2018-03-05 Thread Jeremy Bicha
: medium Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org> Changed-By: Jeremy Bicha <jbi...@debian.org> Description: libswt-cairo-gtk-3-jni - Standard Widget Toolkit for GTK+ Cairo JNI library libswt-glx-gtk-3-jni - Standard Widget Toolkit for GTK+ GLX

Bug#827502: omegat: Recommends libhunspell-1.3-0 but that package no longer exists in Stretch

2016-06-16 Thread Jeremy Bicha
or security updates for that version of the library. Thanks, Jeremy Bicha $ apt show omegat Package: omegat Version: 2.3.0.1+dfsg-4 Priority: optional Section: universe/editors Depends: default-jre | java6-runtime | java7-runtime, libvldocking-java, libhtmlparser-java, libswing-layout-java Recommends

Bug#879175: androidsdk-tools: Duplicate of android-platform-tools-swt

2017-10-19 Thread Jeremy Bicha
and remove androidsdk-tools? On the other hand, the newer android-platform-tools-swt hasn't been buildable since January. But the tools are deprecated and apparently removed in newer Android SDK versions anyway. Thanks, Jeremy Bicha __ This is the maintainer address of Debian's Java team <h

Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-19 Thread Jeremy Bicha
8PM -0400, Jeremy Bicha wrote: >>... >> The package does build successfully without the libwebkitgtk-dev >> build-dependency. > > But the resulting library will still dynamically load it. > >> It feels to me like the libswt-webkit-gtk-3-jni was already broken >> sin

Bug#681726: Time to remove eclipse from Testing?

2017-10-20 Thread Jeremy Bicha
sion. Are there any objections to me requesting that the ftpmasters remove swt-gtk and eclipse from Debian Testing so that we can complete the webkitgtk removal from Testing? Thanks, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/ma

Bug#681726: Time to remove eclipse from Testing?

2017-10-20 Thread Jeremy Bicha
Control: severity -1 serious I'm elevating this bug to RC then. Thanks, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. Please use debian-j...@lists.debian.org for discussions and questions.

Bug#879228: libswt-webkit-gtk-4-jni: Missing webkit dependency

2017-10-20 Thread Jeremy Bicha
Hopefully, this one can be fixed by just having libswt-webkit-gtk-4-jni depend on libwebkit2gtk-4.0-37 Thanks, Jeremy Bicha __ This is the maintainer address of Debian's Java team <http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-java-maintainers>. Please use de

Bug#879228: libswt-webkit-gtk-4-jni: Missing webkit dependency

2017-10-20 Thread Jeremy Bicha
On Fri, Oct 20, 2017 at 3:33 PM, Emmanuel Bourg <ebo...@apache.org> wrote: > Le 20/10/2017 à 20:41, Jeremy Bicha a écrit : >> Hopefully, this one can be fixed by just having >> libswt-webkit-gtk-4-jni depend on libwebkit2gtk-4.0-37 > > Thank you for the hint