Bug#892760: antlr3: FTBFS with Java 9

2018-03-13 Thread Tiago Daitx
After reviewing this again I found out that the problem is caused by the direct calling of javadoc's jar goal - note that this is specific to cdbs, antlr4 relies on dh and calls the 3 goals "package javadoc:jar javadoc:aggregate" together, which causes generate-sources to be run before both

Bug#892760: antlr3: FTBFS with Java 9

2018-03-14 Thread Tiago Daitx
I am attaching a simple fix to get rid of the FTBFS when building with openjdk-9. BTW, I didn't mention this before, but the reason that javadoc goals worked with openjdk-8 is because openjdk-8's javadoc binary ignored the missing packages/files instead of failing to run - the documentation for

Bug#895583: libcommons-lang3-java FTBFS due to unsupported locale type

2018-04-12 Thread Tiago Daitx
A debdiff with the fix has been provided in bug #895234 [1]. thanks [1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895234 On Fri, Apr 13, 2018 at 12:32 AM, Tiago Stürmer Daitx wrote: > Package: libcommons-lang3-java > Version: 3.5-1 > Severity: normal > > Dear

Bug#895234: libcommons-lang3-java: update for OpenJDK 10 and OpenJDK 11

2018-04-12 Thread Tiago Daitx
> 1) libcommons-lang3-java must be rebuild using openjdk-9 with docs and > tests disabled Then install the resulting deb binary. > 2) rebuild with openjdk-10, keep doc and tests disabled Or maybe with just tests disabled, I might have run with docs disabled just to get a binary a bit faster.

Bug#895234: libcommons-lang3-java: update for OpenJDK 10 and OpenJDK 11

2018-04-12 Thread Tiago Daitx
This fix (or testing it) might be blocked by bug #895587. -- Tiago Stürmer Daitx Software Engineer tiago.da...@canonical.com PGP Key: 4096R/F5B213BE (hkp://keyserver.ubuntu.com) Fingerprint = 45D0 FE5A 8109 1E91 866E 8CA4 1931 8D5E F5B2 13BE __ This is the maintainer address of Debian's Java

Bug#895619: plexus-compiler: use --release instead of -source/-target for jdk9+ when setting defaults

2018-04-13 Thread Tiago Daitx
o, fork and an alternative javac compiler might be set, thus I would > like to discuss as to what behavior it should default it in that case. > > Regards, > Tiago Daitx > > References: > [1] https://bugs.launchpad.net/ubuntu/+source/gradle/+bug/1760359 > [2] https://github.c

Bug#895616: gradle: fix support for openjdk-9 --release flag

2018-04-13 Thread Tiago Daitx
Please consider the attached debdiff for fixing this bug. thanks -- Tiago Stürmer Daitx Software Engineer tiago.da...@canonical.com PGP Key: 4096R/F5B213BE (hkp://keyserver.ubuntu.com) Fingerprint = 45D0 FE5A 8109 1E91 866E 8CA4 1931 8D5E F5B2 13BE diff -Nru gradle-3.4.1/debian/changelog

Bug#895234: libcommons-lang3-java: update for OpenJDK 10 and OpenJDK 11

2018-04-12 Thread Tiago Daitx
On Sun, 8 Apr 2018 19:03:14 +0200 Matthias Klose wrote: > Package: src:libcommons-lang3-java > Version: 3.5-1 > Severity: important > Tags: patch sid buster > > Please either apply the following patches for 10 and 11, or update to the > upstream 3.6 release, and only apply the

Bug#873227: Please upgrade to 4.1: Java 9 support

2018-03-21 Thread Tiago Daitx
Please see the attached debdiff to enable some basic OpenJDK 9 support for gradle 3.4.1. The patches were downloaded from gradle upstream to prevent the dreadful "Could not determine java version from '9.0.x'". After applying the patches and rebuilding with OpenJDK 8, gradle can then build itself

Bug#875336: FTBFS with Java 9: _ as identifier

2018-03-21 Thread Tiago Daitx
On Tue, 20 Mar 2018 23:07:13 +0800 =?UTF-8?B?5q635ZWf6IGwIHwgS2FpLUNodW5nIFlhbg==?= wrote: > I just tried building it and Groovy was fine enough, but now Gradle > complains > > Theoretically, ALL Gradle packages FTBFS since the current version is too old > to play with