Bug#863803: ca-certificates-java: depends on obsolete openjdk-7-jre-headless

2017-05-31 Thread Emmanuel Bourg
Thank you for the report Andreas. The upgrade problem is odd because ca-certificates-java expects openjdk-7-jre-headless *or* java7-runtime-headless which is provided by openjdk-8-jre-headless. openjdk-8 isn't pulled automatically in this case? __ This is the maintainer address of Debian's Java

Bug#863803: ca-certificates-java: depends on obsolete openjdk-7-jre-headless

2017-05-31 Thread Andreas Beckmann
On 2017-05-31 14:16, Emmanuel Bourg wrote: > Thank you for the report Andreas. The upgrade problem is odd because > ca-certificates-java expects openjdk-7-jre-headless *or* > java7-runtime-headless which is provided by openjdk-8-jre-headless. > openjdk-8 isn't pulled automatically in this case?

Bug#863803: ca-certificates-java: depends on obsolete openjdk-7-jre-headless

2017-05-31 Thread Andreas Beckmann
Package: ca-certificates-java Version: 20161107 Severity: serious User: debian...@lists.debian.org Usertags: piuparts Hi, during a test with piuparts I noticed upgrade problems from jessie to stretch. apt tries to keep openjdk-7-jre-headless from jessie installed to satisfy the dependency in