Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-24 Thread Adrian Bunk
On Tue, Oct 24, 2017 at 05:50:05PM -0400, Jeremy Bicha wrote: > On Tue, Oct 24, 2017 at 5:34 PM, Adrian Bunk wrote: > > Any fix for swt-gtk should also include fixing the other RC bug #879170, > > and that would keep webkitgtk in buster - removing webkitgtk from buster > >

Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-24 Thread Jeremy Bicha
On Tue, Oct 24, 2017 at 5:34 PM, Adrian Bunk wrote: > Any fix for swt-gtk should also include fixing the other RC bug #879170, > and that would keep webkitgtk in buster - removing webkitgtk from buster > without also removing libswt-webkit-gtk-3-jni is simply wrong. > > An actual

Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-24 Thread Adrian Bunk
On Tue, Oct 24, 2017 at 03:26:06PM -0400, Jeremy Bicha wrote: > Control: tags -1 pending > > I am uploading a NMU now that is numbered as swt-gtk 3.8.2-4.1 to drop > the unnecessary build-depends since this is the last thing keeping > webkitgtk in Buster. I am uploading to DELAYED/2. Please let

Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-24 Thread Jeremy Bicha
Control: tags -1 pending I am uploading a NMU now that is numbered as swt-gtk 3.8.2-4.1 to drop the unnecessary build-depends since this is the last thing keeping webkitgtk in Buster. I am uploading to DELAYED/2. Please let me know if I should delay this fix any further. git patch attached.

Processed: Re: Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-24 Thread Debian Bug Tracking System
Processing control commands: > tags -1 pending Bug #871964 [src:swt-gtk] swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated Added tag(s) pending. -- 871964: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=871964 Debian Bug Tracking System Contact ow...@bugs.debian.org with

Processed: Re: Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-20 Thread Debian Bug Tracking System
Processing control commands: > tags 879170 - buster sid Bug #879170 [src:swt-gtk] libswt-webkit-gtk-3-jni: Needs libwebkitgtk-1.0-0 dep Removed tag(s) buster and sid. > clone 879170 -2 Bug #879170 [src:swt-gtk] libswt-webkit-gtk-3-jni: Needs libwebkitgtk-1.0-0 dep Bug 879170 cloned as bug 879228

Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-20 Thread Adrian Bunk
Control: tags 879170 - buster sid Control: clone 879170 -2 Control: reassign 879170 libswt-webkit-gtk-3-jni Control: reassign -2 libswt-webkit-gtk-4-jni Control: retitle -2 libswt-webkit-gtk-4-jni: Missing webkit dependency On Thu, Oct 19, 2017 at 08:22:26PM -0400, Jeremy Bicha wrote: >... > On

Processed: Re: Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-19 Thread Debian Bug Tracking System
Processing control commands: > clone -1 -2 Bug #871964 [src:swt-gtk] swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated Bug 871964 cloned as bug 879170 > retitle -2 libswt-webkit-gtk-3-jni: Missing dependency on Bug #879170 [src:swt-gtk] swt-gtk: Build-depends on libwebkitg

Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-19 Thread Jeremy Bicha
Control: clone -1 -2 Control: retitle -2 libswt-webkit-gtk-3-jni: Missing dependency on libwebkitgtk-1.0-0 Control: reassign -2 libswt-webkit-gtk-3-jni Control: tags -2 +stretch On Tue, Oct 17, 2017 at 5:12 PM, Adrian Bunk wrote: > On Sat, Aug 12, 2017 at 11:43:58PM -0400,

Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-10-17 Thread Adrian Bunk
On Sat, Aug 12, 2017 at 11:43:58PM -0400, Jeremy Bicha wrote: >... > The package does build successfully without the libwebkitgtk-dev > build-dependency. But the resulting library will still dynamically load it. > It feels to me like the libswt-webkit-gtk-3-jni was already broken > since it

Bug#871964: swt-gtk: Build-depends on libwebkitgtk-dev which is deprecated

2017-08-12 Thread Jeremy Bicha
Source: swt-gtk Severity: serious Tags: sid buster User: pkg-webkit-maintain...@lists.alioth.debian.org Usertags: oldlibs libwebkitgtk-1.0-0 webkit1 Hi, swt-gtk Build-Depends on libwebkitgtk-dev, which is deprecated in favor of libwebkit2gtk-4.0-dev (provided in Debian by webkit2gtk). Please