[Pkg-javascript-devel] node-npm-package-arg 6.0.0-2 MIGRATED to testing

2018-09-18 Thread Debian testing watch
FYI: The status of the node-npm-package-arg source package in Debian's testing distribution has changed. Previous version: (not in testing) Current version: 6.0.0-2 -- This email is automatically generated once a day. As the installation of new packages into testing happens multiple times

[Pkg-javascript-devel] Bug#909151: 'Uncaught TypeError: nextTick is not a function' with node-process-nextick-args 2.0.0

2018-09-18 Thread Mauricio Oliveira
Package: node-cloneable-readable Version: 1.0.0-1 Tags: patch node-cloneable-readable 1.0.0-1 needs an update for the newer node-process-nextick-args 2.0.0, which is now present in Debian sid and Ubuntu Cosmic. This can be verified in node-gulp's autotests: $ sudo apt-get build-dep node-gulp $

Re: [Pkg-javascript-devel] Draft to embed more than one Node module in a Debian package

2018-09-18 Thread Xavier
Le 18/09/2018 à 21:08, Moritz Mühlenhoff a écrit : > On Thu, Sep 13, 2018 at 11:59:20AM +0200, Xavier wrote: >> Ref: >> >> Hi all, >> >> Ftpmasters want to reduce node packages in NEW queue [1]. Extract: >> >> ... >> >> After a long discussion in JS team, I built a Wiki draft [2] and I would >>

Re: [Pkg-javascript-devel] Draft to embed more than one Node module in a Debian package

2018-09-18 Thread Xavier
Le 14/09/2018 à 14:09, Yves-Alexis Perez a écrit : > On Thu, 2018-09-13 at 11:59 +0200, Xavier wrote: >> After a long discussion in JS team, I built a Wiki draft [2] and I would >> like to have an opinion of Security Team before continuing in this way. > > Hi Xavier, > > could you elaborate on

[Pkg-javascript-devel] node-forever-agent_0.6.1-1_source.changes ACCEPTED into unstable

2018-09-18 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Tue, 18 Sep 2018 20:54:49 +0530 Source: node-forever-agent Binary: node-forever-agent Architecture: source Version: 0.6.1-1 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers Changed-By:

[Pkg-javascript-devel] Bug#847091: marked as done (update node-extend to latest upstream release)

2018-09-18 Thread Debian Bug Tracking System
Your message dated Tue, 18 Sep 2018 15:34:30 + with message-id and subject line Bug#847091: fixed in node-extend 3.0.2-1 has caused the Debian Bug report #847091, regarding update node-extend to latest upstream release to be marked as done. This means that you claim that the problem has been

[Pkg-javascript-devel] Bug#831568: marked as done (node-extend: A new upstream version is available: 3.0.0)

2018-09-18 Thread Debian Bug Tracking System
Your message dated Tue, 18 Sep 2018 15:34:30 + with message-id and subject line Bug#831568: fixed in node-extend 3.0.2-1 has caused the Debian Bug report #831568, regarding node-extend: A new upstream version is available: 3.0.0 to be marked as done. This means that you claim that the

[Pkg-javascript-devel] Processing of node-forever-agent_0.6.1-1_source.changes

2018-09-18 Thread Debian FTP Masters
node-forever-agent_0.6.1-1_source.changes uploaded successfully to localhost along with the files: node-forever-agent_0.6.1-1.dsc node-forever-agent_0.6.1.orig.tar.gz node-forever-agent_0.6.1-1.debian.tar.xz node-forever-agent_0.6.1-1_source.buildinfo Greetings, Your Debian queue

[Pkg-javascript-devel] node-extend_3.0.2-1_source.changes ACCEPTED into unstable

2018-09-18 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Tue, 18 Sep 2018 20:03:26 +0530 Source: node-extend Binary: node-extend Architecture: source Version: 3.0.2-1 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers Changed-By: Pirate

[Pkg-javascript-devel] Processing of node-extend_3.0.2-1_source.changes

2018-09-18 Thread Debian FTP Masters
node-extend_3.0.2-1_source.changes uploaded successfully to localhost along with the files: node-extend_3.0.2-1.dsc node-extend_3.0.2.orig.tar.gz node-extend_3.0.2-1.debian.tar.xz node-extend_3.0.2-1_source.buildinfo Greetings, Your Debian queue daemon (running on host

[Pkg-javascript-devel] node-combined-stream_1.0.6-1_source.changes ACCEPTED into unstable

2018-09-18 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Tue, 18 Sep 2018 19:00:27 +0530 Source: node-combined-stream Binary: node-combined-stream Architecture: source Version: 1.0.6-1 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

[Pkg-javascript-devel] Bug#909101: npm2deb create fails with Error downloading package %s@s\n" % (self.name, self.version)

2018-09-18 Thread Pirate Praveen
package: npm2deb version: 0.2.8-1 severity: grave justification: fails to perform its core function of creating debs npm2deb create @ava/write-file-atomic Traceback (most recent call last): File "/usr/bin/npm2deb", line 7, in sys.exit(main(sys.argv)) File

[Pkg-javascript-devel] Processing of node-combined-stream_1.0.6-1_source.changes

2018-09-18 Thread Debian FTP Masters
node-combined-stream_1.0.6-1_source.changes uploaded successfully to localhost along with the files: node-combined-stream_1.0.6-1.dsc node-combined-stream_1.0.6.orig.tar.gz node-combined-stream_1.0.6-1.debian.tar.xz node-combined-stream_1.0.6-1_source.buildinfo Greetings, Your

Re: [Pkg-javascript-devel] Update package node-uuid? Move it to salsa? (see #895625)

2018-09-18 Thread W. Martin Borgert
Quoting Jonas Smedegaard : All ok and appreciated. Thanks! If you choose to refactor the packaging (e.g. abandon cdbs) then please remove me as uploader. I plan to have as few changes as possible. Cheers -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net

[Pkg-javascript-devel] Bug#844072: also required for yarnpkg

2018-09-18 Thread Jonas Smedegaard
Quoting Pirate Praveen (2018-09-18 12:49:16) > On Wed, 25 Apr 2018 15:34:25 +0200 Paolo Greppi > wrote: > > I am OK with moving the repo from collab-maint to salsa and trying a team > > upload. > > Unless the previous uploaders want to take action. > > I'm planning to update request now. I have

Re: [Pkg-javascript-devel] Update package node-uuid? Move it to salsa? (see #895625)

2018-09-18 Thread Jonas Smedegaard
Hi Martin, Quoting W. Martin Borgert (2018-09-17 23:27:36) > I can't find node-uuid on salsa, and collab-maint is dead. > > Therefore: > > - Is it OK, if I just create the git repo in the js-team space >using the versions 1.4.0-1 (oldstable, stable) and 1.4.7-5 >(testing, unstable)? >

[Pkg-javascript-devel] node-aws4_1.8.0-1_source.changes ACCEPTED into unstable

2018-09-18 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Tue, 18 Sep 2018 18:15:20 +0530 Source: node-aws4 Binary: node-aws4 Architecture: source Version: 1.8.0-1 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers Changed-By: Pirate Praveen

[Pkg-javascript-devel] Processing of node-aws4_1.8.0-1_source.changes

2018-09-18 Thread Debian FTP Masters
node-aws4_1.8.0-1_source.changes uploaded successfully to localhost along with the files: node-aws4_1.8.0-1.dsc node-aws4_1.8.0.orig.tar.gz node-aws4_1.8.0-1.debian.tar.xz node-aws4_1.8.0-1_source.buildinfo Greetings, Your Debian queue daemon (running on host usper.debian.org)

[Pkg-javascript-devel] Bug#844072: also required for yarnpkg

2018-09-18 Thread Pirate Praveen
On Wed, 25 Apr 2018 15:34:25 +0200 Paolo Greppi wrote: > I am OK with moving the repo from collab-maint to salsa and trying a team > upload. > Unless the previous uploaders want to take action. I'm planning to update request now. I have already moved the repo to salsa under js-team. I'm

[Pkg-javascript-devel] node-hosted-git-info_2.7.1-1~bpo9+1_amd64.changes ACCEPTED into stretch-backports

2018-09-18 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Tue, 18 Sep 2018 14:04:38 +0530 Source: node-hosted-git-info Binary: node-hosted-git-info Architecture: source all Version: 2.7.1-1~bpo9+1 Distribution: stretch-backports Urgency: medium Maintainer: Debian Javascript

[Pkg-javascript-devel] node-brace-expansion_1.1.8-1~bpo9+1_amd64.changes is NEW

2018-09-18 Thread Debian FTP Masters
binary:node-brace-expansion is NEW. binary:node-brace-expansion is NEW. source:node-brace-expansion is NEW. Your package has been put into the NEW queue, which requires manual action from the ftpteam to process. The upload was otherwise valid (it had a good OpenPGP signature and file hashes are

[Pkg-javascript-devel] node-osenv_0.1.5-1~bpo9+1_amd64.changes is NEW

2018-09-18 Thread Debian FTP Masters
binary:node-osenv is NEW. binary:node-osenv is NEW. source:node-osenv is NEW. Your package has been put into the NEW queue, which requires manual action from the ftpteam to process. The upload was otherwise valid (it had a good OpenPGP signature and file hashes are valid), so please be patient.

[Pkg-javascript-devel] Processing of node-osenv_0.1.5-1~bpo9+1_amd64.changes

2018-09-18 Thread Debian FTP Masters
node-osenv_0.1.5-1~bpo9+1_amd64.changes uploaded successfully to localhost along with the files: node-osenv_0.1.5-1~bpo9+1.dsc node-osenv_0.1.5.orig.tar.gz node-osenv_0.1.5-1~bpo9+1.debian.tar.xz node-osenv_0.1.5-1~bpo9+1_all.deb node-osenv_0.1.5-1~bpo9+1_amd64.buildinfo Greetings,

[Pkg-javascript-devel] Processing of node-hosted-git-info_2.7.1-1~bpo9+1_amd64.changes

2018-09-18 Thread Debian FTP Masters
node-hosted-git-info_2.7.1-1~bpo9+1_amd64.changes uploaded successfully to localhost along with the files: node-hosted-git-info_2.7.1-1~bpo9+1.dsc node-hosted-git-info_2.7.1.orig.tar.gz node-hosted-git-info_2.7.1-1~bpo9+1.debian.tar.xz node-hosted-git-info_2.7.1-1~bpo9+1_all.deb

[Pkg-javascript-devel] Processing of node-brace-expansion_1.1.8-1~bpo9+1_amd64.changes

2018-09-18 Thread Debian FTP Masters
node-brace-expansion_1.1.8-1~bpo9+1_amd64.changes uploaded successfully to localhost along with the files: node-brace-expansion_1.1.8-1~bpo9+1.dsc node-brace-expansion_1.1.8.orig.tar.gz node-brace-expansion_1.1.8-1~bpo9+1.debian.tar.xz node-brace-expansion_1.1.8-1~bpo9+1_all.deb

[Pkg-javascript-devel] node-cyclist_1.0.1-2~bpo9+1_amd64.changes is NEW

2018-09-18 Thread Debian FTP Masters
binary:node-cyclist is NEW. binary:node-cyclist is NEW. source:node-cyclist is NEW. Your package has been put into the NEW queue, which requires manual action from the ftpteam to process. The upload was otherwise valid (it had a good OpenPGP signature and file hashes are valid), so please be

[Pkg-javascript-devel] Processing of node-cyclist_1.0.1-2~bpo9+1_amd64.changes

2018-09-18 Thread Debian FTP Masters
node-cyclist_1.0.1-2~bpo9+1_amd64.changes uploaded successfully to localhost along with the files: node-cyclist_1.0.1-2~bpo9+1.dsc node-cyclist_1.0.1.orig.tar.gz node-cyclist_1.0.1-2~bpo9+1.debian.tar.xz node-cyclist_1.0.1-2~bpo9+1_all.deb node-cyclist_1.0.1-2~bpo9+1_amd64.buildinfo

Re: [Pkg-javascript-devel] Update package node-uuid? Move it to salsa? (see #895625)

2018-09-18 Thread W. Martin Borgert
On 2018-09-18 12:28, Pirate Praveen wrote: > You can import the old repo from alioth-archive.debian.net. Thanks! It's on salsa now. > I support this as node-uuid and uuid projects merged and uuid is the new name. OK, I'll work on that later. -- Pkg-javascript-devel mailing list

Re: [Pkg-javascript-devel] Update package node-uuid? Move it to salsa? (see #895625)

2018-09-18 Thread Pirate Praveen
On 2018, സെപ്റ്റംബർ 18 2:57:36 AM IST, "W. Martin Borgert" wrote: >Hi Jonas, hi team, > >I can't find node-uuid on salsa, and collab-maint is dead. > >Therefore: > > - Is it OK, if I just create the git repo in the js-team space > using the versions 1.4.0-1 (oldstable, stable) and 1.4.7-5 >