Re: [Pkg-javascript-devel] Packages ready to review

2018-05-07 Thread Xavier
Updated list of packages to review: - node-mongodb - node-mongodb-core - node-require-optional - bson.js - node-nodedbi - node-file-cache-simple - node-fs-jetpack - node-inireader - node-q - node-syslog-client Regards, Xavier -- Pkg-javascript-devel mailing list Pkg

Re: [Pkg-javascript-devel] Packages ready to review

2018-05-09 Thread Xavier
Le 08/05/2018 à 10:55, Pirate Praveen a écrit : > On തി, മേയ് 7, 2018 at 8:10 വൈകു, Xavier <x.guim...@free.fr> wrote: >> Updated list of packages to review: - node-mongodb - node-mongodb-core >> - node-require-optional > > Try to enable tests. > See https://wik

[Pkg-javascript-devel] New packages to review

2018-04-30 Thread Xavier
Hi all, I've packaged these libs: - fs-jetpack.js, - file-cache-simple.js, - inireader.js, - node-bufferlist, - node-fastcgi-stream, - node-fastcgi - node-nodedbi. @kapouer: could you review them ? Best regards, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth

[Pkg-javascript-devel] Packages ready to review

2018-05-01 Thread Xavier
regards, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Packages ready to review

2018-05-02 Thread Xavier
Le 02/05/2018 à 08:07, Xavier a écrit : > Le 02/05/2018 à 07:18, Pirate Praveen a écrit : >> >> >> On ബു, മേയ് 2, 2018 at 10:44 രാവിലെ, Xavier <x.guim...@free.fr> wrote: >>> Hi all, these packages are ready for review (with dependencies): - >>> node-fa

Re: [Pkg-javascript-devel] Packages ready to review

2018-05-02 Thread Xavier
Le 02/05/2018 à 13:22, Pirate Praveen a écrit : > On ബുധന്‍ 02 മേയ് 2018 02:21 വൈകു, Xavier wrote: >> Done for node-fs-jetpack, node-file-cache-simple and node-inireader. >> List is now: >> - node-fastcgi >>- node-fastcgi-stream >>- node-bufferlist >

Re: [Pkg-javascript-devel] node packages in NEW

2018-09-05 Thread Xavier
CodeCopies We could also have a different policy for: - dependency of a end-user software - development libraries not yet used by any end-user software in main In the first case, could follow normal process, and your proposition could be applied for the second Cheers, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] node packages in NEW

2018-09-05 Thread Xavier
Le 05/09/2018 à 22:58, Xavier a écrit : > Le 05/09/2018 à 22:45, Thorsten Alteholz a écrit : >> Hi everybody, >> >> as you already know, there is a big number of node packages waiting in >> NEW. Does Debian really need all those packages? >> >> node packages

Re: [Pkg-javascript-devel] node packages in NEW

2018-09-07 Thread Xavier
s maybe we could get something like: > mainpackage+embded-nameembded1-version+embded-namembdedversion2-version+version > ? > > Bastien Hello, I've written a little draft: https://wiki.debian.org/Javascript/GroupedSourcePackageProxy Cheers, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] node packages in NEW

2018-09-08 Thread Xavier
Le 07/09/2018 à 16:36, Xavier a écrit : > Le 07/09/2018 à 13:38, Bastien ROUCARIES a écrit : >> On Thu, Sep 6, 2018 at 9:45 PM Thorsten Alteholz wrote: >>> >>> Hi Bastien, >>> >>> On Wed, 5 Sep 2018, Bastien ROUCARIES wrote: >>>>> - pu

[Pkg-javascript-devel] node packages in NEW

2018-09-06 Thread Xavier
eposted with my debian address) Hello, Thanks, I've updated this wiki page with my proposed packages: - 8 to reject/embed - 3 to keep - 2 to discuss Cheers, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] node packages in NEW

2018-09-06 Thread Xavier
e could perhaps build a "proxy" like https://qa.debian.org/cgi-bin/fakeupstream.cgi which could populate `node_modules/` directory. Example of such debian/watch: version=3 opts="dversionmangle=s/\+embed\d*$//,repacksuffix=+embed" \ https://qa.debian.org/cgi-bin/embednpmjs.cgi?upstream=npmjs/package=npmjs/dependency1,npmjs/dependency2 \ .*=package-(\d.*)\.(?:tgz|tar\.(?:gz|bz2|xz)) This CGI could add node_modules/dependency1 and node_modules/dependency2 in upstream archive. Note that something may be found to verify gpg signatures if any. Cheers, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] node packages in NEW

2018-09-09 Thread Xavier
Le 09/09/2018 à 23:36, Bastien ROUCARIES a écrit : > On Sat, Sep 8, 2018 at 6:17 PM Xavier wrote: >> >> Le 07/09/2018 à 16:36, Xavier a écrit : >>> Le 07/09/2018 à 13:38, Bastien ROUCARIES a écrit : >>>> On Thu, Sep 6, 2018 at 9:45 PM Thorsten Alteholz

Re: [Pkg-javascript-devel] node packages in NEW

2018-09-10 Thread Xavier
Le 10/09/2018 à 07:59, Bastien ROUCARIES a écrit : > On Mon, Sep 10, 2018 at 7:33 AM Xavier wrote: >> >> Le 09/09/2018 à 23:36, Bastien ROUCARIES a écrit : >>> On Sat, Sep 8, 2018 at 6:17 PM Xavier wrote: >>>> >>>> Le 07/09/2018 à 16:36, Xavie

Re: [Pkg-javascript-devel] node packages in NEW

2018-09-10 Thread Xavier
Le 10/09/2018 à 17:09, Xavier a écrit : > Le 10/09/2018 à 07:59, Bastien ROUCARIES a écrit : >> On Mon, Sep 10, 2018 at 7:33 AM Xavier wrote: >>> >>> Le 09/09/2018 à 23:36, Bastien ROUCARIES a écrit : >>>> On Sat, Sep 8, 2018 at 6:17 PM Xavier wrote: &g

[Pkg-javascript-devel] GroupSourcesTutorial page to review

2018-09-10 Thread Xavier
Dear fellow maintainers, QA team accepted my changes, so now fakeupstream.cgi is able to handle npmjs multiple sources. I've written a draft here: https://wiki.debian.org/Javascript/GroupSourcesTutorial Please review it. Many thanks! Xavier -- Pkg-javascript-devel mailing list Pkg-javascript

[Pkg-javascript-devel] node-mongodb embedded modules

2018-09-11 Thread Xavier
Le 10/09/2018 à 23:34, Xavier a écrit : > Dear fellow maintainers, > > QA team accepted my changes, so now fakeupstream.cgi is able to handle > npmjs multiple sources. I've written a draft here: > https://wiki.debian.org/Javascript/GroupSourcesTutorial > > Please review

[Pkg-javascript-devel] Packaging of node-lemonldap-ng-handler

2018-04-23 Thread Xavier
file-cache-simple inireader js-md5 node-dbi node-fastcgi). Would you like to accept me in pkg-javascript team to do this or do you prefer creating RFPs ? Regards, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin

[Pkg-javascript-devel] Packaging of node-lemonldap-ng-handler

2018-04-24 Thread Xavier
file-cache-simple inireader js-md5 node-dbi node-fastcgi). Would you like to accept me in pkg-javascript team to do this or do you prefer creating RFPs ? Regards, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin

Re: [Pkg-javascript-devel] Packaging of node-lemonldap-ng-handler

2018-04-24 Thread Xavier
Done, thanks ! Le 24/04/2018 à 10:13, Jérémy Lal a écrit : > Sure, you just have to "request access" from there: > https://salsa.debian.org/js-team > > Cheers, > Jérémy > > > > 2018-04-23 18:54 GMT+02:00 Xavier <xavier.guim...@polytechnique.org &g

Re: [Pkg-javascript-devel] acorn status

2018-10-22 Thread Xavier
Le 22/10/2018 à 13:52, Bastien ROUCARIES a écrit : > Hi, > > I have grouped some small package for acorn, see salsa > > But i could not progress due to dynamic-import failling test > > Do you have idea ? > > Bastien There is a bug with gbp. This works: - launch uscan - use gbp import-orig

Re: [Pkg-javascript-devel] GroupSourcesTutorial page to review

2018-10-22 Thread Xavier
Le 22/10/2018 à 12:52, Bastien ROUCARIES a écrit : > On Mon, Oct 22, 2018 at 12:34 PM Xavier wrote: >> >> Le 22/10/2018 à 11:23, Bastien ROUCARIES a écrit : >>> I really need it for next ckeditor (40 small packages) and acorn. >>> >>> For uscan I do n

Re: [Pkg-javascript-devel] GroupSourcesTutorial page to review

2018-10-22 Thread Xavier
0.0+~23.4.65 version (sum) will be more efficient for 40 packages. It guaranties that upstream updates will be detected > Bastien > On Sat, Oct 20, 2018 at 5:18 PM Xavier wrote: >> >> Le 20/10/2018 à 16:47, Bastien ROUCARIES a écrit : >>> On Thu, Sep 27, 2018

Re: [Pkg-javascript-devel] acorn status

2018-10-22 Thread Xavier
Le 22/10/2018 à 15:23, Bastien ROUCARIES a écrit : > On Mon, Oct 22, 2018 at 1:55 PM Xavier wrote: >> >> Le 22/10/2018 à 13:52, Bastien ROUCARIES a écrit : >>> Hi, >>> >>> I have grouped some small package for acorn, see salsa >>> >>>

Re: [Pkg-javascript-devel] acorn status

2018-10-22 Thread Xavier
Le 22/10/2018 à 21:21, Bastien ROUCARIES a écrit : > Ok, thanks. Last bug fixed, you missed a filenamemangle. Now uscan downloads the 3 components + main package > The main bug is why test fail > On Mon, Oct 22, 2018 at 9:08 PM Xavier wrote: >> >> Le 22/10/2018 à 15:

Re: [Pkg-javascript-devel] GroupSourcesTutorial page to review

2018-10-20 Thread Xavier
Le 20/10/2018 à 16:47, Bastien ROUCARIES a écrit : > On Thu, Sep 27, 2018 at 3:29 PM Bastien ROUCARIES > wrote: >> >> On Mon, Sep 24, 2018 at 10:03 AM Xavier wrote: >>> >>> Le 13/09/2018 à 11:16, Xavier a écrit : >>>> Le 11/09/2018 à 19:48, Pirat

Re: [Pkg-javascript-devel] GroupSourcesTutorial page to review

2018-10-20 Thread Xavier
Le 20/10/2018 à 16:47, Bastien ROUCARIES a écrit : > On Thu, Sep 27, 2018 at 3:29 PM Bastien ROUCARIES > wrote: >> >> On Mon, Sep 24, 2018 at 10:03 AM Xavier wrote: >>> >>> Le 13/09/2018 à 11:16, Xavier a écrit : >>>> Le 11/09/2018 à 19:48, Pirat

Re: [Pkg-javascript-devel] RFC: javascript bundle of small packages

2018-10-30 Thread Xavier
Le 30/10/2018 à 10:51, Bastien ROUCARIES a écrit : > Hi, > > I have just pushed a new version of acorn and associated small package > to salsa (https://salsa.debian.org/js-team/acorn) > > It group small package using dpkg module and for now fakeupstream redirector. > > We plan to modify uscan

Re: [Pkg-javascript-devel] RFC: javascript bundle of small packages

2018-10-30 Thread Xavier
Le 30/10/2018 à 11:14, Xavier a écrit : > Le 30/10/2018 à 10:51, Bastien ROUCARIES a écrit : >> Hi, >> >> I have just pushed a new version of acorn and associated small package >> to salsa (https://salsa.debian.org/js-team/acorn) >> >> It group smal

Re: [Pkg-javascript-devel] GroupSourcesTutorial page to review

2018-09-24 Thread Xavier
Le 13/09/2018 à 11:16, Xavier a écrit : > Le 11/09/2018 à 19:48, Pirate Praveen a écrit : >> >> On 9/11/18 10:45 PM, Jérémy Lal wrote: >>> Hi Xavier, >>> >>> The example in Provides section should be written >>> Provides: node-ta, node-

[Pkg-javascript-devel] Update policy for Buster

2018-12-30 Thread Xavier
ot; policy. Some ways: - declare JS team as "Low Threshold Nmu" [1] - organize some online hacking parties to release "team uploads" regardless uploader name Cheers, Xavier [1] https://wiki.debian.org/LowThresholdNmu -- Pkg-javascript-devel mailing list Pkg-javascript

Re: [Pkg-javascript-devel] Bug#917750: node-redis: FTBFS: tests failed

2018-12-30 Thread Xavier
Hello, node-redis seems also out-of-date. Would you accept co-maintenance on this package ? Cheers, Xavier Le 29/12/2018 à 23:40, Lucas Nussbaum a écrit : > Source: node-redis > Version: 0.12.1-2 > Severity: serious > Justification: FTBFS on amd64 > Tags: buster sid > Userta

Re: [Pkg-javascript-devel] RFS: node-markdown-it-html5-embed

2019-01-16 Thread Xavier
arkdown-it doesn't exist for now (even if ruby-team pushed a libjs-markdown-it package [source: ruby-rails-assets-markdown-it] but without node files). Cheers, Xavier @Utkarsh: take a look at my changes -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

[Pkg-javascript-devel] Bug#918627: node-cacache FTBFS with nodejs 10.15.0

2019-01-16 Thread Xavier
Update to 11.3.2 fixes partially failing build. Last problem is in node-readable-stream -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

[Pkg-javascript-devel] Bug#918670: node-duplexer3: incompatible with Node >=10 stream

2019-01-18 Thread Xavier
Control: reopen -1 Control: severity -1 important Control: tags -1 - ftbfs Control: retitle -1 node-duplexer3: incompatible with Node >=10 stream Even using `npm install` files, the failing test shows that duplexer3 isn't compatible with Node.js stream. Tagged as "important" instead of "serious"

Re: [Pkg-javascript-devel] RFS: RainLoop Webmail and dependencies

2019-01-19 Thread Xavier
Le 19/01/2019 à 13:51, Xavier a écrit : > Le 19/01/2019 à 13:34, Xavier a écrit : >> Le 19/01/2019 à 11:34, Daniel Ring a écrit : >>> Hello Debian JS Maintainers, >>> >>> I've updated Rainloop and all of its dependencies to the latest versions >>>

Re: [Pkg-javascript-devel] RFS: RainLoop Webmail and dependencies

2019-01-19 Thread Xavier
Le 19/01/2019 à 14:18, Xavier a écrit : > Le 19/01/2019 à 13:51, Xavier a écrit : >> Le 19/01/2019 à 13:34, Xavier a écrit : >>> Le 19/01/2019 à 11:34, Daniel Ring a écrit : >>>> Hello Debian JS Maintainers, >>>> >>>> I've updated Rainl

[Pkg-javascript-devel] Bug#751605: node-amdefine: Embedded copy of "RequireJS text"

2019-01-15 Thread Xavier
Control: severity -1 minor Decrease severity since tests are not launched for now (missing dependencies). -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] RFS: node-markdown-it-html5-embed

2019-01-15 Thread Xavier
Le 15/01/2019 à 22:06, Utkarsh Gupta a écrit : > > > On Wed, Jan 16, 2019 at 2:34 AM Utkarsh Gupta > mailto:guptautkarsh2...@gmail.com>> wrote: > > Hi, > > The package node-markdown-it-html5-embed_1.0.0+ds-1_amd64.changes > was rejected because of the issues in the license block. >

Re: [Pkg-javascript-devel] RFS: node-markdown-it-html5-embed

2019-01-15 Thread Xavier
Le 15/01/2019 à 23:57, Utkarsh Gupta a écrit : > On Wed, Jan 16, 2019 at 3:37 AM Xavier <mailto:x.guim...@free.fr>> wrote: > > Le 15/01/2019 à 22:06, Utkarsh Gupta a écrit : > > > > > > On Wed, Jan 16, 2019 at 2:34 AM Utkarsh Gupta >

Re: [Pkg-javascript-devel] node-lemonldap-ng-handler_0.3.0-1_amd64.changes REJECTED

2019-01-21 Thread Xavier
Hello, yes reject it for now, I'll packaged it after buster release. Cheers, Xavier Le 21/01/2019 à 17:00, Thorsten Alteholz a écrit : > > Hi Xavier, > > some dependencies of this module are mentioned on the list of to be embedded > modules. > > Thorsten > >

[Pkg-javascript-devel] Bug#895316: Fixed ?

2019-01-22 Thread Xavier
Control: severity -1 important According to debci reports, this FTBFS seems fixed. I'm going to upload a new version since license is wrong (upstream has changed to ISC, not reported in debian/changelog) -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net

[Pkg-javascript-devel] Bug#897156: node-cache-base: FTBFS and Debci failure with node-is-extendable 1.0.1-1

2019-01-22 Thread Xavier
An update of node-union-value fixes the problem. Let's do it -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

[Pkg-javascript-devel] Bug#918404: node-temporary FTBFS with nodejs 10.15.0

2019-01-23 Thread Xavier
node-temporary seems orphaned upstream, looking at apt-cache depends, it seems that no package needs it, so I think it can be safely removed from testing. -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net

[Pkg-javascript-devel] Fwd: [vesln/temporary] Tests fail (#28)

2019-01-23 Thread Xavier
node-temporary in memoriam... Anyway, keeping this package in buster seems not a security problem: very simple wrapper around node.fs() Message transféré Subject : Re: [vesln/temporary] Tests fail (#28) Date : Wed, 23 Jan 2019 08:57:32 -0800 From : Will To :

[Pkg-javascript-devel] Proposed fix

2019-01-23 Thread Xavier
Hi all, to fix missing popper.js, I propose to embed it for now in twitter-bootstrap4 (done in salsa repo but not pushed). After buster release, we could split it in a separate package. Please review this. Cheers, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth

Re: [Pkg-javascript-devel] Bug#920188: Proposed fix

2019-01-23 Thread Xavier
Le 23/01/2019 à 21:55, Xavier a écrit : > Hi all, > > to fix missing popper.js, I propose to embed it for now in > twitter-bootstrap4 (done in salsa repo but not pushed). After buster > release, we could split it in a separate package. > > Please review this. Reverted.

Re: [Pkg-javascript-devel] RFS: node-markdown-it-html5-embed

2019-01-16 Thread Xavier
Le 16/01/2019 à 06:54, Xavier a écrit : > Le 15/01/2019 à 23:57, Utkarsh Gupta a écrit : >> On Wed, Jan 16, 2019 at 3:37 AM Xavier > <mailto:x.guim...@free.fr>> wrote: >> >> Le 15/01/2019 à 22:06, Utkarsh Gupta a écrit : >> > >> > >

Re: [Pkg-javascript-devel] RFS: RainLoop Webmail and dependencies

2019-01-22 Thread Xavier
Hello, wait new unstable index, bug is fixed Le 22/01/2019 à 16:14, Christoph Berg a écrit : > Re: Daniel Ring 2019-01-19 <71c60884-6b98-e568-02c3-abddcf200...@wolfishly.me> >> I've updated Rainloop and all of its dependencies to the latest versions >> that don't require new packages. All of

[Pkg-javascript-devel] Bug#918404: Bug#918404: node-temporary FTBFS with nodejs 10.15.0

2019-01-23 Thread Xavier
Le 23/01/2019 à 09:33, Xavier a écrit : > node-temporary seems orphaned upstream, looking at apt-cache depends, it > seems that no package needs it, so I think it can be safely removed from > testing. However I fixed this package. -- Pkg-javascript-devel mailing list Pkg-javascript-dev

Re: [Pkg-javascript-devel] Plan for bootstrap 4

2018-12-01 Thread Xavier
4? > > Thanks > Praveen Hi all, did someone package it ? Cheers, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] Plan for bootstrap 4

2018-12-01 Thread Xavier
Le 01/12/2018 à 12:14, Jonas Smedegaard a écrit : > Quoting Xavier (2018-12-01 09:24:54) >> Le 21/09/2018 à 10:16, Pirate Praveen a écrit : >>> I need bootstrap 4 for gitlab (though only its node counterpart). >>> I'm thinking of creating a new source package node-

Re: [Pkg-javascript-devel] components without major risks

2018-11-27 Thread Xavier
Le 27/11/2018 à 15:24, Jérémy Lal a écrit : > > > Le mar. 27 nov. 2018 à 15:22, Xavier <mailto:y...@debian.org>> a écrit : > > Le 27/11/2018 à 15:03, Jonas Smedegaard a écrit : > > Quoting Xavier (2018-11-27 14:00:42) > >> Le 27/11

Re: [Pkg-javascript-devel] components without major risks

2018-11-27 Thread Xavier
Le 27/11/2018 à 15:48, Bastien ROUCARIES a écrit : > On Tue, Nov 27, 2018 at 3:45 PM Xavier wrote: >> >> Le 27/11/2018 à 15:33, Jonas Smedegaard a écrit : >>> Quoting Xavier (2018-11-27 15:22:10) >>>> Le 27/11/2018 à 15:03, Jonas Smedegaard a écrit : >&

Re: [Pkg-javascript-devel] script to generate debian/watch for embedding nodejs modules

2018-11-26 Thread Xavier
Le 26/11/2018 à 15:55, Paolo Greppi a écrit : > I am thinking of using this approach: > https://wiki.debian.org/Javascript/GroupSourcesTutorial > to embed the modules required for yarkpkg. > > I have created a Python script to automatically generate required the > debian/watch file: >

Re: [Pkg-javascript-devel] script to generate debian/watch for embedding nodejs modules

2018-11-26 Thread Xavier
Le 26/11/2018 à 16:29, Xavier a écrit : > Le 26/11/2018 à 15:55, Paolo Greppi a écrit : >> I am thinking of using this approach: >> https://wiki.debian.org/Javascript/GroupSourcesTutorial >> to embed the modules required for yarkpkg. >> >> I have created a Python

Re: [Pkg-javascript-devel] script to generate debian/watch for embedding nodejs modules

2018-11-26 Thread Xavier
Xavier wrote: >> ... >> Looks acceptable IMO > > Policy update: > - components used only during build => not used in version >(except if they inject some code) > - components without major risks=> not used in version > - components that mus

[Pkg-javascript-devel] components without major risks

2018-11-27 Thread Xavier
Le 27/11/2018 à 11:55, Jonas Smedegaard a écrit : > Hi Xavier and Paolo, > > Please allow me to highlight this security-related detail: > > Quoting Xavier (2018-11-26 16:29:32) >> Embedding components without following them may be a lack of security. >> I th

[Pkg-javascript-devel] components without major risks

2018-11-27 Thread Xavier
Le 27/11/2018 à 13:47, Xavier a écrit : > Le 27/11/2018 à 11:55, Jonas Smedegaard a écrit : >> Hi Xavier and Paolo, >> >> Please allow me to highlight this security-related detail: >> >> Quoting Xavier (2018-11-26 16:29:32) >>> Embedding components withou

Re: [Pkg-javascript-devel] components without major risks

2018-11-27 Thread Xavier
Le 27/11/2018 à 11:55, Jonas Smedegaard a écrit : > Hi Xavier and Paolo, > > Please allow me to highlight this security-related detail: > > Quoting Xavier (2018-11-26 16:29:32) >> Embedding components without following them may be a lack of security. >> I th

Re: [Pkg-javascript-devel] components without major risks

2018-11-27 Thread Xavier
Le 27/11/2018 à 13:47, Xavier a écrit : > Le 27/11/2018 à 11:55, Jonas Smedegaard a écrit : >> Hi Xavier and Paolo, >> >> Please allow me to highlight this security-related detail: >> >> Quoting Xavier (2018-11-26 16:29:32) >>> Embedding components withou

Re: [Pkg-javascript-devel] components without major risks

2018-11-27 Thread Xavier
Le 27/11/2018 à 15:03, Jonas Smedegaard a écrit : > Quoting Xavier (2018-11-27 14:00:42) >> Le 27/11/2018 à 11:55, Jonas Smedegaard a écrit : >>> Hi Xavier and Paolo, >>> >>> Please allow me to highlight this security-related detail: >>> >>&g

Re: [Pkg-javascript-devel] components without major risks

2018-11-27 Thread Xavier
Le 27/11/2018 à 15:22, Xavier a écrit : > Le 27/11/2018 à 15:03, Jonas Smedegaard a écrit : >> Quoting Xavier (2018-11-27 14:00:42) >>> Le 27/11/2018 à 11:55, Jonas Smedegaard a écrit : >>>> Hi Xavier and Paolo, >>>> >>>> Please allow me to hig

Re: [Pkg-javascript-devel] script to generate debian/watch for embedding nodejs modules

2018-11-26 Thread Xavier
Le 26/11/2018 à 19:40, Jérémy Lal a écrit : > > > Le lun. 26 nov. 2018 à 17:29, Xavier <mailto:y...@debian.org>> a écrit : > > Xavier wrote: > >> ... > >> Looks acceptable IMO > > > > Policy update: > >

Re: [Pkg-javascript-devel] node-duplexer2 and 3 - possible to keep only one ?

2019-01-08 Thread Xavier
Le 08/01/2019 à 23:23, Jérémy Lal a écrit : > Hi, > > is there a reason to keep both  > node-duplexer2 > node-duplexer3 > packages ? > It seems it's feasible to keep only one, unless we miss a deeper issue ? > > Jérémy Only 1 difference: node-duplexer2 uses `readable-stream` while

[Pkg-javascript-devel] Bug#902508: node-send: FTBFS in buster/sid (TypeError: mime.lookup is not a function)

2019-01-10 Thread Xavier
Problem found: node-send depends on node-mime 1.6 while unstable has node-mime 2.3.1-1 (with breaking changes) Probably same issue for #902507 -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net

[Pkg-javascript-devel] Bug#902509: node-serve-static: FTBFS in buster/sid (TypeError: mime.lookup is not a function)

2019-01-10 Thread Xavier
Control: reassign -1 node-send Build error is in node-send (index.js line 693) -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

[Pkg-javascript-devel] Time for a RC bug ?

2019-01-10 Thread Xavier
[MR]: build fail on low performance machine (another too short timeout) Cheers, Xavier MR: https://salsa.debian.org/js-team/node-lru-cache/merge_requests/1 -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo

Re: [Pkg-javascript-devel] Bug#918935: node-browserify-lite FTBFS: Error: Cannot find module '../tools/exit'

2019-01-10 Thread Xavier
Le 10/01/2019 à 19:41, Xavier a écrit : >> ... >> That does actually look like a bug in the new uglifyfs. >> >> cu >> Adrian > > I tried to reproduce but have different errors related to debian/examples* : debian/control should require node-pend (>= 1.2.0)

Re: [Pkg-javascript-devel] Bug#918935: node-browserify-lite FTBFS: Error: Cannot find module '../tools/exit'

2019-01-10 Thread Xavier
Le 10/01/2019 à 19:34, Adrian Bunk a écrit : > Control: reassign -1 uglifyjs 3.4.9-2 > Control: retitle -1 uglifyjs: Error: Cannot find module '../tools/exit' > Control: affects -1 src:node-browserify-lite > > On Thu, Jan 10, 2019 at 08:04:46PM +0200, Adrian Bunk wrote: >> Source:

Re: [Pkg-javascript-devel] libjs-cryptojs: Please upgrade to 3.1.9

2018-12-28 Thread Xavier
Hello, do you want that we take maintenance of this package under JS-Team umbrella Cheers, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

Re: [Pkg-javascript-devel] mocha timeout

2019-01-11 Thread Xavier
Le 11/01/2019 à 10:19, Jérémy Lal a écrit : > > > Le ven. 11 janv. 2019 à 09:26, Xavier <mailto:y...@debian.org>> a écrit : > > Hi all, > > for some packages, default mocha timeout (2000 ms) is too short for > autopkgtest. I patched some package to

Re: [Pkg-javascript-devel] mocha timeout

2019-01-11 Thread Xavier
Le 11/01/2019 à 10:22, Xavier a écrit : > Le 11/01/2019 à 10:19, Jérémy Lal a écrit : >> >> >> Le ven. 11 janv. 2019 à 09:26, Xavier > <mailto:y...@debian.org>> a écrit : >> >> Hi all, >> >> for some packages, default mocha timeout

Re: [Pkg-javascript-devel] mocha timeout

2019-01-11 Thread Xavier
Same for mocha itself ! https://tests.reproducible-builds.org/debian/rbuild/unstable/amd64/node-mocha_4.1.0+ds3-1.rbuild.log.gz Le 11/01/2019 à 09:26, Xavier a écrit : > Hi all, > > for some packages, default mocha timeout (2000 ms) is too short for > autopkgtest. I patched

[Pkg-javascript-devel] mocha timeout

2019-01-11 Thread Xavier
Hi all, for some packages, default mocha timeout (2000 ms) is too short for autopkgtest. I patched some package to increase it but I think we could increase this timeout directly in mocha source to avoid these failures. Cheers, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel

Re: [Pkg-javascript-devel] node-livescript FTBFS with nodejs 10.15.0

2019-01-10 Thread Xavier
Control: tags -1 + moreinfo Hello, I'm unable to reproduce this bug and https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/node-livescript.html seems clean at least since 2019-01-07 Cheers, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth

Re: [Pkg-javascript-devel] node-duplexer2 and 3 - possible to keep only one ?

2019-01-09 Thread Xavier
Le 09/01/2019 à 08:02, Pirate Praveen a écrit : > > > On Wed, Jan 9, 2019 at 11:51 AM, Xavier wrote: >> Le 08/01/2019 à 23:23, Jérémy Lal a écrit : >> >> Hi, is there a reason to keep both  node-duplexer2 node-duplexer3 >> packages ? It seems it's fea

Re: [Pkg-javascript-devel] Request to join Javascript team

2019-01-14 Thread Xavier
y [3] To ask for review, you can add an issue to [4] with tag RFS or RFC. Don't hesitate to ask for help if necessary on this list. Cheers, Xavier [1] https://wiki.debian.org/Javascript/Policy [2] https://wiki.debian.org/Javascript/Nodejs [3] https://wiki.debian.org/Javascript/GroupSource

[Pkg-javascript-devel] Draft to embed more than one Node module in a Debian package

2018-09-13 Thread Xavier
[2] and I would like to have an opinion of Security Team before continuing in this way. Cheers, Xavier [1] https://alioth-lists.debian.net/pipermail/pkg-javascript-devel/2018-September/027849.html [2] https://wiki.debian.org/Javascript/GroupSourcesTutorial signature.asc Description: OpenP

Re: [Pkg-javascript-devel] GroupSourcesTutorial page to review

2018-09-13 Thread Xavier
Le 11/09/2018 à 19:48, Pirate Praveen a écrit : > > On 9/11/18 10:45 PM, Jérémy Lal wrote: >> Hi Xavier, >> >> The example in Provides section should be written >> Provides: node-ta, node-tb >> ? > > I think there should not be Provides as it implies s

Re: [Pkg-javascript-devel] node-mongodb-core_3.1.0-1_amd64.changes REJECTED

2018-09-16 Thread Xavier
Le 16/09/2018 à 23:00, Thorsten Alteholz a écrit : > > appears in REJECT-section of https://wiki.debian.org/Javascript/Nodejs/NEW Hello, thanks for our work, does this means that our embedding draft seems acceptable for ftpmasters ? Cheers, Xavier -- Pkg-javascript-devel mailing li

Re: [Pkg-javascript-devel] Draft to embed more than one Node module in a Debian package

2018-09-18 Thread Xavier
Le 14/09/2018 à 14:09, Yves-Alexis Perez a écrit : > On Thu, 2018-09-13 at 11:59 +0200, Xavier wrote: >> After a long discussion in JS team, I built a Wiki draft [2] and I would >> like to have an opinion of Security Team before continuing in this way. > > Hi Xavier, >

Re: [Pkg-javascript-devel] Draft to embed more than one Node module in a Debian package

2018-09-18 Thread Xavier
Le 18/09/2018 à 21:08, Moritz Mühlenhoff a écrit : > On Thu, Sep 13, 2018 at 11:59:20AM +0200, Xavier wrote: >> Ref: >> >> Hi all, >> >> Ftpmasters want to reduce node packages in NEW queue [1]. Extract: >> >> ... >> >> After a long di

Re: [Pkg-javascript-devel] GroupSourcesTutorial page to review

2018-09-12 Thread Xavier
Le 12/09/2018 à 11:48, Bastien ROUCARIES a écrit : > On Tue, Sep 11, 2018 at 7:16 PM Jérémy Lal wrote: >> >> Hi Xavier, >> >> The example in Provides section should be written >> Provides: node-ta, node-tb >> ? > > Provides MUST be versionned in orde

Re: [Pkg-javascript-devel] GroupSourcesTutorial page to review

2018-09-11 Thread Xavier
Le 11/09/2018 à 19:15, Jérémy Lal a écrit : > Hi Xavier, > > The example in Provides section should be written > Provides: node-ta, node-tb > ? Hi Jérémy, updated, thanks ! -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists

Re: [Pkg-javascript-devel] GroupSourcesTutorial page to review

2018-09-11 Thread Xavier
Le 11/09/2018 à 19:48, Pirate Praveen a écrit : > > On 9/11/18 10:45 PM, Jérémy Lal wrote: >> Hi Xavier, >> >> The example in Provides section should be written >> Provides: node-ta, node-tb >> ? > > I think there should not be Provides as it implies s

Re: [Pkg-javascript-devel] GroupSourcesTutorial page to review

2018-09-11 Thread Xavier
Le 11/09/2018 à 21:01, Xavier a écrit : > Le 11/09/2018 à 19:48, Pirate Praveen a écrit : >> >> On 9/11/18 10:45 PM, Jérémy Lal wrote: >>> Hi Xavier, >>> >>> The example in Provides section should be written >>> Provides: node-ta, node-

Re: [Pkg-javascript-devel] GroupSourcesTutorial page to review

2018-09-11 Thread Xavier
Le 11/09/2018 à 21:06, Xavier a écrit : > Le 11/09/2018 à 21:01, Xavier a écrit : >> Le 11/09/2018 à 19:48, Pirate Praveen a écrit : >>> >>> On 9/11/18 10:45 PM, Jérémy Lal wrote: >>>> Hi Xavier, >>>> >>>> The example in Pro

Re: [Pkg-javascript-devel] RFS: node-yarnpkg

2019-01-26 Thread Xavier
Le 26/01/2019 à 08:50, Paolo Greppi a écrit : > Il 25/01/19 09:18, Paolo Greppi ha scritto: >> Il 25/01/19 09:06, Xavier ha scritto: >>> Le 25/01/2019 à 09:04, Xavier a écrit : >>> >>> Install also docs in the right place: >>> I: yarnpkg: extra-lice

Re: [Pkg-javascript-devel] Testsuite proposal

2019-01-24 Thread Xavier
Le 25/01/2019 à 04:07, Pirate Praveen a écrit : > > > On 2019, ജനുവരി 24 7:46:32 PM IST, Xavier wrote: >> Hi all, >> >> I try to write a package that could be called by autodep8 to have a >> "Testsuite: pkg-js" instead of writing debian/tests/* file

[Pkg-javascript-devel] Bug#925517: Bug#925517: Non-NSA/Microsoft upstream repo, new version

2019-03-26 Thread Xavier
Le 26/03/2019 à 17:53, Jeffrey Cliff a écrit : > I don't use NSA/Microsoft github so I'll assume you mean to update the > readme in the repo I control, which I have added a note to.  Is there > anything in specific you are interested in my adding? > > On Tue, 26 Mar 2019 a

[Pkg-javascript-devel] Bug#925517: Bug#925517: Non-NSA/Microsoft upstream repo, new version

2019-03-26 Thread Xavier
Le 26/03/2019 à 19:04, Jeffrey Cliff a écrit : > 2.0.0 was the version when Microsoft captured Github.  That's the newest > one I have, but thankfully that's as new as is needed by the version of > eslint in RFP. > > I prefer to do my contributions anonymously.  I am not the author. > >>

[Pkg-javascript-devel] Bug#925517: Bug#925517: Non-NSA/Microsoft upstream repo, new version

2019-03-26 Thread Xavier
Le 26/03/2019 à 20:17, Jeffrey Cliff a écrit : > As maintainer, that's up to you, but I do not accept any project hosted > in the NSA/Microsoft walled garden as the legitimate upstream of > anything and I will continue to host 'progress', in particular, > somewhere, until a 2.0.0+ version is

Re: [Pkg-javascript-devel] Giuseppe Pereira Interesting to join js-team

2019-03-26 Thread Xavier
Hello, join us on https://salsa.debian.org/js-team and read our docs: * https://wiki.debian.org/Javascript * https://wiki.debian.org/Javascript/Tutorial Cheers, Xavier -- Pkg-javascript-devel mailing list Pkg-javascript-devel@alioth-lists.debian.net https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-javascript-devel

[Pkg-javascript-devel] node-yamljs updated

2019-03-30 Thread Xavier
Hello, I updated node-yamljs, please check my changes to see if all is OK and ready to push. Following our policy, source package should be renamed yamljs.js (provides node-yamljs and libjs-yamljs). Cheers, Xavier https://salsa.debian.org/js-team/node-yamljs -- Pkg-javascript-devel mailing

Re: [Pkg-javascript-devel] node-yamljs updated

2019-03-30 Thread Xavier
Le 30/03/2019 à 12:39, Xavier a écrit : > Hello, > > I updated node-yamljs, please check my changes to see if all is OK and > ready to push. > > Following our policy, source package should be renamed yamljs.js > (provides node-yamljs and libjs-yamljs). > >

Re: [Pkg-javascript-devel] Request for review: src:node-ansi-up

2019-04-01 Thread Xavier
update > * upstream tests pass Modified to use pkg-js-tools and so enable upstream test in autopkgtest > * debian/tests/require is successful Removed and replaced by pkg-js-tools/pkg-js-autopkgtest It looks good now for me Cheers, Xavier > What is not done: > > * I do no

[Pkg-javascript-devel] Bug#926616: Bug#926616: CVE-2018-3750: Prototype Pollution

2019-04-08 Thread Xavier
Control: tags -1 + security Le 08/04/2019 à 00:22, Jeff Cliff a écrit : > Package: node-deep-extend > Version: 0.4.1-1 > Severity: important > > Dear Maintainer, > > As per the ubuntu bug report: > > from https://snyk.io/vuln/npm:deep-extend:20180409 : > > deep-extend "all the listed modules

[Pkg-javascript-devel] Bug#926616: Fwd: Bug#926650 closed by Ivo De Decker (unblock node-deep-extend)

2019-04-08 Thread Xavier
node-deep-extend 0.4.1-2 is unblocked Message transféré Sujet : Bug#926650 closed by Ivo De Decker (unblock node-deep-extend) Date : Mon, 08 Apr 2019 14:36:04 + De : Debian Bug Tracking System Répondre à : 926...@bugs.debian.org Pour : Xavier Guimard

Re: [Pkg-javascript-devel] RC bugs

2019-02-18 Thread Xavier
Le 19/02/2019 à 07:40, Pirate Praveen a écrit : > > On Tue, Feb 19, 2019 at 2:50 AM, Xavier wrote: >> Le 18/02/2019 à 21:20, Xavier a écrit : >>>  Le 18/02/2019 à 20:46, Bastien ROUCARIES a écrit : >>>> >>>>  Le lun. 18 févr. 2019 à 19:17, Xa

  1   2   3   4   5   >