[Pkg-javascript-devel] Bug#846007: marked as done (node-grunt-contrib-concat: Incomplete debian/copyright)

2016-12-09 Thread Debian Bug Tracking System
Your message dated Sat, 10 Dec 2016 06:03:30 + with message-id and subject line Bug#846007: fixed in node-grunt-contrib-concat 1.0.1-2 has caused the Debian Bug report #846007, regarding node-grunt-contrib-concat: Incomplete debian/copyright to be marked

Re: [Pkg-javascript-devel] RFS: node-loose-envify 1.3.0

2016-12-09 Thread Pirate Praveen
On ശനി 10 ഡിസംബര്‍ 2016 11:55 രാവിലെ, Paolo Greppi wrote: > BTW Pirate, what do you mean with "If you get it working, may be add it > to a wiki page." ? Document steps to create a dfsg version in wiki,debian.org so we can just link to it when someone else asks the same question. signature.asc

Re: [Pkg-javascript-devel] RFS: node-tar-stream 1.5.2

2016-12-09 Thread Pirate Praveen
On ശനി 10 ഡിസംബര്‍ 2016 12:10 വൈകു, Paolo Greppi wrote: > node-bl has been updated so node-tar-stream should be OK now ! You should commit tarballs with this name node-tar-stream_1.5.2.orig.tar.gz (you committed node-tar-stream-1.5.2.tar.gz). I have fixed it and uploaded, please remember this

Re: [Pkg-javascript-devel] RFS: node-loose-envify 1.3.0

2016-12-09 Thread Paolo Greppi
On 05/12/2016 11:41, Pirate Praveen wrote: > On തിങ്കള്‍ 05 ഡിസംബര്‍ 2016 03:45 വൈകു, Paolo Greppi wrote: >> It does the trick because the lintian error is gone. > > But its bad for long term maintenance, any time that file changes, > you'll have to refresh the patch. >> I'd rather avoid dfsg

Re: [Pkg-javascript-devel] RFS: node-loose-envify 1.3.0

2016-12-09 Thread Paolo Greppi
On 05/12/2016 11:46, Pirate Praveen wrote: > On തിങ്കള്‍ 05 ഡിസംബര്‍ 2016 04:07 വൈകു, Jérémy Lal wrote: >> Add this to debian/watch params: >> repacksuffix=~dfsg > > I think +dfsg is better here, else any module depending on it has to add > a ~ at the end to its version. May be we make npm2deb do

[Pkg-javascript-devel] Bug#847643: node-uglify: help output does not usefully describe the command

2016-12-09 Thread Ben Finney
Package: node-uglify Version: 2.7.4-1 Severity: normal The ‘uglifyjs --help’ output is not helpful for learning to use the command: $ uglifyjs --help [object Object] Conventionally that should produce a usage message that tells the reader what the command does, and all the ways to

Re: [Pkg-javascript-devel] RFS: node-loose-envify 1.3.0

2016-12-09 Thread Pirate Praveen
On ശനി 10 ഡിസംബര്‍ 2016 11:56 രാവിലെ, Paolo Greppi wrote: > BTW2, can you elaborate on the difference between ~dfsg and +dfsg ? x.y~dfsg < x.y < x.y+dfsg So if you use ~dfsg for your package, when a dependency on this package is specified, it has to be >= x.y~ as opposed to commonly used >= x.y

[Pkg-javascript-devel] Processing of node-loose-envify_1.3.0+dfsg-1_amd64.changes

2016-12-09 Thread Debian FTP Masters
node-loose-envify_1.3.0+dfsg-1_amd64.changes uploaded successfully to localhost along with the files: node-loose-envify_1.3.0+dfsg-1.dsc node-loose-envify_1.3.0+dfsg.orig.tar.gz node-loose-envify_1.3.0+dfsg-1.debian.tar.xz node-loose-envify_1.3.0+dfsg-1_all.deb

Re: [Pkg-javascript-devel] RFS: node-tar-stream 1.5.2

2016-12-09 Thread Paolo Greppi
On 04/12/2016 10:06, Pirate Praveen wrote: > On ഞായര്‍ 04 ഡിസംബര്‍ 2016 02:18 വൈകു, Paolo Greppi wrote: >> It should be low risk to upgrade because the command: >> apt-cache rdepends node-bl >> >> returns: >> >> node-bl >> Reverse Depends: >> node-yawl >> >> The latter has a FTBFS big open for

[Pkg-javascript-devel] Bug#847642: node-uglify: manual page ‘uglifyjs?=(1)=?UTF-8?Q?’ lacks important information for all document sections

2016-12-09 Thread Ben Finney
Package: node-uglify Version: 2.7.4-1 Severity: normal The command ‘uglifyjs’ has a manual page ‘uglifyjs(1)’ that does not helpfully describe the command: NAME uglify-js - manual page for uglify-js 2.7.5 DESCRIPTION [object Object] The manual page should have the

Re: [Pkg-javascript-devel] RFS: node-loose-envify 1.3.0

2016-12-09 Thread Pirate Praveen
On ശനി 10 ഡിസംബര്‍ 2016 11:55 രാവിലെ, Paolo Greppi wrote: > Hi this one should be ready, please review & upload. Uploaded, thanks! signature.asc Description: OpenPGP digital signature -- Pkg-javascript-devel mailing list Pkg-javascript-devel@lists.alioth.debian.org

[Pkg-javascript-devel] node-grunt-contrib-concat_1.0.1-2_source.changes ACCEPTED into unstable

2016-12-09 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Sat, 10 Dec 2016 11:07:45 +0530 Source: node-grunt-contrib-concat Binary: node-grunt-contrib-concat Architecture: source Version: 1.0.1-2 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

[Pkg-javascript-devel] Processing of node-cpr_2.0.0-2_source.changes

2016-12-09 Thread Debian FTP Masters
node-cpr_2.0.0-2_source.changes uploaded successfully to localhost along with the files: node-cpr_2.0.0-2.dsc node-cpr_2.0.0-2.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org) -- Pkg-javascript-devel mailing list

[Pkg-javascript-devel] Bug#846010: marked as done (node-cpr: Incomplete debian/copyright)

2016-12-09 Thread Debian Bug Tracking System
Your message dated Sat, 10 Dec 2016 05:33:30 + with message-id and subject line Bug#846010: fixed in node-cpr 2.0.0-2 has caused the Debian Bug report #846010, regarding node-cpr: Incomplete debian/copyright to be marked as done. This means that you claim

[Pkg-javascript-devel] Processing of node-grunt-contrib-concat_1.0.1-2_source.changes

2016-12-09 Thread Debian FTP Masters
node-grunt-contrib-concat_1.0.1-2_source.changes uploaded successfully to localhost along with the files: node-grunt-contrib-concat_1.0.1-2.dsc node-grunt-contrib-concat_1.0.1-2.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org) --

[Pkg-javascript-devel] node-groove is marked for autoremoval from testing

2016-12-09 Thread Debian testing autoremoval watch
node-groove 2.5.0-1 is marked for autoremoval from testing on 2017-01-05 It is affected by these RC bugs: 844137: node-groove: FTBFS: Tests failures -- Pkg-javascript-devel mailing list Pkg-javascript-devel@lists.alioth.debian.org

[Pkg-javascript-devel] node-cpr_2.0.0-2_source.changes ACCEPTED into unstable

2016-12-09 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Sat, 10 Dec 2016 10:43:12 +0530 Source: node-cpr Binary: node-cpr Architecture: source Version: 2.0.0-2 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

Re: [Pkg-javascript-devel] Processing of node-bl_1.1.2-1_amd64.changes

2016-12-09 Thread Pirate Praveen
On വെള്ളി 09 ഡിസംബര്‍ 2016 01:29 വൈകു, Jérémy Lal wrote: > Nothing ! > My key has expired, i renewed it as explained here: > https://keyring.debian.org/ > but it's not updated immediately by "ftp masters" - i don't think it has to > be available in the debian-keyring package to work again, but

Re: [Pkg-javascript-devel] Processing of node-bl_1.1.2-1_amd64.changes

2016-12-09 Thread Paolo Greppi
On 09/12/2016 09:19, Pirate Praveen wrote: > On വെള്ളി 09 ഡിസംബര്‍ 2016 01:29 വൈകു, Jérémy Lal wrote: >> Nothing ! >> My key has expired, i renewed it as explained here: >> https://keyring.debian.org/ >> but it's not updated immediately by "ftp masters" - i don't think it has to >> be available in

[Pkg-javascript-devel] node-bl_1.1.2-1_source.changes ACCEPTED into unstable

2016-12-09 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Sun, 04 Dec 2016 22:56:24 +0100 Source: node-bl Binary: node-bl Architecture: source Version: 1.1.2-1 Distribution: unstable Urgency: low Maintainer: Debian Javascript Maintainers

[Pkg-javascript-devel] datatables.js_1.10.13+dfsg-1_amd64.changes ACCEPTED into unstable

2016-12-09 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Fri, 09 Dec 2016 08:11:48 + Source: datatables.js Binary: libjs-jquery-datatables Architecture: source all Version: 1.10.13+dfsg-1 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

[Pkg-javascript-devel] Processing of node-bl_1.1.2-1_source.changes

2016-12-09 Thread Debian FTP Masters
node-bl_1.1.2-1_source.changes uploaded successfully to localhost along with the files: node-bl_1.1.2-1.dsc node-bl_1.1.2.orig.tar.gz node-bl_1.1.2-1.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org) -- Pkg-javascript-devel mailing list

Re: [Pkg-javascript-devel] Processing of node-bl_1.1.2-1_amd64.changes

2016-12-09 Thread Jérémy Lal
2016-12-09 8:55 GMT+01:00 Paolo Greppi : > Hi all this does not seem to get through. > > The new version does not come up here: > https://tracker.debian.org/pkg/node-bl > > What did I do wrong ? > > Paolo > > On 08/12/2016 18:19, Debian FTP Masters wrote: >>

[Pkg-javascript-devel] Bug#845227: generate sub modules like lodash.isplainobject

2016-12-09 Thread John-David Dalton
It looks like you've ended up publishing all 407 individual packages as a single package  They were individual to allow folks to cherry-pick individual packages at their desired versions for each. - JDD -- Pkg-javascript-devel mailing list Pkg-javascript-devel@lists.alioth.debian.org

[Pkg-javascript-devel] Processing of datatables.js_1.10.13+dfsg-1_amd64.changes

2016-12-09 Thread Debian FTP Masters
datatables.js_1.10.13+dfsg-1_amd64.changes uploaded successfully to localhost along with the files: datatables.js_1.10.13+dfsg-1.dsc datatables.js_1.10.13+dfsg.orig.tar.xz datatables.js_1.10.13+dfsg-1.debian.tar.xz datatables.js_1.10.13+dfsg-1_amd64.buildinfo

Re: [Pkg-javascript-devel] jqueryui_1.12.1+dfsg-3_amd64.changes is NEW

2016-12-09 Thread Pirate Praveen
On വ്യാഴം 08 ഡിസംബര്‍ 2016 03:22 വൈകു, Pirate Praveen wrote: > Please review this so I can fix RC bug of gitlab (via #847353). This is blocking a security update of gitlab (work is already done in git to use ruby-jquery-ui 6.0.1 which now build depend on node-jquery-ui). It would be extra work to

[Pkg-javascript-devel] new uglifyjs package ready for release (but failing for me)

2016-12-09 Thread Jonas Smedegaard
I have prepared a new upstream release of uglifyjs - but it still fails for me, as was the case also for last package (related to enabling testsuite). Please someone do the release. And that someone please share here your buildlog, to help me triangulate how my build environment may differ from

Re: [Pkg-javascript-devel] new uglifyjs package ready for release (but failing for me)

2016-12-09 Thread Jérémy Lal
2016-12-09 12:48 GMT+01:00 Jonas Smedegaard : > I have prepared a new upstream release of uglifyjs - but it still fails > for me, as was the case also for last package (related to enabling > testsuite). > > Please someone do the release. > > And that someone please share here your

Re: [Pkg-javascript-devel] Bug#798278: Node-tape depends on node-has which is very small

2016-12-09 Thread Ross Gammon
Aah, thanks. I has been a long time since I started on node-tape. Time enough to pick up new dependencies :-) For the record, here is the latest list (although I am using an older npm2deb, and it does not pick up some that have already been packaged.): $ npm2deb depends -r tape Dependencies:

[Pkg-javascript-devel] Bug#845227: generate sub modules like lodash.isplainobject

2016-12-09 Thread Pirate Praveen
[adding -devel] On Fri, 9 Dec 2016 00:53:05 -0800 John-David Dalton wrote: > It looks like you've ended up publishing all 407 individual packages as a > single package 😕 > They were individual to allow folks to cherry-pick individual packages at > their desired

Re: [Pkg-javascript-devel] new uglifyjs package ready for release (but failing for me)

2016-12-09 Thread Pirate Praveen
On 2016, ഡിസംബർ 9 7:31:47 PM IST, "Jérémy Lal" wrote: >Sure ! I'm just waiting for the monthly HKP keyring push, >which should happen in the next three days if keyring repository >maintainer isn't busy. >Anyone feel free to do it before. > >Jérémy > I had uploaded 2.7.4 on

Re: [Pkg-javascript-devel] new uglifyjs package ready for release (but failing for me)

2016-12-09 Thread Jérémy Lal
2016-12-09 14:57 GMT+01:00 Jonas Smedegaard : > Excerpts from Jérémy Lal's message of December 9, 2016 2:37 pm: >> >> 2016-12-09 12:48 GMT+01:00 Jonas Smedegaard : >>> >>> I have prepared a new upstream release of uglifyjs - but it still fails >>> for me, as was the

[Pkg-javascript-devel] Processing of node-gettext-parser_1.2.1-2_amd64.changes

2016-12-09 Thread Debian FTP Masters
node-gettext-parser_1.2.1-2_amd64.changes uploaded successfully to localhost along with the files: node-gettext-parser_1.2.1-2.dsc node-gettext-parser_1.2.1-2.debian.tar.xz node-gettext-parser_1.2.1-2_all.deb node-gettext-parser_1.2.1-2_amd64.buildinfo Greetings, Your Debian

[Pkg-javascript-devel] Bug#845227: generate sub modules like lodash.isplainobject

2016-12-09 Thread John-David Dalton
> So in debian we patch grunt to use globally installed modules and tasks. I'm OK with creating more hoops to jump through in this case. I think the approach you've outlined is a bit wonky. There are ways to bundle deps without flattening versions. You could package grunt, gulp, and whatever else

[Pkg-javascript-devel] node-gettext-parser_1.2.1-2_amd64.changes ACCEPTED into unstable

2016-12-09 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Format: 1.8 Date: Fri, 09 Dec 2016 17:06:10 +0100 Source: node-gettext-parser Binary: node-gettext-parser Architecture: source all Version: 1.2.1-2 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

Re: [Pkg-javascript-devel] new uglifyjs package ready for release (but failing for me)

2016-12-09 Thread Jonas Smedegaard
Excerpts from Jérémy Lal's message of December 9, 2016 2:37 pm: 2016-12-09 12:48 GMT+01:00 Jonas Smedegaard : I have prepared a new upstream release of uglifyjs - but it still fails for me, as was the case also for last package (related to enabling testsuite). Please someone do

Re: [Pkg-javascript-devel] new uglifyjs package ready for release (but failing for me)

2016-12-09 Thread Pirate Praveen
On വെള്ളി 09 ഡിസംബര്‍ 2016 07:45 വൈകു, Pirate Praveen wrote: > I had uploaded 2.7.4 on Dec 1 and it is now in testing. > Sorry about the confusion. I thought you missed my last upload. I have uploaded 2.7.5 signature.asc Description: OpenPGP digital signature -- Pkg-javascript-devel mailing

Re: [Pkg-javascript-devel] new uglifyjs package ready for release (but failing for me)

2016-12-09 Thread Jonas Smedegaard
Excerpts from Pirate Praveen's message of December 9, 2016 7:39 pm: On വെള്ളി 09 ഡിസംബര്‍ 2016 07:45 വൈകു, Pirate Praveen wrote: I had uploaded 2.7.4 on Dec 1 and it is now in testing. Sorry about the confusion. No problem. I thought you missed my last upload. I have uploaded 2.7.5

[Pkg-javascript-devel] help with node-shelljs tests

2016-12-09 Thread Pirate Praveen
Hi, shelljs is required for enabling tests of grunt. I have disabled 'shjs' tests now (see disable-failing-tests.patch). Can someone see if we can fix it? 'cd' tests are failing in sbuild because sbuild user home directory is /sbuild-nonexistent. Also chmod and ls tests that pass during build in

[Pkg-javascript-devel] Processing of node-shelljs_0.7.5-1_amd64.changes

2016-12-09 Thread Debian FTP Masters
node-shelljs_0.7.5-1_amd64.changes uploaded successfully to localhost along with the files: node-shelljs_0.7.5-1.dsc node-shelljs_0.7.5.orig.tar.gz node-shelljs_0.7.5-1.debian.tar.xz node-shelljs_0.7.5-1_all.deb node-shelljs_0.7.5-1_amd64.buildinfo Greetings, Your Debian queue

[Pkg-javascript-devel] Bug#845227: Bug#845227: generate sub modules like lodash.isplainobject

2016-12-09 Thread Pirate Praveen
On വെള്ളി 09 ഡിസംബര്‍ 2016 11:33 വൈകു, John-David Dalton wrote: >> That means we have to maintain multiple copies of the same library and > that increases our effort to maintain it. > > The maintenance cost is reduced since they're just bundled with the > package. You can treat each release of

[Pkg-javascript-devel] Processing of uglifyjs_2.7.5-1_source.changes

2016-12-09 Thread Debian FTP Masters
uglifyjs_2.7.5-1_source.changes uploaded successfully to localhost along with the files: uglifyjs_2.7.5-1.dsc uglifyjs_2.7.5.orig.tar.gz uglifyjs_2.7.5-1.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org) -- Pkg-javascript-devel mailing list

[Pkg-javascript-devel] uglifyjs_2.7.5-1_source.changes ACCEPTED into unstable

2016-12-09 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Fri, 09 Dec 2016 12:42:57 +0100 Source: uglifyjs Binary: node-uglify libjs-uglify Architecture: source Version: 2.7.5-1 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

[Pkg-javascript-devel] node-shelljs_0.7.5-1_amd64.changes is NEW

2016-12-09 Thread Debian FTP Masters
binary:node-shelljs is NEW. binary:node-shelljs is NEW. source:node-shelljs is NEW. Your package has been put into the NEW queue, which requires manual action from the ftpteam to process. The upload was otherwise valid (it had a good OpenPGP signature and file hashes are valid), so please be

[Pkg-javascript-devel] Bug#845227: Bug#845227: generate sub modules like lodash.isplainobject

2016-12-09 Thread Pirate Praveen
On വെള്ളി 09 ഡിസംബര്‍ 2016 09:47 വൈകു, John-David Dalton wrote: >> So in debian we patch grunt to use globally installed modules and tasks. > > I'm OK with creating more hoops to jump through in this case. I think > the approach you've outlined is a bit wonky. There are ways to bundle > deps

[Pkg-javascript-devel] Bug#845227: generate sub modules like lodash.isplainobject

2016-12-09 Thread John-David Dalton
> That means we have to maintain multiple copies of the same library and that increases our effort to maintain it. The maintenance cost is reduced since they're just bundled with the package. You can treat each release of say gulp as a snapshot of their deps and bundle it with them. Packages

[Pkg-javascript-devel] Bug#847614: node-yargs FTBFS in stretch due to missing node-cpr

2016-12-09 Thread Adrian Bunk
Source: node-yargs Version: 6.4.0-2 Severity: serious Tags: stretch sid Control: block -1 by 846010 node-yargs build-depends on node-cpr, which is not in stretch due to #846010 -- Pkg-javascript-devel mailing list Pkg-javascript-devel@lists.alioth.debian.org

[Pkg-javascript-devel] Processed: node-yargs FTBFS in stretch due to missing node-cpr

2016-12-09 Thread Debian Bug Tracking System
Processing control commands: > block -1 by 846010 Bug #847614 [src:node-yargs] node-yargs FTBFS in stretch due to missing node-cpr 847614 was not blocked by any bugs. 847614 was not blocking any bugs. Added blocking bug(s) of 847614: 846010 -- 847614: