[Pkg-javascript-devel] Bug#848904: marked as done (node-tap: autopkgtests fail since 2016-11-13)

2016-12-20 Thread Debian Bug Tracking System
Your message dated Tue, 20 Dec 2016 17:48:34 + with message-id and subject line Bug#848904: fixed in node-tap 8.0.0-3 has caused the Debian Bug report #848904, regarding node-tap: autopkgtests fail since 2016-11-13 to be marked as done. This means that

[Pkg-javascript-devel] Bug#848912: RFS: node-file-sync-cmp/0.1.1-1 [ITP]

2016-12-20 Thread Ross Gammon
Package: sponsorship-requests Severity: wishlist Tags: l10n Dear mentors, I am looking for a sponsor for my package "node-file-sync-cmp" * Package name: node-file-sync-cmp Version : 0.1.1-1 Upstream Author : Martin Geisler (http://geisler.net/) * URL

[Pkg-javascript-devel] Bug#847614: marked as done (node-yargs FTBFS in stretch due to missing node-cpr)

2016-12-20 Thread Debian Bug Tracking System
Your message dated Tue, 20 Dec 2016 21:26:09 +0200 with message-id <20161220192609.le2nozqqlilt5...@bunk.spdns.de> and subject line node-cpr is now in testing has caused the Debian Bug report #847614, regarding node-yargs FTBFS in stretch due to missing node-cpr to be marked as done. This means

[Pkg-javascript-devel] node-tap_8.0.0-3_source.changes ACCEPTED into unstable

2016-12-20 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Tue, 20 Dec 2016 18:20:01 +0100 Source: node-tap Binary: node-tap Architecture: source Version: 8.0.0-3 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

Re: [Pkg-javascript-devel] node-tap_8.0.0-3_source.changes ACCEPTED into unstable

2016-12-20 Thread Paul Gevers
Hi, On 20-12-16 18:48, Debian FTP Masters wrote: >* Disable segv test if gcc is missing (Closes: #848904) Why not make sure gcc is installed instead? Paul signature.asc Description: OpenPGP digital signature -- Pkg-javascript-devel mailing list

[Pkg-javascript-devel] acorn_4.0.3-3_source.changes ACCEPTED into unstable

2016-12-20 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA512 Format: 1.8 Date: Tue, 20 Dec 2016 11:37:59 +0100 Source: acorn Binary: node-acorn Architecture: source Version: 4.0.3-3 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

[Pkg-javascript-devel] Bug#802351: marked as done (node-zipfile: FTBFS: error: 'Arguments' does not name a type)

2016-12-20 Thread Debian Bug Tracking System
Your message dated Wed, 21 Dec 2016 00:36:01 + with message-id and subject line Bug#802351: fixed in node-zipfile 0.5.11+ds-1 has caused the Debian Bug report #802351, regarding node-zipfile: FTBFS: error: 'Arguments' does not name a type to be marked as

[Pkg-javascript-devel] Processing of acorn_4.0.3-3_source.changes

2016-12-20 Thread Debian FTP Masters
acorn_4.0.3-3_source.changes uploaded successfully to localhost along with the files: acorn_4.0.3-3.dsc acorn_4.0.3-3.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org) -- Pkg-javascript-devel mailing list

[Pkg-javascript-devel] Bug#848857: marked as done (acorn is missing src directory)

2016-12-20 Thread Debian Bug Tracking System
Your message dated Wed, 21 Dec 2016 00:03:27 + with message-id and subject line Bug#848857: fixed in acorn 4.0.3-3 has caused the Debian Bug report #848857, regarding acorn is missing src directory to be marked as done. This means that you claim that the

[Pkg-javascript-devel] Processing of node-zipfile_0.5.11+ds-1_source.changes

2016-12-20 Thread Debian FTP Masters
node-zipfile_0.5.11+ds-1_source.changes uploaded successfully to localhost along with the files: node-zipfile_0.5.11+ds-1.dsc node-zipfile_0.5.11+ds.orig.tar.gz node-zipfile_0.5.11+ds-1.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org) --

[Pkg-javascript-devel] Processing of node-pre-gyp_0.6.32-1_source.changes

2016-12-20 Thread Debian FTP Masters
node-pre-gyp_0.6.32-1_source.changes uploaded successfully to localhost along with the files: node-pre-gyp_0.6.32-1.dsc node-pre-gyp_0.6.32.orig.tar.gz node-pre-gyp_0.6.32-1.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org) --

[Pkg-javascript-devel] node-zipfile_0.5.11+ds-1_source.changes ACCEPTED into unstable

2016-12-20 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Tue, 20 Dec 2016 16:46:19 +0100 Source: node-zipfile Binary: node-zipfile Architecture: source Version: 0.5.11+ds-1 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

[Pkg-javascript-devel] node-pre-gyp_0.6.32-1_source.changes ACCEPTED into unstable

2016-12-20 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Wed, 21 Dec 2016 01:08:04 +0100 Source: node-pre-gyp Binary: node-pre-gyp Architecture: source Version: 0.6.32-1 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

[Pkg-javascript-devel] RFS: node-grunt-contrib-uglify 2.0.0

2016-12-20 Thread Paolo Greppi
Hi, I have packaged node-grunt-contrib-uglify, see the ITP I am CC-ing and the repo: https://anonscm.debian.org/git/pkg-javascript/node-grunt-contrib-uglify.git I had to repackage to get rid of uglyfied files part of the test suite. Therefore I can not not run tests during build or autopkgtests

Re: [Pkg-javascript-devel] grunt-contrib-uglify and grunt-contrib-copy

2016-12-20 Thread Paolo Greppi
On 20/12/2016 03:41, Pirate Praveen wrote: > On ചൊവ്വ 20 ഡിസംബര്‍ 2016 12:15 രാവിലെ, Paolo Greppi wrote: >> Hi, >> >> while packaging node-rx and trying to build it with grunt, I noticed >> that apart from a number of non-relevant grunt add-ons related to >> linting (grunt-jscs and

[Pkg-javascript-devel] Bug#848749: marked as done (node-fined: FTBFS: Test failures)

2016-12-20 Thread Debian Bug Tracking System
Your message dated Tue, 20 Dec 2016 10:11:02 + with message-id and subject line Bug#848749: fixed in node-fined 1.0.2-2 has caused the Debian Bug report #848749, regarding node-fined: FTBFS: Test failures to be marked as done. This means that you claim

[Pkg-javascript-devel] Processing of node-tap_8.0.0-3_source.changes

2016-12-20 Thread Debian FTP Masters
node-tap_8.0.0-3_source.changes uploaded successfully to localhost along with the files: node-tap_8.0.0-3.dsc node-tap_8.0.0-3.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org) -- Pkg-javascript-devel mailing list

Re: [Pkg-javascript-devel] Help needed on rollup

2016-12-20 Thread Pirate Praveen
On ഞായര്‍ 18 ഡിസംബര്‍ 2016 02:27 രാവിലെ, Julien Puydt wrote: > PS: notice that the git repo created by Sruthi Chandran looks pretty > incorrect : it uses npm to install things! This is only to bootstrap, I did jison in the same way. 1. Build rollup using npm (this can go into contrib) 2. Build

[Pkg-javascript-devel] Bug#848857: Bug#848857: acorn is missing src directory

2016-12-20 Thread Pirate Praveen
On ചൊവ്വ 20 ഡിസംബര്‍ 2016 02:32 വൈകു, Julien Puydt wrote: > Have you seen my recent mail to the pkg-javascript-devel mailing-list? > There I provide a tarball with the current state of my work ; it > includes two patches changing where some things are found. I have replied there. This particular

[Pkg-javascript-devel] Processed: OCD

2016-12-20 Thread Debian Bug Tracking System
Processing commands for cont...@bugs.debian.org: > retitle 844939 git-remote-hg: FTBFS: Test failures Bug #844939 [src:git-remote-hg] git-remote-hg: FTBFS: Tests failures Changed Bug title to 'git-remote-hg: FTBFS: Test failures' from 'git-remote-hg: FTBFS: Tests failures'. > retitle 844923

[Pkg-javascript-devel] nodejs 6 and dh_nodejs

2016-12-20 Thread Jérémy Lal
Hi, i'm preparing the transition to nodejs 6.9.2. Several packages build-depending on node-gyp are probably c++ addons, and they should declare a dependency on nodejs-abi-xx meta-package, by build-depending on nodejs-dev and using in debian/rules: dh $@ --with nodejs These packages may need to

[Pkg-javascript-devel] Processing of node-ws_1.1.0+ds1.e6ddaae4-2_amd64.changes

2016-12-20 Thread Debian FTP Masters
node-ws_1.1.0+ds1.e6ddaae4-2_amd64.changes uploaded successfully to localhost along with the files: node-ws_1.1.0+ds1.e6ddaae4-2.dsc node-ws_1.1.0+ds1.e6ddaae4-2.debian.tar.xz node-ws-dbgsym_1.1.0+ds1.e6ddaae4-2_amd64.deb node-ws_1.1.0+ds1.e6ddaae4-2_amd64.buildinfo

[Pkg-javascript-devel] node-fined_1.0.2-2_source.changes ACCEPTED into unstable

2016-12-20 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Tue, 20 Dec 2016 07:16:08 + Source: node-fined Binary: node-fined Architecture: source Version: 1.0.2-2 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

[Pkg-javascript-devel] Bug#848507: The node-acorn package has some kind of walk

2016-12-20 Thread Julien Puydt
Hi, I just realize that in nodejs, the following works: walk = require('acorn/walk') simple = simple.walk and it looks like that 'simple' function is what bluebird wants -- so perhaps it's possible to get along with the current node-acorn package? I hope that helps, Snark on #debian-js PS:

[Pkg-javascript-devel] Bug#848858: Error: 'Bundle' is not exported

2016-12-20 Thread Pirate Praveen
package: node-magic-string, node-sourcemap-codec severity: important When I'm trying to build rollup, I get this error. I symlinked both from /usr/lib/nodejs to node_modules Error: 'Bundle' is not exported by node_modules/magic-string/index.js (imported by src/Bundle.js). For help fixing this

[Pkg-javascript-devel] Bug#848858: Bug#848858: Error: 'Bundle' is not exported

2016-12-20 Thread Julien Puydt
Hi, On 20/12/2016 10:06, Pirate Praveen wrote: package: node-magic-string, node-sourcemap-codec severity: important When I'm trying to build rollup, I get this error. I symlinked both from /usr/lib/nodejs to node_modules Error: 'Bundle' is not exported by node_modules/magic-string/index.js

[Pkg-javascript-devel] Bug#848857: acorn is missing src directory

2016-12-20 Thread Pirate Praveen
package: node-acorn severity: important version: 4.0.3-2 When trying to build rollup, I get this error Error: Could not resolve 'acorn/src/index.js' from /home/pravi/forge/debian/git/pkg-javascript/node-rollup/src/Module.js after copying src directory from source repo to /usr/lib/nodejs/acorn,

[Pkg-javascript-devel] Processing of node-fined_1.0.2-2_source.changes

2016-12-20 Thread Debian FTP Masters
node-fined_1.0.2-2_source.changes uploaded successfully to localhost along with the files: node-fined_1.0.2-2.dsc node-fined_1.0.2-2.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org) -- Pkg-javascript-devel mailing list

[Pkg-javascript-devel] node-ws_1.1.0+ds1.e6ddaae4-2_amd64.changes ACCEPTED into unstable

2016-12-20 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Tue, 20 Dec 2016 10:57:16 +0100 Source: node-ws Binary: node-ws Architecture: source amd64 Version: 1.1.0+ds1.e6ddaae4-2 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

Re: [Pkg-javascript-devel] Bug#848749: disable build-time tests

2016-12-20 Thread Paolo Greppi
On 20/12/2016 07:41, Pirate Praveen wrote: > On ചൊവ്വ 20 ഡിസംബര്‍ 2016 12:03 വൈകു, Paolo Greppi wrote: >> Il looks like node-expand-tilde returns a directory which does not exist >> (sbuild-nonexistent) at this line in >> node-fined/test/utils/get-userhome-file.js: >> var userHomeDir =

Re: [Pkg-javascript-devel] Re: Help needed on rollup

2016-12-20 Thread Pirate Praveen
On ചൊവ്വ 20 ഡിസംബര്‍ 2016 03:28 വൈകു, Julien Puydt wrote: >> 1. Build rollup using npm (this can go into contrib) >> 2. Build babel-cli using rollup (again will have to be in contrib) >> 3. Remove npm and upload rollup and babel-cli together to main > > Is it that simple? yes, in theory. In

[Pkg-javascript-devel] Processing of node-ws_1.1.0+ds1.e6ddaae4-3_source.changes

2016-12-20 Thread Debian FTP Masters
node-ws_1.1.0+ds1.e6ddaae4-3_source.changes uploaded successfully to localhost along with the files: node-ws_1.1.0+ds1.e6ddaae4-3.dsc node-ws_1.1.0+ds1.e6ddaae4-3.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org) -- Pkg-javascript-devel mailing

[Pkg-javascript-devel] Bug#848886: node-stringprep: Please use dh_nodejs

2016-12-20 Thread Jérémy Lal
Source: node-stringprep Severity: normal Hi, dh_nodejs should be called during build, (the package will need to depend on nodejs-dev). This ensures this addon depends on nodejs-abi-xx metapackage. Thank you for your help, Jérémy -- System Information: Debian Release: stretch/sid APT

[Pkg-javascript-devel] node-ws_1.1.0+ds1.e6ddaae4-3_source.changes ACCEPTED into unstable

2016-12-20 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Tue, 20 Dec 2016 15:09:28 +0100 Source: node-ws Binary: node-ws Architecture: source Version: 1.1.0+ds1.e6ddaae4-3 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

[Pkg-javascript-devel] node-groove_2.5.0-2_source.changes REJECTED

2016-12-20 Thread Debian FTP Masters
node-groove_2.5.0-2.dsc: Invalid size hash for node-groove_2.5.0.orig.tar.gz: According to the control file the size hash should be 104389, but node-groove_2.5.0.orig.tar.gz has 104530. If you did not include node-groove_2.5.0.orig.tar.gz in your upload, a different version might already be

[Pkg-javascript-devel] Processing of node-groove_2.5.0-2_source.changes

2016-12-20 Thread Debian FTP Masters
node-groove_2.5.0-2_source.changes uploaded successfully to localhost along with the files: node-groove_2.5.0-2.dsc node-groove_2.5.0-2.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org) -- Pkg-javascript-devel mailing list

[Pkg-javascript-devel] Processing of node-leveldown_1.5.0+dfsg-1_source.changes

2016-12-20 Thread Debian FTP Masters
node-leveldown_1.5.0+dfsg-1_source.changes uploaded successfully to localhost along with the files: node-leveldown_1.5.0+dfsg-1.dsc node-leveldown_1.5.0+dfsg.orig.tar.gz node-leveldown_1.5.0+dfsg-1.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org)

[Pkg-javascript-devel] node-leveldown_1.5.0+dfsg-1_source.changes ACCEPTED into unstable

2016-12-20 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Tue, 20 Dec 2016 16:10:31 +0100 Source: node-leveldown Binary: node-leveldown Architecture: source Version: 1.5.0+dfsg-1 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

[Pkg-javascript-devel] Processing of node-groove_2.5.0-2_source.changes

2016-12-20 Thread Debian FTP Masters
node-groove_2.5.0-2_source.changes uploaded successfully to localhost along with the files: node-groove_2.5.0-2.dsc node-groove_2.5.0-2.debian.tar.xz Greetings, Your Debian queue daemon (running on host usper.debian.org) -- Pkg-javascript-devel mailing list

[Pkg-javascript-devel] node-groove_2.5.0-2_source.changes ACCEPTED into unstable

2016-12-20 Thread Debian FTP Masters
Accepted: -BEGIN PGP SIGNED MESSAGE- Hash: SHA256 Format: 1.8 Date: Tue, 20 Dec 2016 15:36:56 +0100 Source: node-groove Binary: node-groove Architecture: source Version: 2.5.0-2 Distribution: unstable Urgency: medium Maintainer: Debian Javascript Maintainers

[Pkg-javascript-devel] Bug#848857: Bug#848857: acorn is missing src directory

2016-12-20 Thread Julien Puydt
Hi, On 20/12/2016 09:53, Pirate Praveen wrote: package: node-acorn severity: important version: 4.0.3-2 When trying to build rollup, I get this error Error: Could not resolve 'acorn/src/index.js' from /home/pravi/forge/debian/git/pkg-javascript/node-rollup/src/Module.js after copying src

Re: [Pkg-javascript-devel] Re: Help needed on rollup

2016-12-20 Thread Julien Puydt
Hi, On 20/12/2016 10:27, Pirate Praveen wrote: On ഞായര്‍ 18 ഡിസംബര്‍ 2016 02:27 രാവിലെ, Julien Puydt wrote: PS: notice that the git repo created by Sruthi Chandran looks pretty incorrect : it uses npm to install things! This is only to bootstrap, I did jison in the same way. 1. Build rollup

[Pkg-javascript-devel] Bug#848904: node-tap: autopkgtests fail since 2016-11-13

2016-12-20 Thread Graham Inggs
Source: node-tap Version: 8.0.0-1 Severity: normal Hi maintainer Node-tap has been consistently failing its autopkgtests since 2016-11-13 [1]. This corresponds to the upload of node-tap 8.0.0-1. Regards Graham [1] https://ci.debian.net/packages/n/node-tap/unstable/amd64/ --

[Pkg-javascript-devel] node-gettext-parser 1.2.1-2 MIGRATED to testing

2016-12-20 Thread Debian testing watch
FYI: The status of the node-gettext-parser source package in Debian's testing distribution has changed. Previous version: 1.2.1-1 Current version: 1.2.1-2 -- This email is automatically generated once a day. As the installation of new packages into testing happens multiple times a day you

[Pkg-javascript-devel] uglifyjs 2.7.5-1 MIGRATED to testing

2016-12-20 Thread Debian testing watch
FYI: The status of the uglifyjs source package in Debian's testing distribution has changed. Previous version: 2.7.4-1 Current version: 2.7.5-1 -- This email is automatically generated once a day. As the installation of new packages into testing happens multiple times a day you will

[Pkg-javascript-devel] node-bl 1.1.2-1 MIGRATED to testing

2016-12-20 Thread Debian testing watch
FYI: The status of the node-bl source package in Debian's testing distribution has changed. Previous version: 0.9.3-1 Current version: 1.1.2-1 -- This email is automatically generated once a day. As the installation of new packages into testing happens multiple times a day you will

[Pkg-javascript-devel] node-grunt-contrib-concat 1.0.1-2 MIGRATED to testing

2016-12-20 Thread Debian testing watch
FYI: The status of the node-grunt-contrib-concat source package in Debian's testing distribution has changed. Previous version: (not in testing) Current version: 1.0.1-2 -- This email is automatically generated once a day. As the installation of new packages into testing happens multiple

[Pkg-javascript-devel] node-cpr 2.0.0-2 MIGRATED to testing

2016-12-20 Thread Debian testing watch
FYI: The status of the node-cpr source package in Debian's testing distribution has changed. Previous version: (not in testing) Current version: 2.0.0-2 -- This email is automatically generated once a day. As the installation of new packages into testing happens multiple times a day you

[Pkg-javascript-devel] datatables.js 1.10.13+dfsg-1 MIGRATED to testing

2016-12-20 Thread Debian testing watch
FYI: The status of the datatables.js source package in Debian's testing distribution has changed. Previous version: 1.10.12+dfsg-1 Current version: 1.10.13+dfsg-1 -- This email is automatically generated once a day. As the installation of new packages into testing happens multiple times a