[Pkg-javascript-devel] Maintain impress.js and highlight.js in the JavaScript team

2012-11-19 Thread Cédric Boutillier
Dear members of the Debian JavaScript team, Please Cc: me since I am not (yet) subscribed to the list. I proposed recently to package mdpress, after RFP bug #692864. It is a Ruby tool to make HTML5 presentations using impress.js library. The current code contains convenience copies of

[Pkg-javascript-devel] [RFR] highlight.js and impress.js

2012-12-11 Thread Cédric Boutillier
Dear JavaScript team members, I would like to kindly ask you to review my first two JavaScript packages to see if they are conform to what is expected. Those are dependencies of a Ruby tool, mdpress, used to create presentations from Markdown files. The two packages are: - impress.js This

Re: [Pkg-javascript-devel] Comments regarding impress.js_0.5.3-1_amd64.changes

2013-02-27 Thread Cédric Boutillier
Hi Ansgar, On Wed, Feb 27, 2013 at 01:03:48PM +, Ansgar Burchardt wrote: Hi, why does d/copyright say Expat or GPL-2+? The upstream sources contain a notice saying Released under the MIT and GPL Licenses. (i.e. any version of the GPL). Note that MIT License might refer to one of

Re: [Pkg-javascript-devel] highlight.js_7.3+ds-1_amd64.changes REJECTED

2013-08-16 Thread Cédric Boutillier
Hi Paul, On Fri, Aug 16, 2013 at 09:00:15PM +, Paul Richards Tagliamonte wrote: Hello, Maintainer, I'm sorry, but I've had to reject this package. highlight.js-7.3\tools\yuicompressor.jar Which is a sourceless jar full of code. I think it's packaged, too. I see in your changelog you

[Pkg-javascript-devel] Bug#762033: node-highlight: incompatible with nodejs module name: highlight.js

2014-09-18 Thread Cédric Boutillier
On Wed, 17 Sep 2014 23:51:08 +0200 Leo Iannacone l...@ubuntu.com wrote: Source: node-highlight Severity: important Dear Maintainer, This package must be renamed (and installed properly) to node-highlight.js according with upstream module name (see package.json). Please, rename it

[Pkg-javascript-devel] Bug#762033: node-highlight: incompatible with nodejs module name: highlight.js

2014-09-18 Thread Cédric Boutillier
On Wed, 17 Sep 2014 23:51:08 +0200 Leo Iannacone l...@ubuntu.com wrote: Source: node-highlight Severity: important Dear Maintainer, This package must be renamed (and installed properly) to node-highlight.js according with upstream module name (see package.json). Please, rename it

Re: [Pkg-javascript-devel] node-highlight: incompatible with nodejs module name: highlight.js

2014-09-18 Thread Cédric Boutillier
Source: highlight.js Followup-For: Bug #762033 Thanks for your report. I packaged highlight.js as a dependency of another tool, and I am not completely familiar with the JavaScript world. Excuse my naive questions below. I understand that because the package name in the package.json file is

[Pkg-javascript-devel] Bug#762033: node-highlight: incompatible with nodejs module name: highlight.js

2014-10-13 Thread Cédric Boutillier
Hi, On Fri, Oct 10, 2014 at 09:33:41AM +0100, Jonathan Wiltshire wrote: What's your plan for the three reverse dependencies of libjs-highlight? I filed bugs with patches for ckeditor (#765003) and ipython (#765001). I will fix mdpress myself, as I am its maintainer. Cédric