kdebase-workspace needs help

2008-05-25 Thread Sune Vuorela
(If discussing arch specific issues, please trim the To: field) Hi! Kdebase-workspace (4:4.0.74-1) needs some porting help. so far, it at least fails in the kde process monitor tool where it seems to do archspecific things. Only amd64, i386 and ppc seems to be covered by the code. The issues

Re: KDE version in Lenny: KDE 3.5.9 vs KDE 4.1

2008-06-05 Thread Sune Vuorela
On Thursday 05 June 2008, Ana Guerrero wrote: Hi folks, We have been delaying taking a decision about this for too much time now, the freeze is coming up [0], and we need to have it clear, for our users, the release team and the rest of Debian. True. We need to have it clear. Basically we

roadmap for kde4 in lenny?

2008-06-07 Thread Sune Vuorela
Hi! This is a attempt to describe what and when to do things to get kde4 in lenny. Middle june: Fix hppa build failure. Sune looking into that. Strip down kde3 kdebase to only contain kde3 specific stuff (kio-plugins and kcontrol). Fedora has some work and Sune is looking into that kde4libs

away bindings

2008-07-04 Thread Sune Vuorela
Hi! I'm being away from the internets this weekends. back on sunday. I have been working on the kde4 kdebindings and I wouldn't mind if someone follows up and finishes it while I'm gone ;) /Sune -- Man, how can I insert the attachment? First you must cancel the back-end of the graphic mouse

Re: rev 11376 - in branches/kde4/packages/kdebase-workspace/debian: . patches

2008-07-07 Thread Sune Vuorela
On Monday 07 July 2008 18:10:01 Ana Guerrero wrote: On Mon, Jul 07, 2008 at 05:38:11PM +0200, Sune Vuorela wrote: On Monday 07 July 2008 16:54:26 Ana Beatriz Guerrero López wrote: -* ksysguard now depends on ksysguardd. + * ksysguard now recommends on ksysguardd. Modified

Re: rev 11376 - in branches/kde4/packages/kdebase-workspace/debian: . patches

2008-07-08 Thread Sune Vuorela
On Mon, 7 Jul 2008 19:24:59 +0200, Sune Vuorela [EMAIL PROTECTED] wrote: I think we should put it in as Depends for now and downgrade if upstream considers it optional. I can write them a email (or locate on irc) I just spoke with upstream. A few quotes from my irc conversation: me

Re: klaptopdaemon uses obsolete methods.

2008-07-10 Thread Sune Vuorela
On Thursday 10 July 2008 09:27:03 Ana Guerrero wrote: Question after reading your mail is: what kernel version will be in Lenny? 2.6.24 or 2.4.25? .25 is fallback. .26 is the kernel teams planed kernel. For even more details for the interested reader, see -release maillist. /Sune -- Do

Re: Akonadi and MySQL

2008-08-18 Thread Sune Vuorela
On Monday 18 August 2008 15:20:43 Matthew Rosewarne wrote: There's no way around it: Akonadi needs MySQLd. Nope. The goal is to somehow allow Akonadi to do what it needs to do without requiring the user to mess around with MySQL configuration. The Akonadi service can either start manage

Re: patches to kde4

2008-08-28 Thread Sune Vuorela
Some time ago ... On Monday 17 December 2007 19:53:59 Ana Guerrero wrote: On Mon, Dec 17, 2007 at 01:04:55AM +0100, Sune Vuorela wrote: I would like if we could have all patches in kde4 have a corresponding bug report in the bugzilla - and even a link to the bug report in the top

for KDE ...

2008-09-05 Thread Sune Vuorela
On Friday 05 September 2008 13:50:52 Ana Beatriz Guerrero López wrote: Author: ana Date: 2008-09-05 11:50:52 + (Fri, 05 Sep 2008) New Revision: 12095 (This is just a random commit chosen - but the issue is more generic) -Description: hexeditor for binary files - okteta is a KDE 4

Re: rev 12740 - branches/kde4.2/packages/kdelibs/debian

2008-12-11 Thread Sune Vuorela
On Thursday 11 December 2008 17:09:10 Ana Guerrero wrote: I do not remember well about this. So question: did not we move this for co-installibility reasons? We moved for many reasons. Coinstallability is one, but general they are not needed by normal user is also important. /Sune Ana On

Re: rev 12740 - branches/kde4.2/packages/kdelibs/debian

2008-12-11 Thread Sune Vuorela
On Thursday 11 December 2008 19:24:51 Ana Guerrero wrote: On Thu, Dec 11, 2008 at 06:38:41PM +0100, Sune Vuorela wrote: On Thursday 11 December 2008 17:09:10 Ana Guerrero wrote: I do not remember well about this. So question: did not we move this for co-installibility reasons? We

Re: krypt

2008-12-31 Thread Sune Vuorela
On Wednesday 31 December 2008 22:58:07 Stefanos Harhalakis wrote: I believe that there are some arguments for including it in debian too: I really think that uploading any NEW packages to debian that uses kde3 libraries is a waste of everybodys time, as long as there is no plan for a kde4

Re: Need to download KDE 4.1 iso

2009-01-24 Thread Sune Vuorela
On Saturday 24 January 2009 10:56:48 Beojan Stanislaus wrote: On Friday 23 January 2009 22:15:50 Scott Kitterman wrote: On Thu, 22 Jan 2009 20:10:00 + Beojan Stanislaus beo...@lavabit.com wrote: Kubuntu, the KDE version of Ubuntu, offers KDE4.1 for Intrepid Ibex, but provides a

Re: Uploads to lenny and the $KDEHOME dilemma

2009-02-03 Thread Sune Vuorela
On Tuesday 03 February 2009 22:53:42 Armin Berres wrote: So, which options do you see? What would you prefer? Don't forget that we have to decide/code all this before we upload kde4libs to unstable. The biggest problem, as I see it, is that choosing .kde screws our current kde4 users, because

Re: [DRAFT for discussion] KDE 4.2 upload to unstable

2009-02-04 Thread Sune Vuorela
On Wednesday 04 February 2009 10:11:49 Ana Guerrero wrote: [snip kdebase legacy] It is not a blocker, but I do not see why it needs to wait? Actually it could be uploaded in any time if the source package name is different (will need conflcits with current stuff) and people will be able to

Re: Uploads to lenny and the $KDEHOME dilemma

2009-02-04 Thread Sune Vuorela
On Tuesday 03 February 2009 22:53:42 Armin Berres wrote: Hi all! As you all know Lenny is near, which also means that our 4.2 packages will enter Unstable in the very near future. Until today, we still have not decided how to handle KDEHOME. The current situation is, that KDE 3 applications

Re: Uploads to lenny and the $KDEHOME dilemma

2009-02-12 Thread Sune Vuorela
On Thursday 12 February 2009 12:14:02 Ana Guerrero wrote: [1] For what I have understood in this thread, everything should be migrated, and when it is not possible, being ignored. And when it is not correclty migrated it is a bug to report to upstream. That's also my understanding. And ack

KDE in the transition queue

2009-02-15 Thread Sune Vuorela
(please keep pkg-kde-talk in cc, but no need to keep me) Hi release team! We are as good as ready to push a new and better KDE into unstable at your command. You basically have two choices. Brief and rough or less pain over a longer period of time. The total breakages/pain is expected to be

library packaging

2009-02-25 Thread Sune Vuorela
Hi! KDevPlatform has apparantly just been uploaded building the following binary packages: kdevplatform - KDevelop platform for KDE4 kdevplatform-dbg - debugging symbols for the KDevelop platform kdevplatform-dev - development files for the KDevelop platform libsublime-dev - development files

Re: rev 13969 - trunk/packages/kdevplatform/debian

2009-03-04 Thread Sune Vuorela
On Wednesday 04 March 2009 17:45:27 Jeremy Lainé wrote: Author: sharky Date: 2009-03-04 16:45:27 + (Wed, 04 Mar 2009) New Revision: 13969 Modified: trunk/packages/kdevplatform/debian/control Log: rename kdevplatform to kdevplatform1-libs Thank you very much. /Sune --

testing kaboom - how to?

2009-03-15 Thread Sune Vuorela
Hi! I guess we are about a stage now where we need to figure out the exact steps on how to get the kde324 migration app, kaboom, full scale tested across the users of experimental. First, we need to get a list of remaining issues that we know should get fixed. Then, I think we should upload a

this maillist

2009-03-18 Thread Sune Vuorela
Hi! Just to make everything clear. This list is *not* intended for user support in any way. Replies to user support questions should have a firm, but friendly, message about *not* using this list for user support, and instead use debian- k...@lists.debian.org Friendly, Sune -- How to explore

Re: [Pkg-kde-extras] Bug#504109: Bug#504109: please provide a kde4 version of kdebluetooth

2009-03-23 Thread Sune Vuorela
On Tuesday 17 March 2009 12:10:50 Sune Vuorela wrote: On Tuesday 17 March 2009 11:38:14 Peter Eisentraut wrote: Is anyone working on this? If not, would anyone mind if I prepare this package in the kde-extras SVN for upload to experimental? I'm already a member of pkg-kde

Re: testing kaboom - how to?

2009-03-23 Thread Sune Vuorela
On Monday 16 March 2009 00:18:34 George Kiagiadakis wrote: 2009/3/15 Sune Vuorela deb...@pusling.com: Hi! I guess we are about a stage now where we need to figure out the exact steps on how to get the kde324 migration app, kaboom, full scale tested across the users of experimental

kde4 in unstable blockers ?

2009-04-03 Thread Sune Vuorela
Hi! I know Modestas plans to do some debconf warnings in preinst of kdelibs. (can be stolen from virtualbox/lenny) There is also a few issues in kaboom, one related to ktorrent, which I didn't hit. I don't know how serious this is. Any comments? Was the running under nonexistant locale really

Re: meta-kde4 and meta-kde

2009-04-06 Thread Sune Vuorela
On Tuesday 07 April 2009 06:49:33 Ana Guerrero wrote: What do you think? What is your proposal here?. do s/kde4/kde/ across meta-kde4 - and maybe make kde-minimal provide kde-core. And maybe rename kde meta package to kde-full. And nothing else. /Sune -- How can I load the bus to the

Re: meta-kde4 and meta-kde

2009-04-08 Thread Sune Vuorela
On Wednesday 08 April 2009 20:31:04 Rainer Kluge wrote: Ana Guerrero schrieb: - kde-minimal (just rename current kde4-mininal) I am not sure kde-core longer fits. - kde-full (renamed from current kde4) I agree it is clearer than kde. The real question is about the need of the

Re: Bug#523899: Stop providing KDE 3 support

2009-04-13 Thread Sune Vuorela
On Monday 13 April 2009 15:35:08 Ana Guerrero wrote: about -kde is supposed to show it integrated with kde4/qt4 and if that is working (i have not checked), it will be kde3/qt3 and you have to install kdelibs from kde3 that some users might have ride of already. I agree that kde3 integration

Re: Bug#526852: diff of the debian directory

2009-05-05 Thread Sune Vuorela
(I'm moving this out of the bug and over to the packagers coordination list pkg-kde-talk@lists.alioth.debian.org, as this is no longer specific to this bug) On Tuesday 05 May 2009 09:42:13 Praveen A wrote: 2009/5/4 Sune Vuorela s...@vuorela.dk: A quick review shows that something python

Re: Bug#526852: diff of the debian directory

2009-05-05 Thread Sune Vuorela
On Tuesday 05 May 2009 12:03:56 Praveen A wrote: 2009/5/5 Sune Vuorela s...@vuorela.dk: Your first steps is to take a look at http://pkg-kde.alioth.debian.org/join.html and create a account on alioth.debian.org and ask for project membership to pkg-kde. I already have an alioth account (I

Re: qt4-x11 Kubuntu Debian diff

2009-05-11 Thread Sune Vuorela
On Tuesday 12 May 2009 01:40:12 Jonathan Riddell wrote: pkg-kde-tools is merged and adds a bunch of stuff for Launchpad Translations which won't be interesting to Debian (well possibly if tdebs come along, I don't know). Erm. what's pkg-kde-tools doing in Qt ? ;)

Re: libkexiv2, kdegraphics, and libkexiv2-7-dev

2009-05-12 Thread Sune Vuorela
On Tuesday 12 May 2009 11:50:53 Adeodato Simó wrote: Hello, KDE people. I notice kdegraphics 4.2.2 provides a libkexiv2-7 binary, which is is a higher SONAME than the one provided by the libkexiv2 source package both in unstable and experimental. Does this mean the libkexiv2 source package,

Re: Pushing kde4 into testing

2009-05-12 Thread Sune Vuorela
On Tuesday 12 May 2009 12:29:14 Adeodato Simó wrote: |knights (= 0.6-8.2): FAILED |The following constraints cannot be satisfied: | knights (= 0.6-8.2) depends on kdebase-kio-plugins {NOT AVAILABLE} Package unmaintained and up for adoption - and haven't had a maintainer upload since

Re: [Pkg-kde-extras] krecipes and team membership

2009-06-04 Thread Sune Vuorela
On Thursday 04 June 2009 17:10:21 Michael Meskes wrote: On Thu, Jun 04, 2009 at 03:26:57PM +0200, Fathi Boudra wrote: CC'ed -talk to get feedback from others people in the project. For the record, I proposed sponsors requests should be done on -talk mailing list. It's a low traffic

Re: [Pkg-kde-extras] krecipes and team membership

2009-06-04 Thread Sune Vuorela
On Thursday 04 June 2009 18:29:58 Matthias Julius wrote: How has this matter been handled so far? There are a number of non-DD members here. How do they get their packages uploaded? Do they all have a DD as co-maintainer? It varies, but usually in some way, irc ends up being involved, as I

big plans for kde4.3.x ?

2009-07-02 Thread Sune Vuorela
Hi! (mail style: brief, but friendly) If any of you have big plans for packaigng changes regarding kde4.3.0, now is the time to speak up with your plans and a timeline for accomplishing it and/or mentioning what help you need from others to accomplish it. Especially plans that requires NEW

Re: metapackage for lokalize

2009-07-12 Thread Sune Vuorela
On Thursday 09 July 2009 08:21:17 Nick Shaforostoff wrote: And your first commit looks good. One thing though, please add a changelog entry. I currently added a dummy entry for you ;) should I somehow communicate my changes to ubuntu? or they are on their own? I think they sync from time

Re: Upgrade path from KDE 3 to KDE 4

2009-08-21 Thread Sune Vuorela
On Friday 21 August 2009 12:41:50 Armin Berres wrote: Hi everybody! We invested a lot of time to make the upgrade from KDE 3 to KDE 4 as smooth as possible. Sadly, there are still some more or less rough edges. The most important issue I have on my radar is the installation of

Re: KDE plans for the squeeze cycle

2009-08-23 Thread Sune Vuorela
Hi In our response, I think we should really avoid mentioning at all a possible freeze in december 2009, as this is not what we are asked about. We are asked about what we would like to see in a release and when we can get that. So: * Which major upstream releases of KDE are expected in the

Re: Switch to orig.tar.bz2 dpkg-source format 3.0 (quilt)?

2009-11-02 Thread Sune Vuorela
On Monday 02 November 2009 19:35:11 Modestas Vainius wrote: Hello, since Debian ftpmasters have made it possible to upload source packages packaged in the next generation formats: 1) I don't see any blockers to use pristine KDE upstream tarballs anymore (renamed to appropriate

Re: rev 18367 - in krap/libdbusmenu-qt/trunk/debian: . patches

2010-06-16 Thread Sune Vuorela
changes if needed This makes the debian package effectively GPLv3+, and it will trigger license violations when actually used by KDE SC where there still is gplv2only software. Thanks in advance, /Sune Vuorela -- How to forward from the LCD CPU? First you can't forward to the 3Dfx virus

Re: Switching KDE packaging to git

2010-07-12 Thread Sune Vuorela
On Sunday 11 July 2010 19:38:29 Fathi Boudra wrote: Hi, 1) We would use the same workflow as for qt4-x11.git, i.e. no upstream branch. It proved to be fine, didn't it? Fathi, you worked most with qt4-x11.git, is there anything you would like to be changed? nothing to change, I like the

Re: Switching KDE packaging to git

2010-07-12 Thread Sune Vuorela
On Monday 12 July 2010 10:47:42 Michael Meskes wrote: Do we move all of kde-extras to git too? I think this is up to kde-extras people. And if KDE extras people want to stay parted in svn and git, I think that should also be allowed. /Sune -- How to boot from the desktop? You must install a

Reviving the Kde Debconf frontend

2010-07-14 Thread Sune Vuorela
Hi I have worked at Akademy (kde conference) and a bit after getting home to try revive the debconf Kde frontend, and I think I'm currently at a state where a bit wider testing and feedback would be nice. perlqt4 sources can be found at:

Re: [Debconf-devel] Reviving the Kde Debconf frontend

2010-07-24 Thread Sune Vuorela
On Wednesday 14 July 2010 12:24:14 Sune Vuorela wrote: Hi perlqt4 sources can be found at: http://alioth.debian.org/~pusling-guest/qt4-perl_4.5~~svn1145508-1.dsc As this is my first perl package, I have asked teh debian perl guys to review it before upload. This entered debian unstable some

Re: Qt Patches

2010-11-17 Thread Sune Vuorela
On Wednesday 17 November 2010 15:57:52 Jonathan Riddell wrote: 07_trust_dpkg-arch_over_uname-m.diff sune wasn't sure but can likely be dropped The underlying bug is fixed, but we need it around for backwards compatibility reasons with apps that might or might not have been rebuilt since

removal of phonon-backend-xine

2012-01-15 Thread Sune Vuorela
Hi I think we should remove the xine backend from the archive - it is completely abandoned upstream - it is broken for amarok users - it is buggy - it is installed by default in stable, so users won't automaticalyl get migrated away from it - kde multimedia upstream is getting drowned in

Re: removal of phonon-backend-xine

2012-01-22 Thread Sune Vuorela
On Sunday 15 January 2012 13:45:39 Sune Vuorela wrote: Hi I think we should remove the xine backend from the archive I've set it in motion /Sune -- How could I ping a line? You should open a mailer and you neither have to send the parallel clock, nor must click with the sendmail to a RO

libkipi abi oops

2012-09-25 Thread Sune Vuorela
Hi Someone noticed a abi change that I didn't notice at the upload of the latest libkipi upstream release (bug 682593). The state of the archive is that everything built after the upload on june 17th is built against new abi. everything built before is built using the old abi. The abi change

Re: plans for qtsingleapplication

2013-06-05 Thread Sune Vuorela
On Wednesday 05 June 2013 02:37:21 Sandro Knauß wrote: Hello, I started packaging owncloud-client [1] and there the question pops up, if there are a plan to put qtsingleapplication and qtlockedfile in seperate packages. codesearch.d.n gives many packages (kudu, qbittorrent, smplayer, ...),

Re: Qt5 switching qreal from float to double on arm*

2013-11-09 Thread Sune Vuorela
On Saturday 09 November 2013 10:22:44 Philipp Kern wrote: What is your plan to support partial upgrades? BinNMUs can require new Qt versions to be installed, but Qt can be upgraded independently to the newer version, causing the rdepends to crash. This can potentially be solved by Breaks, but

Re: qt4's qtwebkit, phonon and gstreamer [0.10 1.0]

2014-09-12 Thread Sune Vuorela
On Thursday 11 September 2014 16:37:25 Lisandro Damián Nicanor Pérez Meyer wrote: As you already may know, we have a new qtwebkit version in unstable which is currently FTBFS. This seems to be fixed with the latest patch. But this webkit version links against gstreamer 1.0. We currently have

Stopping the svn extra layer of permissions

2014-11-09 Thread Sune Vuorela
Hi We have historically had when most stuff was in svn a set of commit rules to allow some people to only access kde-extras packages and such. Given it is mostly old kde-extras packages that are left in svn, I think this extra layer of things is unneeded by now, and I suggest to remove the

Re: Moving forward on fixing bug 721938

2015-04-22 Thread Sune Vuorela
On Wednesday 22 April 2015 14:51:32 Rohan Garg wrote: So far I haven't seen a good reason not to include the patch ( from what I've gathered talking to people on IRC ) It is the other way around. We don't need reasons why not to include things. We need reasons to include it, despite not being

Re: pkg-kde-tools build type debian

2015-05-12 Thread Sune Vuorela
On Wednesday 13 May 2015 00:30:19 Lisandro Damián Nicanor Pérez Meyer wrote: On Tuesday 12 May 2015 23:25:18 Sune Vuorela wrote: On Tuesday 12 May 2015 13:04:42 Lisandro Damián Nicanor Pérez Meyer wrote: * -O2 is removed to let dpkg-buildflags use whatever we decide in Debian should

pkg-kde team meeting at debconf

2015-08-16 Thread Sune Vuorela
Hi Maxy has scheduled a pkg-kde team meeting in Wien (yes. that's a room name) tomorrow monday at 17.00-18.00. See you there hopefully. /Sune -- http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-kde-talk

Re: pkg-kde team meeting at debconf

2015-08-18 Thread Sune Vuorela
On Sunday 16 August 2015 19:31:40 Sune Vuorela wrote: Hi Maxy has scheduled a pkg-kde team meeting in Wien (yes. that's a room name) tomorrow monday at 17.00-18.00. My rough notes PKG-KDE TEAM meeting AGENDA Presentation - maxy tells who he is. Talks about his script - Sune talked about

Re: kdecoration2 mess - std::function makes the world fun

2015-08-21 Thread Sune Vuorela
On Friday 21 August 2015 11:01:49 Matthias Klose wrote: 1) Immediately binNMU src:kdecoration2 in testing, then when that is done, binNMU src:kwin, src:oxygen and src:breeze all in testing. (that's for release team) this won't work, the GCC 5 in testing is not built using the dual

Re: Setting QT_SELECT globally via debian-qt-kde.mk v3

2015-11-09 Thread Sune Vuorela
On Tuesday 10 November 2015 01:25:24 Rohan Garg wrote: > Hey > > > Ah, it uses qmake to know where the Qt plugins are possibly (ie, qmake - > > query)? In that case yes, it is a good idea to set it up. > > Yep, exactly. Isn't there a cmake variable that tells where qmake is, so we don't have to

Re: Keeping the Qt5 stack together: some ideas

2015-10-30 Thread Sune Vuorela
On Thursday 29 October 2015 17:46:12 Lisandro Damián Nicanor Pérez Meyer wrote: > - it turned out to not use any symbol from qtbase >= 5.5.x, so after being > built it's dependencies got satisfied with testing's ones. > > Except it broke. > > a) Suggested by Adam Majer and improved by Felix

Re: Enabling accessibility stack by default in Qt4/Qt5

2015-10-18 Thread Sune Vuorela
On Sunday 18 October 2015 17:24:59 Samuel Thibault wrote: > Hello, > > Could the qt-at-spi package be depended on by e.g. libqtcore4? Hi I guess one could put in a suggests somewhere, or maybe even a recommends, but having it as a dependency would be making a dependency circle which I really

Re: Enabling accessibility stack by default in Qt4/Qt5

2015-12-30 Thread Sune Vuorela
On Friday 11 December 2015 23:41:00 Samuel Thibault wrote: > Lisandro Damián Nicanor Pérez Meyer, on Fri 11 Dec 2015 18:11:40 -0300, wrote: > > Ah, now I get it. Please go ahead. > > Good, now done! Konqueror seems to crash for me now. Removing qt-at-spi fixes it. I don't know if there are

Re: Digikam

2015-12-20 Thread Sune Vuorela
On Sunday 20 December 2015 11:21:05 Steve M. Robbins wrote: > Hi Lisandro, > > On December 20, 2015 01:18:31 PM Lisandro Damián Nicanor Pérez Meyer wrote: > > On Saturday 19 December 2015 23:58:34 Steve M. Robbins wrote: > > > I found the config file (commit-access-control.cfg). Who is able to >

Re: Bug#810124: digikam: Does not show albums until kbuildsycoca is manually called

2016-01-10 Thread Sune Vuorela
On Saturday 09 January 2016 15:01:19 Steve M. Robbins wrote: > Hi, > > I recently picked up maintenance of digikam and haven't finished ramping up > on KDE internals... > > I received the following bug report. I haven't noticed this problem myself, > so it makes me wonder: > > 1. When,

Re: Digikam 5.0.0 uploaded

2016-07-11 Thread Sune Vuorela
On Sunday 10 July 2016 14:01:04 Steve M. Robbins wrote: > 2. The configuration files are in a new location, but digikam does no > migration [1]. To the user, it appears you are starting from scratch and > there is a risk of confusion -- the referenced bug is from someone who > thought

Re: QtWebEngine build fails

2016-12-25 Thread Sune Vuorela
Hi Unfortunately the build logs does not show the compiler invocations, so it is a bit hard to guess what's going on. But at least with webkit, we had to forcefully disable debug symbols to get stuff to build. dwarf2 is huge. and webengine is huge. So start by checking that - and please make