This is an automated email from the git hooks/post-receive script.

gregoa pushed a change to annotated tag upstream/0.37
in repository libcourriel-perl.

        at  087e9cb   (tag)
   tagging  a4ac52fa6879c01fb408de6e9ae8ea98061769b9 (commit)
  replaces  upstream/0.36
 tagged by  gregor herrmann
        on  Sat May 9 22:25:31 2015 +0200

- Log -----------------------------------------------------------------
Upstream version 0.37

Dave Rolsky (357):
      initial checkin
      Test against real headers
      Add some tests for bad headers
      Tighten up regex to catch some bad header variations
      add some tests for Part::Single
      remove some unused code
      move headers to shared part role, add ContentType type
      Started testing Courriel.pm
      Tests for Courriel.pm
      get part parsing to actually work
      Courriel is really just a thing wrapper around a part
      add some benchmark code
      add datetime method
      Add recipients and participants methods
      Add new Disposition class
      Get header MIME encoding/decoding to not be totally broken.
      Add a test for round tripping all Chinese header
      Add more tests for mime encoded words in headers
      Formatting tweaks
      add as_string method
      Start working on docs, which means lots of little API tweaks too
      Wrap line sep re in parens for safety
      Tidy code
      Docs for Headers
      small doc tweaks
      add pod coverage & spelling tests
      Skip Courriel::Helpers
      Docs for Courriel
      CPAN Changes test
      add $NEXT token
      lots of docs and some API changes
      Pod coverage is manual
      No need for Hash::MultiValue
      Include prereqs
      Add CREDITS section
      Add more words to whitelist
      Always trust BUILD method
      fix some small doc errors
      Can't use EOLTests for now
      s/v5/5/
      Add .gitignore
      v0.01
      a bunch of small doc fixes
      Handle escaped backslash and quoted in header attribute values
      Changes for next release
      Properly unescape all escaped values in a quoted attr string
      Add content-disposition to test multipart emalis
      Connect Content-Type and -Disposition headers to their respective objects 
more closely.
      Only add value from ContentType or Disposition object to headers if one 
is explicitly provided.
      Add Headers->replace and use it where appropriate.
      Add some test for Multipart parts
      Make sure boundary in Multipart object and ContentType object stay in sync
      More changes for next release
      Allow passing unencoded content to the Single part constructor, and 
create raw_content as needed
      s/raw_content/encoded_content/ - this is a lot clearer
      Doc encoded_content change
      Add _set_headers method, and make sure content-type stays in sync
      Allow setting disposition in a Single part as an object, and make sure it 
stays in sync with the headers
      use MX::StrictConstructor in all classes
      Changes for explicit disposition
      More about change
      Add some new prereqs
      Builder module - has some tests but needs a bunch more
      some more builder tests.
      Add test for bad args to build_email
      Builder is working and reasonable well tested
      add validation to all function in Builder
      Rename _part to top_level_part and add replace_part method (for 
Email::Abstract)
      Make the replace_body method work
      Add mention Email::Abstract hacks
      Doc text_body -> plain_body change
      Allow setting filename, mime type, and content id for all attachments.
      Tidy code
      Remove some TODO items
      Clarify why Mail::Box is complex
      Tests for clone_without_attachments
      Add all_parts_matching method
      Reorder changes by importance (ish)
      Don't doc Courriel->replace_body
      add some missing docs
      Add more words to whitelist
      doc clone_without_attachments
      Doc clone_without_attachments addition
      Bump version
      v0.02
      Ensure that encoding attribute is always synced with headers
      Changes for 0.03
      Bump version
      v0.03
      Add File::LibMagic prereq
      Bump version
      Changes for 0.04
      v0.04
      Test clone_without_attachments for email with multi/alt body
      Changes for 0.05
      Bump version
      v0.05
      Add File::Slurp as test prereq
      Move encoding attr to Single part.
      Cannot get default encoding from headers or we have a circular dep issue
      When creating a clone, set encoding in new Single part based on old part
      Changes for 0.06
      Bump version
      v0.06
      Loosen up mime type check for perl code
      Bump version
      Changes for 0.07
      v0.07
      wrap Content-ID in brackets
      Make content & encoded_content return a string rather than a ref
      Bump version
      v0.08
      Add Email::Abstract plugin to distro
      Changes for 0.09
      Bump version
      v0.09
      set_body does work
      No need to require a specific version of Courriel since this ships with 
Courriel itself
      Add tests for using Courriel with Email::Sender
      Test that transfer encoding is preserved during clone
      Put some more vertical whitespace around parts
      Tidy all code
      make sure that parsing sets the encoding properly for parts that are 
parsed
      Changes for 0.10
      Bump version
      v0.10
      add MIME-Version: 1.0 in Builder
      Bump version
      v0.11
      Encode/decode character set for content/encoded content
      Doc cleanup for encoding/decoding
      Make sure that content is always run through Encode even if transfer 
encoding is 8bit, etc.
      Bump version
      Tweak changes text
      fix test to expect properly encoded bytes in quoted-printable
      v0.12
      s/needed/required/
      Formatting tweaks
      fix a bug where the Content-Type did not have a boundary attribute set 
properly
      Changes for content-type boundary bug
      Don't mess with line endings of unencoded content
      Changes for CRLF fix
      test that attachment content matches original
      Don't mess with encoded content line endings either
      Changes for 0.13
      Another test for content round tripping
      Recommend that encoding not be set
      Recommend passing content
      Bump version
      v0.13
      Don't decode binary data into character data.
      Bump version
      v0.14
      Return $bytes as ref
      Skip test which sometimes fails except on my machines
      Changs for 0.15
      Bump version
      v0.15
      add ->from, ->to, and ->cc methods
      Add some more pod tests
      Skip all tests for mime type of perl script except for release testing
      Doc test fix
      Bump version
      v0.16
      tidy all code
      no need for Courriel::Role::Headers
      Remove Role::HasParts, since the only thing which consumed it was 
Part::Multipart
      ignore case of mime type
      Revamp case handling of mime type - save original casing in ContentType 
object but make ->mime_type return lc value
      Allow a continuation line in the header with no content beyond its 
initial whitespace - probably not RFC compliant but it apparently happens
      Need Test::Requires
      Added stress tests
      handle more broken headers without an exception
      Make part parsing a little less picky
      Make mbox separator removal much more accepting of broken separators
      Show unparseable chunk in error message
      Handle empty headers cleanly
      add more tests for weird cases
      Handle more broken From lines
      Don't blow up on totally bogus headers, just return empty headers
      Stress tests pass
      Remove unreachable die
      Test totally broken multipart message with no boundaries
      Changes for next release
      Bump version
      v0.17
      s/$mail/$text/g
      Small formatting fix
      No need for Test::Differences
      Explicitly handle charste of "unknown-8bit" when decoding part content
      Don't load Email::MIME
      Try harder to find a date for the email
      Changes for next version
      More changes for next release
      Clarify handling of broken email addresses in headers
      This seems to be about mbox handling, which isn't really a Courriel issue
      explicitly test some weird cases
      Changes clarification
      Bump version
      Refactor datetime extraction a bit
      get dates from Received in reverse order, and expect UTC
      v0.18
      Explicitly set all DateTimes to UTC for comparisons
      When comparing datetimes, use strftime to compare strings
      Changes for next release
      Bump version
      set all DateTime objects to UTC
      v0.19
      Massive refactoring of how headers are handled
      Add Scalar::Util dep
      Parse encoded header attributes correctly, as well as continuation lines
      Make $TSPECIALS a regex
      No need to escape backslash in qr
      first stab at proper encoding of header parameters
      s/\x07f/\x7f/
      Formatting fix
      Handle no language in an encoded parameter properly
      Enforce UTF-8 for non-ascii data via constructor
      tests for header attribute formatting
      Skip Courriel::ContentType and ::Disposition
      Add some tests for ContentType object
      Make HeaderWithAttributes a parameterized role to share more code between 
CT and Disp
      Add docs for all modules.
      various doc/pod fixes
      Add section about robustness principle
      Changes for next release
      Bump version
      Add Postel's
      Ignore _trial_temp dir
      v0.20
      Add another utf-8 decoding test
      Fix dumb typo in range for decoding substitution
      add attribute_value method for headers with attributes
      Fix docs for ->get_attribute, replace with ->attribute & ->attribute_value
      Add Headers->get_values()
      Mention Courriel::Header in Headers docs
      s/RFC/RFC /
      Changes for next release
      Bump version
      v0.21
      Add rt ticket info
      Require List::Moreutils 0.28+
      Sort prereqs
      Update prereqs
      More changes for next release
      Bump version
      Fix spelling of MoreUtils
      v0.22
      Allow passing both binary & character data to Courriel->parse
      small doc tweaks
      Doc is_binary flag for Courriel->parse
      Doc is_binary flag in Changes
      Bump version
      v0.23
      Fix grammar in pod
      Replace is_binary with is_character
      Changes for is_character
      Bump version
      Credit zby for change
      v0.24
      Move header mime encoding into Courriel::Header
      Make sure whitespace is preserved properly when mime-encoding header 
values
      Always need a space between an encoded chunk and anything that follows it
      Add a test to ensure that we only encode chunks that have unicode
      Doc as_header_string method
      Make section names match the ones we use with Moose
      Bump version
      Changes for next release - header encoding fixes
      s/L/C/
      v0.25
      Add missing prereq - MooseX::Role::Parameterized
      Changes for next release
      Bump version
      LinkCheck consistently reported a bad link where none exists
      v0.26
      s/\2/\g{2}/
      s/as_header_string/as_string/g
      Added a stream_to API for all objects which stringify
      Mention stream_to API in Changes
      Remove extra line break
      Add docs for Courriel->stream_to
      small doc fixes for stream_to
      Bump version
      v0.27
      Add missing make_immutable
      Add lookup to spelling whitelist
      Allow case-insensitive attribute lookup
      Bump version
      s/use base/use parent/
      Use autoprereqs
      v0.28
      Use :encoding(UTF-8) instead of :utf8
      No need for CheckChangeLog plugin
      Merge remote-tracking branch 'zby/master'
      Use proper types and allow an empty subject in Builder too
      Changes for next release
      Bump version
      v0.29
      Remove bcc "header" support in Courriel::Builder
      Changes for next release
      Bump version
      v0.30
      Typo fix in Changes
      Small grammar fix
      Doc fixes
      Remove old comment
      Add Sendgrid example
      Require Perl 5.10
      Remove alpha warning
      Bump version
      Update test plugins
      Add BUGS and DONATIONS to docs
      Add contributors to META.* & docs
      Add names to spelling whitelist
      v0.31
      Fix comment - RFC5322 does specify how folding whitespace is treated
      Fix typo in pod
      Make Courriel much laxer about line endings
      Bump version
      Remove long deprecated modules
      Add [Encoding] directive for images
      Add =encoding directive to all POD
      Temporarily disable LinkCheck test
      v0.32
      Fix tests that fail with latest DT::F::Mail
      Bump version
      v0.33
      Relax date header regex more
      Bump version
      v0.34
      Replace File::Slurp with File::Slurp::Tiny
      Bump version
      v0.35
      Merge pull request #2 from oschwald/greg/allow-whitespace-prefix
      Changes for space in header fix
      Handle a set of chunks with no text, just whitespace when encoding a 
header
      Remove links to roles without POD
      Switch to DROLSKY plugin bundle
      v0.36
      Merge pull request #3 from rjbs/patch-1
      Require MX::PV 0.21 and fix failing test with changed error message
      Add generated files
      Add $VERSION to all modules
      EOLTests is not Test::EOL
      ispell apparently spell checks "Postel's" as "Postel" now
      Tidying and critic fixes
      Ignore .tidyall.d dir
      Add more generated files
      Add .travis.yml
      Add Email::Sender to TestRecommends
      Update generated files
      Install libmagic-dev for File::LibMagic in .travis.yml
      Add Pod::Coverage::Moose to DevelopRequires
      more tidying
      Only test MIME type detection on my desktop machine
      Add Path::Class to TestRecommends
      v0.37

Gregory Oschwald (1):
      Allow headers with whitespace prefixes

Ricardo Signes (1):
      don't call character strings "utf-8 encoded"

Zbigniew Łukasiak (1):
      People often send emails with empty subjects

gregor herrmann (1):
      Imported Upstream version 0.37

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-perl/packages/libcourriel-perl.git

_______________________________________________
Pkg-perl-cvs-commits mailing list
Pkg-perl-cvs-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-perl-cvs-commits

Reply via email to