This is an automated email from the git hooks/post-receive script.

js pushed a change to annotated tag v0.09
in repository libweb-machine-perl.

        at  8e2d3c5   (tag)
   tagging  204712bacca94ba5ee7111eeaf01fd809958c26d (commit)
 tagged by  Dave Rolsky
        on  Wed Mar 27 11:02:13 2013 -0500

- Log -----------------------------------------------------------------
v0.09

Andrew Nelson (1):
      HEAD should not return a message body, per the spec.

Dave Rolsky (21):
      Test for is_authorized state returning undef
      Check that $result is defined in the is_authorized state to avoid a 
warning
      Doc uninit value warning fix in Changes
      When a resource throws an error, log it
      Add bugtracker and repository meta info to dist.ini
      Merge pull request #6 from oalders/master
      Remove unneeded word
      Fix reference to nonexistent package
      Add some additional dzil test plugins
      s/conneg/content negotiation/
      Add spelling test and fix a bunch of spelling/capitalization errors
      Update .gitignore
      Add ContributorsFromGit plugin to dzil and Contributors to Pod Weaver
      Changes for next release
      Use NextRelease dzil plugin
      Small Changes formatting tweaks for consistency
      Add InstallGuide and MetaJSON dzil plugins
      Make sure all prereqs are declared in code
      Add CheckPrereqsIndexed and @Git dzil plugins
      Bump version
      v0.09

Fayland Lam (1):
      fix charsets_provided default to [] so that choose_charset will not be 
broken

Gregory Oschwald (1):
      Added failing test for 500 received with malformed auth header.

Jesse Luehrs (15):
      skip tests properly
      don't rely on header order in this test
      fix pod
      fix test name typo
      allow io handle responses too
      implement streaming
      Content-Type is a required header, according to PSGI
      add long poll test
      don't require json
      remove the separate metadata variable
      move content filters out of the metadata
      more refactoring
      support push streaming too
      allow passing args to resource constructors
      fix test dependencies

John SJ Anderson (1):
      Add AutoPrereqs to dist.ini

Olaf Alders (2):
      Fixes Pod error in Web::Machine::Resource
      Fixes chronology of Changes.

Stevan Little (232):
      add in the files so far
      more translation from ruby
      add the media type and the tests
      add the priority list and test
      add the new_from_header constructor
      change name of the ->parse method
      need to make sure this exists first
      to_string method and tests
      adding the MediaTypeList (subclass of PriorityList)
      be greedy about parsing params
      correct testing here now
      make the params hash ordered and test the stringification
      add some failure tests for equality
      tweaked the test to do what I really want
      need to reverse sort it, best one wins
      first content negotiation functions and tests
      adding in this stuff, not sure if this is worth the headache right now
      just inline the regexp
      I don't need an ordered hash here
      just some notes
      do proper sorting of specificity
      properly sort items with the same priority
      tests derived from RFC-2616 section 14
      move states to their own package
      de-Moose-ify
      move this test since it is only media type specific
      implement the language choosing
      remove that inner reverse, it is not correct for things other then media 
types for some reason
      move this logic into here so that we can be specific on media types
      adding in a dist.ini
      dist ini
      don't need this, it is in the metadata
      this shouldn't stringify on its own
      this should overload "" though
      this needs to return something
      this is the format we are working with
      charset negotiation
      adding comments for each state, also fixing up the Accept header stuff, 
the Accept-Language stuff and the Accept-Charset stuff
      encoding choosing
      re-arrange code and add unquote header
      handle the change in the Utils importer
      change data type here
      change in imports for Util and adding in the encoding import
      check point commit, going well here
      cleaning up the test
      removing some debugging
      don't need this hack anymore
      moosify;
      removing some unnecessary dependencies and replacing them with the 
equivalent. Also removing the use of JSON::XS boolean values and just using 
standard perl bools.
      cleaning up the dist.ini more
      accept_helper
      n11 implementation
      add in the state description hash, to provide more info for the state 
descriptions
      add in new function for finding an acceptable media type
      implement the body encoding helpers
      add in the new helpers and finish up a few more states
      partial docs
      since this is called as a method, we need to return the second item in @_
      remember to import stuff we are using
      make sure we have something to call as an array, and make sure we return 
the second element in @_ because we call this as a method
      all done!
      we can handle the debugging later
      cleaning up, yeah I know, totally anal
      make this into a proper test
      I shouldn't be providing defaults here, cause not everything is gonna 
render HTML
      which means I have to add this
      include a read me too
      spelling is hard
      forgot this method
      didn't check the code on this well enough, so changing it accordingly
      had the arguments backwards here, whoops
      charsets_provided should return undef by default so that the 
short-circuiting happens correctly
      handle Plack response bodies correctly, whoops
      fix this test
      finish converting the docs
      if language just returned true, then we should not put it in the  header
      return true if nothing is found
      actually, this is more correct
      handle the short circuiting where appropriate
      short circuit here
      handle the short circuiting correctly
      handle the short circuiting correctly in the tests
      add an example app that can be run with plackup
      add debugging flag
      I am pretty sure this is the correct behavior, but I have an email out to 
the ruby port author to confirm
      tweaking the README
      numifying things actually causes issues, better to leave them as strings 
and let alpha sort just work
      this is just wrong, so lets remove that
      these match some of the simple cases in the Erlang version
      be more explicit about checking these conditions, again to better match 
the Erlang version
      correct these tests
      this is wrong, not sure why it is in the ruby version, but it is not in 
the Erlang version (best i can tell) so I am removing it
      better translate this call from the Ruby to work as expected
      add in the test with the more extensive headers
      make this more idiomatic perl
      get state descriptions as well
      add a little more to the debugging
      move stuff to the util module
      convert everything over to using HASH ref pairs and enforce use of 
pair_{key, value} accessors
      adjust this for the new pairs
      make sure to properly construct the body here
      need to be detecting and handling this exception case
      need to extract the pair-key here
      add context to the resource, kinda ugly, but meh it works for now
      quick version of the ENV resource example app, missing a few bits, but 
mostly there
      actually, the resource itself should decide what kind of state it wants 
to keep
      little code cleanup
      renaming the folder for consistency
      i am anal like this, yeah, its bad
      code cleanup and syntax error fix
      two example tests
      some more tests
      no need to let these be assignable from the constructor, they are internal
      make JSON::XS an optional sep
      remove Moose usage
      adding in tests for all the states (based largely on the nodemachine test 
suite)
      more resource tests
      ...even more resource tests
      more tests
      more tests
      small fix
      gitignore
      more tests
      sometimes the chosen-charset is not set
      more tests
      found a bug!
      more tests
      adding in support for tracing via the FSM
      clean out stuff we don't actually need in the request
      forgot this method, whoops
      add in tracing checks
      response doesn't actually have that method
      some URI usage cleanup
      more tests
      using commas is more HTTPish I think
      fixing the redirect stuff, adding in all the new tests and changing some 
tests too
      ignore the nytprof stuff
      more test changes
      fixing the tests s/:/,/
      tweaking the error conditions some and adding tests
      remove any/includes in favor of grep
      bunch more resource tests
      thats the last of the resource tests, this should have 100% (ish) 
coverage now
      making dzil and pod-weaver happy
      The start of some docs
      Web::Machine will load Web::Machine::FSM now
      docs and more docs.
      Merge pull request #1 from fayland/master
      these are needed for everything really, so might as well load them
      use HTTP::Headers::Util to parse headers, it is only sensible
      stop parsing our own headers, better to use HTTP::Headers::Util to do the 
dirty work
      make HTTP::Header::Util into Web::Machine::Utils and make them behave as 
I want (to avoid duplicated code), also do not lowercase all the keys and 
entries either, and also make the add_header_value private, cause we really 
don't need it externally
      Merge branch 'master' of github.com:stevan/webmachine-perl
      convert to Action Pack
      finish_request gets metadata
      add init
      notes
      make Web::Machine into a Plack::Component and document this
      breaking down the methods in call and documenting them
      adjusting tests for new features
      tweaks for the newly strict-ified HTTP::Headers::ActionPack, now all 
header params are quoted if they need it or not
      make these examples use the simpler API
      content negotiation should only inflate objects when needed
      simple path binding util
      return nothing, do not throw exception
      context sensitive results
      more bind_path tests
      convert the ENV example to use bind_path
      everything using and expecting object headers now
      more docs
      little example cleanup
      s/to_string/as_string/ for the change in HTTP::Headers::ActionPack;
      not sure why I never had this here
      basic infrastructure for some i18n handling
      return i18n error bodys
      TODO comments
      some basic i18n docs
      handle 304 responses correctly by stripping them of content headers and 
adding in the caching headers
      some examples for the upcoming YAPC talk
      bunch more examples for YAPC
      examples and tests for YAPC
      last test
      update the Auth example to use the ActionPack headers
      hide ActionPack a little, behind some util functions
      path binding example
      make sure to catch failure to create a language handle
      update this to match the actual slides
      add an example of tracing
      don't forget 418
      another demo
      clean up example and test
      refine this test to be better example
      show extension of existing resource
      make this not complain
      break down the post back examples even more (makes for better slides)
      formatting cleanup
      whoops
      more test
      apparently sometimes a filename can be too long, so I need to create them 
here with Path::Class instead
      clean up the pre-reqs
      HTTP::Headers::ActionPack requires MIME::Base64, so we don't need to 
require it anymore
      make a note to address this later
      release stuff
      Merge pull request #2 from genehack/patch-3
      fixing this so that if deps are missing it will still be a passing test
      0.02 release
      fixing the missing semicolon
      let people decide how they want to handle errors (adjust the tests 
accordingly)
      0.03
      improve the bind_path function and add tests
      changeloggin
      add in some more tests
      document the optional parameter and the edge cases
      changeloggin
      new test for frew
      add an accessor for our action pack instance
      all the content negotiation is now moved to HTTP::Headers::ActionPack
      updating changelog and dist.ini
      always use GMT to just avoid time zone issues
      0.04
      Merge pull request #3 from autarch/autarch/shut-up-uninit-warning
      Merge pull request #5 from autarch/autarch/dist-ini-has-repo
      Merge pull request #4 from autarch/autarch/log-errors
      Merge pull request #7 from doy/streaming
      0.06
      fix to allow for n11 to be bypassed
      test for the N11 bypass
      0.07
      0.08 (*sigh* today is not my day)
      Merge pull request #8 from oalders/master
      Merge pull request #9 from oschwald/greg/auth_500
      fixing the RT# 84232

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-perl/packages/libweb-machine-perl.git

_______________________________________________
Pkg-perl-cvs-commits mailing list
Pkg-perl-cvs-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-perl-cvs-commits

Reply via email to