D18245: [DrKonqi] Create QApplication in a scope to fix possible deadlock

2019-02-23 Thread Oswald Buddenhagen
ossi added subscribers: thiago, dfaure. ossi added a comment. the patch definitely looks like a hack, but i'll leave the final judgment on that to thiago. kcrash closes all file descriptors to make the crashed process appear "as gone as possible" to anyone who might have wanted to talk t

D11235: [DrKonqi] Request change of ptrace scope from KCrash

2019-01-24 Thread Oswald Buddenhagen
ossi accepted this revision. ossi added a comment. This revision is now accepted and ready to land. note that for extra correctness it should be "ancestor" not "parent". REPOSITORY R871 DrKonqi BRANCH ptracer REVISION DETAIL https://phabricator.kde.org/D11235 To: croick, #plasma_works

D11235: [DrKonqi] Request change of ptrace scope from KCrash

2019-01-17 Thread Oswald Buddenhagen
ossi added a comment. In D11235#395021 , @croick wrote: > What do you mean? The (internal) debugger is a child of the debuggee. yes, that's why you need setPtracer() - if crashtest was *under* gdb, that would be unnecessary. ;) (i'm sti

D11235: [DrKonqi] Request change of ptrace scope from KCrash

2019-01-17 Thread Oswald Buddenhagen
ossi added a comment. you got the parent-child ordering wrong in the commit message. ^^ INLINE COMMENTS > ptracer.cpp:61 > +char msg[msize], rmsg[msize]; > +int bytes = 0, r; > +sprintf(msg, "%lld", debuggerpid); this looks stupid, i'd swap the order. REPOSITORY R8

D11235: [DrKonqi] Request change of ptrace scope from KCrash

2019-01-16 Thread Oswald Buddenhagen
ossi added a comment. will also need to wait for commit message update, like the other change. INLINE COMMENTS > ptracer.cpp:92 > + > +qCWarning(DRKONQI_LOG) << "debugged process did not acknowledge setting > ptracer to" << debuggerpid; > +close(sfd); not wrong per se, but mildly mi

D11235: [DrKonqi] Request change of ptrace scope from KCrash

2019-01-16 Thread Oswald Buddenhagen
ossi requested changes to this revision. ossi added inline comments. This revision now requires changes to proceed. INLINE COMMENTS > ptracer.cpp:65 > +bytes += r; > +else if (r == -1 && !(errno == EINTR)) > +break; you really could just use != here ..

D11235: [DrKonqi] Request change of ptrace scope from KCrash

2019-01-16 Thread Oswald Buddenhagen
ossi requested changes to this revision. ossi added a comment. This revision now requires changes to proceed. mark handled issues as done here as well. INLINE COMMENTS > ptracer.cpp:47 > + > QStringLiteral("%1/kcrash_%2").arg(QStandardPaths::writableLocation(QStandardPaths::RuntimeLoc

D11235: [DrKonqi] Request change of ptrace scope from KCrash

2019-01-14 Thread Oswald Buddenhagen
ossi requested changes to this revision. ossi added inline comments. This revision now requires changes to proceed. INLINE COMMENTS > debuggerlaunchers.cpp:57 > if ( pid > 0 ) { > +queryPtrace(pid); > m_monitor->startMonitoring(pid); according to my reading of the documenta

Re: Review Request: Screen Locker daemon

2011-11-11 Thread Oswald Buddenhagen
u promise to personally coerce at least two and a half people to do Thorough Testing ™ for you. fwiw, i'd rename kscreenunlocker to ksld_greet for clarity and consistency with kdm. also, ksld is not too well chosen, as it does't naturally associate with anything - kscreenlocker should

Re: The future of Power Management - together with Activities

2011-10-06 Thread Oswald Buddenhagen
On Sat, Oct 01, 2011 at 08:33:06PM +0300, Andras Mantia wrote: > What I can say that I use the selection combo between the different > power management schemes from time to time, as I can do the same thing > (e.g developing so not anything like now I develop and then switch to > mail reading/wa