Re: new spec (lyricue)

2007-11-09 Thread Caleb Maclennan
On Fri, Nov 09, 2007 at 06:11:19PM -0700, Aria Stewart wrote: On Nov 9, 2007, at 5:49 PM, Andrzej Krzysztofowicz wrote: We try to keep the BuildRoot entry as the last in this section. Patch# just after Sources. Indeed. The ./adapter script in the SPECS repo does a lot of this. The

Re: new spec (lyricue)

2007-11-09 Thread Caleb Maclennan
Thanks for the pointers Andrzej. I am attaching an updated spec file with your changes. Caleb # $Revision:$, $Date:$ Summary:The GNU Lyric Display System Name: lyricue Version:1.9.6 Release:0.6 License:GPL Group: X11/Applications/Graphics URL:

Re: new spec (lyricue)

2007-11-09 Thread Caleb Maclennan
On Sat, Nov 10, 2007 at 04:16:36AM +0200, Elan Ruusamäe wrote: but rather using rpmbuildroot paths use relative %doc from builddir, then documents get compressed too: %doc docs/* Ok, this didn't quite make sense to me but I think I figured out what you were after. See if this fits the bill.

Amazon EC2 AMI for pld-linux

2008-08-25 Thread Caleb Maclennan
I have been working on setting up some servers using Amazons Elastic Cloud Computing offering. If anyone is interested, I have created a base image that can be used as a starting point for anyone else wishing to run PLD as an Amazon Machine Image. The process of getting a new image up and running

Commit access

2009-08-22 Thread Caleb Maclennan
Can somebody tell me who to get in touch with regarding commit access to PLD spec files? I requested access back in Nov of 2007 after submitting some patches and specs. I was +1'd by Aria and Krystian as well as feedback from Andrzej and Elan. I was then contacted and asked to turn in my desired

Re: new spec (lyricue)

2010-03-29 Thread Caleb Maclennan
around in dozens of locations) is making me dizzy. I have subscribed to the cvs commit list and will try to keep up with what's current that way. Caleb 2010/3/29 Elan Ruusamäe g...@pld-linux.org: On Monday 29 March 2010 14:48:05 Caleb Maclennan wrote: Question about log messages. I noticed

Re: packages: icedtea6/TODO (NEW), icedtea6/icedtea6.spec (NEW) - new package, ...

2010-04-15 Thread Caleb Maclennan
2010/4/14 Elan Ruusamäe g...@pld-linux.org: even now the version: tag matches Yes, the version tag matches, but the base package is different and they are in fact different versions! I looked at the upstream project files the other day and they apparently have different branches of the project

Adapter problem, difference between make and %{__make}

2010-04-23 Thread Caleb Maclennan
In an attempt to get emerillon packaged for PLD I've been working on specs for the two missing deps, librest and libethos. Librest went ok but I'm having fits with libethos. Most PLD packages use the macro %{__make} for the build, but for some reason that breaks the build whereas just make runs

Re: packages: flvtool2/flvtool2.spec, flvtool2/flvtool2-ruby19.patch (NEW) - up...

2010-05-01 Thread Caleb Maclennan
2010/5/1 caleb ca...@pld-linux.org: - patched setup script to run on ruby-1.9 +Patch0:                %{name}-ruby19.patch +%patch0 -p1 Some [widely bemoaned] changes to the way ruby handles string encoding from 1.8 to 1.9 require changes in some scripts to run reliably. I took a cue from

Re: Native upstart scripts

2010-05-04 Thread Caleb Maclennan
2010/5/4 Jacek Konieczny jaj...@jajcus.net: I think Upstart support should be implemented as an option, coexisting with current solution, so the administrator may choose what he prefers and even use init.d for some services and upstart for other. +1  - chkconfig would link/unlink the files

Arch / Locale packaging issue.

2010-06-15 Thread Caleb Maclennan
I'm having some trouble packaging trac-0.12. The current spec compiles, but the languages files are not generated properly. If I remove BuildArch: noarch, everything builds and runs fine but it doesn't seem that trac should be architecture specific just because of some locale files. What is the

Re: Arch / Locale packaging issue.

2010-06-15 Thread Caleb Maclennan
2010/6/15 Elan Ruusamäe g...@delfi.ee: yet it was missing python-genshi dep Thanks for sorting that and the rest of the lang file mess out. ___ pld-devel-en mailing list pld-devel-en@lists.pld-linux.org

Re: packages: GoogleEarth/GoogleEarth.spec - %lang

2010-08-18 Thread Caleb Maclennan
2010/8/18 Elan Ruusamäe g...@pld-linux.org: On 18/08/10 02:57, Caleb Maclennan wrote: 2010/8/16 glen g...@pld-linux.org:  %define                buildid 3533.1731 Where can the correct source package version be downloaded from or how should this be built? Building with the package from

Re: [PATCH] NetworkManager ModemManager

2010-09-25 Thread Caleb Maclennan
On Sat, Sep 25, 2010 at 19:21, Mariusz Mazur mma...@kernel.pl wrote: On Friday 13 of August 2010, Pawel Golaszewski wrote: I think we should give you chance to work on your own account. me: +1 +1 Anyone else? :) +1 ___ pld-devel-en mailing list

Re: [PATCH] NetworkManager ModemManager

2010-09-27 Thread Caleb Maclennan
On Mon, Sep 27, 2010 at 12:04, Tomasz Pala go...@polanet.pl wrote: Who? This voting is too stripped to know who about it is. If you follow the whole email thread this came up after Przemo Firszt prz...@firszt.eu sent in a bunch of stuff to be committed for NetworkManager. 2010/9/27 Elan

kernel-xenU on non-64bit EC2 instance

2010-10-01 Thread Caleb Maclennan
Alright guys I'm lost. I've been poking around in specs trying to figure this out and can't make out what I'm supposed to use or what I need to work on if there isn't the right thing available. I am trying to maintain several TH machines on i386 instances over on EC2. They have recently opened up

Re: packages: VirtualBox-bin/VirtualBox-bin.spec - Up to 3.2.10

2010-10-13 Thread Caleb Maclennan
On Wed, Oct 13, 2010 at 13:50, caleb ca...@pld-linux.org wrote: - Up to 3.2.10 Sorry guys neglected to mark this commit NFY without a release number. There are some path changes and such that need to be fixed in this upgrade, and I had only just started. The commit was just to switch to a

A couple questions about the website

2010-11-08 Thread Caleb Maclennan
Three questions about the main pld-linux.org site: 1) How does one get a working wiki user? I've tried signing up with my cvs editor name and with a WikiName and every other suggestion but no-way-no-how am I able to edit the wiki pages. 2) How are changes from the PLDWWW cvs module pushed to the

Re: packages: poppler/poppler.spec - Up to 0.15.1

2010-11-08 Thread Caleb Maclennan
On Mon, Nov 8, 2010 at 21:55, Artur Frysiak wi...@pld-linux.org wrote: On Mon, Nov 8, 2010 at 20:25, caleb ca...@pld-linux.org wrote: Author: caleb                        Date: Mon Nov  8 19:25:19 2010 GMT Module: packages                      Tag: HEAD Log message: - Up to 0.15.1

Re: packages: poppler/poppler.spec - Up to 0.15.1

2010-11-09 Thread Caleb Maclennan
On Tue, Nov 9, 2010 at 08:37, Jakub Bogusz qbo...@pld-linux.org wrote: Also cairomm 1.9.x and AFAIR fribidi 0.19.x are development versions... (stable cairomm is 1.8.x) The specs for poppler and cairomm have been reset to their proper stable branches. For fribidi, I would argue that it might

Re: PLD-doc: PLD-update-TODO - updated

2010-11-09 Thread Caleb Maclennan
On Tue, Nov 9, 2010 at 13:20, arekm ar...@pld-linux.org wrote: -busybox(42) [OLD] 1.16.2 [NEW] 1.17.3 I've been thinking a little about the notify script that generates these messages. I'm working on a special purpose live-cd project and upgrading the software that will go into it, so it's been

Future direction of official PLD website (Was: A couple questions about the website)

2010-11-20 Thread Caleb Maclennan
2010/11/11 Elan Ruusamäe g...@pld-linux.org: there actually exists dokuwiki install: http://www.pld-linux.org/dokuwiki/ currently it uses pldusers.org theme, so if somebody would create theme similar to current www in dokuwiki format, i'd finish the data migration and replace the moinmoun

Re: Future direction of official PLD website (Was: A couple questions about the website)

2010-11-20 Thread Caleb Maclennan
On Sat, Nov 20, 2010 at 17:54, Marcin Rybak marcin.ry...@gmail.com wrote: I don't know if I have a law to say something :) - but, I'm not sure if dokuwiki with revisions and recent changes is what should appear on PLD site. IMO it is better for guides (like docs.pld-users.org was) I hear your

Re: packages (DEVEL): roundcubemail/roundcubemail.spec - include release on tri...

2010-12-08 Thread Caleb Maclennan
I noticed while doing some testing of the roundcube beta package that it will not build using older rpm-build-macros. Specifically I had a machine with 561 that died trying to run the first %sed macro, after upgrading to 596 it builds fine. Is this something that should be noted as a BR? If so

Re: packages (DEVEL): roundcubemail/roundcubemail.spec - include release on tri...

2010-12-08 Thread Caleb Maclennan
2010/12/8 Elan Ruusamäe g...@pld-linux.org: On 08/12/10 21:12, Caleb Maclennan wrote: I noticed while doing some testing of the roundcube beta package that it will not build using older rpm-build-macros. Specifically I had a machine with 561 that died trying to run the first %sed macro, after

Re: packages (DEVEL): roundcubemail/roundcubemail.spec - include release on tri...

2010-12-09 Thread Caleb Maclennan
2010/12/8 Paweł Zuzelski paw...@pld-linux.org: + /bin/sed -i -e s,\r$,, -f php,inc,js,css /bin/sed: couldn't open file php,inc,js,css: No such file or directory Looks like %undos macro. It BRs rpmbuild(macros) = 1.566. Thank you Paweł. I could have cyphered that out if I hadn't had a blind eye

Re: packages: gobject-introspection/gobject-introspection.spec - reverted: dupl...

2010-12-09 Thread Caleb Maclennan
On Thu, Dec 9, 2010 at 19:40, qboosh qbo...@pld-linux.org wrote:  BuildRequires: libffi-devel -BuildRequires: libffi-devel Huh what? These were not back to back when I edited, adapter did that :-) Trying to build was failing during configure with something about missing ffi.h or some such. I

Re: packages: mysql/mysql.spec - requires versioned mawk (see http://www.opensu...

2010-12-13 Thread Caleb Maclennan
2010/12/13 Zsolt Udvari udvzs...@gmail.com: Bug report: http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2010-November/021902.html That link isn't a bug report so much as a request for one. Also it was suggested what information would be helpful to include in the bug report. I just

Re: exim in PLD-AC

2010-12-13 Thread Caleb Maclennan
Does anybody maintain AC? Is there any chance that exim will be patched or upgraded to 4.7x in case of this bug: http://seclists.org/bugtraq/2010/Dec/77 ? I imagine for a security issue like that someone will step in and update AC. However it might be pertinent to ask whether that should be

Re: packages: mysql/mysql.spec - requires versioned mawk (see http://www.opensu...

2010-12-13 Thread Caleb Maclennan
Bug in the tracker: https://bugs.launchpad.net/pld-linux/+bug/689563 ___ pld-devel-en mailing list pld-devel-en@lists.pld-linux.org http://lists.pld-linux.org/mailman/listinfo/pld-devel-en

Re: [Bug 689563] Re: packages: mysql/mysql.init, mysql/mysql.spec - allow spaces and tabs after ...

2010-12-14 Thread Caleb Maclennan
...pff, make temp var key there you have write access.  no, fix yourself, Hey guys don't forget we're on the same team here. I tried making this change myself, but either my smattering of awk knowledge is not enough or something else is going on here. I made up a variable and striped the

Re: packages: kernel-xenU/kernel-xenU.spec - up to 2.6.36.2 - please, test i686

2010-12-14 Thread Caleb Maclennan
On Tue, Dec 14, 2010 at 03:35, pawelz paw...@pld-linux.org wrote: - up to 2.6.36.2 - please, test i686 This builds fine on i686 for me. I don't know why you had a problem with it. What kind of error did you get? Are you cross-compiling? Caleb ___

Re: packages: kernel-xenU/kernel-xenU.spec - up to 2.6.36.2 - please, test i686

2010-12-14 Thread Caleb Maclennan
2010/12/14 Paweł Zuzelski paw...@pld-linux.org: It does not build on th-i686 builder: http://buildlogs.pld-linux.org/index.php?dist=tharch=i686ok=0name=kernel-xenUid=39eeab1b-c086-4036-b8df-31473ed7822caction=tail Roger that ... I think I know what that's about. I'll try to fix it when I get

Re: packages: mono/mono.spec, mono/mono-encryption.patch (REMOVED) - Up to 2.8....

2011-01-10 Thread Caleb Maclennan
2011/1/10 Michał Lisowski lis...@gmail.com - Removed patch8, applied upstream ^^^ if you remove patch, make sure you also remove it from cvs. I did, the whole action was in one commit. This is noted in the subject of the notification email sent to the list: mono/mono.spec,

Re: packages: mm-common/mm-common.spec - %files fix - rel. 2

2011-03-22 Thread Caleb Maclennan
2011/3/22 wiget wi...@pld-linux.org: - %files fix ... +%{_npkgconfigdir}/mm-common-util.pc Widget ... sorry I guess I broke that, but that file did not show up when I built the first time. It does now. Any idea what I was doing wrong? Caleb ___

Re: packages: telepathy-glib/telepathy-glib.spec - merge DEVEL branch

2011-03-22 Thread Caleb Maclennan
2011/3/22 wiget wi...@pld-linux.org: - merge DEVEL branch Is there a magic CVS command for doing that merge or did you do it by hand? I've wanted to do it to a few other specs and not known what was the best practice. ___ pld-devel-en mailing list

Re: packages: telepathy-glib/telepathy-glib.spec - merge DEVEL branch

2011-03-22 Thread Caleb Maclennan
2011/3/22 Bartosz Taudul wolf@gmail.com: cvs up -jDEVEL Thanks widget. http://images.mylot.com/userImages/images/postphotos/2130671.jpg Wolf, I feel like I'm on the outside of an insider joke. Caleb ___ pld-devel-en mailing list

Re: ntfs-3g and ntfsprogs merge

2011-04-21 Thread Caleb Maclennan
or how do you foresee the upgrade path in pld if both package names just dissapear? Some Provides and Obsoletes should be sufficient. Correct meif i'm wrong. Yes, the Provides and Obsoletes will take care of being able to upgrade and replace the previous package names. The problem is that

Re: ntfs-3g and ntfsprogs merge

2011-04-21 Thread Caleb Maclennan
http://cvs.pld-linux.org/cgi-bin/cvsweb/packages/obsoleted/obsoleted.spec?rev=HEAD It works by building an empty package that marks the upgrade target and immediately gets obsoleted by said target. There is nothing to clean up then. Where have you been all my life?

Re: packages: transmission/transmission.spec - ta_LK (Sri Lanka Tamil) unsuppor...

2011-06-03 Thread Caleb Maclennan
caleb, why only this one? :) Valid question. The workings of find_lang and some other rpm ninja tricks are still slightly magic to me. In this case, because it worked. That one language was causing RPM to fail to install, and removing it allowed it to be installed without errors. Right now

Re: packages: transmission/transmission.spec - ta_LK (Sri Lanka Tamil) unsuppor...

2011-06-03 Thread Caleb Maclennan
- ta_LK (Sri Lanka Tamil) unsupported, rel 2 caleb, why only this one? :) Valid question. The workings of  find_lang and some other rpm ninja tricks are still slightly magic to me. In this case, because it worked. That one language was causing RPM to fail to install, and removing it

Deps in TH

2011-06-03 Thread Caleb Maclennan
The current zsh package on the main mirror site for TH x86_64 is zsh-4.3.12-1. When I try to upgrade to it from 4.3.11-1 I get something like this: error: zsh-4.3.12-1.x86_64: req libc.so.6(GLIBC_2.14)(64bit) not found The version of glibc in the same TH tree is 2.13-6. Only the th-test tree

Re: Deps in TH

2011-06-03 Thread Caleb Maclennan
ready is a place where packages are moved over longer period of time to get kind of package set ready to be moved to main. So is there a reason Gnome3 skipped the ready tree? Because there is no checking in python scripts for that. Shouldn't there be some kind of test using rpm to check that

Re: DISTFILES: pacgraph: ERRORS: keenerd-pacgraph-e495c03.tar.gz

2011-07-23 Thread Caleb Maclennan
On Sat, Jul 23, 2011 at 11:35, caleb ca...@pld-linux.org wrote: wget -nv --no-check-certificate --user-agent=PLD/distfiles -O ./tmp/9c4646a0-f84d-45c6-9e96-8c9a251e6297/fdf09c8cdea9c9e58c6fc2acc79a0528/keenerd-pacgraph-e495c03.tar.gz

Re: DISTFILES: pacgraph: ERRORS: keenerd-pacgraph-e495c03.tar.gz

2011-07-25 Thread Caleb Maclennan
2011/7/25 Elan Ruusamäe g...@pld-linux.org: or just use our distfiles upload... Would you believe I don't know how to do that? ___ pld-devel-en mailing list pld-devel-en@lists.pld-linux.org http://lists.pld-linux.org/mailman/listinfo/pld-devel-en

poldek hooks

2011-08-23 Thread Caleb Maclennan
Does poldek offer any hooks or way to trigger actions at any point? For example are there pre/post transaction hooks that I could modify to run something before and/or after any rpm action is taken? How about an on exit if any package installed / upgraded / uninstalled during the lifetime of the

Re: poldek hooks

2011-08-23 Thread Caleb Maclennan
On Tue, Aug 23, 2011 at 17:54, Patryk Zawadzki pat...@pld-linux.org wrote: If you're only interested in a particular group of packages, consider faking install-time expansion by calling a common shell script in %post or %posttrans. I am interested in ALL packages, however I don't understand

Re: poldek hooks

2011-08-23 Thread Caleb Maclennan
On Tue, Aug 23, 2011 at 19:14, Patryk Zawadzki pat...@pld-linux.org wrote: Yes, other rpm wrappers support triggers. I think the proper way would be to add these to rpm itself rather than trying to hack them into poldek. Add add system wide %pre-transaction %post-transaction macros to rpm

Segfaults on across the board in TH

2012-03-27 Thread Caleb Maclennan
-- Forwarded message -- From: Caleb Maclennan ca...@alerque.com Date: Mar 26, 2012 1:51 PM Subject: Segfaults on across the board in TH To: PLD Devel pld-devel-en@lists.pld-linux.org Recently I've upgraded several desktop oriented machines against the latest TH repositories

Re: Segfaults on across the board in TH

2012-03-27 Thread Caleb Maclennan
I have reported this problem long time ago on a polish devel list. There was no solution given (only we must wait for the next nvidia release) and I've switched to nv. Then pluto suggested to try: I started seeing this with a 290.x nvidia driver version and never figured it out, but I've

Re: Segfaults on across the board in TH

2012-03-27 Thread Caleb Maclennan
http://www.nvnews.net/vbulletin/showthread.php?p=2538961 Fixed a bug that caused OpenGL applications to crash with some libc versions, such as eglibc 2.15. Eh? Now that looks promising. I'm trying to build PLD's packages now. Silly me I would have thought nvidia would fix major bugs like

Re: Segfaults on across the board in TH

2012-03-27 Thread Caleb Maclennan
2012/3/27 Caleb Maclennan ca...@pld-linux.org: http://www.nvnews.net/vbulletin/showthread.php?p=2538961 Fixed a bug that caused OpenGL applications to crash with some libc versions, such as eglibc 2.15. And ... that did the trick. 295.33 with the 3.3.3 kernel from th-test runs without a hitch

Re: gimp 2.8.0 rc1, gimp plugins

2012-04-19 Thread Caleb Maclennan
2012/4/19 Artur Wroblewski wrob...@pld-linux.org: hi, i would like to move gimp 2.8.0 rc1 from DEVEL to HEAD. any argument against? btw. we have some quite old gimp plugins on ftp, i.e. build in 2010, 2009. shall they be removed, rebuilt? regards, w Yes. That is an RC for a major

Re: gimp 2.8.0 rc1, gimp plugins

2012-04-20 Thread Caleb Maclennan
Ac is stable release for which we have appropriate branch and Th is in constant development mode, isn't it? This is one area where PLD's release system is actually pretty wonky. Other than a few emebeded or very static applications, AC is simply too old to use for most stable systems. This puts

Re: th stable (Re: gimp 2.8.0 rc1, gimp plugins)

2012-04-20 Thread Caleb Maclennan
well... if you need more stable line, then why not to create one with appropriate branch in CVS? of course, the problem is that somebody needs to maintain that, which I believe is full time job and lack of resources causes the stable branch to freeze. therefore, imho, it is not good idea to

Re: th stable (Re: gimp 2.8.0 rc1, gimp plugins)

2012-04-20 Thread Caleb Maclennan
Caleb, stop trolling*! You're asking very inconvenient questions :) Wink wink. I'm not actually trying to troll or be inconvenient. I'm also not interested in pointing fingers. I am a system administrator having a hard time keeping up with all the broken systems. I think a contributing factor

Re: th stable (Re: gimp 2.8.0 rc1, gimp plugins)

2012-04-20 Thread Caleb Maclennan
2012/4/20 Artur Wroblewski wrob...@pld-linux.org: it is very simple. th-stable, ac-stable or whatever... provide meaningful, self documenting names to things. Hey guys, how does this compute? My version control experience is mostly subversion with a bit of git lately. CVS is still black magic

CVS rename for nautilussvn

2012-05-04 Thread Caleb Maclennan
The upstream project NautilusSVN has been renamed to RabbitVCS. Can we get our CVS module renamed or should I work on a new spec? Thanks, Caleb ___ pld-devel-en mailing list pld-devel-en@lists.pld-linux.org

Re: CVS rename for nautilussvn

2012-05-05 Thread Caleb Maclennan
Package copied/renamed server-side. Thank you! Can I ask why our gedit module is called gedit2 on cvs? The upstream project seems to be at 3.4.1, which is what we have in that spec file. Is there any point in keeping that legacy name in our cvs module? Caleb

Re: gedit2 (Re: CVS rename for nautilussvn)

2012-05-07 Thread Caleb Maclennan
2012/5/6 Elan Ruusamäe g...@pld-linux.org: feel free to merge gedit2.spec to gedit.spec (and drop the former), just remember to handle obsoletes properly As a latecomer to CVS (backporting my knowledge of VCS from subversion, git, etc) I am not sure which button to push here. Since these two

Re: gedit2 (Re: CVS rename for nautilussvn)

2012-05-07 Thread Caleb Maclennan
2012/5/7 Elan Ruusamäe g...@pld-linux.org: 1. rename gedit dir to gedit0 in cvs server side and optionally drop it client side 2. rename gedit2 dir to gedit in cvs server side, and adjust names in files on cvs client side This sounds good. If somebody takes care of the server side bit I'll

Re: Cluster stuff (cman, dlm, heartbeat, corosync, openais, pacemaker, drbd, lvm)

2012-07-02 Thread Caleb Maclennan
2012/7/1 Jacek Konieczny jaj...@jajcus.net: On Sun, Jul 01, 2012 at 10:47:19PM +0300, Elan Ruusamäe wrote: On 07/01/2012 11:51 AM, Jacek Konieczny wrote: Do we need clvmd in the main lvm2 package? It pulls some dependencies irrelevant for non-clustered setups. i'm in for moving clustered

Re: cdg: proponowane-glosowania/cdg_membership_caleb - temporarily withdraw my ...

2012-07-06 Thread Caleb Maclennan
- temporarily withdraw my second; let's wait a week or two and see how caleb's current projects with regards to the cdg go; if he succeeds, that means he might be of use at conflict resolution; if he fails, he fails, and there's no point in granting him cdg membership at the present time

Re: cdg: proponowane-glosowania/cdg_membership_caleb - temporarily withdraw my ...

2012-07-06 Thread Caleb Maclennan
2012/7/6 Bartosz Taudul wolf@gmail.com: I told you it's just a stupid kindergarten power play. Some people never learn... Look. If all you guys want is to make me part of a power play, please just count me out. Don't vote for me. I'm not interested in joining a pre-school. I skipped that

Re: Git in PLD - basic HOWTO

2012-07-10 Thread Caleb Maclennan
2012/7/9 Kacper Kornet drae...@pld-linux.org: * Some documentation For some basic introduction to git and how to use it to work with PLD repositories please see: http://www.pld-linux.org/dokuwiki/howto-git Two simple questions: 1) I haven't seen any notes in the docs

Re: Git in PLD - basic HOWTO

2012-07-10 Thread Caleb Maclennan
2012/7/10 Jakub Bogusz qbo...@pld-linux.org: On Tue, Jul 10, 2012 at 03:40:58PM +0200, Kacper Kornet wrote: On Tue, Jul 10, 2012 at 04:26:00PM +0300, Caleb Maclennan wrote: 2) Is there a way to set git's user.email config variable without doing it globally? I use git for other things where

Re: Git in PLD - basic HOWTO

2012-07-10 Thread Caleb Maclennan
2012/7/10 Mariusz Mazur mma...@kernel.pl: Or one can alias the 'git' command to a simple script that checks for .git/config, check if remote origin is git.pld-linux.org and if so, uses a different user.email. Hm, I could use that. Wonder if anyone already wrote it. I thought of that too and

Re: Git in PLD - basic HOWTO

2012-07-10 Thread Caleb Maclennan
2012/7/10 Kacper Kornet drae...@pld-linux.org: The solution that I know is to define a wrapper around git, that calls call git -c user.email=whatever, where whatever depends on the current path. It's cumbersome, but maybe better then nothing. Here's my current hack as function for my zsh

Re: [packages/cryptsetup] Providing and obsoleting itself makes no sense Release 2

2012-08-07 Thread Caleb Maclennan
2012/8/7 Jan Rękorajski bagg...@pld-linux.org: You missed the real change, I did not remove P/O for cryptsetup-luks. I removed P/O for cryptsetup i.e itself A... sure enough. Looks like I missed that one too. Sorry to bother you, but having broken upgrade paths myself in the past over that

Re: w32codec updated

2012-08-08 Thread Caleb Maclennan
2012/8/7 Bartosz Taudul wolf@gmail.com: Ponieważ Bartek cały czas jest żywotnie zainteresowany rozwojem dystrybucji i aktywnie przyczynia się do wprowadzania zmian, proponuję aby dać mu dostęp RW do repozytorium. Aren't you rather skipping over a number or relevant issues? First of all,

Re: w32codec updated

2012-08-08 Thread Caleb Maclennan
Search the mailing list archives for mkochano who also dropped his RW access, also sent a number of patches to the list afterwards and was asked many times to send the password hash, so he would regain his access. Quite honestly, that has nothing to do with the present case. Even if a

Re: w32codec updated

2012-08-09 Thread Caleb Maclennan
2012/8/10 Bartosz Świątek shad...@tld-linux.org: should be punished This isn't about punishment. It's about civility and cooperation. If you're interested in those things, start practicing them instead of trying to stir things up. People would be fine with your participation if you did. Caleb

Re: Is there a merged git repository?

2012-08-11 Thread Caleb Maclennan
I'm afraid ohloh might be overwhelmed by *all* the things you do (just as it was when facing *all* the ALT Linux gear repos when Their recent takeover by BlackDuck has given them a few more resources and they've got a lot of stuff cleaned up. I don't think they would give us the boot do to DoS

Re: packages case sensitivity

2012-09-29 Thread Caleb Maclennan
2012/9/29 Aria Stewart aredri...@nbtsc.org: seems github packages are case insensitive, perhaps we should limit similarily in pld to disallow creating packages that differ just character case? +1. And lowercase be the norm. +1, the current mix-n-match case is kind of a mess and is more of a

Package rename

2013-09-30 Thread Caleb Maclennan
Can we rename the terminator package to gnome-terminator? There are actually two projects by this name and I'd like to introduce the one we don't have to a couple of my systems. I looked at the upstream projects and it looks like the one currently in our specs repo is already partially renamed

CRI images

2013-10-09 Thread Caleb Maclennan
Are there sanely recent CRI images for TH to be had anywhere? Caleb ___ pld-devel-en mailing list pld-devel-en@lists.pld-linux.org http://lists.pld-linux.org/mailman/listinfo/pld-devel-en

Missing kernel packages from TH repos

2013-10-10 Thread Caleb Maclennan
I tried to do an install via Rescue CD and poldek --root the other day only to discover that apparently a lot of packages (including the kernel) are missing from the current main TH ftp repository. What's the deal with this? How is anybody supposed to get a system up and running without a way to

Re: Th 2013 snapshot released

2014-01-01 Thread Caleb Maclennan
On Tue, Dec 31, 2013 at 10:46 PM, Aria Stewart aredri...@nbtsc.org wrote: On Tue, Dec 31, 2013 at 09:36:40PM +0100, Jan Rękorajski wrote: As promised I made a new snapshot of the PLD Th line. See the announcment on http://www.pld-linux.org/ for details. And there was much rejoicing!

Re: [packages/asterisk] Note about the ASTERISK_12 branch

2014-01-24 Thread Caleb Maclennan
On Fri, Jan 24, 2014 at 11:14 PM, Jacek Konieczny jaj...@jajcus.net wrote: Before merging on master I would like to see opinion of anybody using the asterisk package. I am using the 1.8 packages in production but the boxes are EOLed and I'm in the process of migrating the services, so I don't