Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-03-07 Thread PasTim
Morbeas wrote: I never knew about that /classic switch, awesome tip! I never knew there were supposed to be play buttons next to each track! And I always hated not having an option to play a specific song in the playlist and always just skipped! Is there any way to bring those play

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-03-07 Thread PasTim
Morbeas wrote: I have that clicked and still don't see those buttons and never have! Any other suggestions? Though I'm using the DefaultCB skin, I wonder if that's the reason. Let me try with the regular version. Edit: Just tried with the regular Default skin and the result was the

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-03-07 Thread PasTim
Morbeas wrote: Wait, yes you're right. I forgot to hover my mouse! It works now, thank you. :) PasTim's Profile: http://forums.slimdevices.com/member.php?userid=41642 View this thread:

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-07-16 Thread PasTim
mps wrote: I recently upgraded to LMS 7.7.2, and when I do a scan, the Settings Information page of the web interface no longer shows my Custom Scan taking place like it used to (just Discovering files..., Scanning new music files, Discovering playlists, Scanning new playlists, and

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-08-03 Thread PasTim
erland wrote: The first one is safe to ignore, it's just a warning because you run a newer version of Perl. The second one indicates that you have a Database Query report named workscount which contains invalid configuration data and won't be available. It shouldn't cause any problems but

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-08-03 Thread PasTim
I'm running 7.8. In an attempt to clear up my server log so as to try and analyse some problems I came across this, every time LMS is started. It's been happening for many moons but I've previously ignored it. Code: Slim::Utils::Misc::msg (1304) Warning:

Re: [SlimDevices: Plugins] Announce: Beta version of SvrPowerControl

2013-08-05 Thread PasTim
epoch1970 wrote: In short, what you want is possible. But I am afraid I do not know the best way of doing it. HTH I installed and run etherwake on my linux debian system to wake my vortexbox appliance from my laptop when not in the same room as my Logitech Touch (which wakes it automatically

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-10-06 Thread PasTim
I have had an intermittent problem for some months now and have failed to track down the cause. I'm posting here on the off-chance that the cause might be related to plugins. What happens is that once in a while when I play a series of tracks, each track pauses briefly around 10 seconds before

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-10-08 Thread PasTim
The problem occurs however I select tracks, usually just using a menu item on custom browse (as opposed to a dynamic playlist). I have usually selected an album, or a work consisting of several movements, and have settled down to listen to the lot without touching anything at all. I think it's

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-10-09 Thread PasTim
erland wrote: When the next track starts to play, it will increase the play counts and sets the last time a track was played and optionally call MusicIP if you have the MusicIP Statistics Export enabled in Custom Scan settings page and write to iTunes export file if you have iTunes

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-10-09 Thread PasTim
Thanks, but no. I think it must be related to my Vortexbox, possibly the fact that it hibernates and resumes a few times, but I'm pretty clueless, LMS 7.8 on VortexBox Midi, FLACs 16 or 24 bit, up to 192kbps. Touch on Ethernet (in another room), digital out to a Musical Fidelity M1 CLiC. Old

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-10-09 Thread PasTim
garym wrote: Hmmm, why is the vortexbox hibernating and resuming? Have you set it up that way? My vortexbox is on 24/7 and never hibernates. Yes I have. I'm not sure why anyone would not do so. Leaving it on 24/7 seems enormously wasteful to me. I guess I have a postwar (II) habit drilled

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-10-10 Thread PasTim
:-) LMS 7.8 on VortexBox Midi, FLACs 16 or 24 bit, up to 192kbps. Touch on Ethernet (in another room), digital out to a Musical Fidelity M1 CLiC. Old wireless laptop running Xubuntu controls server using Chromium. Squeezelite on Vortexbox, Ubuntu Windows desktops plus the laptop. Meridian

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-10-19 Thread PasTim
Pilru wrote: I have exactly the same problem as you. My server hybernates and resumes (via SrvPowerControl) and after few resumes, need to restart the lms otherwise each tracks pause for half a second around 10sec before the ends. My server runs on a Debian Stable. At last someone has has

Re: [SlimDevices: Plugins] Announce: WaveInput for Linux

2013-11-12 Thread PasTim
LazySqueeze wrote: I would like to let shaydon and bpa that this version _is_ working on newer versions of LMS and sox. I must be blind but I do not see an easy way to contact those members. I will delete this if a gentle soul helps me with that :) Cheers! If they don't see your reply here

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-12-06 Thread PasTim
When I boot up LMS 7.8, I typically get a sequence like that below. Is there any reason why the 'Install Custom Scan hooks' step takes some time? I don't have 'Startup refresh' on. Code: [13-12-06 21:02:26.5443] Plugins::CustomScan::Scanner::initDatabase (96)

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2013-12-09 Thread PasTim
erland wrote: You can try to temporarily enable debug level logging on TrackStat, Custom Scan and possibly also SQL Playlist and Custom Browse for the ones of these plugins you have installed. Make sure to check the Save logging settings for use at next application restart option and then

Re: [SlimDevices: Plugins] Announce: WaveInput for Linux

2013-12-30 Thread PasTim
pnw wrote: I am trying to use VLC to capture the PC audio and stream it through LMS to a squeezebox receiver (attached to hifi system) I am running Ubuntu Linux 12.04 which has pulse audio by default and I don't really want to fiddle with this.. Any ideas? I have a similar set-up,

Re: [SlimDevices: Plugins] Announce: WaveInput for Linux

2013-12-30 Thread PasTim
pnw wrote: edit: To isolate the problem (i.e. LMS or VLC) - can you play the VLC mp3 stream on another system with a Browser or VLC, mplayer or a smartphone etc.. Yes - I can play the stream from another PC on my home network through a browser (to URL http:198.162.0.2:8079/st.mp3) so

Re: [SlimDevices: Plugins] Announce: WaveInput for Linux

2013-12-30 Thread PasTim
pnw wrote: Yes - I was only using parec to test the audio capture I have tried your command line text (removing the space from channels) and modifying the port and dummy filename, but I get the same result. The problem appears to be from the LMS end? Apologies - I should have ensured that

Re: [SlimDevices: Plugins] LMS does not play http audio stream from VLC media player

2013-12-31 Thread PasTim
pnw wrote: After a good night's sleep, I was thinking about your previous post and decided to try a different test. I ran the VLC stream on my spare PC (on 192.168.0.3 to port 8079/st.mp3), and tuned into it from LMS running on main PC on 192.168.0.2. It played the stream no problem :)

Re: [SlimDevices: Plugins] LMS does not play http audio stream from VLC media player

2013-12-31 Thread PasTim
pnw wrote: It was the firewall ... ugh - sorry Here's the full working Ubuntu Linux command line I am now using to capture PC pulse audio and stream to local port 8079. cvlc --sout #transcode{acodec=mp3,ab=320,channels=2,samplerate=44100}:std{access=http,mux=raw,dst=:8079/st.mp3}

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-07 Thread PasTim
Apologies for this rather English statement, but I seem to have lost my marbles. I have rarely created playlists ahead of time. I decided to create one, under the Custom Browse menu, for an upcoming visit from an old friend. I created one (called Dick - my friend) and then tried to edit it a

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-08 Thread PasTim
erland wrote: How do you use the playlist in Custom Browse ? Do you refer to it from a Custom Browse menu ? Which menu template ? Do you refer to it from a Multi Library library ? Which library template ? If it's a Multi Library library, and you have disable the startup refresh option in

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-08 Thread PasTim
PasTim wrote: I also don't see how to edit a playlist except by mucking about with the text, which is a little prone to error. Quite by chance I found a way to edit a playlist. I fired up a different browser (firefox). I tried to 'move' a track, and it worked. Why? Well, by default

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-08 Thread PasTim
erland wrote: If you are talking about changing a playlist in a text editor or through an external program, I assume you perform a scan in LMS afterwards ? External changes to playlists are imported into LMS through the scanning process, so you at least have to run a scan of type Only rescan

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-09 Thread PasTim
erland wrote: I think there is a risk for inconsistently if you abort it. However, you can probably abort it and then run it again over the night if you want to avoid having an unusable system at the moment. If you plan to do a lot of playlist changes you should probably disable automatic

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-27 Thread PasTim
For a long time I've had a bit of an issue with some of my custom browse menus and a couple of other actions that seem to bring LMS to a halt for several seconds, such that the music stops. I've been wondering whether there is any solution. I'm running LMS on a 4 cpu Vortexbox appliance. One

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-27 Thread PasTim
erland wrote: It looks like I have a database dump from your setup from beginning of 2012 and also a works by composer menu configuration. Do you remember if the problem was the same at that time or if it's something that have started to appear later ? I got my Vortexbox in early 2012,

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-27 Thread PasTim
erland wrote: Is there a particular level in the menu hierarchy that's slow ? Like when it lists all Composers ? all Works ? or all work artists ? Or are all menu levels slow ? It is all my top level menus which do things like: Works by Composers WorkArtists by Composer Composers by

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-27 Thread PasTim
PasTim wrote: It is all my top level menus which do things like: Works by Composers WorkArtists by Composer Composers by Orchestra Composers by Conductor Almost all my menus aim to drill down to find Works, and then show or play the tracks. I'd give you a full list but unfortunately

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-28 Thread PasTim
Erland, Thanks for your help. Having dug around a bit, and tried a few things, it seems clear that the issue is getting sufficient indices and data into cache. Whilst my menus could be tidied up, they aren't the main cause of the delay on 1st use after boot. I've seen suggestions of trying to

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-28 Thread PasTim
I recently tried a UPnP sever that has a novel (to me anyway) interface. I was wondering if there is any way to do the same with Custom Browse. The menu strategy is as follows. 1) You nominate the tags you are interested in - that's effectively already done using the mixed tags and custom tags

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-28 Thread PasTim
erland wrote: The closest is probably the Tags menu which is based on the Dynamic Tags menu type. Generally it's hard to do dynamic menus like this with Custom Browse, the Tags menu solves it by implementing the menus through programatic logic instead of hardcoding the menu structure.

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-01-28 Thread PasTim
erland wrote: As you suspect, dropping and recreating an index will likely load the database into the in-memory cache and this is the reason why it improves the performance. I don't think I can introduce this as standard as having a startup time of several minutes would make the system more

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-02-02 Thread PasTim
I cannot reconfigure MultiLibrary on a new system. I must be getting thick in my old age. I am setting up a new LMS, and was trying to configure my Classical and Standard libraries. I have my old library xml files. For some reason the libraries are both empty (0 entries). Further, when I try

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-02-02 Thread PasTim
PasTim wrote: I cannot reconfigure MultiLibrary on a new system. I must be getting thick in my old age. I am setting up a new LMS, and was trying to configure my Classical and Standard libraries. I have my old library xml files. For some reason the libraries are both empty (0 entries

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-02-04 Thread PasTim
PasTim wrote: I agree that delaying startup will probably be unacceptable to many. I think I can adjust my habits to live with tit rather than hiccups when playing later in the day. Please don't spend time on my menus (unless you have time on your hands, which I suspect you don't). I

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-02-07 Thread PasTim
Having moved from one version of linux to another I thought my slow custom browse/scan menus were now sorted. I was too quick to judgement. I have a menu (of several, but this is the worst) that takes around 4 minutes to appear the first time it is run when LMS is started. I have spent a great

Re: [SlimDevices: Plugins] Announce: WaveInput for Linux

2014-02-09 Thread PasTim
sbellon wrote: Hi all, three years ago I tried to configure WaveInput for Linux and failed miserably. Having not felt any need to spend more time on this issue, today I thought I might give it another try. What I'm trying to do is to copy all sound (not just from a specific

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-02-11 Thread PasTim
This is just to confirm that I have now repeated tests on my custom browse / scan menus, and the following linux script (using sqlite3 installed on linux), run after a full scan with lms stopped, resolves all my menu performance issues. Code: sqlite3

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-02-28 Thread PasTim
Roland0 wrote: persist.db seems to be very large - my library is larger than yours, and persist.db is 96MB You could try (while LMS is stopped) to - run 'vacuum' (http://www.sqlite.org/lang_vacuum.html) on it and see if it shrinks it - or export your data w/ TrackStat and delete it - LMS

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-03-07 Thread PasTim
erland wrote: persist.db can grow quite a bit if Custom Scan plugin is used to scan a lot of tags in a large library. Also, if you have been using TrackStat for a while it will store playback history and this accumulates over time. However, you are correct that running vacuum on it might

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-04-05 Thread PasTim
nidzo wrote: Hi Erland, and everybody -first of all, in *CS* the *Various Setting* page doesn't show up, no answer at all. it keeps waiting till connection dies. i have another PC LMS installation (for testing purpose) and there it works. i tried to unistall and install again ... same

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-04-07 Thread PasTim
nidzo wrote: Hi PasTim on my synology, it turns out that sqlite3 is already installed. so, i will try this solution and i will tell you my experience. but, what is this supposed to do, (more or less) exactly? Thanks Nidzo On my system, every time I do a Custom Scan to rebuild my library

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-04-07 Thread PasTim
erland wrote: To speed up the scanning process, Custom Scan will delete existing data and add new one as it scans the files again, this can probably cause the fragmentation. I would like to add it to the plugin so it is easy to run, but it sounds like it can't be executed while the

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-04-23 Thread PasTim
You mention a Soloists tag. I've not come across this one before. Is there a definitive list of tags that LMS supports as 'standard'? LMS 7.8 on VortexBox Midi running Xubuntu 14.04, FLACs 16-24 bit, 44.1-192kbps. Wired Touch + EDO, coax to Musical Fidelity M1 CLiC. Wireless Xubuntu 14.04

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-04-24 Thread PasTim
erland wrote: Hopefully this should be complete, if it isn't we should update it: http://wiki.slimdevices.com/index.php/SlimServerSupportedTags Thanks - I never found that before. It's a good start, and may, for all I know, be definitive and up to date. In some of the custom menus

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-05-04 Thread PasTim
erland wrote: Since 7.9 is a beta and changed every week and sometimes changes due to incompatible changes, I can't guarantee that it will always work. However, I'm still supporting it so if people use 7.9 and one of my plugins doesn't work I'll try to fix any issues as soon as possible.

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-05-06 Thread PasTim
SlimChances wrote: I did a clean install of my OS, LMS and restored my prefs folder from backup. All went well more or less and LMS has all it's plugins working as far as I can tell. The exception seems to be Dynamic Playlists (and SQL Playlists) which have a few playlists that I made up

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-05-07 Thread PasTim
Mycenius wrote: Hello again Mynb! Yes they are on the same PC - no couldn't install as a plugin as it wasn't showing - even when I allowed all third party plugins - I downloaded the Windows Installer instead... The plugin is called 'local player'. You may need to add

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-05-07 Thread PasTim
SlimChances wrote: Code: [14-05-06 22:12:32.0799] Plugins::TrackStat::Backup::File::initRestore (165) Restore from: 2014 05 TrackStat.xml [14-05-06 22:12:32.0806] Plugins::TrackStat::Backup::File::scanFunction (251) Couldn't open backup file: 2014 05

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-05-08 Thread PasTim
Mycenius wrote: One last question - is there anyway to disable the soft volume on Squeezelite (or lock it on 100%)? Assuming you are using Local Player, go to Settings, Player. Select your Local Player, and Audio. There are several options here. I haven't tried fixing the volume myself for

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-05-22 Thread PasTim
Apologies if this has been gone over before (I suspect it has, several times), but I couldn't find a solution. I have been experimenting to see if I can store all names in natural order (first, middle, last), but keep them sorted on the last name. This works as standard for Artist and

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-05-23 Thread PasTim
PasTim wrote: Apologies if this has been gone over before (I suspect it has, several times), but I couldn't find a solution. I have been experimenting to see if I can store all names in natural order (first, middle, last), but keep them sorted on the last name. This works as standard

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-05-24 Thread PasTim
erland wrote: The important part should be to make sure they are omitted from the MixedTag configuration. The tags you enter in the Mixed Tag configuration will be copied from the standard LMS table/scanner and due to this they will not contain the correct sort values. Thanks, understood.

[SlimDevices: Plugins] Using LMS with network connected amplifiers without SB devices

2014-06-15 Thread PasTim
I have spent many hundreds of hours getting all my music, mainly classical, sorted out and playable in various ways using LMS. And then I thought, what if my Touch fails? No other system gives me the flexibility of LMS and associated plugins, such as: - many of my own menus, the way I want

Re: [SlimDevices: Plugins] Using LMS with network connected amplifiers without SB devices

2014-06-15 Thread PasTim
How to Play LMS without SB Hardware on a Headless Linux system. Note that some familiarity with Linux is required. 1. Install LMS, music etc. as normal. 2. Install DLNA server of your choice, I use the excellent minimserver from http://minimserver.com/ , autostarted at boot time (a choice when

Re: [SlimDevices: Plugins] Using LMS with network connected amplifiers without SB devices

2014-06-15 Thread PasTim
The python program referred to in 5(c) above is as follows: Code: #!/usr/bin/python import BaseHTTPServer import SocketServer import subprocess # For running flac, sox or whatever import sys

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-06-15 Thread PasTim
gahabana wrote: understand now . as i can not get 'local player' plugin to load/start i can not use that. when i start it as a service it works fine but i can not disable local file access without modifying squeezelite source code OR until Erland makes Trackstat compatible with squeezelite.

Re: [SlimDevices: Plugins] Using LMS with network connected amplifiers without SB devices

2014-06-23 Thread PasTim
get.amped wrote: That's quite a dissertation! You definitely brought this a long way from your initial inquiries into how it might be possible to accomplish this. Kudos! Thanks. I've been listening a lot on the FLAC version and it seems fine to me. LMS 7.9 on VortexBox Midi running Xubuntu

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-08-13 Thread PasTim
garym wrote: Hmmm. good question. Just checked on my win7 install of LMS and I have the local player installed (and it works). With the squeezelite selected as active player, when I go to settings under PLAYER tab, it also tells me that I have nothing connected. Which brings me to the

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-08-13 Thread PasTim
HumanMedia wrote: After trying for 30mins I gave up and went downstairs to listen to the SBT. As soon as I connected to the server using an existing SBT player, Local Player appeared instantly. Not sure why using another player made it appear, but it has. Haven't tested it yet but it shows

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-08-13 Thread PasTim
garym wrote: hmm, when adding -r it causes the squeezelite player to show as not playing on the settings page, and nothing about it works. removing the -r makes it all work again. I've use -r 192000 for many months, with no issues. My complete set of parameters for a Meridian Explorer DAC

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-08-13 Thread PasTim
garym wrote: thanks for the info. perhaps the difference is that your -r 192000 may relate to the DAC. In my case I have no DAC connected (squeezelite is just using the onboard latpop soundcard). I don't actually use squeezelite for anything...just installed it to see how it works. edit:

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-08-13 Thread PasTim
garym wrote: Thanks. -r by itself wasn't working (player not running), but -r 96000 works (or not using -r at all works). I can get the options in the dropdown player list without -r or with -r 96000. So I'm not having trouble with that issue. Some other problem then. If it's reported as

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-08-13 Thread PasTim
garym wrote: I think we're at cross purposes now. Sorry for any confusion. To be clear, my squeezelite is working perfectly. Plays audio with my laptop builtin audio, shows up as player in LMS player menu, shows up as a player in LMS Settings Player tab, and I can set audio, smartmix,

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-09-11 Thread PasTim
SlimChances wrote: Erland I updated the plugins and today updated to the latest version of LMS 7.9. Everything seems to work great now. I appreciate the work you put into these plugins And so say all of us :) LMS 7.9 on VortexBox Midi running Xubuntu 14.04, FLACs 16-24 bit, 44.1-192kbps.

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-09-15 Thread PasTim
NPD wrote: Local Player v1.6.3 does not start automatically. It doesn't appear in the list of players and squeezelite doesn't appear in the list of running processes. I can manually start squeezelite in folder above from terminal with this ./squeezelite-i386 -d all=debug -f

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-09-23 Thread PasTim
audiomuze wrote: I have a similar scenario in that the plugin installs,, but under Local Player settings I get: Start Player With Server is ticked, but in brackets it shows Not Running (squeezelite-x86-64) Trying to start it manually from

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-09-26 Thread PasTim
wortgefecht wrote: Yes: Code: $ groups squeezeboxserver squeezeboxserver : nogroup audio But the log said: Home directory not accessible : Permission denied So I deleted the user from the audio group and readded it, restarted LMS

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-09-26 Thread PasTim
DJanGo wrote: Hi, this is a real offtopic question, cause its a basic feature - even Winblows is handling file/folder permissions - so it doesnt belong to this big unreadable Thread. Well it isn't off topic if the reason several people cannot get local player to run is some form of

Re: [SlimDevices: Plugins] Announce: Local Player plugin and Squeezelite for Linux/Windows/OSX

2014-09-26 Thread PasTim
DJanGo wrote: Well thats not really helpfull to answer with a this or that - its clear that you didnt mean the log from the Black Pearl (The Ship from Jack Sparrow) It may surprise you to know that I don't know what the Black Pearl is, nor what The Ship from Jack Sparrow is. It doesn't

Re: [SlimDevices: Plugins] Howto install/Setup Local-Player-plugin under Linux (debian/ubunto etc.)

2014-09-26 Thread PasTim
DJanGo wrote: * The User that starts LMS must be in the group audio to use audiohardware. Code: sudo groups squeezeboxserver |grep audio || sudo useradd -G audio squeezeboxserver Can I just ask whether this has been proven? I used

Re: [SlimDevices: Plugins] Howto install/Setup Local-Player-plugin under Linux (debian/ubunto etc.)

2014-09-26 Thread PasTim
DJanGo wrote: Thanks (this time no ironic taste) for proven the fact that this Thread is necessary otherwise you have read Triodes #1 in the main Announce Thread. I did read it over a year ago. Strangely enough I don't remember everything I've read. A failing I know. My excuse is age and

Re: [SlimDevices: Plugins] Announce: Beta version of SvrPowerControl

2014-10-12 Thread PasTim
If you are intending to produce a new release at some point, there's a trivial matter - I get this in the log every time LMS starts up: Code: [14-10-12 08:16:00.3750] Slim::Utils::Misc::msg (1343) Warning: [08:16:00.3739] defined(@array) is deprecated at

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-10-26 Thread PasTim
nidzo wrote: more than that. after a new install of LMS everything from erland has disappeared Forgive me if this is obvious, but do you have access to some other 3rd party plugins? LMS 7.9 on VortexBox Midi running Xubuntu 14.04, FLACs 16-24 bit, 44.1-192kbps. Wired Touch + EDO,

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-10-27 Thread PasTim
nidzo wrote: i have to say no. at least, i can see a Herger plugin, but there are manymany missing. i cant' understand... there is another problem, probably connected. when i re-installed LMS, it asked (as usual) the squeezebox.com credentials. it turned out that it's impossible to

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-10-27 Thread PasTim
nidzo wrote: the point is that i can login, but in the webinterface www.mysqueezebox.com, so the credentials are correct.. but in cannot use them in the settings page of logitech media server. Well I guess there's something seriously wrong with your installation. I don't suppose

Re: [SlimDevices: Plugins] Announce: Beta version of SvrPowerControl

2014-11-02 Thread PasTim
I thought I'd try your latest version as in #2085 to see what's new. It's all be fine except two things. I think I must have run the setup script wrong (as a user, with sudo), since sudoers got corrupted and I couldn't use sudo at all. Fortunately a search came to the rescue and using 'pkexec

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-11-02 Thread PasTim
Erland, I was wondering whether there's anything that could be changed in LMS 7.9 to assist in running custom scan in parallel with the normal scan. See http://forums.slimdevices.com/showthread.php?101248-What-should-be-included-in-7-9p=794961viewfull=1#post794961 LMS 7.9 on VortexBox Midi

Re: [SlimDevices: Plugins] Announce: Beta version of SvrPowerControl

2014-11-04 Thread PasTim
I decided to clear 'prefs' and re-install the new version. All seems well now with wake alarms, even without the edit to hwclock-save.conf. One of those mysteries of life that I'll make a note of but otherwise leave well alone (whilst it still works) :) LMS 7.9 on VortexBox Midi running

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-11-17 Thread PasTim
mps wrote: I have created a Dynamic Playlist (using SQL Playlists) that returns all of the tracks in a work so I can play an entire symphony, etc.. This works fine for the first few works but then I run into a truncation problem. Suppose I have a 4 movement symphony that is returned as track

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-11-17 Thread PasTim
mps wrote: Hi PasTim, That's essentially what I did, but how do you deal with the problem of dynamic playlists truncating the list? Thanks, Mike I don't get truncation with this SQL. I don't see why you should. What this SQL does is select 10 Works and lists them in a table

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-11-18 Thread PasTim
mps wrote: Thanks for the response, PasTim. Maybe I am missing something obvious. I use the following SQL, which works fine from Test/Save Play in the SQL playlist menu. Code: -- PlaylistName:Random Played Works -- PlaylistGroups: DROP TABLE IF EXISTS

Re: [SlimDevices: Plugins] Announce: New versions of erlands plugins

2014-11-18 Thread PasTim
mps wrote: Thanks! That's very helpful. I also moved the WHERE playcount 0 into the first query because I was only getting 4 or 5 tracks, but I'm hopeful everything will work now. Thanks again, Mike Is it working OK now? LMS 7.9 on VortexBox Midi running Xubuntu 14.04, FLACs 16-24

[SlimDevices: Plugins] Custom Scan speed

2011-01-29 Thread PasTim
the Custom Scan? -- PasTim PasTim's Profile: http://forums.slimdevices.com/member.php?userid=41642 View this thread: http://forums.slimdevices.com/showthread.php?t=85180 ___ plugins

Re: [SlimDevices: Plugins] Custom Browse, Classical Albums

2011-01-29 Thread PasTim
a major problem. -- PasTim PasTim's Profile: http://forums.slimdevices.com/member.php?userid=41642 View this thread: http://forums.slimdevices.com/showthread.php?t=85195 ___ plugins

Re: [SlimDevices: Plugins] Custom Scan speed

2011-02-03 Thread PasTim
When doing a custom scan my PC doesn't seem to be doing much. One task, SQUEEZ~3.exe, uses between 0 and 3%. Nothing much else seems to be using much CPU (user or kernel). The disks seem pretty quiet. What's going on? -- PasTim

Re: [SlimDevices: Plugins] Custom Scan speed

2011-02-03 Thread PasTim
for classical music. I have made a small contribution. I'd quite like to know how you worked out how to construct the plugins. Is there a guide somewhere? I'm reasonably SQL literate, and have some familiarity with XML, but have no idea how you have linked everything up with SB. -- PasTim

Re: [SlimDevices: Plugins] Custom Scan speed

2011-02-03 Thread PasTim
). This makes me suspicious that something odd is happening in custom scans to make it use resources inefficiently (and periodically). -- PasTim PasTim's Profile: http://forums.slimdevices.com/member.php?userid=41642 View this thread

Re: [SlimDevices: Plugins] Custom Scan speed

2011-02-04 Thread PasTim
interests, what is the chance your very valuable plug-ins will still work in the future? -- PasTim PasTim's Profile: http://forums.slimdevices.com/member.php?userid=41642 View this thread: http://forums.slimdevices.com

Re: [SlimDevices: Plugins] Custom Scan speed

2011-02-04 Thread PasTim
things. It sounds as if SB 7.6 is what we need. I don't know when this is due for official release, not whether a new version of the plugin will be needed. -- PasTim PasTim's Profile: http://forums.slimdevices.com/member.php

Re: [SlimDevices: Plugins] Custom Scan speed

2011-02-04 Thread PasTim
it in mind for the future. Thanks also for your continued work on the plugins. The ones I have installed (Custom Browse, Custom Scan and Multi Library) make a really big difference to the usability of SB for classical music. -- PasTim

[SlimDevices: Plugins] Import ratings from a tag

2011-02-09 Thread PasTim
). I'm still fairly new to SB and the plug-ins, so please forgive me if I'm being a bit dim. -- PasTim PasTim's Profile: http://forums.slimdevices.com/member.php?userid=41642 View this thread: http://forums.slimdevices.com

Re: [SlimDevices: Plugins] Import ratings from a tag

2011-02-09 Thread PasTim
=0 then 'Unrated' else concat(floor((+10)/20),' stars') end got error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'case when =0 then 'Unrated' else concat(floor((+10)/20),' stars') end' at line 1 -- PasTim

Re: [SlimDevices: Plugins] Import ratings from a tag

2011-02-10 Thread PasTim
by albums.titlesort,albums.disc asc got error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '} group by albums.id order by albums.titlesort,albums.disc asc' at line 4 -- PasTim

Re: [SlimDevices: Plugins] Import ratings from a tag

2011-02-10 Thread PasTim
facilities I can find in SB server Player Settings. Thanks for your help, and I apologise if I have wasted any of your time. -- PasTim PasTim's Profile: http://forums.slimdevices.com/member.php?userid=41642 View this thread

Re: [SlimDevices: Plugins] Import ratings from a tag

2011-02-10 Thread PasTim
. I'm truly astonished by how flexible it is, and by how much people like yourself have done to enhance it. -- PasTim PasTim's Profile: http://forums.slimdevices.com/member.php?userid=41642 View this thread: http

[SlimDevices: Plugins] Custom browse menus and headers

2011-02-14 Thread PasTim
is not null and contributors.id=Lewis%252C%2520P group by contributors.id got error: Unknown column 'Lewis' in 'where clause' -- PasTim PasTim's Profile: http://forums.slimdevices.com/member.php?userid=41642 View this thread: http

  1   2   3   4   5   6   7   8   9   10   >