Re: [poppler] Any one compile poppler with mingw for windows?

2009-09-10 Thread Albert Astals Cid
A Dijous, 10 de setembre de 2009, Shen Liang va escriure: Is it possible compile poppler with mingw+msys on windows or with mingw on linux? I git the latest source. When I compiled with mingw+msys, I always got error about freetype. I installed mingw 32 on Ubuntu, and run: export

Re: [poppler] Any one compile poppler with mingw for windows?

2009-09-10 Thread Shen Liang
For latest poppler from git, on Ubuntu, I do ./autogen --host=i586-mingw32msvc. Then I got: .. checking for FREETYPE... yes checking for FONTCONFIG... yes checking for CAIRO... yes checking fcntl.h usability... yes checking fcntl.h presence... yes checking for fcntl.h... yes checking

[poppler] Any one compile poppler with mingw for windows?

2009-09-09 Thread Shen Liang
Is it possible compile poppler with mingw+msys on windows or with mingw on linux? I git the latest source. When I compiled with mingw+msys, I always got error about freetype. I installed mingw 32 on Ubuntu, and run: export CC=i586-mingw32msvc-gcc export CXX=i586-mingw32msvc-g++ export

Re: [poppler] Any one compile poppler with mingw for windows?

2009-09-09 Thread Vincent Torri
On Thu, 10 Sep 2009, Shen Liang wrote: Is it possible compile poppler with mingw+msys on windows or with mingw on linux? I git the latest source. When I compiled with mingw+msys, I always got error about freetype. which error ? I installed mingw 32 on Ubuntu, and run: export

Re: [poppler] Any one compile poppler with mingw for windows?

2009-09-09 Thread Shen Liang
I got cd . /bin/sh /h/projects/poppler/poppler/missing --run autoconf Can't locate object method path via package Autom4te::Request (perhaps you forgot to load Autom4te::Request?) at /usr/bin/autom4te line 81. make: *** [configure] Error 1 after autogen.sh and make with mingw+msys on windows.

Re: [poppler] Any one compile poppler with mingw for windows?

2009-09-09 Thread Vincent Torri
On Thu, 10 Sep 2009, Shen Liang wrote: I got cd . /bin/sh /h/projects/poppler/poppler/missing --run autoconf Can't locate object method path via package Autom4te::Request (perhaps you forgot to load Autom4te::Request?) at /usr/bin/autom4te line 81. make: *** [configure] Error 1 you said