[jira] [Commented] (PROTON-872) Ruby Messenger should not use send as it conflicts with Ruby's Object::send method

2015-04-29 Thread Darryl L. Pierce (JIRA)

[ 
https://issues.apache.org/jira/browse/PROTON-872?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14519918#comment-14519918
 ] 

Darryl L. Pierce commented on PROTON-872:
-

Very good point. Thanks for the link, Rafi. I'll update the Reactive code to 
use __send__ instead of send.

> Ruby Messenger should not use send as it conflicts with Ruby's Object::send 
> method
> --
>
> Key: PROTON-872
> URL: https://issues.apache.org/jira/browse/PROTON-872
> Project: Qpid Proton
>  Issue Type: Bug
>  Components: ruby-binding
>Affects Versions: 0.9
>Reporter: Darryl L. Pierce
>Assignee: Darryl L. Pierce
>
> Ruby's Object class has a method named "send" that is used for 
> programmatically invoking methods on an instance of a class. Classes should 
> not use "send" but instead use a different name for such methods.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (PROTON-872) Ruby Messenger should not use send as it conflicts with Ruby's Object::send method

2015-04-29 Thread Rafael H. Schloming (JIRA)

[ 
https://issues.apache.org/jira/browse/PROTON-872?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14519860#comment-14519860
 ] 

Rafael H. Schloming commented on PROTON-872:


I'm not sure I would count this is a bug. The following thread suggests that 
Object#send is unsafe to depend on and that you should use Object#__send__ 
instead.

   http://stackoverflow.com/questions/4658269/ruby-send-vs-send


> Ruby Messenger should not use send as it conflicts with Ruby's Object::send 
> method
> --
>
> Key: PROTON-872
> URL: https://issues.apache.org/jira/browse/PROTON-872
> Project: Qpid Proton
>  Issue Type: Bug
>  Components: ruby-binding
>Affects Versions: 0.9
>Reporter: Darryl L. Pierce
>Assignee: Darryl L. Pierce
>
> Ruby's Object class has a method named "send" that is used for 
> programmatically invoking methods on an instance of a class. Classes should 
> not use "send" but instead use a different name for such methods.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)