[As suggested by Tobie - reposted from
http://groups.google.com/group/rubyonrails-spinoffs/browse_thread/thread/a7edd31205e69472]

I've started a path to reimplementing commonly reused global names
with a patch (http://dev.rubyonrails.org/ticket/10958)

This patch is for $ function. I've giving it the namespace
Prototype.upgradeElement, but the actual name is unimportant currently
- its very easy to change in my git branch and to recreate the patch.

Whilst there are many classes and functions in the global namespace,
this patch is a start to give an idea how easy it is to replace the
code throughout the src, and ensure the original tests still work (and
thus all dependent code will still work).

Subsequent patches can fix up other commonly overused variables/
functions, and most importantly, create a noConflict() method to let
users manage it at runtime.

Cheers
Nic
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to prototype-core@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/prototype-core?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to