Re: Lifetime of Blob URL

2010-08-30 Thread Arun Ranganathan
Jian, On 8/28/10 8:59 PM, Jian Li wrote: Adding explicit methods to window and WorkerGlobalScope seems to be a better solution that solves potential problems we currently have with blob.url. Given that, we're going to experiment the proposed new APIs in the WebKit implementation, That is,

[Bug 10127] EventSource does not need to deal with HTTP 3xx responses as they are dealt with by the fetching algorithm.

2010-08-30 Thread bugzilla
http://www.w3.org/Bugs/Public/show_bug.cgi?id=10127 Ian 'Hixie' Hickson i...@hixie.ch changed: What|Removed |Added Status|NEW |RESOLVED

[Bug 10128] Step 4 of the EventSource algorithm should reference the fail the connection algorithm.

2010-08-30 Thread bugzilla
http://www.w3.org/Bugs/Public/show_bug.cgi?id=10128 Ian 'Hixie' Hickson i...@hixie.ch changed: What|Removed |Added Status|NEW |RESOLVED

[Bug 10130] The steps to dispatch the event within EventSource should first remove the LF from the data buffer before checking whether it is empty. Otherwise it can never be empty.

2010-08-30 Thread bugzilla
http://www.w3.org/Bugs/Public/show_bug.cgi?id=10130 Ian 'Hixie' Hickson i...@hixie.ch changed: What|Removed |Added Status|NEW |RESOLVED

Re: Lifetime of Blob URL

2010-08-30 Thread Darin Fisher
On Mon, Aug 30, 2010 at 11:14 AM, Jian Li jia...@chromium.org wrote: On Mon, Aug 30, 2010 at 9:59 AM, Arun Ranganathan a...@mozilla.comwrote: Jian, On 8/28/10 8:59 PM, Jian Li wrote: Adding explicit methods to window and WorkerGlobalScope seems to be a better solution that solves

Re: Lifetime of Blob URL

2010-08-30 Thread Jonas Sicking
On Mon, Aug 30, 2010 at 9:59 AM, Arun Ranganathan a...@mozilla.com wrote: In addition, BlobError and BlobException sound better because these names are consistent with current Blob naming scheme in File API. So we're also going to adopt these new names in the WebKit implementation when we

Re: Lifetime of Blob URL

2010-08-30 Thread Darin Fisher
On Mon, Aug 30, 2010 at 1:08 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Aug 30, 2010 at 9:59 AM, Arun Ranganathan a...@mozilla.com wrote: In addition, BlobError and BlobException sound better because these names are consistent with current Blob naming scheme in File API. So we're

Re: Lifetime of Blob URL

2010-08-30 Thread Jonas Sicking
On Mon, Aug 30, 2010 at 4:22 PM, Darin Fisher da...@chromium.org wrote: On Mon, Aug 30, 2010 at 1:08 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Aug 30, 2010 at 9:59 AM, Arun Ranganathan a...@mozilla.com wrote: In addition, BlobError and BlobException sound better because these names

Re: Lifetime of Blob URL

2010-08-30 Thread Dmitry Titov
As for wild ideas, it also could be something more generic, lets say DataReader which can take Blobs and Files (and perhaps something else in the future). Like XHR that has overloaded methods for xhr.open(..). It seems possible that web developers may not realize that File is actually a Blob and

Re: Lifetime of Blob URL

2010-08-30 Thread Jonas Sicking
On Mon, Aug 30, 2010 at 5:14 PM, Dmitry Titov dim...@chromium.org wrote: As for wild ideas, it also could be something more generic, lets say DataReader which can take Blobs and Files (and perhapsĀ somethingĀ else in the future). Like XHR that has overloaded methods for xhr.open(..). It seems

Re: Lifetime of Blob URL

2010-08-30 Thread Jian Li
The other alternative is to have both FileReader and BlobReader, while the former one is for reading only File object and the later one is for reading any Blob object. With that, we also have FileReaderSync and BlobReaderSync. On Mon, Aug 30, 2010 at 5:17 PM, Jonas Sicking jo...@sicking.cc wrote:

Re: Lifetime of Blob URL

2010-08-30 Thread Jonas Sicking
On Mon, Aug 30, 2010 at 5:23 PM, Jian Li jia...@chromium.org wrote: The other alternative is to have both FileReader and BlobReader, while the former one is for reading only File object and the later one is for reading any Blob object. With that, we also have FileReaderSync and BlobReaderSync.

Re: Lifetime of Blob URL

2010-08-30 Thread Mike Clement
As a developer who eagerly awaits this API, I'm fine with using File- prefixes for most everything, since many times a file in many APIs is really an abstraction for a stream of data anyway, and I think that most experienced developers can wrap their heads around that. That's my two cent's worth,

FileSystem API - overwrite flag for copy/move?

2010-08-30 Thread Kinuko Yasuda
Hi, I have a question about Entry.moveTo/copyTo behavior defined in the File API: Directories and System [1]. Currently the API doesn't specify how Entry.moveTo() and copyTo() should behave when a source entry is a file and there's *already* a file at the destination path. Should UAs overwrite

[Bug 10130] The steps to dispatch the event within EventSource should first remove the LF from the data buffer before checking whether it is empty. Otherwise it can never be empty.

2010-08-30 Thread bugzilla
http://www.w3.org/Bugs/Public/show_bug.cgi?id=10130 Anne ann...@opera.com changed: What|Removed |Added Resolution|NEEDSINFO |INVALID --- Comment #2 from

Re: Lifetime of Blob URL

2010-08-30 Thread Anne van Kesteren
On Tue, 31 Aug 2010 01:22:45 +0200, Darin Fisher da...@chromium.org wrote: Another idea (possibly a crazy one) would be to eliminate Blob, and just use File for everything. We could rename BlobBuilder to FileBuilder and have it return a File instead of a Blob. Same goes for Blob.slice().