Re: XMLHttpRequest.responseBlob

2010-05-11 Thread Simon Pieters
On Fri, 30 Apr 2010 05:43:36 +0200, Jonas Sicking jo...@sicking.cc wrote: So we have Opera: Document.URL WebSocket.URL StorageEvent.url WebKit: Document.URL EventSource.URL WebSocket.URL StorageEvent.uri WebKit changed 'uri' to 'url'. Gecko: Document.URL File.url

StorageEvent.url (WAS: XMLHttpRequest.responseBlob)

2010-04-29 Thread Jeremy Orlow
On Thu, Apr 29, 2010 at 6:11 AM, Simon Pieters sim...@opera.com wrote: You mean StorageEvent? javascript:alert('url' in StorageEvent.prototype) Opera: false Firefox: true Chrome: false I tried actually causing a storage event and then enumerated its properties with each browser and got

Re: StorageEvent.url (WAS: XMLHttpRequest.responseBlob)

2010-04-29 Thread Boris Zbarsky
On 4/29/10 9:23 AM, Jeremy Orlow wrote: Opera 10.50 does return false for your bit of javascript, but when I enumerate the properties on event after causing a storage event, url is there. Weird. All that means is that the property is an own property of the object, not a property

Re: StorageEvent.url (WAS: XMLHttpRequest.responseBlob)

2010-04-29 Thread Boris Zbarsky
On 4/29/10 12:13 PM, Jeremy Orlow wrote: The following script does not work for me in 3.6. Would love to know what I'm doing wrong: window.onstorage = function() { alert(HI); } localStorage.foo = localStorage.foo + ; In Gecko storage events for a change in window X are fired at all windows

Re: XMLHttpRequest.responseBlob

2010-04-29 Thread Ian Hickson
On Wed, 28 Apr 2010, Jonas Sicking wrote: I really think we should make sure we end up with a consistent naming scheme here. If Gecko is the only engine that's going to do .url instead of .URL, then I'm happy to change it back (on the assumption that Gecko will eventually be forced to

Re: XMLHttpRequest.responseBlob

2010-04-29 Thread Jonas Sicking
On Thu, Apr 29, 2010 at 7:01 PM, Ian Hickson i...@hixie.ch wrote: On Wed, 28 Apr 2010, Jonas Sicking wrote: I really think we should make sure we end up with a consistent naming scheme here. If Gecko is the only engine that's going to do .url instead of .URL, then I'm happy to change it

Re: XMLHttpRequest.responseBlob

2010-04-28 Thread Darin Fisher
On Tue, Apr 27, 2010 at 2:04 PM, Jonas Sicking jo...@sicking.cc wrote: On Tue, Apr 27, 2010 at 1:59 PM, Darin Fisher da...@chromium.org wrote: On Tue, Apr 27, 2010 at 1:33 PM, Jonas Sicking jo...@sicking.cc wrote: On Tue, Apr 27, 2010 at 1:26 PM, Darin Fisher da...@chromium.org wrote:

Re: XMLHttpRequest.responseBlob

2010-04-28 Thread Jonas Sicking
Ugh, sent this originally to just Darin. Resending to the list. On Wed, Apr 28, 2010 at 10:11 AM, Darin Fisher da...@chromium.org wrote: On Tue, Apr 27, 2010 at 2:04 PM, Jonas Sicking jo...@sicking.cc wrote: On Tue, Apr 27, 2010 at 1:59 PM, Darin Fisher da...@chromium.org wrote: On Tue, Apr

Re: XMLHttpRequest.responseBlob

2010-04-28 Thread Michael Nordman
On Wed, Apr 28, 2010 at 11:21 AM, Jonas Sicking jo...@sicking.cc wrote: Ugh, sent this originally to just Darin. Resending to the list. On Wed, Apr 28, 2010 at 10:11 AM, Darin Fisher da...@chromium.org wrote: On Tue, Apr 27, 2010 at 2:04 PM, Jonas Sicking jo...@sicking.cc wrote: On Tue,

Re: XMLHttpRequest.responseBlob

2010-04-28 Thread Darin Fisher
On Wed, Apr 28, 2010 at 11:57 AM, Michael Nordman micha...@google.comwrote: On Wed, Apr 28, 2010 at 11:21 AM, Jonas Sicking jo...@sicking.cc wrote: Ugh, sent this originally to just Darin. Resending to the list. On Wed, Apr 28, 2010 at 10:11 AM, Darin Fisher da...@chromium.org wrote: On

Re: XMLHttpRequest.responseBlob

2010-04-28 Thread Jonas Sicking
On Wed, Apr 28, 2010 at 12:45 PM, Darin Fisher da...@chromium.org wrote: On Wed, Apr 28, 2010 at 11:57 AM, Michael Nordman micha...@google.com wrote: On Wed, Apr 28, 2010 at 11:21 AM, Jonas Sicking jo...@sicking.cc wrote: Ugh, sent this originally to just Darin. Resending to the list. On

Re: XMLHttpRequest.responseBlob

2010-04-28 Thread Eric Uhrhane
On Wed, Apr 28, 2010 at 12:45 PM, Darin Fisher da...@chromium.org wrote: On Wed, Apr 28, 2010 at 11:57 AM, Michael Nordman micha...@google.com wrote: On Wed, Apr 28, 2010 at 11:21 AM, Jonas Sicking jo...@sicking.cc wrote: Ugh, sent this originally to just Darin. Resending to the list. On

Re: XMLHttpRequest.responseBlob

2010-04-28 Thread Jonas Sicking
On Wed, Apr 28, 2010 at 8:18 PM, Ian Hickson i...@hixie.ch wrote: On Tue, 27 Apr 2010, Simon Pieters wrote: Fine, fine. I've updated HTML5 to rename WebSocket.URL, EventSource.URL, and Stream.URL to be lowercase. Can you change it back? We've implemented and written tests for

Re: XMLHttpRequest.responseBlob

2010-04-28 Thread Simon Pieters
On Thu, 29 Apr 2010 05:27:44 +0200, Jonas Sicking jo...@sicking.cc wrote: Can you change it back? We've implemented and written tests for WebSocket.URL. WebKit has implemented EventSource.URL and WebSocket.URL. Do you plan to implement the File API attribute as .URL also?

Re: XMLHttpRequest.responseBlob

2010-04-27 Thread Darin Fisher
On Mon, Apr 26, 2010 at 3:52 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Apr 26, 2010 at 3:39 PM, Darin Fisher da...@chromium.org wrote: On Mon, Apr 26, 2010 at 3:29 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Apr 26, 2010 at 3:21 PM, Darin Fisher da...@chromium.org wrote:

Re: XMLHttpRequest.responseBlob

2010-04-27 Thread Simon Pieters
On Tue, 27 Apr 2010 01:19:52 +0200, Ian Hickson i...@hixie.ch wrote: On Mon, 26 Apr 2010, Jonas Sicking wrote: I initially implemented an uppercased name, but when I was writing test cases for this property it was incredibly awkward to use the uppercased version and I kept mistyping it using

Re: XMLHttpRequest.responseBlob

2010-04-27 Thread Jonas Sicking
On Tue, Apr 27, 2010 at 12:12 AM, Simon Pieters sim...@opera.com wrote: I would rather keep consistency with the hundreds of other properties that use lower case name, than the single one that use upper case. I would rather have all attributes with the same name use the same case. Add to

Re: XMLHttpRequest.responseBlob

2010-04-27 Thread Simon Pieters
On Tue, 27 Apr 2010 10:00:02 +0200, Jonas Sicking jo...@sicking.cc wrote: On Tue, Apr 27, 2010 at 12:12 AM, Simon Pieters sim...@opera.com wrote: I would rather keep consistency with the hundreds of other properties that use lower case name, than the single one that use upper case. I would

Re: XMLHttpRequest.responseBlob

2010-04-27 Thread Eric Uhrhane
On Mon, Apr 26, 2010 at 11:03 PM, Darin Fisher da...@chromium.org wrote: On Mon, Apr 26, 2010 at 3:52 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Apr 26, 2010 at 3:39 PM, Darin Fisher da...@chromium.org wrote: On Mon, Apr 26, 2010 at 3:29 PM, Jonas Sicking jo...@sicking.cc wrote: On

Re: XMLHttpRequest.responseBlob

2010-04-27 Thread Darin Fisher
On Tue, Apr 27, 2010 at 10:11 AM, Eric Uhrhane er...@google.com wrote: On Mon, Apr 26, 2010 at 11:03 PM, Darin Fisher da...@chromium.org wrote: On Mon, Apr 26, 2010 at 3:52 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Apr 26, 2010 at 3:39 PM, Darin Fisher da...@chromium.org wrote:

Re: XMLHttpRequest.responseBlob

2010-04-27 Thread Jonas Sicking
On Mon, Apr 26, 2010 at 11:03 PM, Darin Fisher da...@chromium.org wrote: On Mon, Apr 26, 2010 at 3:52 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Apr 26, 2010 at 3:39 PM, Darin Fisher da...@chromium.org wrote: On Mon, Apr 26, 2010 at 3:29 PM, Jonas Sicking jo...@sicking.cc wrote: On

Re: XMLHttpRequest.responseBlob

2010-04-27 Thread Darin Fisher
On Tue, Apr 27, 2010 at 11:01 AM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Apr 26, 2010 at 11:03 PM, Darin Fisher da...@chromium.org wrote: On Mon, Apr 26, 2010 at 3:52 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Apr 26, 2010 at 3:39 PM, Darin Fisher da...@chromium.org wrote:

Re: XMLHttpRequest.responseBlob

2010-04-27 Thread Jonas Sicking
On Tue, Apr 27, 2010 at 1:26 PM, Darin Fisher da...@chromium.org wrote: It would be nice to be able to allow streaming such that every time a progress event is fired only the newly downloaded data is available. The UA is then free to throw away that data once the event is done firing. This

Re: XMLHttpRequest.responseBlob

2010-04-27 Thread Darin Fisher
On Tue, Apr 27, 2010 at 1:33 PM, Jonas Sicking jo...@sicking.cc wrote: On Tue, Apr 27, 2010 at 1:26 PM, Darin Fisher da...@chromium.org wrote: It would be nice to be able to allow streaming such that every time a progress event is fired only the newly downloaded data is available. The UA

Re: XMLHttpRequest.responseBlob

2010-04-27 Thread Jonas Sicking
On Tue, Apr 27, 2010 at 1:59 PM, Darin Fisher da...@chromium.org wrote: On Tue, Apr 27, 2010 at 1:33 PM, Jonas Sicking jo...@sicking.cc wrote: On Tue, Apr 27, 2010 at 1:26 PM, Darin Fisher da...@chromium.org wrote: It would be nice to be able to allow streaming such that every time a

Re: XMLHttpRequest.responseBlob

2010-04-26 Thread Jonas Sicking
On Mon, Apr 26, 2010 at 3:21 PM, Darin Fisher da...@chromium.org wrote: There is some interest from application developers at Google in being able to get a Blob corresponding to the response body of a XMLHttpRequest. The use case is to improve the efficiency of getting a Blob from a binary

Re: XMLHttpRequest.responseBlob

2010-04-26 Thread Michael Nordman
On Mon, Apr 26, 2010 at 3:52 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Apr 26, 2010 at 3:39 PM, Darin Fisher da...@chromium.org wrote: On Mon, Apr 26, 2010 at 3:29 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Apr 26, 2010 at 3:21 PM, Darin Fisher da...@chromium.org wrote:

Re: XMLHttpRequest.responseBlob

2010-04-26 Thread Jonas Sicking
On Mon, Apr 26, 2010 at 3:57 PM, Ian Hickson i...@hixie.ch wrote: On Mon, 26 Apr 2010, Jonas Sicking wrote: Can we please rename .URN to .URL for consistency with the rest of the platform? It really sticks out like a sore thumb being the only one that's different... I'm worried people are

Re: XMLHttpRequest.responseBlob

2010-04-26 Thread Jonas Sicking
On Mon, Apr 26, 2010 at 4:02 PM, James Robinson jam...@google.com wrote: On Mon, Apr 26, 2010 at 3:52 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Apr 26, 2010 at 3:39 PM, Darin Fisher da...@chromium.org wrote: On Mon, Apr 26, 2010 at 3:29 PM, Jonas Sicking jo...@sicking.cc wrote: On

Re: XMLHttpRequest.responseBlob

2010-04-26 Thread Jonas Sicking
On Mon, Apr 26, 2010 at 4:01 PM, Michael Nordman micha...@google.com wrote: On Mon, Apr 26, 2010 at 3:52 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Apr 26, 2010 at 3:39 PM, Darin Fisher da...@chromium.org wrote: On Mon, Apr 26, 2010 at 3:29 PM, Jonas Sicking jo...@sicking.cc wrote:

Re: XMLHttpRequest.responseBlob

2010-04-26 Thread Ian Hickson
On Mon, 26 Apr 2010, Jonas Sicking wrote: I initially implemented an uppercased name, but when I was writing test cases for this property it was incredibly awkward to use the uppercased version and I kept mistyping it using the lower cased name. I would rather keep consistency with the

Re: XMLHttpRequest.responseBlob

2010-04-26 Thread Jonas Sicking
On Mon, Apr 26, 2010 at 4:19 PM, Thomas Broyer t.bro...@gmail.com wrote: On Tue, Apr 27, 2010 at 1:11 AM, Jonas Sicking jo...@sicking.cc wrote: I'm not sure I understand how you envision the implementation working. You can't before hand know that the implementation won't ever access those

Re: XMLHttpRequest.responseBlob

2010-04-26 Thread Jonas Sicking
On Mon, Apr 26, 2010 at 5:22 PM, Michael Nordman micha...@google.com wrote: On Mon, Apr 26, 2010 at 4:24 PM, Jonas Sicking jo...@sicking.cc wrote: On Mon, Apr 26, 2010 at 4:19 PM, Thomas Broyer t.bro...@gmail.com wrote: On Tue, Apr 27, 2010 at 1:11 AM, Jonas Sicking jo...@sicking.cc wrote: