Re: [pulseaudio-discuss] [PATCH] util: Try finding out application name using dladdr if available

2014-09-10 Thread David Henningsson
On 2014-08-30 02:00, Felipe Sateler wrote: This fixes getting the binary name in the Hurd, or any other port using the GNU C library, but only in the case where the library is directly linked to. Opening with dlopen will not work. Hi Felipe, Do you recognise this code would help something

Re: [pulseaudio-discuss] Few questions about PA API

2014-09-10 Thread David Henningsson
On 2014-06-11 16:35, Lukasz M wrote: On 10 June 2014 12:19, David Henningsson david.hennings...@canonical.com mailto:david.hennings...@canonical.com wrote: Thanks for the patch. Overall I think this is good new functionality. Here's a review, which is mostly about details: I've

Re: [pulseaudio-discuss] [PATCH] daemon: Stop session-started PA daemon when exiting X session

2014-09-10 Thread David Henningsson
On 2014-04-13 20:21, Balint Reczey wrote: Hi, This patch has been contributed through Debian's bug tracker. Please review it and consider accepting it to the project's code base if you find it useful. Thanks, Balint Hi Balint, I wonder if the above can cause a problem if: 1) User starts

Re: [pulseaudio-discuss] [PATCH 4/5] configure: fix headset check

2014-09-10 Thread David Henningsson
I pushed this one (together with a related spelling mistake) because it looks obvious, trivial, and not directly related to the new native backend. Thanks! On 2014-09-08 11:15, Wim Taymans wrote: --- configure.ac | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [pulseaudio-discuss] [PATCH 0/5] Add simple HSP support in new native backend

2014-09-10 Thread David Henningsson
On 2014-09-08 11:15, Wim Taymans wrote: This set of patches adds a simple handler for the HSP profile to bluez and makes a new card for each connected device. This makes it possible to send audio to a Headset. The profile is implemented in a new native headset backend. The first 4 patches are

[pulseaudio-discuss] [PATCH v2 07/14] bluetooth: Implement transport release for hf_audio_agent transports

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org --- src/modules/bluetooth/backend-ofono.c | 16 1 file changed, 16 insertions(+) diff --git a/src/modules/bluetooth/backend-ofono.c b/src/modules/bluetooth/backend-ofono.c index 1ba40b1..8b2cea2 100644 ---

[pulseaudio-discuss] [PATCH v2 02/14] bluetooth: Create hf_dbus_send_and_add_to_pending() for oFono backend

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org --- src/modules/bluetooth/backend-ofono.c | 21 + 1 file changed, 21 insertions(+) diff --git a/src/modules/bluetooth/backend-ofono.c b/src/modules/bluetooth/backend-ofono.c index 99da783..1a4416e 100644 ---

[pulseaudio-discuss] [PATCH v2 13/14] bluetooth: Suspend the source/sink the HFP-oFono stream fd HUP

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org --- src/modules/bluetooth/module-bluez5-device.c | 6 ++ 1 file changed, 6 insertions(+) diff --git a/src/modules/bluetooth/module-bluez5-device.c b/src/modules/bluetooth/module-bluez5-device.c index fdf4078..d5d97c1 100644 ---

[pulseaudio-discuss] [PATCH v2 06/14] bluetooth: Implement transport acquire for hf_audio_agent transports

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org --- src/modules/bluetooth/backend-ofono.c | 67 ++- 1 file changed, 66 insertions(+), 1 deletion(-) diff --git a/src/modules/bluetooth/backend-ofono.c b/src/modules/bluetooth/backend-ofono.c index

[pulseaudio-discuss] [PATCH v2 03/14] bluetooth: Register/Unregister Handsfree Audio Agent with oFono

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org Register as a HandsfreeAudioAgent with oFono during backend initialization and unregiter during backend finalization. This commit also adds a check when receiving method calls or signals to make sure the sender matches with the D-Bus service we're

[pulseaudio-discuss] [PATCH v2 10/14] bluetooth: Handle CardRemoved signal

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org --- src/modules/bluetooth/backend-ofono.c | 27 +++ 1 file changed, 27 insertions(+) diff --git a/src/modules/bluetooth/backend-ofono.c b/src/modules/bluetooth/backend-ofono.c index f3936b4..c23f495 100644 ---

[pulseaudio-discuss] [PATCH v2 05/14] bluetooth: Parse HandsfreeAudioCard properties

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org --- src/modules/bluetooth/backend-ofono.c | 109 +- 1 file changed, 107 insertions(+), 2 deletions(-) diff --git a/src/modules/bluetooth/backend-ofono.c b/src/modules/bluetooth/backend-ofono.c index

[pulseaudio-discuss] [PATCH] bluetooth: Add discovery to pa_bluetooth_backend_new

2014-09-10 Thread Luiz Augusto von Dentz
From: Luiz Augusto von Dentz luiz.von.de...@intel.com --- src/modules/bluetooth/backend-null.c | 2 +- src/modules/bluetooth/backend-ofono.c | 4 +++- src/modules/bluetooth/bluez5-util.c | 2 +- src/modules/bluetooth/bluez5-util.h | 2 +- 4 files changed, 6 insertions(+), 4 deletions(-)

[pulseaudio-discuss] [PATCH v2 09/14] bluetooth: Handle CardAdded signal

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org --- src/modules/bluetooth/backend-ofono.c | 38 ++- 1 file changed, 28 insertions(+), 10 deletions(-) diff --git a/src/modules/bluetooth/backend-ofono.c b/src/modules/bluetooth/backend-ofono.c index

[pulseaudio-discuss] [PATCH v2 04/14] bluetooth: List HandsfreeAudioCard objects from oFono

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org --- src/modules/bluetooth/backend-ofono.c | 54 ++- 1 file changed, 53 insertions(+), 1 deletion(-) diff --git a/src/modules/bluetooth/backend-ofono.c b/src/modules/bluetooth/backend-ofono.c index

[pulseaudio-discuss] [PATCH v2 12/14] bluetooth: Implement org.ofono.HandsfreeAudioAgent.NewConnection()

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org --- src/modules/bluetooth/backend-ofono.c | 32 ++-- 1 file changed, 30 insertions(+), 2 deletions(-) diff --git a/src/modules/bluetooth/backend-ofono.c b/src/modules/bluetooth/backend-ofono.c index c17aed7..9a530b8

[pulseaudio-discuss] [PATCH v2 08/14] bluetooth: Track oFono service

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org --- src/modules/bluetooth/backend-ofono.c | 36 +++ 1 file changed, 36 insertions(+) diff --git a/src/modules/bluetooth/backend-ofono.c b/src/modules/bluetooth/backend-ofono.c index 8b2cea2..94dbf61 100644 ---

[pulseaudio-discuss] [PATCH v2 14/14] bluetooth: Allow policy module to pick 'off' profile

2014-09-10 Thread Luiz Augusto von Dentz
From: Luiz Augusto von Dentz luiz.von.de...@intel.com This allow 'off' profile to be choosen when no other profile is available which is considered better since it requires less resources than other profiles. --- src/modules/bluetooth/module-bluetooth-policy.c | 9 - 1 file changed, 4

[pulseaudio-discuss] [PATCH v2 01/14] bluetooth: Monitor D-Bus signals

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org --- src/modules/bluetooth/backend-ofono.c | 49 --- 1 file changed, 45 insertions(+), 4 deletions(-) diff --git a/src/modules/bluetooth/backend-ofono.c b/src/modules/bluetooth/backend-ofono.c index

[pulseaudio-discuss] [PATCH v2 11/14] bluetooth: Implement org.ofono.HandsfreeAudioAgent.Release()

2014-09-10 Thread Luiz Augusto von Dentz
From: João Paulo Rechi Vita jprv...@openbossa.org --- src/modules/bluetooth/backend-ofono.c | 10 +- 1 file changed, 9 insertions(+), 1 deletion(-) diff --git a/src/modules/bluetooth/backend-ofono.c b/src/modules/bluetooth/backend-ofono.c index c23f495..c17aed7 100644 ---

Re: [pulseaudio-discuss] [PATCH v2] bluetooth: Only create backend instance once objects are listed

2014-09-10 Thread Luiz Augusto von Dentz
Hi Tanu, On Mon, Sep 8, 2014 at 1:35 PM, Luiz Augusto von Dentz luiz.de...@gmail.com wrote: From: Luiz Augusto von Dentz luiz.von.de...@intel.com This makes sure the devices are discovered before the backend start creating new transports. --- src/modules/bluetooth/bluez5-util.c | 8

Re: [pulseaudio-discuss] [PATCH] bluetooth: Add discovery to pa_bluetooth_backend_new

2014-09-10 Thread Tanu Kaskinen
On Wed, 2014-09-10 at 11:48 +0200, Luiz Augusto von Dentz wrote: From: Luiz Augusto von Dentz luiz.von.de...@intel.com --- src/modules/bluetooth/backend-null.c | 2 +- src/modules/bluetooth/backend-ofono.c | 4 +++- src/modules/bluetooth/bluez5-util.c | 2 +-

Re: [pulseaudio-discuss] PulseAudio miniconference 2014, Oct 15, Düsseldorf, Germany

2014-09-10 Thread Alexander E. Patrakov
09.09.2014 17:22, Tanu Kaskinen wrote: More details are in the wiki: http://www.freedesktop.org/wiki/Software/PulseAudio/Events/2014_Dusseldorf/ We don't yet have discussion topics for the miniconference, so if you plan to attend, topic ideas would be very welcome! Send them to the list, and

Re: [pulseaudio-discuss] [PATCH] bluetooth: Move stuff to pa_transport_put/unlink()

2014-09-10 Thread Luiz Augusto von Dentz
Hi Tanu, On Mon, Sep 8, 2014 at 2:30 PM, Tanu Kaskinen tanu.kaski...@linux.intel.com wrote: This should not have any effect on behaviour. The goal is to align with the pattern that I think we should follow: Object initialization: - put() is the place to create references from other objects

Re: [pulseaudio-discuss] [PATCH] daemon: Stop session-started PA daemon when exiting X session

2014-09-10 Thread Felipe Sateler
On Wed, Sep 10, 2014 at 6:18 AM, David Henningsson david.hennings...@canonical.com wrote: On 2014-04-13 20:21, Balint Reczey wrote: Hi, This patch has been contributed through Debian's bug tracker. Please review it and consider accepting it to the project's code base if you find it

Re: [pulseaudio-discuss] [PATCH] util: Try finding out application name using dladdr if available

2014-09-10 Thread Felipe Sateler
On Wed, Sep 10, 2014 at 4:37 AM, David Henningsson david.hennings...@canonical.com wrote: On 2014-08-30 02:00, Felipe Sateler wrote: This fixes getting the binary name in the Hurd, or any other port using the GNU C library, but only in the case where the library is directly linked to.

Re: [pulseaudio-discuss] [PATCH 01/13] cpu: Add force_generic_code flag to cpu_info struct

2014-09-10 Thread Peter Meerwald
Hello David, The remapper and channel mixing code have (faster) specialized and (slower) generic code certain code path. The flag force_generic_code can be set to force the generic code path which is useful for testing. Code duplication (such as in mix-special-test) can be avoided,

[pulseaudio-discuss] [PATCH v2 00/14] cpu-test rework patches

2014-09-10 Thread Peter Meerwald
v2 addresses review comments by David, http://lists.freedesktop.org/archives/pulseaudio-discuss/2014-September/021529.html Peter Meerwald (14): core: Add pa_cpu_init() / cpu.c cpu: Don't check for both x86 and ARM code cpu: Add force_generic_code flag to cpu_info struct tests: Split cpu

[pulseaudio-discuss] [PATCH v2 05/14] tests: Use single-line #ifdef for ARM NEON code

2014-09-10 Thread Peter Meerwald
From: Peter Meerwald p.meerw...@bct-electronic.com Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/tests/cpu-mix-test.c | 16 +--- src/tests/cpu-sconv-test.c | 16 +--- 2 files changed, 10 insertions(+), 22 deletions(-) diff --git a/src/tests/cpu-mix-test.c

[pulseaudio-discuss] [PATCH v2 08/14] tests: Use remap function passed in remap struct

2014-09-10 Thread Peter Meerwald
Cleanup and add function to setup remap struct Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/tests/cpu-remap-test.c | 101 + 1 file changed, 46 insertions(+), 55 deletions(-) diff --git a/src/tests/cpu-remap-test.c

[pulseaudio-discuss] [PATCH v2 13/14] tests: Use float constants in cpu-sconv-test

2014-09-10 Thread Peter Meerwald
Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/tests/cpu-sconv-test.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/src/tests/cpu-sconv-test.c b/src/tests/cpu-sconv-test.c index 4e7848d..428ebe0 100644 --- a/src/tests/cpu-sconv-test.c +++

[pulseaudio-discuss] [PATCH v2 09/14] tests: Reorganize cpu-remap-test program

2014-09-10 Thread Peter Meerwald
Make run_remap_test() support up to 8 input and output channels. Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/tests/cpu-remap-test.c | 187 ++--- 1 file changed, 108 insertions(+), 79 deletions(-) diff --git a/src/tests/cpu-remap-test.c

[pulseaudio-discuss] [PATCH v2 14/14] tests: Remove mix-special-test

2014-09-10 Thread Peter Meerwald
From: Peter Meerwald p.meerw...@bct-electronic.com code has been moved to cpu-mix-test Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/.gitignore | 1 - src/Makefile.am | 8 +- src/tests/mix-special-test.c | 326 ---

[pulseaudio-discuss] [PATCH v2 02/14] cpu: Don't check for both x86 and ARM code

2014-09-10 Thread Peter Meerwald
Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/pulsecore/cpu.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/pulsecore/cpu.c b/src/pulsecore/cpu.c index 542e86f..814abf6 100644 --- a/src/pulsecore/cpu.c +++ b/src/pulsecore/cpu.c @@ -26,7 +26,7 @@ void

[pulseaudio-discuss] [PATCH v2 10/14] tests: Add to remapping special case code tests to cpu-remap-test

2014-09-10 Thread Peter Meerwald
Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/tests/cpu-remap-test.c | 45 + 1 file changed, 45 insertions(+) diff --git a/src/tests/cpu-remap-test.c b/src/tests/cpu-remap-test.c index 319b119..f424a2d 100644 --- a/src/tests/cpu-remap-test.c

[pulseaudio-discuss] [PATCH v2 06/14] tests: Add tests for mix special-case code

2014-09-10 Thread Peter Meerwald
Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/tests/cpu-mix-test.c | 30 +- 1 file changed, 25 insertions(+), 5 deletions(-) diff --git a/src/tests/cpu-mix-test.c b/src/tests/cpu-mix-test.c index 2facaae..ab53c6c 100644 --- a/src/tests/cpu-mix-test.c +++

[pulseaudio-discuss] [PATCH v2 04/14] tests: Split cpu tests in separate files

2014-09-10 Thread Peter Meerwald
From: Peter Meerwald p.meerw...@bct-electronic.com Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/.gitignore | 5 +- src/Makefile.am | 28 +- src/tests/cpu-mix-test.c| 206 +++ src/tests/cpu-remap-test.c | 273 ++

[pulseaudio-discuss] [PATCH v2 11/14] tests: Add rearrange remapping test cases to cpu-remap-test

2014-09-10 Thread Peter Meerwald
From: Peter Meerwald p.meerw...@bct-electronic.com Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/tests/cpu-remap-test.c | 67 +++--- 1 file changed, 45 insertions(+), 22 deletions(-) diff --git a/src/tests/cpu-remap-test.c

[pulseaudio-discuss] [PATCH v2 12/14] tests: Add ARM NEON test code to cpu-remap-test

2014-09-10 Thread Peter Meerwald
From: Peter Meerwald p.meerw...@bct-electronic.com Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/tests/cpu-remap-test.c | 75 ++ 1 file changed, 75 insertions(+) diff --git a/src/tests/cpu-remap-test.c b/src/tests/cpu-remap-test.c index

[pulseaudio-discuss] [PATCH v2 07/14] tests: Add ARM NEON test code to cpu-mix-test

2014-09-10 Thread Peter Meerwald
Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/tests/cpu-mix-test.c | 8 +++- 1 file changed, 7 insertions(+), 1 deletion(-) diff --git a/src/tests/cpu-mix-test.c b/src/tests/cpu-mix-test.c index ab53c6c..181a767 100644 --- a/src/tests/cpu-mix-test.c +++ b/src/tests/cpu-mix-test.c

[pulseaudio-discuss] [PATCH v2 01/14] core: Add pa_cpu_init() / cpu.c

2014-09-10 Thread Peter Meerwald
move code dealing with CPU specific code path initialization from daemon/main.c to pulsecore/cpu.c Signed-off-by: Peter Meerwald pme...@pmeerw.net --- src/Makefile.am | 2 +- src/daemon/main.c | 13 ++--- src/pulsecore/cpu.c | 33 +

[pulseaudio-discuss] [PATCH v2 03/14] cpu: Add force_generic_code flag to cpu_info struct

2014-09-10 Thread Peter Meerwald
From: Peter Meerwald p.meerw...@bct-electronic.com The remapper and channel mixing code have (faster) specialized and (slower) generic code certain code path. The flag force_generic_code can be set to force the generic code path which is useful for testing. Code duplication (such as in

Re: [pulseaudio-discuss] [PATCH v2 06/14] tests: Add tests for mix special-case code

2014-09-10 Thread Alexander E. Patrakov
10.09.2014 20:40, Peter Meerwald wrote: + +START_TEST (mix_special_test) { +pa_cpu_info cpu_info = { PA_CPU_UNDEFINED, {}, false }; +pa_do_mix_func_t orig_func, special_func; + +cpu_info.force_generic_code = true; I don't see the point of first initializing the

Re: [pulseaudio-discuss] [PATCH v2 09/14] tests: Reorganize cpu-remap-test program

2014-09-10 Thread Alexander E. Patrakov
10.09.2014 20:40, Peter Meerwald wrote: +if (in_channels == 1) { +for (o = 0; o out_channels; o++) { +m-map_table_f[o][0] = 1.0f; +m-map_table_i[o][0] = 0x1; +} +} else { +for (o = 0; o out_channels; o++) { +for (i = 0; i

Re: [pulseaudio-discuss] [PATCH v2 10/14] tests: Add to remapping special case code tests to cpu-remap-test

2014-09-10 Thread Alexander E. Patrakov
10.09.2014 20:40, Peter Meerwald wrote: +pa_cpu_info cpu_info = { PA_CPU_UNDEFINED, {}, false }; +pa_remap_t remap_orig, remap_func; + +cpu_info.force_generic_code = true; Same as in patch 06/14. tc = tcase_create(remap); +tcase_add_test(tc, remap_special_test);

Re: [pulseaudio-discuss] [PATCH v2 09/14] tests: Reorganize cpu-remap-test program

2014-09-10 Thread Peter Meerwald
+if (in_channels == 1) { +for (o = 0; o out_channels; o++) { +m-map_table_f[o][0] = 1.0f; +m-map_table_i[o][0] = 0x1; +} +} else { +for (o = 0; o out_channels; o++) { +for (i = 0; i in_channels; i++) { +

Re: [pulseaudio-discuss] [PATCH v2 10/14] tests: Add to remapping special case code tests to cpu-remap-test

2014-09-10 Thread Alexander E. Patrakov
10.09.2014 21:52, I wrote: 10.09.2014 20:40, Peter Meerwald wrote: +pa_cpu_info cpu_info = { PA_CPU_UNDEFINED, {}, false }; +pa_remap_t remap_orig, remap_func; + +cpu_info.force_generic_code = true; Same as in patch 06/14. tc = tcase_create(remap); +tcase_add_test(tc,

Re: [pulseaudio-discuss] [PATCH v2 10/14] tests: Add to remapping special case code tests to cpu-remap-test

2014-09-10 Thread Peter Meerwald
+pa_cpu_info cpu_info = { PA_CPU_UNDEFINED, {}, false }; +pa_remap_t remap_orig, remap_func; + +cpu_info.force_generic_code = true; Same as in patch 06/14. tc = tcase_create(remap); +tcase_add_test(tc, remap_special_test); Something weird happened to