[Puppet - Feature #4022] Crontab environment variables

2012-10-01 Thread tickets
Issue #4022 has been updated by Justin Ellison. I've got what I think is an excellent use case for this. I have several (10+) cron jobs that are java applications. These cronjobs are setup via many different modules. Usually, these jobs are ran as the same user. It's nice to be able to set

[Puppet - Feature #16647] (Unreviewed) Client-side soft alternative to fail()

2012-10-01 Thread tickets
Issue #16647 has been reported by Dan Carley. Feature #16647: Client-side soft alternative to fail() https://projects.puppetlabs.com/issues/16647 Author: Dan Carley Status: Unreviewed Priority: Normal Assignee: Category: Target version: Affected

[Puppet - Feature #16647] Client-side soft alternative to fail()

2012-10-01 Thread tickets
Issue #16647 has been updated by Dan Carley. I guess this would require a new attribute being added to resources in the catalog. Feature #16647: Client-side soft alternative to fail() https://projects.puppetlabs.com/issues/16647#change-72064 Author:

[Puppet - Bug #16568] (Rejected) Modules added to modulepath aren't recognized until service restart

2012-10-01 Thread tickets
Issue #16568 has been updated by Jeff McCune. Status changed from Unreviewed to Rejected I just tried this on my CentOS 6.2 system with Puppet 3.0.0 from the official RPM and it worked exactly as I expected it to. I followed the steps to reproduce exactly and MediWiki was immediately

[Puppet - Feature #16647] (Needs Decision) Client-side soft alternative to fail()

2012-10-01 Thread tickets
Issue #16647 has been updated by Nigel Kersten. Category set to functions Status changed from Unreviewed to Needs Decision Assignee set to eric sorenson Feature #16647: Client-side soft alternative to fail()

[Puppet - Feature #16647] Client-side soft alternative to fail()

2012-10-01 Thread tickets
Issue #16647 has been updated by Nigel Kersten. Thinking about this, it doesn't have to require client-side functions. We could have a function that inserted a resource that always fails into the graph at the relevant spot. Feature #16647: Client-side

[Puppet - Bug #7316] (In Topic Branch Pending Review) puppet face applications (subcommands) delivered via pluginsync and as modules should work

2012-10-01 Thread tickets
Issue #7316 has been updated by Jeff McCune. Status changed from Re-opened to In Topic Branch Pending Review Assignee deleted (eric sorenson) Priority changed from Urgent to Normal Target version changed from 3.0.0 to 3.0.x Affected Puppet version set to 3.0.0 We missed the boat for this

[Puppet - Bug #16651] (Unreviewed) Installing the cloud provisioner module breaks the node subcommand

2012-10-01 Thread tickets
Issue #16651 has been reported by Jeff McCune. Bug #16651: Installing the cloud provisioner module breaks the node subcommand https://projects.puppetlabs.com/issues/16651 Author: Jeff McCune Status: Unreviewed Priority: Normal Assignee: Category: Faces

[Puppet - Bug #7316] puppet face applications (subcommands) delivered via pluginsync and as modules should work

2012-10-01 Thread tickets
Issue #7316 has been updated by Jeff McCune. I've also filed #16651 which specifically calls out the bug we've introduced (or rather failed to fix?) in 3.0.0. I think a new bug is warranted because we're explicitly breaking existing functionality on the node subcommand, which is a subtlety

[Puppet - Bug #16651] Installing the cloud provisioner module breaks the node subcommand

2012-10-01 Thread tickets
Issue #16651 has been updated by Jeff McCune. I've also filed #16651 which specifically calls out the bug we've introduced (or rather failed to fix?) in 3.0.0. I think a new bug is warranted because we're explicitly breaking existing functionality on the node subcommand, which is a subtlety

[Puppet - Bug #16651] Installing the cloud provisioner module breaks the node subcommand

2012-10-01 Thread tickets
Issue #16651 has been updated by Jeff McCune. # Trace pre root@pe-centos6:~# puppet help node --trace Error: Could not autoload puppet/face/node/classify: no such file to load -- puppet/cloudpack /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'

[Puppet - Bug #16651] Installing the cloud provisioner module breaks the node subcommand

2012-10-01 Thread tickets
Issue #16651 has been updated by Jeff McCune. Keywords set to faces node face subcommand cloud_provisioner Bug #16651: Installing the cloud provisioner module breaks the node subcommand https://projects.puppetlabs.com/issues/16651#change-72088 Author:

[Puppet - Bug #16657] (Unreviewed) puppet cert clean does not work for CSRs with DNS alt names

2012-10-01 Thread tickets
Issue #16657 has been reported by Ruth Linehan. Bug #16657: puppet cert clean does not work for CSRs with DNS alt names https://projects.puppetlabs.com/issues/16657 Author: Ruth Linehan Status: Unreviewed Priority: Normal Assignee: Category: Target

[Puppet - Bug #16659] (Unreviewed) Namespace segments of custom tags match with the == operator in resource collectors

2012-10-01 Thread tickets
Issue #16659 has been reported by Nick Chappell. Bug #16659: Namespace segments of custom tags match with the == operator in resource collectors https://projects.puppetlabs.com/issues/16659 Author: Nick Chappell Status: Unreviewed Priority: Normal

[Puppet - Bug #16274] static compiler doesn't work when a file resource has more than one source URL

2012-10-01 Thread tickets
Issue #16274 has been updated by Jeff McCune. # Community update In an effort to clearly communicate our intentions regarding this bug, here's what we're going to do: In the 3.x series, we'll be addressing themes for each of the feature releases. We're almost 100% certain that 3.1 will

[Puppet - Bug #16645] (Accepted) puppet module tool fails to resolve dependencies

2012-10-01 Thread tickets
Issue #16645 has been updated by Ryan Coleman. Status changed from Unreviewed to Accepted Assignee set to Ryan Coleman mrepo expresses its dependency on the puppetlabs apache module like 'puppetlabs-apache' when it should be 'puppetlabs/apache'. This causes the tool to fail. Short-term fix:

[Puppet] 'Downloading Puppet' wiki page has been updated

2012-10-01 Thread tickets
The 'Downloading Puppet' wiki page has been updated by Moses Mendoza. Downloading Puppet: https://projects.puppetlabs.com/projects/puppet/wiki/Downloading_Puppet View differences: https://projects.puppetlabs.com/projects/puppet/wiki/Downloading_Puppet/diff/208 -- You have received this

[Facter - Bug #16665] (Unreviewed) [windows] wrong ipaddress with locale != en

2012-10-01 Thread tickets
Issue #16665 has been reported by Sebastian Lehn. Bug #16665: [windows] wrong ipaddress with locale != en https://projects.puppetlabs.com/issues/16665 Author: Sebastian Lehn Status: Unreviewed Priority: Normal Assignee: Category: windows Target version:

[Puppet - Bug #16667] (Unreviewed) Misleading error message after upgrading from 2.7 to 3.0

2012-10-01 Thread tickets
Issue #16667 has been reported by Jeff McCune. Bug #16667: Misleading error message after upgrading from 2.7 to 3.0 https://projects.puppetlabs.com/issues/16667 Author: Jeff McCune Status: Unreviewed Priority: Normal Assignee: Category: error reporting

[Puppet - Bug #16667] Misleading error message after upgrading from 2.7 to 3.0

2012-10-01 Thread tickets
Issue #16667 has been updated by Jeff McCune. Description updated Bug #16667: Misleading error message after upgrading from 2.7 to 3.0 https://projects.puppetlabs.com/issues/16667#change-72114 Author: Jeff McCune Status: Unreviewed Priority: Normal

[Puppet - Bug #16667] Misleading error message after upgrading from 2.7 to 3.0

2012-10-01 Thread tickets
Issue #16667 has been updated by Jeff McCune. (Originally reported to me by bosszaru on the IRC channel.) Bug #16667: Misleading error message after upgrading from 2.7 to 3.0 https://projects.puppetlabs.com/issues/16667#change-72116 Author: Jeff McCune

[Puppet - Bug #16667] Misleading error message Not authorized to call find after upgrading from 2.7 to 3.0

2012-10-01 Thread tickets
Issue #16667 has been updated by Jeff McCune. Subject changed from Misleading error message after upgrading from 2.7 to 3.0 to Misleading error message Not authorized to call find after upgrading from 2.7 to 3.0 Bug #16667: Misleading error message

[Puppet - Bug #16376] (Merged - Pending Release) Inventory service fails on fact search with `undefined method `has_fact_with_value' for #Class:0x2adba4999d50`

2012-10-01 Thread tickets
Issue #16376 has been updated by Michael Stahnke. Status changed from In Topic Branch Pending Review to Merged - Pending Release merged at https://github.com/puppetlabs/puppet/commit/8fb16c875a6abfbed34015f86472e3ff81137fc9 Bug #16376: Inventory

[Facter - Bug #16668] (Unreviewed) [windows] ipaddress fact reports hostname

2012-10-01 Thread tickets
Issue #16668 has been reported by Sebastian Lehn. Bug #16668: [windows] ipaddress fact reports hostname https://projects.puppetlabs.com/issues/16668 Author: Sebastian Lehn Status: Unreviewed Priority: Normal Assignee: Category: windows Target version:

[Facter - Bug #16665] [windows] wrong ipaddress with locale != en

2012-10-01 Thread tickets
Issue #16665 has been updated by Sebastian Lehn. Maybe related ticket: #16668 Used system: Windows Server 2008 R2 Enterprise (German) Bug #16665: [windows] wrong ipaddress with locale != en https://projects.puppetlabs.com/issues/16665#change-72120

[Puppet] 'Release Notes' wiki page has been updated

2012-10-01 Thread tickets
The 'Release Notes' wiki page has been updated by Moses Mendoza. Release Notes: https://projects.puppetlabs.com/projects/puppet/wiki/Release_Notes View differences: https://projects.puppetlabs.com/projects/puppet/wiki/Release_Notes/diff/211 -- You have received this notification because you

[Facter - Bug #16665] (Accepted) [windows] wrong ipaddress with locale != en

2012-10-01 Thread tickets
Issue #16665 has been updated by Josh Cooper. Status changed from Unreviewed to Accepted Thanks for the report Sebastian. Can you provide the output of: pre netsh.exe interface ip show interface netsh.exe interface ipv6 show interface /pre And pre netsh.exe interface ipv6 show address

[Puppet] 'Release Notes' wiki page has been updated

2012-10-01 Thread tickets
The 'Release Notes' wiki page has been updated by Moses Mendoza. Release Notes: https://projects.puppetlabs.com/projects/puppet/wiki/Release_Notes View differences: https://projects.puppetlabs.com/projects/puppet/wiki/Release_Notes/diff/212 -- You have received this notification because you

[Facter - Bug #16665] [windows] wrong ipaddress with locale != en

2012-10-01 Thread tickets
Issue #16665 has been updated by Josh Cooper. Description updated Bug #16665: [windows] wrong ipaddress with locale != en https://projects.puppetlabs.com/issues/16665#change-72122 Author: Sebastian Lehn Status: Accepted Priority: Normal Assignee:

[Puppet - Bug #16672] (Unreviewed) Puppet comments generate errors if not at ^beginning of line

2012-10-01 Thread tickets
Issue #16672 has been reported by Forrest Aldrich. Bug #16672: Puppet comments generate errors if not at ^beginning of line https://projects.puppetlabs.com/issues/16672 Author: Forrest Aldrich Status: Unreviewed Priority: Normal Assignee: Category:

[Puppet - Bug #16672] Puppet comments generate errors if not at ^beginning of line

2012-10-01 Thread tickets
Issue #16672 has been updated by Forrest Aldrich. Here are the error messages that the above will generage: Oct 1 16:55:46 central puppet-agent[26980]: Could not autoload puppet/indirector/certificate/rest: Invalid duration format '900 # 15 mins' for parameter: runinterval Oct 1

[Puppet - Bug #16675] (Unreviewed) Issue with puppetlabs-firewall and puppet 3.0

2012-10-01 Thread tickets
Issue #16675 has been reported by Jason Hancock. Bug #16675: Issue with puppetlabs-firewall and puppet 3.0 https://projects.puppetlabs.com/issues/16675 Author: Jason Hancock Status: Unreviewed Priority: Normal Assignee: Ken Barber Category: Target

[Puppet - Bug #16676] (Unreviewed) End of line comments in puppet.conf are not treated as comments

2012-10-01 Thread tickets
Issue #16676 has been reported by Jeff McCune. Bug #16676: End of line comments in puppet.conf are not treated as comments https://projects.puppetlabs.com/issues/16676 Author: Jeff McCune Status: Unreviewed Priority: Normal Assignee: Category: settings

[Puppet] 'Release Notes' wiki page has been updated

2012-10-01 Thread tickets
The 'Release Notes' wiki page has been updated by eric sorenson. Release Notes: https://projects.puppetlabs.com/projects/puppet/wiki/Release_Notes View differences: https://projects.puppetlabs.com/projects/puppet/wiki/Release_Notes/diff/213 -- You have received this notification because you

[Puppet] 'Telly Upgrade Issues' wiki page has been added

2012-10-01 Thread tickets
The 'Telly Upgrade Issues' wiki page has been added by eric sorenson. https://projects.puppetlabs.com/projects/puppet/wiki/Telly_Upgrade_Issues -- You have received this notification because you have either subscribed to it, or are involved in it. To change your notification preferences,

[Puppet] 'Telly Upgrade Issues' wiki page has been updated

2012-10-01 Thread tickets
The 'Telly Upgrade Issues' wiki page has been updated by eric sorenson. Telly Upgrade Issues: https://projects.puppetlabs.com/projects/puppet/wiki/Telly_Upgrade_Issues View differences: https://projects.puppetlabs.com/projects/puppet/wiki/Telly_Upgrade_Issues/diff/2 -- You have received this

[Puppet - Bug #16667] Misleading error message Not authorized to call find after upgrading from 2.7 to 3.0

2012-10-01 Thread tickets
Issue #16667 has been updated by Jeff McCune. Reference: [commit 4053722](https://github.com/puppetlabs/puppet/commit/4053722) Bug #16667: Misleading error message Not authorized to call find after upgrading from 2.7 to 3.0

[Puppet] 'Telly Upgrade Issues' wiki page has been updated

2012-10-01 Thread tickets
The 'Telly Upgrade Issues' wiki page has been updated by Jeff McCune. Telly Upgrade Issues: https://projects.puppetlabs.com/projects/puppet/wiki/Telly_Upgrade_Issues View differences: https://projects.puppetlabs.com/projects/puppet/wiki/Telly_Upgrade_Issues/diff/3 -- You have received this

[Puppet - Bug #4224] (Closed) vardir and confdir should be in ~/.puppet if not run as root

2012-10-01 Thread tickets
Issue #4224 has been updated by Jeff McCune. Status changed from Needs More Information to Closed # Closing in favor of 16637 We discussed this in the puppet-dev IRC channel today and we feel we've missed the boat for fixing this bug in the 2.7 series. We do still accept responsibility for

[Puppet - Bug #16637] (Merged - Pending Release) Puppet confdir and vardir are wrong when running non-root

2012-10-01 Thread tickets
Issue #16637 has been updated by Andrew Parker. Status changed from In Topic Branch Pending Review to Merged - Pending Release Merge in https://github.com/puppetlabs/puppet/commit/8d59823fa1877fd28d834cfcd8528057a30cd0b0 Bug #16637: Puppet confdir and

[Puppet - Bug #16681] (Accepted) Using WMI to resolve user and group SIDs is very slow

2012-10-01 Thread tickets
Issue #16681 has been reported by Josh Cooper. Bug #16681: Using WMI to resolve user and group SIDs is very slow https://projects.puppetlabs.com/issues/16681 Author: Josh Cooper Status: Accepted Priority: Normal Assignee: Josh Cooper Category: Target

[Puppet - Bug #16271] (Accepted) launchd resources don't refresh/restart

2012-10-01 Thread tickets
Issue #16271 has been updated by Gary Larizza. File servicetest.zip added Status changed from Unreviewed to Accepted I've attached a module to test this out. It worked according to how Clay reported it. Also, I've done the following in the lib/puppet/provider/service/launchd.rb file at

[Puppet - Bug #16271] launchd resources don't refresh/restart

2012-10-01 Thread tickets
Issue #16271 has been updated by Gary Larizza. Branch set to https://github.com/glarizza/puppet-1/tree/bug/master/16271_launchd_restart_action Filed a pull request -- https://github.com/puppetlabs/puppet/pull/1197 Bug #16271: launchd resources don't