Re: [pylons-devel] 'future_imports' in Mako's template lookup?

2014-04-07 Thread Bert JW Regeer
Hey Vincent, Create a ticket on Github if you would please, and I will take a look at it. It looks like it would be fairly simple to add :-). Cheers, Bert On Apr 7, 2014, at 03:49 , Vincent Férotin vincent.fero...@gmail.com wrote: Hi, Pyramid's developers and Bert! Developing a Pyramid

Re: [pylons-devel] Probelms with wairtress in Python 2.7.7

2014-06-05 Thread Bert JW Regeer
https://github.com/Pylons/webob/pull/150 Is an outstanding pull request to fix this in from_file() in WebOb, would this solve the problem? Bert On Jun 5, 2014, at 08:26 , Chris McDonough chr...@plope.com wrote: On 06/05/2014 05:39 AM, Christoph Zwerschke wrote: Am 04.06.2014 12:58, schrieb

Re: [pylons-devel] suggestion - internal lifecycle logging

2014-10-02 Thread Bert JW Regeer
This seems like functionality that any ol’ profiler should be able to give you, and wouldn’t require any changes in Pyramid. Bert On Oct 2, 2014, at 20:10, Jonathan Vanasco jonat...@findmeon.com wrote: When doing performance audits, an annoying feature of Pyramid is that it's not very easy

Re: [pylons-devel] Add to the assets.yaml

2014-11-04 Thread Bert JW Regeer
Pyramid by default doesn’t have an assets.yaml file. Are you using an extension that parses that file? Bert On Nov 4, 2014, at 13:59 , Shawn DeWolfe mikedewo...@gmail.com wrote: I am wading back into Python, so this may be a newbie question. I am working on some modifications to the

Re: [pylons-devel] Pylons 1.x maintenance

2015-07-19 Thread Bert JW Regeer
On Jul 19, 2015, at 11:34 , Steve Piercy steve.piercy@gmail.com wrote: Take over implies ownership. Is that what you mean? You could be added as a Core Developer so that you can manage pull requests. https://github.com/orgs/Pylons/teams/core-developers That’s a non-public team.

Re: [pylons-devel] wsgi server of choice?

2015-10-20 Thread Bert JW Regeer
Sorry, Michael is right. pserve uses what is defined in the .ini, it has no default… > On Oct 20, 2015, at 12:26, Bert JW Regeer <xiste...@0x58.com> wrote: > > pserve by default uses waitress. But you can change what server it uses in > your .ini file. (Check the section

Re: [pylons-devel] wsgi server of choice?

2015-09-24 Thread Bert JW Regeer
I personally use uWSGI with nginx, however there are also a lot of people that simply reverse proxy to waitress. > On Sep 24, 2015, at 10:25, Chris Withers wrote: > > Hi All, > > What's the recommended wsgi server for Pyramid apps nowadays? > > My go-to would

Re: [pylons-devel] github pages for pylons project sites

2016-01-02 Thread Bert JW Regeer
Bert would indeed be happy. Cheers, Bert > On Jan 2, 2016, at 15:22, Michael Merickel wrote: > > Which websites are you planning to affect in the short term? Is it the 3 I > originally listed? I expect Bert will be happy if webob.org is on the list. > > On Sat, Jan 2,

Re: [pylons-devel] Please reconsider deprecating --daemon from pserve

2015-12-30 Thread Bert JW Regeer
to daemonise. Bert JW Regeer > On Dec 30, 2015, at 11:40, Iain Duncan <iainduncanli...@gmail.com> wrote: > > Hi folks, I wanted to weigh in on the decision to deprecate --daemon, as I > think that's a bad idea. I agree that in production we should use "real > mon

Re: [pylons-devel] weberror: Fix CSRF validation when token is unicode

2016-02-08 Thread Bert JW Regeer
WebError 0.12 is out on PyPi. Pulled in that CSRF fix :-) Cheers, Bert > On Feb 8, 2016, at 22:50, Jan Heylen <heyl...@gmail.com> wrote: > > Great, thanks! > > On Tue, Feb 9, 2016 at 1:11 AM, Bert JW Regeer <xiste...@0x58.com> wrote: >> I’ve just received pus

[pylons-devel] New release of WebError, meet version 0.12

2016-02-08 Thread Bert JW Regeer
and can easily be verified to work correctly I will merge and release as necessary. I am however NOT maintaining the project, and no new features or additions will be added. Thank you, Bert JW Regeer -- You received this message because you are subscribed to the Google Groups "pylons-devel&q

Re: [pylons-devel] PasteDeploy in the Pylons GitHub org?

2016-03-08 Thread Bert JW Regeer
That’s why he is asking if he can create the new repo under the Pylons banner. WebOb is another Ian Bicking project that now lives under the Pylons banner. Bert > On Mar 8, 2016, at 14:13, Jonathan Vanasco wrote: > > Assuming (1) Ian isn't going to maintain it anymore,

Re: [pylons-devel] pserve.exe syntax error on windows with --reload

2016-09-24 Thread Bert JW Regeer
What is Does it have a non-ascii character in the folder path? Try moving your project to C:\Projects\myproject or something similar, and that should hopefully avoid the error. Bert > On Sep 24, 2016, at 05:49 , only...@gmail.com wrote: > > > I have created a pyramid application using

Re: [pylons-devel] pserve.exe syntax error on windows with --reload

2016-09-25 Thread Bert JW Regeer
> On Sep 25, 2016, at 00:59 , Marius Gedminas wrote: > > On Sat, Sep 24, 2016 at 04:49:45AM -0700, only...@gmail.com wrote: >> I have created a pyramid application using pcreate, now when I try to run it >> using pserve with --reload, I get following error >> >> SyntaxError:

[pylons-devel] Waitress 1.1.0 has been released

2017-10-10 Thread Bert JW Regeer
, please file an issue here: https://github.com/pylons/waitress/issues Thank you, Bert JW Regeer -- You received this message because you are subscribed to the Google Groups "pylons-devel" group. To unsubscribe from this group and stop receiving emails from it, send an email to py

[pylons-devel] WebOb 1.8.2 has been released

2018-06-05 Thread Bert JW Regeer
Docs https://docs.pylonsproject.org/projects/webob/en/1.8-branch/index.html <https://docs.pylonsproject.org/projects/webob/en/1.8-branch/index.html> Issues https://github.com/pylons/webob/issues <https://github.com/pylons/webob/issues> Thanks, Bert JW Regeer -- You received

[pylons-devel] WebOb 1.8.1 has been released

2018-04-10 Thread Bert JW Regeer
Good evening, I've released WebOb 1.8.1 which contains a small fix to lessen the impact of the new Accept handling that was added to WebOb 1.8.0 when still using the old MIMEAccept API. No further changes were made in this release. Changelog:

[pylons-devel] Waitress 1.2.0 beta 1

2018-12-31 Thread Bert JW Regeer
ress/1.2.0b1/ <https://pypi.org/project/waitress/1.2.0b1/> pip install waitress=1.2.0b1 Thank you, Bert JW Regeer -- You received this message because you are subscribed to the Google Groups "pylons-devel" group. To unsubscribe from this group and stop receiving emails from it, se

[pylons-devel] Waitress 1.2.0 has been released

2019-01-15 Thread Bert JW Regeer
the changelog on PyPi: https://pypi.org/project/waitress/1.2.0/ <https://pypi.org/project/waitress/1.2.0/> To install: pip install waitress=1.2.0 If you run into any issues or concerns please file them here: https://github.com/Pylons/waitress/issues Thank you, Bert JW Regeer -- You re

Re: [pylons-devel] Waitress 1.2.0 beta 1

2019-01-07 Thread Bert JW Regeer
e the docs assume something other than ini file for the > config definition, anyway it was a small gotcha until I removed the quotes. > > Lance > > > > On 12/31/18 3:12 PM, Bert JW Regeer wrote: >> Hey all, >> >> As a new years gift, I have just rel

[pylons-devel] Waitress 1.2.1

2019-01-25 Thread Bert JW Regeer
, there are no other new changes. Please file issues here: https://github.com/Pylons/waitress/issues <https://github.com/Pylons/waitress/issues> Installing it from PyPI (https://pypi.org/project/waitress/ <https://pypi.org/project/waitress/>): pip install waitress==1.2.1 Thanks, Bert JW Rege

[pylons-devel] Waitress 1.3.0 beta 0 is now available

2019-04-11 Thread Bert JW Regeer
Hello everyone, With a giant shout-out to Michael Merickel for all his hard work on the latest version of waitress. Deprecations: - The send_bytes adjustment now defaults to 1 and is deprecated pending removal in a future release. It no longer changes how many bytes are placed into the

[pylons-devel] Waitress 1.3.1 has been released

2019-08-27 Thread Bert JW Regeer
waitress/issues> Thanks! Bert JW Regeer -- You received this message because you are subscribed to the Google Groups "pylons-devel" group. To unsubscribe from this group and stop receiving emails from it, send an email to pylons-devel+unsubscr...@googlegroups.com. To view this

[pylons-devel] Waitress 1.3.1 has been released

2019-08-28 Thread Bert JW Regeer
waitress/issues> Thanks! Bert JW Regeer -- You received this message because you are subscribed to the Google Groups "pylons-devel" group. To unsubscribe from this group and stop receiving emails from it, send an email to pylons-devel+unsubscr...@googlegroups.com. To view this

[pylons-devel] Venusian updates

2019-11-05 Thread Bert JW Regeer
ies getting updates! I have validated that 3.0.0 correctly has Requires-Python: >=3.5 set and pip won't install it on Python 2 or download it. Thanks all, and please let me know if there are any other issues you run into! Thanks, Bert JW Regeer -- You received this message because you are subs