Re: [pylons-devel] i18n in deformdemo dysfunctional - solved!

2017-02-09 Thread Hans-Peter Jansen
On Mittwoch, 8. Februar 2017 16:33:17 Michael Merickel wrote: > I got the renderer working via the following diff. Unfortunately the > translator is still not invoked which leads me to believe that there is > something wrong with the i18n tags in the chameleon templates, but I don't > know enough

Re: [pylons-devel] i18n in deformdemo dysfunctional

2017-02-09 Thread Hans-Peter Jansen
Hi Michael, I will look into this right now. Thanks for your care. Much appreciated. Cheers, Pete On Mittwoch, 8. Februar 2017 16:33:17 Michael Merickel wrote: > I got the renderer working via the following diff. Unfortunately the > translator is still not invoked which leads me to believe

Re: [pylons-devel] i18n in deformdemo dysfunctional

2017-02-08 Thread Michael Merickel
I got the renderer working via the following diff. Unfortunately the translator is still not invoked which leads me to believe that there is something wrong with the i18n tags in the chameleon templates, but I don't know enough about chameleon to dive in there. Hopefully this was helpful though.

Re: [pylons-devel] i18n in deformdemo dysfunctional

2017-02-08 Thread Michael Merickel
I noticed that the renderer is not being used. The `deform.Form.set_default_renderer(render)` is commented out. Uncommenting it doesn't solve the problem but it's definitely an issue as the zpt_renderer isn't actually being used as a result. On Wed, Feb 8, 2017 at 4:14 PM, Michael Merickel

Re: [pylons-devel] i18n in deformdemo dysfunctional

2017-02-08 Thread Michael Merickel
The issue is *usually* that the TranslationString instance hasn't been run through `request.localizer.translate(..)`. Now, why not? I haven't dug in to try and figure that out yet. On Wed, Feb 8, 2017 at 3:55 PM, Hans-Peter Jansen wrote: > Hi, > > I've used a good part of the