Re: [pytest-dev] More flexibility on test function naming conventions

2016-01-09 Thread Bruno Oliveira
Ernesto, Nice that you found the solution. Just to note that the documentation seems correct: .. confval:: python_functions One or more name prefixes or glob-patterns determining which test functions and methods are considered tests. Cheers, Bruno. On Sat, Jan 9, 2016 at 8:16 AM

Re: [pytest-dev] More flexibility on test function naming conventions

2016-01-09 Thread Ernesto D. Luzon Jr.
Hi All, I found the solution. It is already implemented in pytest but the usage only exists in the test and not in the documentation. I looked backed on Bruno's commit here and made a similar pytest.ini file he created for the test. https://bitbucket.org/pytest-dev/pytest/commits/4fb4cb5ae00f So

Re: [pytest-dev] More flexibility on test function naming conventions

2016-01-08 Thread Raphael Pierzina
Hi Ernesto, maybe this is what you are looking for https://pytest.org/latest/customize.html#confval-python_functions hth Raphael > On 08 Jan 2016, at 17:30, Ernesto D. Luzon Jr. wrote: > > Hi All, > >

Re: [pytest-dev] More flexibility on test function naming conventions

2016-01-08 Thread Dj Gilcrease
You may also want to look at https://github.com/pytest-dev/pytest-bdd On Fri, Jan 8, 2016 at 9:47 AM Raphael Pierzina wrote: > Hi Ernesto, > > maybe this is what you are looking for > https://pytest.org/latest/customize.html#confval-python_functions > > hth > Raphael >

[pytest-dev] More flexibility on test function naming conventions

2016-01-08 Thread Ernesto D. Luzon Jr.
Hi All, Is there a way to specify multiple naming conventions for test functions? For example, in my pytest.ini, I would like: [pytest] python_functions=[given, when, then, and, but] Then pytest can discover functions such as: def given_iam_an_author(): pass def and_i_wrote_an_article():