[issue4037] doctest.py should include method descriptors when looking inside a class __dict__

2010-02-06 Thread Terry J. Reedy
Terry J. Reedy added the comment: I am not sure whether this would be considered a bugfix or a new feature. (ie, whether it would apply to 2.6 and 3.1 or not) But the change is needed for 3.x also. I am not sure whether the doc needs changing. A testcase should be added to doctest-test.

[issue7869] traceback from logging is unusable.

2010-02-06 Thread INADA Naoki
INADA Naoki added the comment: This patch shows filename and lineno. I can specify my wrong logging code with this patch. -- keywords: +patch Added file: http://bugs.python.org/file16164/logging_show_file_and_line.patch ___ Python tracker

[issue7869] traceback from logging is unusable.

2010-02-06 Thread INADA Naoki
New submission from INADA Naoki : When exception raised in logging, traceback is shown but it doesn't tell me which logging code cause the error. $ cat unusable_traceback.py import logging logging.warn('%s %s', 1) # not enough arguments. $ python unusable_traceback.py Traceback (most recent c

[issue6877] enable compilation of readline module on Mac OS X 10.5 and 10.6

2010-02-06 Thread Zvezdan Petkovic
Changes by Zvezdan Petkovic : Added file: http://bugs.python.org/file16163/readline-libedit-trunk.patch ___ Python tracker ___ ___ Python-bugs-

[issue6877] enable compilation of readline module on Mac OS X 10.5 and 10.6

2010-02-06 Thread Zvezdan Petkovic
Changes by Zvezdan Petkovic : Added file: http://bugs.python.org/file16162/readline-libedit-2.6.5-fix1.patch ___ Python tracker ___ ___ Python-

[issue6877] enable compilation of readline module on Mac OS X 10.5 and 10.6

2010-02-06 Thread Zvezdan Petkovic
Changes by Zvezdan Petkovic : Removed file: http://bugs.python.org/file16161/readline-libedit-trunk.patch ___ Python tracker ___ ___ Python-bug

[issue6877] enable compilation of readline module on Mac OS X 10.5 and 10.6

2010-02-06 Thread Zvezdan Petkovic
Changes by Zvezdan Petkovic : Removed file: http://bugs.python.org/file16160/readline-libedit-2.6.5-1.patch ___ Python tracker ___ ___ Python-b

[issue6877] enable compilation of readline module on Mac OS X 10.5 and 10.6

2010-02-06 Thread Zvezdan Petkovic
Zvezdan Petkovic added the comment: Meador, I just looked at your patch (it seems we were posting patches at about the same time). That's a good fix too. Barry it's your call. -- ___ Python tracker _

[issue6877] enable compilation of readline module on Mac OS X 10.5 and 10.6

2010-02-06 Thread Zvezdan Petkovic
Zvezdan Petkovic added the comment: The patch with the same correction against trunk is attached so that Meador can test it. -- Added file: http://bugs.python.org/file16161/readline-libedit-trunk.patch ___ Python tracker

[issue6877] enable compilation of readline module on Mac OS X 10.5 and 10.6

2010-02-06 Thread Zvezdan Petkovic
Zvezdan Petkovic added the comment: OK, so issue4204 patch is causing problems. As I mentioned before we could choose to #ifdef __FreeBSD__ or check whether __APPLE__ is not defined. I'm attaching a new patch for 2.6.5 (2.6 branch) that uses the __APPLE__ check. -- Added file: http://

[issue6877] enable compilation of readline module on Mac OS X 10.5 and 10.6

2010-02-06 Thread Meador Inge
Meador Inge added the comment: > If not, then we need to make a choice of #ifdef __FreeBSD__ as I > suggested in issue4204, or #ifndef __APPLE__ as I used in my first > personal version of the patch. In the off chance that this same problem were to occur on another platform, wouldn't be bett

[issue7868] add a loggerClass attribute to Manager

2010-02-06 Thread Vinay Sajip
Vinay Sajip added the comment: Patch applied to trunk (r78055). -- resolution: -> fixed status: open -> closed ___ Python tracker ___ ___

[issue7857] test_logging fails

2010-02-06 Thread Vinay Sajip
Vinay Sajip added the comment: Tests now seem to be fine. Thanks, Benjamin Peterson, for the fix. -- status: open -> closed ___ Python tracker ___ ___

[issue2775] Implement PEP 3108

2010-02-06 Thread Éric Araujo
Changes by Éric Araujo : -- nosy: +Merwok ___ Python tracker ___ ___ Python-bugs-list mailing list Unsubscribe: http://mail.python.org

[issue4037] doctest.py should include method descriptors when looking inside a class __dict__

2010-02-06 Thread Steven D'Aprano
Steven D'Aprano added the comment: The patch you suggest is *not* sufficient, at least not by my testing. However, the attached patch does work, according to my tests. -- nosy: +stevenjd Added file: http://bugs.python.org/file16158/patch ___ Python

[issue7250] wsgiref.handlers.CGIHandler caches os.environ, leaking info between requests

2010-02-06 Thread Guido van Rossum
Guido van Rossum added the comment: Marking this as release blocker to ensure the (one-line) fix makes it into 2.7 and 3.2. -- priority: high -> release blocker resolution: -> accepted ___ Python tracker

[issue7301] Add environment variable $PYTHONWARNINGS

2010-02-06 Thread Brian Curtin
Brian Curtin added the comment: Updated patch, tests weren't working. -- Added file: http://bugs.python.org/file16157/issue7301.diff ___ Python tracker ___ __

[issue7301] Add environment variable $PYTHONWARNINGS

2010-02-06 Thread Brian Curtin
Changes by Brian Curtin : Removed file: http://bugs.python.org/file15889/issue7301.diff ___ Python tracker ___ ___ Python-bugs-list mailing lis

[issue5211] Fix complex type to avoid coercion in 2.7.

2010-02-06 Thread Mark Dickinson
Mark Dickinson added the comment: Thanks. I'll try to find time to look at this tomorrow. -- assignee: -> mark.dickinson ___ Python tracker ___

[issue4194] default subprocess.Popen buffer size

2010-02-06 Thread Shashwat Anand
Shashwat Anand added the comment: Tested it on mac OSX (Snow leopard) Shashwat-Anands-MacBook-Pro:Desktop l0nwlf$ python2.5 popentest.py time with os.popen : 0.0342061519623 time with subprocess.Popen : 0.0421631336212 Shashwat-Anands-MacBook-Pro:Desktop l0nwlf$ python2.6 --version Python 2.

[issue7301] Add environment variable $PYTHONWARNINGS

2010-02-06 Thread Éric Araujo
Changes by Éric Araujo : -- nosy: +Merwok ___ Python tracker ___ ___ Python-bugs-list mailing list Unsubscribe: http://mail.python.org

[issue7867] Proposed FAQ entry on pass-by-? semantics and the meaning of 'variable' in python

2010-02-06 Thread Brian Curtin
Changes by Brian Curtin : -- nosy: +brian.curtin ___ Python tracker ___ ___ Python-bugs-list mailing list Unsubscribe: http://mail.pyt

[issue7868] add a loggerClass attribute to Manager

2010-02-06 Thread Éric Araujo
Éric Araujo added the comment: I meant “klass”, right. My fingers are trained not to write it, it seems. Ok, it’s already used elsewhere in the module. Too bad. Kind regards -- ___ Python tracker

[issue7868] add a loggerClass attribute to Manager

2010-02-06 Thread Georg Brandl
Georg Brandl added the comment: You mean, instead of "klass"? It is used in the other setLoggerClass(), and therefore consistent. -- ___ Python tracker ___

[issue7347] Add {Create|Delete}KeyEx to _winreg, doc and test updates

2010-02-06 Thread Brian Curtin
Brian Curtin added the comment: Attached is what I believe is the complete patch. You'll need to apply the patch on #7860 for proper test coverage of a 32-bit Python running on 64-bit Windows. Here's a summary of what's contained: 1. Documented and tested the previously undocumented and unte

[issue7868] add a loggerClass attribute to Manager

2010-02-06 Thread Éric Araujo
Éric Araujo added the comment: s/ocde/code/ -- ___ Python tracker ___ ___ Python-bugs-list mailing list Unsubscribe: http://mail.pyth

[issue7868] add a loggerClass attribute to Manager

2010-02-06 Thread Éric Araujo
Éric Araujo added the comment: Hello I know the internal style (or lack thereof :) of logging forces you to use unReadableNames, but could the ocde use “cls” instead of “class”, as per PEP 8? Kind regards -- nosy: +Merwok ___ Python tracker

[issue7868] add a loggerClass attribute to Manager

2010-02-06 Thread Georg Brandl
New submission from Georg Brandl : This patch adds a loggerClass attribute to logging's Manager, and a setLoggerClass() function to set it. If no loggerClass is set, the global _loggerClass is used. This is for maximum backwards compatibility. There are no doc updates as the Manager is not d

[issue7867] Proposed FAQ entry on pass-by-? semantics and the meaning of 'variable' in python

2010-02-06 Thread R. David Murray
R. David Murray added the comment: Michael: I didn't read the whole thread, but it has definite echos of the thread in which I was involved. While I agree that in pure computer-science terms it may be imprecise to say that python is 'call by value where values are pointers to objects", my go

[issue7867] Proposed FAQ entry on pass-by-? semantics and the meaning of 'variable' in python

2010-02-06 Thread Ezio Melotti
Ezio Melotti added the comment: The difference is that mutable objects may give the illusion of a pass-by-reference (because changes made inside the function are visible outside) whereas immutable objects give the illusion of pass-by-value (because you can't affect the original object in any

[issue7867] Proposed FAQ entry on pass-by-? semantics and the meaning of 'variable' in python

2010-02-06 Thread Michael Foord
Michael Foord added the comment: Over 122 messages so I'm not going to search exhaustively. In this part of the thread you can see Fredrik Lundh and Aahz disputing "call-by-value-where-the-value-is-a-reference" as a useful way of describing Python calling semantices: http://groups.google.com

[issue7867] Proposed FAQ entry on pass-by-? semantics and the meaning of 'variable' in python

2010-02-06 Thread R. David Murray
R. David Murray added the comment: Well, the thrust of the second part is to make it clear that there *are* no differences between mutable and immutable objects as far as the assignment semantics are concerned. All objects in Python are treated the same. What is different is what is on the

[issue7867] Proposed FAQ entry on pass-by-? semantics and the meaning of 'variable' in python

2010-02-06 Thread Ezio Melotti
Ezio Melotti added the comment: The 4-point list at the beginning is in my opinion very clear (for people with some background in C or similar languages). I think that the following part is not really clear, and the example should focus better on the difference about mutable and immutable obj

[issue7867] Proposed FAQ entry on pass-by-? semantics and the meaning of 'variable' in python

2010-02-06 Thread R. David Murray
R. David Murray added the comment: Well, the discussion was *long* and more than a bit contentious. This is my own personal summary. Here is a message I found somewhere in the middle of the thread: http://mail.python.org/pipermail/python-list/2009-January/1187126.html Do you have a pointer

[issue7867] Proposed FAQ entry on pass-by-? semantics and the meaning of 'variable' in python

2010-02-06 Thread Michael Foord
Michael Foord added the comment: Wasn't the description of Python's semantics being 'pass by value where the value is a reference' actually very controversial indeed? Do you have a link to the discussion on c.l.p? -- nosy: +michael.foord ___ Python

[issue7867] Proposed FAQ entry on pass-by-? semantics and the meaning of 'variable' in python

2010-02-06 Thread R. David Murray
New submission from R. David Murray : A while back, after along discussion about variables and their meaning in Python on the python-list, I wrote up the attached FAQ entry to summarize what I got out of that enlightening discussion. I'm proposing that this be added to the FAQs. If this does

[issue7712] Add a context manager to change cwd in test.test_support and run the test suite in a temp dir.

2010-02-06 Thread Florent Xicluna
Florent Xicluna added the comment: There were syntax errors in the previous patch. Sorry. -- Added file: http://bugs.python.org/file16152/issue7712_context_manager_v3a.diff ___ Python tracker __

[issue7712] Add a context manager to change cwd in test.test_support and run the test suite in a temp dir.

2010-02-06 Thread Florent Xicluna
Changes by Florent Xicluna : Removed file: http://bugs.python.org/file16151/issue7712_context_manager_v3.diff ___ Python tracker ___ ___ Python

[issue4978] allow unicode keyword args

2010-02-06 Thread Benjamin Peterson
Benjamin Peterson added the comment: Done in r78027. -- resolution: -> fixed status: open -> closed ___ Python tracker ___ ___ Python

[issue7712] Add a context manager to change cwd in test.test_support and run the test suite in a temp dir.

2010-02-06 Thread Florent Xicluna
Changes by Florent Xicluna : Removed file: http://bugs.python.org/file16150/issue7712_context_manager_v2.diff ___ Python tracker ___ ___ Python

[issue6877] enable compilation of readline module on Mac OS X 10.5 and 10.6

2010-02-06 Thread Barry A. Warsaw
Barry A. Warsaw added the comment: @Meador: confirmed. This does not fix the 10.5 build. -- ___ Python tracker ___ ___ Python-bugs-li

[issue7347] Add {Create|Delete}KeyEx to _winreg, doc and test updates

2010-02-06 Thread Brian Curtin
Brian Curtin added the comment: This needs #7860 for properly figuring out the machine architecture for some 32-bit Python on 64-bit Windows tests. -- dependencies: +32-bit Python on 64-bit Windows reports incorrect architecture ___ Python tracker

[issue7712] Add a context manager to change cwd in test.test_support and run the test suite in a temp dir.

2010-02-06 Thread Florent Xicluna
Florent Xicluna added the comment: Slightly more readable, without 2-spaces indent. -- Added file: http://bugs.python.org/file16151/issue7712_context_manager_v3.diff ___ Python tracker _

[issue5341] A selection of spelling errors and typos throughout source

2010-02-06 Thread Georg Brandl
Georg Brandl added the comment: Thanks, committed as r78024, r78025, respectively. -- status: open -> closed ___ Python tracker ___ __

[issue7712] Add a context manager to change cwd in test.test_support and run the test suite in a temp dir.

2010-02-06 Thread Florent Xicluna
Changes by Florent Xicluna : Removed file: http://bugs.python.org/file15956/issue7712_context_manager.diff ___ Python tracker ___ ___ Python-bu

[issue7712] Add a context manager to change cwd in test.test_support and run the test suite in a temp dir.

2010-02-06 Thread Florent Xicluna
Florent Xicluna added the comment: Patch which fixes the "relative import" issue. ~ $ cd Lib/ ~ $ ../python -m test.regrtest Note: There are some 2-spaces indents for patch readability. Change them before commit. -- versions: -Python 2.6, Python 3.1 Added file: http://bugs.p

[issue7866] it looks like a typo in unittest

2010-02-06 Thread Éric Araujo
Éric Araujo added the comment: No problem, I’m from France :) And yes, automatic translation does not work. Or at least not gratis. Cheers -- ___ Python tracker ___ ___

[issue7866] it looks like a typo in unittest

2010-02-06 Thread Mezhenin Artyom
Mezhenin Artyom added the comment: Sorry, I'm from Russia. P.S. http://translate.google.com/ sucks =) -- ___ Python tracker ___ ___ P

[issue7866] it looks like a typo in unittest

2010-02-06 Thread Ezio Melotti
Changes by Ezio Melotti : -- resolution: -> invalid stage: -> committed/rejected status: open -> closed ___ Python tracker ___ ___ Py

[issue7866] it looks like a typo in unittest

2010-02-06 Thread Éric Araujo
Éric Araujo added the comment: Hello “Ran” is the preterite form of “run”. It is used here because at the time of the print, the tests are done, it’s past. Regards -- nosy: +Merwok ___ Python tracker ___

[issue7866] it looks like a typo in unittest

2010-02-06 Thread Mezhenin Artyom
Mezhenin Artyom added the comment: Same text here: http://docs.python.org/library/unittest.html#basic-example -- ___ Python tracker ___ __

[issue7866] it looks like a typo in unittest

2010-02-06 Thread Mezhenin Artyom
New submission from Mezhenin Artyom : Try to run any test a you will see something like this: ./.py ... -- Ran 7 tests in 0.069s OK But there is no word "Ran" in English. I think the word is "Run". -- components:

[issue6877] enable compilation of readline module on Mac OS X 10.5 and 10.6

2010-02-06 Thread Meador Inge
Meador Inge added the comment: > Can you please try inserting that include and see if 10.5 > builds readline? This does not work out of trunk for me: euclid:trunk minge$ sw_vers ProductName:Mac OS X ProductVersion: 10.5.7 BuildVersion: 9J61 euclid:trunk minge$ svn diff Index: Modules/r

[issue7829] dis module documentation gives no indication of the dangers of bytecode inspection

2010-02-06 Thread Éric Araujo
Changes by Éric Araujo : -- nosy: +Merwok ___ Python tracker ___ ___ Python-bugs-list mailing list Unsubscribe: http://mail.python.org

[issue5211] Fix complex type to avoid coercion in 2.7.

2010-02-06 Thread Meador Inge
Meador Inge added the comment: > if complex were made 'new-style' in 2.7, then it *would* be possible to > > write fairly obvious code (not using coerce or __coerce__) that operated > in > the same way in both 2.7 and 3.2. So I still think it's worth > considering. Agreed. I have attached

[issue7857] test_logging fails

2010-02-06 Thread Vinay Sajip
Changes by Vinay Sajip : -- priority: critical -> normal ___ Python tracker ___ ___ Python-bugs-list mailing list Unsubscribe: http://

[issue7865] io close() swallowing exceptions

2010-02-06 Thread Pascal Chambon
New submission from Pascal Chambon : The current semantic of io streams is to swallow IOErrors on close(), eg. in _pyio from the trunk, we have each time constructs like: try: self.flush() except IOError: pass # If flush() fails, just give up and in C files : /* If flush() fa

[issue7588] unittest.TestCase.shortDescription isn't short anymore

2010-02-06 Thread Michael Foord
Changes by Michael Foord : -- nosy: +gregory.p.smith ___ Python tracker ___ ___ Python-bugs-list mailing list Unsubscribe: http://mail

[issue7712] Add a context manager to change cwd in test.test_support and run the test suite in a temp dir.

2010-02-06 Thread Florent Xicluna
Florent Xicluna added the comment: It looks fine. Few comments: - "{}_python_{}" could be better, to identify the culprit for leftover directories. - the warning message may be more specific: "warnings.warn('tests may fail, unable to switch to ' + name, RuntimeWarning, s

[issue7864] Deprecation markers in unittest docs are unclear

2010-02-06 Thread Georg Brandl
Georg Brandl added the comment: I've added "use ... instead" now in r78018. -- ___ Python tracker ___ ___ Python-bugs-list mailing lis