[issue1621] Do not assume signed integer overflow behavior

2016-07-31 Thread Xiang Zhang
Xiang Zhang added the comment: So these checks are superfluous? Do we need to remove them? Hmm, I still doubt such checks should consider platform characteristics first. In theory List can be PY_SSIZE_T_MAX length. Do we have to put the PY_SIZE_MAX // sizeof(PyObject *) limit on it?

[issue19660] decorator syntax: allow testlist instead of just dotted_name

2016-07-31 Thread Guido van Rossum
Guido van Rossum added the comment: OK, maybe someone else wants to provide a real-world example. Otherwise I am really going to close this (again). -- ___ Python tracker

[issue1621] Do not assume signed integer overflow behavior

2016-07-31 Thread Martin Panter
Martin Panter added the comment: The check in ins1() was originally added in revision b9002da46f69. I presume it references the Python-dev thread “can this overflow (list insertion)?” <2812145155.a7...@activestate.com>, . At that time,

[issue1621] Do not assume signed integer overflow behavior

2016-07-31 Thread Gregory P. Smith
Changes by Gregory P. Smith : -- nosy: -gregory.p.smith ___ Python tracker ___ ___

[issue27660] Replace size_t with Py_ssize_t as the type of local variable in list_resize

2016-07-31 Thread Xiang Zhang
Xiang Zhang added the comment: :( Sorry David, my poor English doesn't enable me understand your message totally. Is list.sort related to this problem? Do I miss something? -- ___ Python tracker

[issue19660] decorator syntax: allow testlist instead of just dotted_name

2016-07-31 Thread Emanuel Barry
Emanuel Barry added the comment: We want to be able to access the instance attributes (as is done e.g. here: https://github.com/lykoss/lykos/blob/1852bf2c442d707ba0cbc16e8c9e012bcbc4fcc5/src/wolfgame.py#L9761 ). I realize we can set the attributes directly on the functions, but we've decided

[issue1621] Do not assume signed integer overflow behavior

2016-07-31 Thread Xiang Zhang
Xiang Zhang added the comment: Hmm, I don't tend to infer platform characteristics. IMHO, it's a simple problem: sum up two lists' length which may overflow in logic. With your argument, does it means it seems somewhat meaningless to have a List a Py_ssize_t length since it can never reach

[issue19660] decorator syntax: allow testlist instead of just dotted_name

2016-07-31 Thread Guido van Rossum
Guido van Rossum added the comment: OK, so if you wanted to be able to call myrole(...) instead of myrole.caller, why doesn't cmd.__call__ return self.caller rather than just self? -- ___ Python tracker

[issue10673] multiprocess.Process join method - timeout indistinguishable from success

2016-07-31 Thread Ned Deily
Changes by Ned Deily : -- nosy: +davin ___ Python tracker ___ ___ Python-bugs-list mailing

[issue27621] Finish IDLE Query dialog appearance and behavior.

2016-07-31 Thread Mark Roseman
Mark Roseman added the comment: Just to follow up, both Windows and Linux the 'correct' behaviour seems to be that space or return activates the button with the current focus. Mac behaves differently in that return key always activates default button even if focus is on another button (and

[issue27641] Do not build Programs/_freeze_importlib when cross-compiling

2016-07-31 Thread Martin Panter
Martin Panter added the comment: Thanks for the feedback. I did wonder about the name. Perhaps I will go with GENERATED_COMMENT: GENERATED_COMMENT='#' Python/importlib_external.h: @GENERATED_COMMENT@ $(srcdir)/Lib/importlib/_bootstrap_external.py Programs/_freeze_importlib --

[issue1621] Do not assume signed integer overflow behavior

2016-07-31 Thread Martin Panter
Martin Panter added the comment: overflow_fix_in_listextend.patch: I doubt Python supports the kinds of platform where this overflow would be possible. It may require pointers smaller than 32 bits, or char objects larger than 8 bits. Perhaps we could just add a comment explaining we assume

[issue19660] decorator syntax: allow testlist instead of just dotted_name

2016-07-31 Thread Emanuel Barry
Emanuel Barry added the comment: Sure, here goes; this is an IRC game bot which I contribute to. Apologies for the long links, it's the only way to make sure this consistently points to the same place regardless of future commits. The 'cmd' decorator we use is defined at

[issue27621] Finish IDLE Query dialog appearance and behavior.

2016-07-31 Thread Terry J. Reedy
Terry J. Reedy added the comment: Serhiy: I believe Notepad, Wordpad, Libre Office Write behave as you describe. But there are differences in details. So I don't consider issue closed, but it is low priority to me. -- ___ Python tracker

[issue27621] Finish IDLE Query dialog appearance and behavior.

2016-07-31 Thread Terry J. Reedy
Terry J. Reedy added the comment: Background: For Open Module, the old commondialog did not have the asymmetrical drop shadow. That is an unintentional addition (from a frame?) and I don't like it. Perhaps we should use grid instead. Rows 0 and 1 for the initial label and entry, with

[issue19660] decorator syntax: allow testlist instead of just dotted_name

2016-07-31 Thread Guido van Rossum
Guido van Rossum added the comment: Could you link to an example decorator definition and its call site(s) that would benefit? I'm lacking the imagination to understand what a "dynamic decorator" might be. @spam().eggs() is not enough to help me understand -- I understand quite well what syntax

[issue27632] build on AIX fails when builddir != srcdir, more than bad path to ld_so_aix

2016-07-31 Thread Ned Deily
Ned Deily added the comment: Possible duplicate of Issue10656 (see also Issue16189) -- nosy: +David.Edelsohn, ned.deily ___ Python tracker ___

[issue27632] build on AIX fails when builddir != srcdir, more than bad path to ld_so_aix

2016-07-31 Thread Ned Deily
Changes by Ned Deily : -- nosy: -ned.deily ___ Python tracker ___ ___ Python-bugs-list

[issue27621] Finish IDLE Query dialog appearance and behavior.

2016-07-31 Thread Mark Roseman
Mark Roseman added the comment: Serhiy, the tk_dialog has been superseded by tk_messageBox, and does not reflect current platform standards. I just tried tk_messageBox on the Mac, which always activates the default button if you press 'return', even if another button has the focus. I expect

[issue27477] IDLE: Switch search dialogs to ttk widgets, and other refinement

2016-07-31 Thread Terry J. Reedy
Terry J. Reedy added the comment: I debated whether to open a new search style issue and copy a message or defer ttk for config to another issue and re-title this. I went with widget group rather than aspect (style) this time. There are multiple search behavior issues. I added Notepad,

[issue27661] Add tzinfo= argument to datetime.combine

2016-07-31 Thread Alexander Belopolsky
Changes by Alexander Belopolsky : -- keywords: +patch stage: -> patch review Added file: http://bugs.python.org/file43958/issue27661.diff ___ Python tracker

[issue27661] Add tzinfo= argument to datetime.combine

2016-07-31 Thread Alexander Belopolsky
New submission from Alexander Belopolsky: Add an optional tzinfo argument to datetime.combine() so that datetime.combine(d, t, info) returns the same object as datetime.combine(d, t).replace(tzinfo=info) but without creating an intermediate naive instance. Guido's LGTM:

[issue19660] decorator syntax: allow testlist instead of just dotted_name

2016-07-31 Thread Emanuel Barry
Emanuel Barry added the comment: TL;DR - Use case is dynamic decorators. Not all of the syntax would make sense, see below. The main benefit of this feature would be for dynamic decorators (as was evidenced from others in this issue). In a project I contribute to, we use dynamic decorators

[issue27660] Replace size_t with Py_ssize_t as the type of local variable in list_resize

2016-07-31 Thread R. David Murray
R. David Murray added the comment: Oh, I got that backward didn't I. My rusty C skills :( -- ___ Python tracker ___

[issue27660] Replace size_t with Py_ssize_t as the type of local variable in list_resize

2016-07-31 Thread R. David Murray
R. David Murray added the comment: ob->allocated is temporarily set to -1 by list.sort to detect mutations, so the restriction of new_allocated to size_t is probably intentional. If so, though, there ought to be a comment making that clear. -- nosy: +r.david.murray

[issue27078] Make f'' strings faster than .format: BUILD_STRING opcode?

2016-07-31 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: Since this introduces a new opcode, this is a new feature. Seems opcodes never were added at beta stage before 3.5b1. -- ___ Python tracker

[issue27660] Replace size_t with Py_ssize_t as the type of local variable in list_resize

2016-07-31 Thread Xiang Zhang
New submission from Xiang Zhang: In list_resize, new_allocated is of type size_t but I think don't have to be now since it finally have to assign back to self->allocated which is of type Py_ssize_t. With Py_ssize_t, we can check some overflows in the first overflow check and don't need the

[issue27078] Make f'' strings faster than .format: BUILD_STRING opcode?

2016-07-31 Thread Eric V. Smith
Eric V. Smith added the comment: I intend to review this. As this is not a new feature, it doesn't need to be completed by beta 1. I'm focusing my energies on new features, then I'll look at this. -- ___ Python tracker

[issue27466] [Copy from github user macartur] time2netscape missing comma

2016-07-31 Thread Senthil Kumaran
Changes by Senthil Kumaran : -- stage: patch review -> resolved ___ Python tracker ___

[issue19660] decorator syntax: allow testlist instead of just dotted_name

2016-07-31 Thread Guido van Rossum
Guido van Rossum added the comment: Nobody has posted a real use case. All the examples are toys. What are the real use cases that are blocked by this? Readability counts! -- ___ Python tracker

[issue27078] Make f'' strings faster than .format: BUILD_STRING opcode?

2016-07-31 Thread Antti Haapala
Antti Haapala added the comment: I would very much like to see this in 3.6. Who could review it? -- ___ Python tracker ___

[issue26439] ctypes.util.find_library fails when ldconfig/glibc not available (e.g., AIX)

2016-07-31 Thread Michael Felt
Michael Felt added the comment: Thanks again for your help. Note: I started a issue# is because too much of what I was submitting here was "extension" and not "correction". Hopefully, the new issue# will be cleaner. -- ___ Python tracker

[issue27435] ctypes and AIX - also for 2.7.X (and later)

2016-07-31 Thread Michael Felt
Michael Felt added the comment: > FYI: I tried to pip install Mercurial - but got an error message from an > include file so the last bit did not compile. Problem for a later date - > could be a user error on my part, or an AIX version dependency. (during > discussion issue26439) I have

[issue27035] Cannot set exit code in atexit callback

2016-07-31 Thread R. David Murray
Changes by R. David Murray : -- type: behavior -> enhancement ___ Python tracker ___

[issue27035] Cannot set exit code in atexit callback

2016-07-31 Thread R. David Murray
R. David Murray added the comment: Well, changing something like this in 2.7 is off the table in any case. This would be a "feature release only" type of change if there is agreement that it is a good idea. -- components: +Interpreter Core versions: +Python 3.6 -Python 3.5

[issue27657] urlparse fails if the path is numeric

2016-07-31 Thread R. David Murray
R. David Murray added the comment: On second thought, what are the chances that special casing something that looks like an IP address in the scheme position would maintain backward compatibility? -- ___ Python tracker

[issue27657] urlparse fails if the path is numeric

2016-07-31 Thread R. David Murray
R. David Murray added the comment: I hate to say it, but this may require a python-dev discussion. We probably ought to be parsing valid urls correctly as our top priority, but if that breaks our parsing of "reasonable" non-valid URLs (that existing code is depending on), it's going to be a

[issue27641] Do not build Programs/_freeze_importlib when cross-compiling

2016-07-31 Thread Thomas Perl
Thomas Perl added the comment: +1 on comment-out-regen.patch, makes things much cleaner and removes the shell "if" in the rule body. Just a small bikeshed issue: Instead of COMMENT_REGEN, maybe call it "CROSS_COMPILE_COMMENT" or "GENERATED_COMMENT" or "COMMENT_IF_CROSS" or somesuch? This

[issue27035] Cannot set exit code in atexit callback

2016-07-31 Thread George King
George King added the comment: The documentation for atexit.register clearly states that a SystemExit raised inside of the registered function is a special case: ''' If an exception is raised during execution of the exit handlers, a traceback is printed (unless SystemExit is raised) and the

[issue1621] Do not assume signed integer overflow behavior

2016-07-31 Thread Xiang Zhang
Xiang Zhang added the comment: Martin, I upload a patch to fix another possible overflow in listextend. -- Added file: http://bugs.python.org/file43956/overflow_fix_in_listextend.patch ___ Python tracker

[issue23746] sysconfg.is_python_build() is buggy

2016-07-31 Thread Berker Peksag
Changes by Berker Peksag : -- components: -Library (Lib) keywords: +easy stage: -> needs patch type: -> enhancement versions: +Python 3.6 -Python 3.4 ___ Python tracker

[issue24773] Implement PEP 495 (Local Time Disambiguation)

2016-07-31 Thread koobs
koobs added the comment: Thank you Alexander, consider me satisfied :) -- ___ Python tracker ___ ___

[issue27275] KeyError thrown by optimised collections.OrderedDict.popitem()

2016-07-31 Thread Xiang Zhang
Xiang Zhang added the comment: There seems to be some difference behaviours between C version and pure Python version when it comes to subclass. Except popitem, the constructor also goes different code path. There may be more. Should these differences be eliminated or they are accepted?

[issue27659] Check for the existence of crypt()

2016-07-31 Thread Chi Hsuan Yen
Chi Hsuan Yen added the comment: Thanks, added to the patch description -- ___ Python tracker ___ ___

[issue26865] Meta-issue: support of the android platform

2016-07-31 Thread Xavier de Gaye
Xavier de Gaye added the comment: issue #27659: Check for the existence of crypt() -- dependencies: +Check for the existence of crypt() ___ Python tracker

[issue27659] Check for the existence of crypt()

2016-07-31 Thread Xavier de Gaye
Xavier de Gaye added the comment: > A question: should I include changes to configure and pyconfig.h.in in the > patch? You just need to mention that one should run autoreconf. -- ___ Python tracker

[issue27568] "HTTPoxy", use of HTTP_PROXY flag supplied by attacker in CGI scripts

2016-07-31 Thread Berker Peksag
Changes by Berker Peksag : -- stage: patch review -> resolved ___ Python tracker ___

[issue27659] Check for the existence of crypt()

2016-07-31 Thread Chi Hsuan Yen
Chi Hsuan Yen added the comment: Some references for crypt(): POSIX standard: http://pubs.opengroup.org/onlinepubs/9699919799/functions/crypt.html Linux man page: http://man7.org/linux/man-pages/man3/crypt.3.html FreeBSD man page: https://www.freebsd.org/cgi/man.cgi?crypt(3) Mac OS X man page:

[issue27659] Check for the existence of crypt()

2016-07-31 Thread Chi Hsuan Yen
Chi Hsuan Yen added the comment: Version 2: correct the name added to `missing` -- Added file: http://bugs.python.org/file43955/check-crypt.patch ___ Python tracker

[issue27659] Check for the existence of crypt()

2016-07-31 Thread Chi Hsuan Yen
New submission from Chi Hsuan Yen: On Android the crypt() function is missing, causing ugly linking errors when compiling the _crypt module. This patch handles it elegantly. A question: should I include changes to configure and pyconfig.h.in in the patch? -- components: Cross-Build

[issue27568] "HTTPoxy", use of HTTP_PROXY flag supplied by attacker in CGI scripts

2016-07-31 Thread Senthil Kumaran
Senthil Kumaran added the comment: This is also committed in 2.7 branch in ba915d561667. This is committed in all active versions(2.7, 3.5, 3.6) and also versions which receive security updates (3.3 and 3.4). This issue is resolved. Thank you for the patch, Rémi. (In msg271688, I pondered

[issue27568] "HTTPoxy", use of HTTP_PROXY flag supplied by attacker in CGI scripts

2016-07-31 Thread Roundup Robot
Roundup Robot added the comment: New changeset 95b09ccc8a3e by Senthil Kumaran in branch '3.3': Prevent HTTPoxy attack (CVE-2016-1000110) https://hg.python.org/cpython/rev/95b09ccc8a3e New changeset 3c19023c9fec by Senthil Kumaran in branch '3.4': [merge from 3.3] Prevent HTTPoxy attack

[issue10673] multiprocess.Process join method - timeout indistinguishable from success

2016-07-31 Thread Berker Peksag
Berker Peksag added the comment: Thread.join() also returns None in all cases so +1 for documenting the current behavior. -- keywords: +easy nosy: +berker.peksag stage: -> needs patch versions: +Python 3.5, Python 3.6 -Python 3.3 ___ Python tracker

[issue27656] [Patch] Make presence of SCHED_* optional

2016-07-31 Thread Roundup Robot
Roundup Robot added the comment: New changeset 095b424127e7 by Benjamin Peterson in branch '3.5': all SCHED_ constants are optional (closes #27656) https://hg.python.org/cpython/rev/095b424127e7 New changeset 64b763290da9 by Benjamin Peterson in branch 'default': merge 3.5 (#27656)

[issue19660] decorator syntax: allow testlist instead of just dotted_name

2016-07-31 Thread Berker Peksag
Changes by Berker Peksag : -- nosy: +berker.peksag ___ Python tracker ___ ___