[issue42546] copy - Allow dict.copy(deep=True) alongside copy.deepcopy() for easier usage and zen

2020-12-02 Thread Daniel Rose
Daniel Rose added the comment: My apologies. I worded that wrong, I meant adding `deep=True` to `dict.copy()`. Otherwise, you're absolutely right. -- ___ Python tracker <https://bugs.python.org/is

[issue42546] copy - Allow dict.copy(deep=True) alongside copy.deepcopy() for easier usage and zen

2020-12-02 Thread Daniel Rose
Change by Daniel Rose : -- title: copy - Allow .copy(deep=True) alongside .deepcopy() for easier usage and zen -> copy - Allow dict.copy(deep=True) alongside copy.deepcopy() for easier usage and zen ___ Python tracker <https://bugs.pyth

[issue42546] copy - Allow .copy(deep=True) alongside .deepcopy() for easier usage and zen

2020-12-02 Thread Daniel Rose
New submission from Daniel Rose : It would be convenient and cleaner/more in line with the Python zen to allow `.copy()` to allow a `deep=True` argument, to use `.deepcopy()` in a simpler way. This is easier to read, and brings some more usefulness to `.copy()`. `.deepcopy()` would be kept