[issue1683368] object.__init__ shouldn't allow args/kwds

2010-04-01 Thread dauerbaustelle
dauerbaustelle jo...@lophus.org added the comment: What exactly is the correct solution with Python 2.6 to avoid this warning? My use case is something like class myunicode(unicode): def __init__(self, *args, **kwargs): unicode.__init__(self, *args, **kwargs) self.someattribute

[issue7725] '-s' option in The Python Profiles Instant User's Manual linked incorrectly

2010-01-17 Thread dauerbaustelle
New submission from dauerbaustelle jo...@lophus.org: [Section 27.4.2] The '-s' option links to the `cmdline` manual rather than to the `profile.Stats` documentation. (rst source line 125) -- assignee: georg.brandl components: Documentation messages: 97956 nosy: dauerbaustelle

[issue6917] .et_folder instead of get_folder in mailbox documentation

2009-09-15 Thread dauerbaustelle
New submission from dauerbaustelle jo...@lophus.org: In the mailbox documentation, http://docs.python.org/library/mailbox.html#mailbox.Maildir..et_folder should be named get_folder instead of .et_folder. -- assignee: georg.brandl components: Documentation messages: 92647 nosy

[issue6456] locale.D_* and .T_* are int, not string

2009-07-10 Thread dauerbaustelle
New submission from dauerbaustelle jo...@lophus.org: The locale.D_* and locale.T_* attributes are ints with weird values instead of strings (see documentation[1]). Example: import locale locale.setlocale(locale.LC_ALL, 'en_US.utf8') 'en_US.utf8' locale.D_T_FMT 131112 locale.D_FMT 131113

[issue6456] locale.D_* and .T_* are int, not string

2009-07-10 Thread dauerbaustelle
dauerbaustelle jo...@lophus.org added the comment: I would suggest to make those constants be strings. There's no need for those int values; in most cases, you want the strings and not the int values. Until then, I would put that nl_langinfo() stuff in a warning or info box (or highlight