[issue28818] simplify lookdict functions

2016-12-27 Thread INADA Naoki
INADA Naoki added the comment: http://bugs.python.org/issue28427#msg284101 > Sidenote: all branches now have a different version of dict object each, > which makes maintenance really painful... Large difference between py36 and py37 is this patch. Can I backport this to py36 to ease maintenanc

[issue28818] simplify lookdict functions

2016-12-11 Thread INADA Naoki
Changes by INADA Naoki : -- stage: patch review -> resolved ___ Python tracker ___ ___ Python-bugs-list mailing list Unsubscribe: htt

[issue28818] simplify lookdict functions

2016-12-11 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: Thank you for your work Inada. -- ___ Python tracker ___ ___ Python-bugs-list mailing list Unsubsc

[issue28818] simplify lookdict functions

2016-12-07 Thread INADA Naoki
INADA Naoki added the comment: Thank you for review. And I'm sorry about I committed the patch before seeing last comment. -- ___ Python tracker ___ _

[issue28818] simplify lookdict functions

2016-12-07 Thread INADA Naoki
Changes by INADA Naoki : -- assignee: rhettinger -> resolution: -> fixed status: open -> closed ___ Python tracker ___ ___ Python-bu

[issue28818] simplify lookdict functions

2016-12-07 Thread Roundup Robot
Roundup Robot added the comment: New changeset 8d4b2c6a0a7f by INADA Naoki in branch 'default': Issue #28818: Simplify lookdict functions https://hg.python.org/cpython/rev/8d4b2c6a0a7f -- nosy: +python-dev ___ Python tracker

[issue28818] simplify lookdict functions

2016-12-07 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: It looks to me that changes to find_empty_slot() can be committed independently. If this would make reviewing easier, may be split the patch on two parts? -- ___ Python tracker

[issue28818] simplify lookdict functions

2016-12-07 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: simplify-lookdict2.patch differs from simplify-lookdict.patch only by variable names. It LGTM as well. -- ___ Python tracker ___

[issue28818] simplify lookdict functions

2016-12-07 Thread INADA Naoki
INADA Naoki added the comment: @rhettinger, could you review simplify-lookdict2.patch? -- assignee: -> rhettinger ___ Python tracker ___

[issue28818] simplify lookdict functions

2016-11-28 Thread INADA Naoki
INADA Naoki added the comment: > Can you make the patch without the unnecessary variable name change from > "value_addr" to "pvalue". The former name is more communicative and is > self-describing. Done. I have changed the variable name to distinguish `PyObject**` with `PyObject***`. But ther

[issue28818] simplify lookdict functions

2016-11-28 Thread Josh Rosenberg
Changes by Josh Rosenberg : -- nosy: +josh.r ___ Python tracker ___ ___ Python-bugs-list mailing list Unsubscribe: https://mail.pytho

[issue28818] simplify lookdict functions

2016-11-28 Thread Raymond Hettinger
Raymond Hettinger added the comment: Can you make the patch without the unnecessary variable name change from "value_addr" to "pvalue". The former name is more communicative and is self-describing. -- ___ Python tracker

[issue28818] simplify lookdict functions

2016-11-28 Thread Serhiy Storchaka
Serhiy Storchaka added the comment: LGTM. I don't expect significant performance difference, but the code looks simpler. -- ___ Python tracker ___ __

[issue28818] simplify lookdict functions

2016-11-28 Thread Serhiy Storchaka
Changes by Serhiy Storchaka : -- nosy: +rhettinger, serhiy.storchaka ___ Python tracker ___ ___ Python-bugs-list mailing list Unsubscr

[issue28818] simplify lookdict functions

2016-11-28 Thread INADA Naoki
New submission from INADA Naoki: This patch reduces indirect access to improve readability. benchmark: Slower (14): - logging_format: 29.9 us +- 2.7 us -> 31.2 us +- 2.8 us: 1.04x slower - scimark_monte_carlo: 227 ms +- 5 ms -> 235 ms +- 16 ms: 1.03x slower - dulwich_log: 149 ms +- 10 ms -> 153