[issue2922] "No windows home dir" doc error

2008-05-19 Thread Martin v. Löwis
Martin v. Löwis <[EMAIL PROTECTED]> added the comment: The problem is that any modern Windows does not just have a single home directory for a user, but many of them. For example, there are the HOMEDRIVE, HOMESHARE, and HOMEPATH variables, which may or may not be set. In the light of these, I wo

[issue2882] Create the html package

2008-05-19 Thread Fred L. Drake, Jr.
Fred L. Drake, Jr. <[EMAIL PROTECTED]> added the comment: Python 2.6 changes reverted in revision 63481. Does anyone really want to pickle HTML parser state, or references to the helper functions in the htmlentitydefs module? I suspect head examinations may be in order. :-( -- resolut

[issue2928] Allow set/frozenset for __all__

2008-05-19 Thread Adam Olsen
New submission from Adam Olsen <[EMAIL PROTECTED]>: Patch allows any iterable (such as set and frozenset) to be used for __all__. I also add some blank lines, making it more readable. -- files: python-importall.diff keywords: patch messages: 67104 nosy: Rhamphoryncus severity: normal st

[issue2927] expose html.parser.unescape

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: The plan is to add html.escape(). Adding html.unescape() wouldn't hurt. -- nosy: +brett.cannon __ Tracker <[EMAIL PROTECTED]> __ ___

[issue2927] expose html.parser.unescape

2008-05-19 Thread Tom Pinckney
New submission from Tom Pinckney <[EMAIL PROTECTED]>: There is currently a private method inside of html.parser.HTMLParser to unescape HTML &...; style escapes. This would be useful to expose for other users who want to unescape a piece of HTML. Additionally, many websites don't use proper uni

[issue2876] Write UserDict fixer for 2to3

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: The that needs to be added to 2to3. -- status: closed -> open title: Backport UserDict move in 3.0 -> Write UserDict fixer for 2to3 __ Tracker <[EMAIL PROTECTED]> _

[issue2876] Backport UserDict move in 3.0

2008-05-19 Thread Raymond Hettinger
Raymond Hettinger <[EMAIL PROTECTED]> added the comment: The DictMixin class gets renamed to collections.MutableMapping. So, it is just another 2-to-3 converter job. -- status: open -> closed __ Tracker <[EMAIL PROTECTED]>

[issue2775] Implement PEP 3108

2008-05-19 Thread Brett Cannon
Changes by Brett Cannon <[EMAIL PROTECTED]>: -- dependencies: +Create the html package, Moving lib-tk to tkinter package, Rename repr to reprlib, Revert ConfigParser rename in 2.6, Revert Queue rename in 2.6, Revert SocketServer rename in 2.6, Revert copy_reg rename in 2.6 ___

[issue2839] Moving lib-tk to tkinter package

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: The changes in 2.6 need to be reverted, leaving only a note in the docs. -- nosy: +brett.cannon resolution: accepted -> status: closed -> open __ Tracker <[EMAIL PROTECTED]>

[issue2882] Create the html package

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: The changes in 2.6 need to be reverted, leaving only a note in the docs. -- resolution: fixed -> status: closed -> open versions: -Python 3.0 __ Tracker <[EMAIL PROTECTED]>

[issue2880] Rename repr to reprlib

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: The rename of repr in 2.6 needs to be removed with only a note in the docs to remain. -- resolution: fixed -> status: closed -> open versions: -Python 3.0 __ Tracker <[EMAIL PROTECTED]>

[issue2926] Revert SocketServer rename in 2.6

2008-05-19 Thread Brett Cannon
New submission from Brett Cannon <[EMAIL PROTECTED]>: The rename of SocketServer in 2.6 needs to be reverted; only a note in the docs should remain. -- components: Library (Lib) messages: 67096 nosy: brett.cannon priority: release blocker severity: normal status: open title: Revert Sock

[issue2925] Revert Queue rename in 2.6

2008-05-19 Thread Brett Cannon
New submission from Brett Cannon <[EMAIL PROTECTED]>: The rename of Queue in 2.6 needs to be reverted with only a note in the docs to remain. -- components: Library (Lib) messages: 67095 nosy: brett.cannon priority: release blocker severity: normal status: open title: Revert Queue renam

[issue2924] Revert copy_reg rename in 2.6

2008-05-19 Thread Brett Cannon
New submission from Brett Cannon <[EMAIL PROTECTED]>: The rename of copy_reg in 2.6 needs to reverted, leaving on a note in the docs. -- components: Library (Lib) messages: 67094 nosy: brett.cannon priority: release blocker severity: normal status: open title: Revert copy_reg rename in

[issue2923] Revert ConfigParser rename in 2.6

2008-05-19 Thread Brett Cannon
New submission from Brett Cannon <[EMAIL PROTECTED]>: The rename of ConfigParser in 2.6 needs to be reverted. Only a note in the docs should remain. -- components: Library (Lib) messages: 67093 nosy: brett.cannon priority: release blocker severity: normal status: open title: Revert Conf

[issue2879] Rename _winreg to winreg

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: The rename is now mostly a 3.0 thing. -- versions: -Python 2.6 __ Tracker <[EMAIL PROTECTED]> __ __

[issue2877] Backport UserString move from 3.0

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: Is MutableString in the UserString module (and any other class) properly handled in 2.6 for transitioning to 3.0? And there is currently no fixer for UserString (same for UserDict). __ Tracker <[EMAIL PROTECTED

[issue2876] Backport UserDict move in 3.0

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: And it is a release blocker as we are trying to get all deprecations into b1. __ Tracker <[EMAIL PROTECTED]> __

[issue2876] Backport UserDict move in 3.0

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: You only kept the UserDict class, right? Well, that means you need to deprecate DictMixin and any other classes in that module. __ Tracker <[EMAIL PROTECTED]> _

[issue2875] Rename the thread module to _thread

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: Renames are only occurring in 3.0, not 2.6. -- versions: -Python 2.6 __ Tracker <[EMAIL PROTECTED]> __

[issue2861] Patch to rename markupbase to _markupbase

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: This does not need to happen in 2.6; only 3.0. -- versions: +Python 3.0 -Python 2.6 __ Tracker <[EMAIL PROTECTED]> __ __

[issue2621] rename test_support to support

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: No renames will occur in 2.6, only in 3.0, which means this can happen whenever. __ Tracker <[EMAIL PROTECTED]> __ _

[issue2775] Implement PEP 3108

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: Because of pickle compatibility in 2.x, all renames in the trunk need to be reverted. Work in 3.0 is still fine and won't be touched. I have already updated the PEP with the new steps required for renames. __ T

[issue1574217] isinstance swallows exceptions

2008-05-19 Thread Neal Norwitz
Neal Norwitz <[EMAIL PROTECTED]> added the comment: > I'd like to clarify the approach to fixing these types of problems. > ... > However, I like constricting it to AttributeError only as that would > make it much less confusing. This might be something to bring up on > python-dev. I suspect tha

[issue1424152] urllib/urllib2: HTTPS over (Squid) Proxy fails

2008-05-19 Thread Cameron Simpson
Cameron Simpson <[EMAIL PROTECTED]> added the comment: Chris, I'm trying your patch out now. My quick reading of it looks ok. _ Tracker <[EMAIL PROTECTED]> _

[issue1424152] urllib/urllib2: HTTPS over (Squid) Proxy fails

2008-05-19 Thread Cameron Simpson
Changes by Cameron Simpson <[EMAIL PROTECTED]>: -- nosy: +cameron _ Tracker <[EMAIL PROTECTED]> _ ___ Python-bugs-list mailing list U

[issue1775025] zipfile: Allow reading duplicate filenames

2008-05-19 Thread Graham Horler
Graham Horler <[EMAIL PROTECTED]> added the comment: Updated to latest revision, and converted documentation part of the patch to reST. Removed the line that pointlessly computes 'filepos', as requested by Scott Dial. (Please excuse my reST, I'm new to it and it's getting late). Added file:

[issue1775025] zipfile: Allow reading duplicate filenames

2008-05-19 Thread Scott Dial
Scott Dial <[EMAIL PROTECTED]> added the comment: In the patch you commented "why is 'filepos' computed next? It's never referenced." The answer is that back at r54152 (#1121142) the method was rewrote removing any reference to 'filepos', but the patch author failed to remove that line. Please re

[issue1775025] zipfile: Allow reading duplicate filenames

2008-05-19 Thread Benjamin Peterson
Changes by Benjamin Peterson <[EMAIL PROTECTED]>: -- type: -> feature request versions: +Python 2.6 _ Tracker <[EMAIL PROTECTED]> _

[issue2819] Full precision summation

2008-05-19 Thread Jean Brouwers
Changes by Jean Brouwers <[EMAIL PROTECTED]>: Added file: http://bugs.python.org/file10381/test_math_sum5.py __ Tracker <[EMAIL PROTECTED]> __ ___ Pytho

[issue2819] Full precision summation

2008-05-19 Thread Jean Brouwers
Changes by Jean Brouwers <[EMAIL PROTECTED]>: Added file: http://bugs.python.org/file10380/cmathmodule5.c.2.6a3.diff __ Tracker <[EMAIL PROTECTED]> __ _

[issue2819] Full precision summation

2008-05-19 Thread Jean Brouwers
Jean Brouwers <[EMAIL PROTECTED]> added the comment: Here is another patch for the mathmodule.c and cmathmodule.c files updated with the suggested and other modifications. Note, if FLT_RADIX is not 2, the sum functions still exist but will raise a NotImplementedError. An update of the test sc

[issue2922] "No windows home dir" doc error

2008-05-19 Thread John Burnett
Changes by John Burnett <[EMAIL PROTECTED]>: -- type: -> behavior __ Tracker <[EMAIL PROTECTED]> __ ___ Python-bugs-list mailing list Unsubscri

[issue2921] enable embedding: declare/#define only py* symbols in #includes

2008-05-19 Thread Benjamin Peterson
Changes by Benjamin Peterson <[EMAIL PROTECTED]>: -- components: +Interpreter Core -None __ Tracker <[EMAIL PROTECTED]> __ ___ Python-bugs-list

[issue2922] "No windows home dir" doc error

2008-05-19 Thread John Burnett
New submission from John Burnett <[EMAIL PROTECTED]>: http://docs.python.org/inst/alt-install-windows.html The above says "Windows has no concept of a user's home directory, and since the standard Python installation under Windows is simpler than under Unix, the --prefix option has traditionally

[issue2921] enable embedding: declare/#define only py* symbols in #includes

2008-05-19 Thread Hallvard B Furuseth
New submission from Hallvard B Furuseth <[EMAIL PROTECTED]>: It can be cumbersome to embed Python in a program which also #includes a config.h from autoconf, because Python's and the program's autoconf macros may interfere with each other. Assuming it compiles at all, both could define the same

[issue2920] Patch to print symbolic value or errno in EnvironmentError.__str__()

2008-05-19 Thread Alexandre Vassalotti
Alexandre Vassalotti <[EMAIL PROTECTED]> added the comment: Overall, the patch looks good. I made a couple of fixes to make the changes more robust. -- nosy: +alexandre.vassalotti priority: -> normal type: -> feature request Added file: http://bugs.python.org/file10378/symbolic-errno.d

[issue2854] Add gestalt back into Python 3.0

2008-05-19 Thread Benjamin Peterson
Benjamin Peterson <[EMAIL PROTECTED]> added the comment: This is just a reminder to myself that when this is checked in, I need to unblock and merge r63460 and r63464. __ Tracker <[EMAIL PROTECTED]> __

[issue2898] Add memory footprint query

2008-05-19 Thread Martin v. Löwis
Martin v. Löwis <[EMAIL PROTECTED]> added the comment: > I'm torn about the extra slot; I'd rather not add one, but I can't see > how to make this flexible enough without one. I think adding a default __sizeof__ implementation into object (__basicsize__ + len()*__itemsize__), plus overriding tha

[issue2920] Patch to print symbolic value or errno in EnvironmentError.__str__()

2008-05-19 Thread Yannick Gingras
New submission from Yannick Gingras <[EMAIL PROTECTED]>: EnvironmentError and its subclass OSError add the value of errno in their error message. This value is an integer but the specific value in an implementation detail and the C runtime recommends that programmers use the symbolic values i

[issue2775] Implement PEP 3108

2008-05-19 Thread Brett Cannon
Changes by Brett Cannon <[EMAIL PROTECTED]>: -- dependencies: +Merge StringIO/cStringIO in 3.0, Merge profile/cProfile in 3.0, merge pickle and cPickle in 3.0 __ Tracker <[EMAIL PROTECTED]> _

[issue2919] Merge profile/cProfile in 3.0

2008-05-19 Thread Brett Cannon
New submission from Brett Cannon <[EMAIL PROTECTED]>: cProfile should go away in 3.0 (as a public module) and just be what profile uses when available. -- components: Library (Lib) messages: 67073 nosy: brett.cannon priority: release blocker severity: normal status: open title: Merge pr

[issue2918] Merge StringIO/cStringIO in 3.0

2008-05-19 Thread Brett Cannon
New submission from Brett Cannon <[EMAIL PROTECTED]>: PEP 3108 calls for StringIO (which is io.StringIO in 3.0) to have an accelerated version behind it when available. Alexandre has been working on this so assigning to him. -- assignee: alexandre.vassalotti components: Library (Lib) m

[issue2917] merge pickle and cPickle in 3.0

2008-05-19 Thread Brett Cannon
New submission from Brett Cannon <[EMAIL PROTECTED]>: cPickle should be gone in 3.0 and pickle should have an accelerated version behind it, when available. Alexandre has been working on this (might even be checked in), so assigning to him to help track for PEP 3108 work. -- assignee:

[issue2775] Implement PEP 3108

2008-05-19 Thread Brett Cannon
Brett Cannon <[EMAIL PROTECTED]> added the comment: OK, so it turns out the way renames have been handled breaks pre-existing pickles. That means that the stubs in 2.6 will actually have to be the new names and not the old ones. I will work with the stdlib-sig to try to come up with a reasonab

[issue2755] IDLE ignores module change before restart

2008-05-19 Thread Mark Veldhuis
Mark Veldhuis <[EMAIL PROTECTED]> added the comment: Sure, and thank you for your efforts. It will be interesting to see if it really is the package. If there is anything I can do to test, just drop a note. __ Tracker <[EMAIL PROTECTED]>

[issue2791] subprocess.py leaks fd in communicate

2008-05-19 Thread Rafael Zanella
Rafael Zanella <[EMAIL PROTECTED]> added the comment: I don't know a lot about the matter at hand, that's why I'm not gonna append a patch. On "_communicate()" after a pipe is read it's closed, doing the same on "communicate()" seems to solve the issue of the extra pipe: """ if [self.stdin, se

[issue2819] Full precision summation

2008-05-19 Thread Mark Dickinson
Mark Dickinson <[EMAIL PROTECTED]> added the comment: The latest mathmodule patch (file 10371) looks pretty good to me. I haven't looked at the complex version yet. A few comments: - for setting _do_sum_pow_2 I think you should use ldexp instead of pow; there's a much greater chance of pow

[issue2916] urlgrabber.grabber calls setdefaulttimeout

2008-05-19 Thread Mads Kiilerich
Changes by Mads Kiilerich <[EMAIL PROTECTED]>: -- type: -> behavior __ Tracker <[EMAIL PROTECTED]> __ ___ Python-bugs-list mailing list Unsubsc

[issue2916] urlgrabber.grabber calls setdefaulttimeout

2008-05-19 Thread Mads Kiilerich
New submission from Mads Kiilerich <[EMAIL PROTECTED]>: Module docstring says """Setting this option causes urlgrabber to call the settimeout method on the Socket object used for the request.""" But actually it temporarily changes the global default timeout. If other threads are creating socket

[issue2915] PyObject_IsInstance() doesn't find bases named in type(name, bases, dict)

2008-05-19 Thread Stefan Behnel
New submission from Stefan Behnel <[EMAIL PROTECTED]>: While porting the code that Cython generates to Py3a5 (almost completed, BTW), I noticed a problem with class creation. We are currently using this call to create a new class in Py3: PyObject_CallFunctionObjArgs((PyObject *)&PyType_Type,

[issue1447222] tkinter Dialog fails when more than four buttons are used

2008-05-19 Thread Guilherme Polo
Guilherme Polo <[EMAIL PROTECTED]> added the comment: The workaround is actually setting wantobjects to 0, which I doubt everyone will like. I've talked with a tcl developer and some interesting points were raised from the talk: 1) Looking at typePtr in _tkinter isn't actually good (this is use

[issue2898] Add memory footprint query

2008-05-19 Thread Guido van Rossum
Guido van Rossum <[EMAIL PROTECTED]> added the comment: I'm torn about the extra slot; I'd rather not add one, but I can't see how to make this flexible enough without one. It should definitely not be a built-in; the sys module is fine though (e.g. sys.getrefcount() lives there too). __

[issue2897] include structmember.h in Python.h

2008-05-19 Thread Alexander Belopolsky
Alexander Belopolsky <[EMAIL PROTECTED]> added the comment: Note that structmember.h pollutes global namespace with macros that do not have conventional Py_ or PY_ prefix. READONLY and RESTRICTED macros seem to be most likely to conflict with other code. I would be -0 on including tructmemb

[issue2914] Logging TimedRotatingFileHandler Feature Request

2008-05-19 Thread Val Schmidt
New submission from Val Schmidt <[EMAIL PROTECTED]>: I would like the TimedRotatingFileHandler in the logging package to optionally rotate on UTC time rather than local time. In my world (oceanographic research ships) important things like log files must always use UTC time rather than relativ

[issue615772] Tkinter.Misc has no __contains__ method

2008-05-19 Thread Benjamin Peterson
Changes by Benjamin Peterson <[EMAIL PROTECTED]>: -- type: -> feature request Tracker <[EMAIL PROTECTED]> ___ Python-bugs-list mail

[issue2913] idlelib/EditorWindow.py uses xrange()

2008-05-19 Thread Mark Summerfield
New submission from Mark Summerfield <[EMAIL PROTECTED]>: In Py30a5 idlelib/EditorWindow.py line 292 uses xrange() when it should use range(). -- components: IDLE messages: 67060 nosy: mark severity: normal status: open title: idlelib/EditorWindow.py uses xrange() versions: Python 3.0 _

[issue615772] Tkinter.Misc has no __contains__ method

2008-05-19 Thread Guilherme Polo
Guilherme Polo <[EMAIL PROTECTED]> added the comment: Can you tell me why anyone would do `option in widget` ? I don't see the benefit of making tkinter widgets more "dict-like". Do you have some good use cases ? -- nosy: +gpolo Tracker <[EMAIL PROTE

[issue2445] Use The CygwinCCompiler Under Cygwin

2008-05-19 Thread Jeevan Varshney
Jeevan Varshney <[EMAIL PROTECTED]> added the comment: The following will also let environment variables be passed to the CygwinCCompiler. --- orig/sysconfig.py 2008-05-19 00:26:03.953125000 -0700 +++ copy/sysconfig.py 2008-05-19 00:14:51.609375000 -0700 @@ -145,7 +145,7 @@ Mainly neede

[issue2849] Remove usage of rfc822 from the stdlib

2008-05-19 Thread Humberto Diogenes
Humberto Diogenes <[EMAIL PROTECTED]> added the comment: Tried to just replace rfc822.Message with email.message_from_file in cgi.py but it didn't work. I still have to figure out how to fix FieldStorage.read_multi. Added file: http://bugs.python.org/file10376/remove_rfc822-cgi-incomplete.py