[issue22915] sax.parser cannot get xml data from a subprocess pipe

2014-11-27 Thread Jocelyn
Jocelyn added the comment: Ok, I understand your tests now. Thanks for the fixes ! -- ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue22915

[issue22915] sax.parser cannot get xml data from a subprocess pipe

2014-11-23 Thread Jocelyn
Jocelyn added the comment: The only explicit documentation I found on SystemId is from the java specification (it is my understanding that python sax implementation is adapted from Java one): http://www.saxproject.org/apidoc/org/xml/sax/InputSource.html#setSystemId%28java.lang.String%29

[issue22915] sax.parser cannot get xml data from a subprocess pipe

2014-11-22 Thread Jocelyn
Jocelyn added the comment: Here is a patch to add a test to test_sax.py. I'm not sure on the fix. Is the following one a correct one ? def prepareParser(self, source): if source.getSystemId() is not None: -self._parser.SetBase(source.getSystemId()) +self

[issue22915] sax.parser cannot get xml data from a subprocess pipe

2014-11-22 Thread Jocelyn
Jocelyn added the comment: Forgot to attach the testcase when opening the bug. -- Added file: http://bugs.python.org/file37250/toto.py ___ Python tracker rep...@bugs.python.org http://bugs.python.org/issue22915

[issue22915] sax.parser cannot get xml data from a subprocess pipe

2014-11-21 Thread Jocelyn
New submission from Jocelyn: With the attached code, and an xml file, I got the following error with python 3.4.2: $ cat toto.xml ?xml version='1.0' encoding='UTF-8'? test/test $ python3.4 toto.py Traceback (most recent call last): File toto.py, line 10, in module parse(proc.stdout