[issue17491] Consolidate traceback.format_tb and traceback.print_tb

2013-04-16 Thread Benjamin Peterson

Changes by Benjamin Peterson benja...@python.org:


--
resolution:  - out of date
status: open - closed
superseder:  - traceback.py has a lot of code duplication

___
Python tracker rep...@bugs.python.org
http://bugs.python.org/issue17491
___
___
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue17491] Consolidate traceback.format_tb and traceback.print_tb

2013-03-27 Thread Radu Voicilas

Radu Voicilas added the comment:

Is there anything else that I have to do in order for this patch to be looked 
at ? I am holding off a similar one for print_exception vs. format_exception

--

___
Python tracker rep...@bugs.python.org
http://bugs.python.org/issue17491
___
___
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue17491] Consolidate traceback.format_tb and traceback.print_tb

2013-03-27 Thread Benjamin Peterson

Benjamin Peterson added the comment:

Thank you for the patch. It seems like it would make more sense to implement 
print_tb in terms of extract_tb. That is, print_tb should iterate through the 
result of extract_tb and do its printing.

--
nosy: +benjamin.peterson

___
Python tracker rep...@bugs.python.org
http://bugs.python.org/issue17491
___
___
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue17491] Consolidate traceback.format_tb and traceback.print_tb

2013-03-19 Thread Radu Voicilas

New submission from Radu Voicilas:

This is a patch that consolidates the implementation of traceback.format_tb and 
traceback.print_tb into one common internal function traceback._get_tb. The 
current implementations are almost identical, except that the print_tb() ones 
also prints to a file ...

Now, I don't really know what the Python developers feel about this kind of 
cleanups which doesn't really add any value for the end user. I've seen 
projects where this kind of patches are not accepted because of this. IMHO, 
making code more readable and reducing duplication is always a good thing.

--
components: Library (Lib)
files: consolidate_tb_functions.diff
keywords: patch
messages: 184725
nosy: raduv
priority: normal
severity: normal
status: open
title: Consolidate traceback.format_tb and traceback.print_tb
type: enhancement
versions: Python 3.4
Added file: http://bugs.python.org/file29497/consolidate_tb_functions.diff

___
Python tracker rep...@bugs.python.org
http://bugs.python.org/issue17491
___
___
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com