[issue30274] Make importlib.abc.ExtensionFileLoader.__init__() documentation match code

2019-04-10 Thread Brett Cannon


Brett Cannon  added the comment:

I realized another solution to this is to make the argument positional-only, 
then the name simply doesn't matter. Probably unnecessary breakage, though.

--
versions: +Python 3.8

___
Python tracker 

___
___
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue30274] Make importlib.abc.ExtensionFileLoader.__init__() documentation match code

2017-07-23 Thread Berker Peksag

Changes by Berker Peksag :


--
stage: needs patch -> patch review
type:  -> enhancement
versions: +Python 3.7

___
Python tracker 

___
___
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue30274] Make importlib.abc.ExtensionFileLoader.__init__() documentation match code

2017-05-22 Thread Sayan Chowdhury

Changes by Sayan Chowdhury :


--
pull_requests: +1826

___
Python tracker 

___
___
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue30274] Make importlib.abc.ExtensionFileLoader.__init__() documentation match code

2017-05-22 Thread Sayan Chowdhury

Sayan Chowdhury added the comment:

I am starting to work on this issue.

--
nosy: +sayanchowdhury

___
Python tracker 

___
___
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue30274] Make importlib.abc.ExtensionFileLoader.__init__() documentation match code

2017-05-05 Thread Brett Cannon

Brett Cannon added the comment:

Another option is to rename 'name' to 'fullname', make 'name' keyword-only, and 
then raise a DeprecationWarning if 'name' is used, eventually removing the 
keyword-only argument.

--

___
Python tracker 

___
___
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com



[issue30274] Make importlib.abc.ExtensionFileLoader.__init__() documentation match code

2017-05-04 Thread Brett Cannon

New submission from Brett Cannon:

https://docs.python.org/3/library/importlib.html#importlib.machinery.ExtensionFileLoader
 says "fullname, path" for __init__(), but 
https://github.com/python/cpython/blob/647c3d381e67490e82cdbbe6c96e46d5e1628ce2/Lib/importlib/_bootstrap_external.py#L909
 says "name, path". While I would much rather change the parameter name to 
match the rest of the module, I don't think I'm comfortable with the 
backwards-compatibility breakage over just a single parameter name (although 
chances are no one will notice in either direction as everyone probably passes 
by position).

--
assignee: docs@python
components: Documentation
messages: 293022
nosy: brett.cannon, docs@python
priority: normal
severity: normal
stage: needs patch
status: open
title: Make importlib.abc.ExtensionFileLoader.__init__() documentation match 
code

___
Python tracker 

___
___
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com